78 lines
2.1 KiB
RPMSpec
78 lines
2.1 KiB
RPMSpec
%define ghc_ver %(ghc --version | sed "s|.*version ||")
|
|
%define pkg_name %(echo %name | sed "s|^ghc-||")
|
|
Name: ghc-List
|
|
Version: 0.6.2
|
|
Release: 1mamba
|
|
Summary: List monad transformer and a List class
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://hackage.haskell.org/package/%{pkg_name}
|
|
Source: http://hackage.haskell.org/packages/archive/List/%{version}/List-%{version}.tar.gz
|
|
License: BSD
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: ghc
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libgmp-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: ghc
|
|
Requires: ghc = %{ghc_ver}
|
|
|
|
%description
|
|
A List monad transformer and a List class. With standard list operations for Lists.
|
|
|
|
%package devel
|
|
Summary: Haskell %{pkg_name} library development files
|
|
Provides: %{name}-static = %{version}-%{release}
|
|
Provides: %{name}-static%{?_isa} = %{version}-%{release}
|
|
%if %{defined ghc_version}
|
|
Requires: ghc = %{ghc_version}
|
|
%endif
|
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
|
|
|
%description devel
|
|
This package provides the Haskell %{pkg_name} library development files.
|
|
|
|
%if %{with haddock}
|
|
%package doc
|
|
Summary: Haskell %{pkg_name} library documentation
|
|
Requires: ghc-filesystem
|
|
|
|
%description doc
|
|
This package provides the Haskell %{pkg_name} library documentation.
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q -n List-%{version}
|
|
|
|
%build
|
|
%ghc_lib_build
|
|
|
|
%install
|
|
%ghc_lib_install
|
|
|
|
rm -f %{buildroot}%{_ghclicensedir}/%{name}/LICENSE
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f %{name}.files
|
|
%defattr(-,root,root)
|
|
%license LICENSE
|
|
|
|
%files devel -f %{name}-devel.files
|
|
%doc CHANGELOG.md
|
|
|
|
%if %{with haddock}
|
|
%files doc -f %{name}-doc.files
|
|
%license LICENSE
|
|
%endif
|
|
|
|
%changelog
|
|
* Tue Nov 14 2023 Automatic Build System <autodist@mambasoft.it> 0.6.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 08 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-1mamba
|
|
- package created by silvan using the webbuild interface
|