automatic version update by autodist [release 3.10.0.1-1mamba;Wed Oct 16 2013]

This commit is contained in:
Automatic Build System 2024-01-05 22:39:48 +01:00
parent 8ae6dd7885
commit 346683ad78
6 changed files with 985 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# gdm # gdm
GDM is the GNOME Display Manager, a graphical login program.

View File

@ -0,0 +1,16 @@
diff -Nru gdm-2.32.1.orig//data/gdm gdm-2.32.1/data/gdm
--- gdm-2.32.1.orig//data/gdm 2011-03-07 18:40:37.000000000 +0100
+++ gdm-2.32.1/data/gdm 2011-05-21 19:15:05.043330513 +0200
@@ -9,4 +9,3 @@
session optional pam_keyinit.so force revoke
session include system-auth
session required pam_loginuid.so
-session optional pam_console.so
diff -Nru gdm-2.32.1.orig//data/gdm-autologin gdm-2.32.1/data/gdm-autologin
--- gdm-2.32.1.orig//data/gdm-autologin 2011-03-07 18:40:37.000000000 +0100
+++ gdm-2.32.1/data/gdm-autologin 2011-05-21 19:14:58.370403932 +0200
@@ -7,4 +7,3 @@
session optional pam_keyinit.so force revoke
session include system-auth
session required pam_loginuid.so
-session optional pam_console.so

338
gdm-3.4.1-plymouth.patch Normal file
View File

@ -0,0 +1,338 @@
From c56fbb65277e8a17db5e0939f0b02e41c4ec784c Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Fri, 27 Nov 2009 18:52:54 -0500
Subject: [PATCH] daemon: enable smooth transition between plymouth and X
This commit adds optional support for interacting with plymouth
from gdm. This feature can be enabled by passing --with-plymouth
to configure.
Hopefully, this will enable the various distributions that use
plymouth to drop a patch.
https://bugzilla.gnome.org/show_bug.cgi?id=572173
---
configure.ac | 32 +++++++++++++
daemon/gdm-server.c | 60 +++++++++++++++++++++++++
daemon/gdm-server.h | 3 +
daemon/gdm-simple-slave.c | 106 ++++++++++++++++++++++++++++++++++++++++++++-
4 files changed, 200 insertions(+), 1 deletions(-)
diff --git a/configure.ac b/configure.ac
index 35e6e04..81ea23e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -264,6 +264,10 @@ AC_ARG_WITH(systemd,
AS_HELP_STRING([--with-systemd],
[Add systemd support @<:@default=auto@:>@]),
[with_systemd=$withval], [with_systemd=auto])
+AC_ARG_WITH(plymouth,
+ AS_HELP_STRING([--with-plymouth],
+ [Add plymouth support @<:@default=auto@:>@]),
+ [with_plymouth=$withval], [with_plymouth=auto])
AC_ARG_WITH(at-spi-registryd-directory,
AS_HELP_STRING([--with-at-spi-registryd-directory],
@@ -952,6 +956,33 @@ AC_SUBST(SYSTEMD_X_SERVER)
AC_DEFINE_UNQUOTED(SYSTEMD_X_SERVER,"$SYSTEMD_X_SERVER",[Path to systemd X server wrapper])
dnl ---------------------------------------------------------------------------
+dnl - Check for plymouth support
+dnl ---------------------------------------------------------------------------
+PKG_CHECK_MODULES(PLYMOUTH,
+ [ply-boot-client],
+ [have_plymouth=yes], [have_plymouth=no])
+
+if test "x$with_plymouth" = "xauto" ; then
+ if test x$have_plymouth = xno ; then
+ use_plymouth=no
+ else
+ use_plymouth=yes
+ fi
+else
+ use_plymouth="$with_plymouth"
+fi
+
+if test "x$use_plymouth" != "xno" ; then
+ if test "x$have_plymouth" = "xno"; then
+ AC_MSG_ERROR([Plymouth support explicitly required, but plymouth not found])
+ fi
+
+ AC_DEFINE(WITH_PLYMOUTH, 1, [Define to enable plymouth support])
+fi
+AC_SUBST(PLYMOUTH_CFLAGS)
+AC_SUBST(PLYMOUTH_LIBS)
+
+dnl ---------------------------------------------------------------------------
dnl - Check for D-Bus
dnl ---------------------------------------------------------------------------
@@ -1537,6 +1568,7 @@ echo \
SELinux support: ${with_selinux}
ConsoleKit support: ${use_console_kit}
systemd support: ${use_systemd}
+ plymouth support: ${use_plymouth}
UPower support: ${have_upower}
Build with RBAC: ${msg_rbac_shutdown}
"
diff --git a/daemon/gdm-server.c b/daemon/gdm-server.c
index d0d8ff9..6f2a939 100644
--- a/daemon/gdm-server.c
+++ b/daemon/gdm-server.c
@@ -32,6 +32,7 @@
#include <pwd.h>
#include <grp.h>
#include <signal.h>
+#include <sys/ioctl.h>
#include <sys/resource.h>
#ifdef HAVE_SYS_PRCTL_H
@@ -42,6 +43,10 @@
#include <systemd/sd-daemon.h>
#endif
+#ifdef WITH_PLYMOUTH
+#include <linux/vt.h>
+#endif
+
#include <glib.h>
#include <glib/gi18n.h>
#include <glib/gstdio.h>
@@ -751,6 +756,61 @@ gdm_server_spawn (GdmServer *server,
return ret;
}
+#ifdef WITH_PLYMOUTH
+static int
+get_active_vt (void)
+{
+ int console_fd;
+ struct vt_stat console_state = { 0 };
+
+ console_fd = open ("/dev/tty0", O_RDONLY | O_NOCTTY);
+
+ if (console_fd < 0) {
+ goto out;
+ }
+
+ if (ioctl (console_fd, VT_GETSTATE, &console_state) < 0) {
+ goto out;
+ }
+
+out:
+ if (console_fd >= 0) {
+ close (console_fd);
+ }
+
+ return console_state.v_active;
+}
+
+static char *
+get_active_vt_as_string (void)
+{
+ int vt;
+
+ vt = get_active_vt ();
+
+ if (vt <= 0) {
+ return NULL;
+ }
+
+ return g_strdup_printf ("vt%d", vt);
+}
+
+gboolean
+gdm_server_start_on_active_vt (GdmServer *server)
+{
+ gboolean res;
+ char *vt;
+
+ g_free (server->priv->command);
+ server->priv->command = g_strdup (X_SERVER " -background none -logverbose 7");
+ vt = get_active_vt_as_string ();
+ res = gdm_server_spawn (server, vt);
+ g_free (vt);
+
+ return res;
+}
+#endif
+
/**
* gdm_server_start:
* @disp: Pointer to a GdmDisplay structure
diff --git a/daemon/gdm-server.h b/daemon/gdm-server.h
index b53d68e..827f7fa 100644
--- a/daemon/gdm-server.h
+++ b/daemon/gdm-server.h
@@ -57,6 +57,9 @@ GdmServer * gdm_server_new (const char *display_id,
const char *seat_id,
const char *auth_file);
gboolean gdm_server_start (GdmServer *server);
+#ifdef HAVE_PLYMOUTH
+gboolean gdm_server_start_on_active_vt (GdmServer *server);
+#endif
gboolean gdm_server_stop (GdmServer *server);
char * gdm_server_get_display_device (GdmServer *server);
diff --git a/daemon/gdm-simple-slave.c b/daemon/gdm-simple-slave.c
index fc8649c..7c709a6 100644
--- a/daemon/gdm-simple-slave.c
+++ b/daemon/gdm-simple-slave.c
@@ -93,6 +93,9 @@ struct GdmSimpleSlavePrivate
#ifdef HAVE_LOGINDEVPERM
gboolean use_logindevperm;
#endif
+#ifdef WITH_PLYMOUTH
+ guint plymouth_is_running : 1;
+#endif
};
enum {
@@ -1204,6 +1207,74 @@ on_start_session_later (GdmGreeterServer *session,
slave->priv->start_session_when_ready = FALSE;
}
+#ifdef WITH_PLYMOUTH
+static gboolean
+plymouth_is_running (void)
+{
+ int status;
+ gboolean res;
+ GError *error;
+
+ error = NULL;
+ res = g_spawn_command_line_sync ("/bin/plymouth --ping",
+ NULL, NULL, &status, &error);
+ if (! res) {
+ g_debug ("Could not ping plymouth: %s", error->message);
+ g_error_free (error);
+ return FALSE;
+ }
+
+ return WIFEXITED (status) && WEXITSTATUS (status) == 0;
+}
+
+static void
+plymouth_prepare_for_transition (GdmSimpleSlave *slave)
+{
+ gboolean res;
+ GError *error;
+
+ error = NULL;
+ res = g_spawn_command_line_sync ("/bin/plymouth deactivate",
+ NULL, NULL, NULL, &error);
+ if (! res) {
+ g_warning ("Could not deactivate plymouth: %s", error->message);
+ g_error_free (error);
+ }
+}
+
+static void
+plymouth_quit_with_transition (GdmSimpleSlave *slave)
+{
+ gboolean res;
+ GError *error;
+
+ error = NULL;
+ res = g_spawn_command_line_sync ("/bin/plymouth quit --retain-splash",
+ NULL, NULL, NULL, &error);
+ if (! res) {
+ g_warning ("Could not quit plymouth: %s", error->message);
+ g_error_free (error);
+ }
+ slave->priv->plymouth_is_running = FALSE;
+}
+
+static void
+plymouth_quit_without_transition (GdmSimpleSlave *slave)
+{
+ gboolean res;
+ GError *error;
+
+ error = NULL;
+ res = g_spawn_command_line_sync ("/bin/plymouth quit",
+ NULL, NULL, NULL, &error);
+ if (! res) {
+ g_warning ("Could not quit plymouth: %s", error->message);
+ g_error_free (error);
+ }
+ slave->priv->plymouth_is_running = FALSE;
+}
+#endif
+
static void
setup_server (GdmSimpleSlave *slave)
{
@@ -1223,6 +1294,12 @@ setup_server (GdmSimpleSlave *slave)
*/
gdm_slave_save_root_windows (GDM_SLAVE (slave));
+#ifdef WITH_PLYMOUTH
+ /* Plymouth is waiting for the go-ahead to exit */
+ if (slave->priv->plymouth_is_running) {
+ plymouth_quit_with_transition (slave);
+ }
+#endif
}
static void
@@ -1426,6 +1503,12 @@ on_server_exited (GdmServer *server,
g_debug ("GdmSimpleSlave: server exited with code %d\n", exit_code);
gdm_slave_stopped (GDM_SLAVE (slave));
+
+#ifdef WITH_PLYMOUTH
+ if (slave->priv->plymouth_is_running) {
+ plymouth_quit_without_transition (slave);
+ }
+#endif
}
static void
@@ -1438,6 +1521,12 @@ on_server_died (GdmServer *server,
g_strsignal (signal_number));
gdm_slave_stopped (GDM_SLAVE (slave));
+
+#ifdef WITH_PLYMOUTH
+ if (slave->priv->plymouth_is_running) {
+ plymouth_quit_without_transition (slave);
+ }
+#endif
}
static gboolean
@@ -1484,7 +1573,17 @@ gdm_simple_slave_run (GdmSimpleSlave *slave)
G_CALLBACK (on_server_ready),
slave);
- res = gdm_server_start (slave->priv->server);
+#ifdef WITH_PLYMOUTH
+ slave->priv->plymouth_is_running = plymouth_is_running ();
+
+ if (slave->priv->plymouth_is_running) {
+ plymouth_prepare_for_transition (slave);
+ res = gdm_server_start_on_active_vt (slave->priv->server);
+ } else
+#endif
+ {
+ res = gdm_server_start (slave->priv->server);
+ }
if (! res) {
g_warning (_("Could not start the X "
"server (your graphical environment) "
@@ -1494,6 +1593,11 @@ gdm_simple_slave_run (GdmSimpleSlave *slave)
"In the meantime this display will be "
"disabled. Please restart GDM when "
"the problem is corrected."));
+#ifdef WITH_PLYMOUTH
+ if (slave->priv->plymouth_is_running) {
+ plymouth_quit_without_transition (slave);
+ }
+#endif
exit (1);
}
--
1.7.8.6

View File

@ -0,0 +1,141 @@
From c93d98b646a9a4fce3052260a1f08808d62d7155 Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Fri, 27 Nov 2009 18:27:53 -0500
Subject: [PATCH] daemon: save root window to pixmap at _XROOTPMAP_ID
This combined with starting the X server with
-background none will give distros using plymouth
(or potentially other boot splashes) a a nice fade
transition when g-s-d starts.
https://bugzilla.gnome.org/show_bug.cgi?id=572173
---
daemon/gdm-simple-slave.c | 8 +++++
daemon/gdm-slave.c | 72 +++++++++++++++++++++++++++++++++++++++++++++
daemon/gdm-slave.h | 1 +
3 files changed, 81 insertions(+), 0 deletions(-)
diff --git a/daemon/gdm-simple-slave.c b/daemon/gdm-simple-slave.c
index 9d1347a..fc8649c 100644
--- a/daemon/gdm-simple-slave.c
+++ b/daemon/gdm-simple-slave.c
@@ -1215,6 +1215,14 @@ setup_server (GdmSimpleSlave *slave)
/* Set the initial keyboard layout to something reasonable */
gdm_slave_set_initial_keyboard_layout (GDM_SLAVE (slave));
+ /* The root window has a background that may be useful
+ * to cross fade or transition from when setting the
+ * login screen background. We read it here, and stuff
+ * it into the standard _XROOTPMAP_ID root window property,
+ * so gnome-settings-daemon can get at it.
+ */
+ gdm_slave_save_root_windows (GDM_SLAVE (slave));
+
}
static void
diff --git a/daemon/gdm-slave.c b/daemon/gdm-slave.c
index a5ce62f..53633c0 100644
--- a/daemon/gdm-slave.c
+++ b/daemon/gdm-slave.c
@@ -43,6 +43,7 @@
#include <dbus/dbus-glib-lowlevel.h>
#include <X11/Xlib.h> /* for Display */
+#include <X11/Xatom.h> /* for XA_PIXMAP */
#include <X11/cursorfont.h> /* for watch cursor */
#include <X11/extensions/Xrandr.h>
#include <X11/Xatom.h>
@@ -364,6 +365,77 @@ gdm_slave_run_script (GdmSlave *slave,
return ret;
}
+static void
+gdm_slave_save_root_window_of_screen (GdmSlave *slave,
+ Atom id_atom,
+ int screen_number)
+{
+ Window root_window;
+ GC gc;
+ XGCValues values;
+ Pixmap pixmap;
+ int width, height, depth;
+
+ root_window = RootWindow (slave->priv->server_display,
+ screen_number);
+
+ width = DisplayWidth (slave->priv->server_display, screen_number);
+ height = DisplayHeight (slave->priv->server_display, screen_number);
+ depth = DefaultDepth (slave->priv->server_display, screen_number);
+ pixmap = XCreatePixmap (slave->priv->server_display,
+ root_window,
+ width, height, depth);
+
+ values.function = GXcopy;
+ values.plane_mask = AllPlanes;
+ values.fill_style = FillSolid;
+ values.subwindow_mode = IncludeInferiors;
+
+ gc = XCreateGC (slave->priv->server_display,
+ root_window,
+ GCFunction | GCPlaneMask | GCFillStyle | GCSubwindowMode,
+ &values);
+
+ if (XCopyArea (slave->priv->server_display,
+ root_window, pixmap, gc, 0, 0,
+ width, height, 0, 0)) {
+
+ long pixmap_as_long;
+
+ pixmap_as_long = (long) pixmap;
+
+ XChangeProperty (slave->priv->server_display,
+ root_window, id_atom, XA_PIXMAP,
+ 32, PropModeReplace, (guchar *) &pixmap_as_long,
+ 1);
+
+ }
+
+ XFreeGC (slave->priv->server_display, gc);
+}
+
+void
+gdm_slave_save_root_windows (GdmSlave *slave)
+{
+ int i, number_of_screens;
+ Atom atom;
+
+ number_of_screens = ScreenCount (slave->priv->server_display);
+
+ atom = XInternAtom (slave->priv->server_display,
+ "_XROOTPMAP_ID", False);
+
+ if (atom == 0) {
+ return;
+ }
+
+ for (i = 0; i < number_of_screens; i++) {
+ gdm_slave_save_root_window_of_screen (slave, atom, i);
+ }
+
+ XSync (slave->priv->server_display, False);
+}
+
void
gdm_slave_set_initial_keyboard_layout (GdmSlave *slave)
{
diff --git a/daemon/gdm-slave.h b/daemon/gdm-slave.h
index 7af20ed..aaaa8f2 100644
--- a/daemon/gdm-slave.h
+++ b/daemon/gdm-slave.h
@@ -78,6 +78,7 @@ void gdm_slave_set_initial_keyboard_layout (GdmSlave *slave);
void gdm_slave_set_initial_cursor_position (GdmSlave *slave);
void gdm_slave_set_busy_cursor (GdmSlave *slave);
+void gdm_slave_save_root_windows (GdmSlave *slave);
gboolean gdm_slave_run_script (GdmSlave *slave,
const char *dir,
const char *username);
--
1.7.8.6

View File

@ -0,0 +1,174 @@
diff -Nru gdm-3.6.1.orig/data/pam-redhat/gdm-autologin.pam gdm-3.6.1/data/pam-redhat/gdm-autologin.pam
--- gdm-3.6.1.orig/data/pam-redhat/gdm-autologin.pam 2012-10-04 23:06:33.000000000 +0200
+++ gdm-3.6.1/data/pam-redhat/gdm-autologin.pam 2012-10-21 21:26:33.583960945 +0200
@@ -1,16 +1,13 @@
#%PAM-1.0
auth required pam_env.so
auth required pam_permit.so
-auth include postlogin
account required pam_nologin.so
account include system-auth
password include system-auth
session required pam_selinux.so close
session required pam_loginuid.so
-session optional pam_console.so
-session optional pam_ck_connector.so
session required pam_selinux.so open
session optional pam_keyinit.so force revoke
session required pam_namespace.so
session include system-auth
-session include postlogin
diff -Nru gdm-3.6.1.orig/data/pam-redhat/gdm-fingerprint.pam gdm-3.6.1/data/pam-redhat/gdm-fingerprint.pam
--- gdm-3.6.1.orig/data/pam-redhat/gdm-fingerprint.pam 2012-10-04 00:03:41.000000000 +0200
+++ gdm-3.6.1/data/pam-redhat/gdm-fingerprint.pam 2012-10-21 21:27:16.159554238 +0200
@@ -1,5 +1,4 @@
auth substack fingerprint-auth
-auth include postlogin
account required pam_nologin.so
account include fingerprint-auth
@@ -8,10 +7,8 @@
session required pam_selinux.so close
session required pam_loginuid.so
-session optional pam_console.so
-session optional pam_ck_connector.so
session required pam_selinux.so open
session optional pam_keyinit.so force revoke
session required pam_namespace.so
session include fingerprint-auth
-session include postlogin
diff -Nru gdm-3.6.1.orig/data/pam-redhat/gdm.pam gdm-3.6.1/data/pam-redhat/gdm.pam
--- gdm-3.6.1.orig/data/pam-redhat/gdm.pam 2012-10-04 00:03:41.000000000 +0200
+++ gdm-3.6.1/data/pam-redhat/gdm.pam 2012-10-21 21:26:53.316772445 +0200
@@ -8,4 +8,3 @@
session optional pam_keyinit.so force revoke
session include system-auth
session required pam_loginuid.so
-session optional pam_console.so
diff -Nru gdm-3.6.1.orig/data/pam-redhat/gdm-password.pam gdm-3.6.1/data/pam-redhat/gdm-password.pam
--- gdm-3.6.1.orig/data/pam-redhat/gdm-password.pam 2012-10-04 00:03:41.000000000 +0200
+++ gdm-3.6.1/data/pam-redhat/gdm-password.pam 2012-10-21 21:27:34.644377661 +0200
@@ -1,7 +1,6 @@
auth [success=done ignore=ignore default=bad] pam_selinux_permit.so
auth substack password-auth
auth optional pam_gnome_keyring.so
-auth include postlogin
account required pam_nologin.so
account include password-auth
@@ -10,11 +9,9 @@
session required pam_selinux.so close
session required pam_loginuid.so
-session optional pam_console.so
-session optional pam_ck_connector.so
session required pam_selinux.so open
session optional pam_keyinit.so force revoke
session required pam_namespace.so
session include password-auth
session optional pam_gnome_keyring.so auto_start
-session include postlogin
diff -Nru gdm-3.6.1.orig/data/pam-redhat/gdm-smartcard.pam gdm-3.6.1/data/pam-redhat/gdm-smartcard.pam
--- gdm-3.6.1.orig/data/pam-redhat/gdm-smartcard.pam 2012-10-04 00:03:41.000000000 +0200
+++ gdm-3.6.1/data/pam-redhat/gdm-smartcard.pam 2012-10-21 21:27:59.605139221 +0200
@@ -1,5 +1,4 @@
auth substack smartcard-auth
-auth include postlogin
account required pam_nologin.so
account include smartcard-auth
@@ -8,10 +7,8 @@
session required pam_selinux.so close
session required pam_loginuid.so
-session optional pam_console.so
-session optional pam_ck_connector.so
session required pam_selinux.so open
session optional pam_keyinit.so force revoke
session required pam_namespace.so
session include smartcard-auth
-session include postlogin
diff -Nru gdm-3.6.1.orig/data/pam-redhat/gdm-fingerprint.pam gdm-3.6.1/data/pam-redhat/gdm-fingerprint.pam
--- gdm-3.6.1.orig/data/pam-redhat/gdm-fingerprint.pam 2012-10-21 21:29:31.617260268 +0200
+++ gdm-3.6.1/data/pam-redhat/gdm-fingerprint.pam 2012-11-05 17:34:23.037735987 +0100
@@ -1,9 +1,9 @@
-auth substack fingerprint-auth
+auth substack system-auth
account required pam_nologin.so
-account include fingerprint-auth
+account include system-auth
-password include fingerprint-auth
+password include system-auth
session required pam_selinux.so close
session required pam_loginuid.so
@@ -11,4 +11,4 @@
session required pam_selinux.so open
session optional pam_keyinit.so force revoke
session required pam_namespace.so
-session include fingerprint-auth
+session include system-auth
diff -Nru gdm-3.6.1.orig/data/pam-redhat/gdm-password.pam gdm-3.6.1/data/pam-redhat/gdm-password.pam
--- gdm-3.6.1.orig/data/pam-redhat/gdm-password.pam 2012-10-21 21:29:31.618260258 +0200
+++ gdm-3.6.1/data/pam-redhat/gdm-password.pam 2012-11-05 17:33:48.269148884 +0100
@@ -1,11 +1,10 @@
-auth [success=done ignore=ignore default=bad] pam_selinux_permit.so
-auth substack password-auth
+auth substack system-auth
auth optional pam_gnome_keyring.so
account required pam_nologin.so
-account include password-auth
+account include system-auth
-password include password-auth
+password include system-auth
session required pam_selinux.so close
session required pam_loginuid.so
@@ -13,5 +12,5 @@
session required pam_selinux.so open
session optional pam_keyinit.so force revoke
session required pam_namespace.so
-session include password-auth
+session include system-auth
session optional pam_gnome_keyring.so auto_start
diff -Nru gdm-3.6.1.orig/data/pam-redhat/gdm-smartcard.pam gdm-3.6.1/data/pam-redhat/gdm-smartcard.pam
--- gdm-3.6.1.orig/data/pam-redhat/gdm-smartcard.pam 2012-10-21 21:29:31.618260258 +0200
+++ gdm-3.6.1/data/pam-redhat/gdm-smartcard.pam 2012-11-05 17:34:53.475374523 +0100
@@ -1,9 +1,9 @@
-auth substack smartcard-auth
+auth substack system-auth
account required pam_nologin.so
-account include smartcard-auth
+account include system-auth
-password include smartcard-auth
+password include system-auth
session required pam_selinux.so close
session required pam_loginuid.so
@@ -11,4 +11,4 @@
session required pam_selinux.so open
session optional pam_keyinit.so force revoke
session required pam_namespace.so
-session include smartcard-auth
+session include system-auth
diff -Nru gdm-3.8.0.orig/data/pam-redhat/gdm-launch-environment.pam gdm-3.8.0/data/pam-redhat/gdm-launch-environment.pam
--- gdm-3.8.0.orig/data/pam-redhat/gdm-launch-environment.pam 2013-02-08 16:26:57.000000000 +0100
+++ gdm-3.8.0/data/pam-redhat/gdm-launch-environment.pam 2013-03-28 09:54:56.132482591 +0100
@@ -1,10 +1,8 @@
#%PAM-1.0
auth required pam_env.so
auth required pam_permit.so
-auth include postlogin
account required pam_nologin.so
account include system-auth
password include system-auth
session optional pam_keyinit.so force revoke
session include system-auth
-session include postlogin

314
gdm.spec Normal file
View File

@ -0,0 +1,314 @@
%define gdm_uid 53
%define gdm_gid 53
%define majver %(echo %version | cut -d. -f1-2)
Name: gdm
Version: 3.10.0.1
Release: 1mamba
Summary: The GNOME Display Manager, a graphical login program
Group: Graphical Desktop/Applications/Other
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.gnome.org
Source: ftp://ftp.gnome.org/pub/gnome/sources/gdm/%{majver}/gdm-%{version}.tar.xz
Patch0: %{name}-2.32.1-remove-pam_console.patch
Patch1: %{name}-3.4.1-save-root-window.patch
Patch2: %{name}-3.4.1-plymouth.patch
Patch3: gdm-3.8.0-pam-openmamba.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libaccountsservice-devel
BuildRequires: libatk-devel
BuildRequires: libaudit-devel
BuildRequires: libbzip2-devel
BuildRequires: libcairo-devel
BuildRequires: libcanberra-devel
BuildRequires: libexpat-devel
BuildRequires: libffi-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel
BuildRequires: libgraphite2-devel
BuildRequires: libgtk-devel
BuildRequires: libharfbuzz-devel
BuildRequires: libicu-devel
BuildRequires: libnspr-devel
BuildRequires: libnss-devel
BuildRequires: libpango-devel
BuildRequires: libpng-devel
BuildRequires: libpthread-stubs-devel
BuildRequires: libselinux-devel
BuildRequires: libstdc++6-devel
BuildRequires: libwrap-devel
BuildRequires: libX11-devel
BuildRequires: libXau-devel
BuildRequires: libxcb-devel
BuildRequires: libXdmcp-devel
BuildRequires: libXext-devel
BuildRequires: libXrandr-devel
BuildRequires: libXrender-devel
BuildRequires: libz-devel
BuildRequires: pam-devel
BuildRequires: systemd-devel
BuildRequires: upower-devel
## AUTOBUILDREQ-END
Requires: ConsoleKit
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
GDM is the GNOME Display Manager, a graphical login program.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
GDM is the GNOME Display Manager, a graphical login program.
This package contains static libraries and header files need for development.
%prep
%setup -q
#%patch0 -p1
#%patch1 -p1
#%patch2 -p1
%patch3 -p1
%build
#libtoolize
#autoreconf
%configure \
--disable-scrollkeeper \
--with-plymouth \
--with-default-pam-config=redhat \
--with-systemd
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%find_lang %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%pre
if [ $1 -ge 1 ]; then
/usr/sbin/groupadd gdm -g %{gdm_gid} 2>/dev/null
/usr/sbin/useradd -c gdm -u %{gdm_uid} -d /var/lib/gdm -g gdm \
-s /bin/false gdm 2>/dev/null
# fix home for previously created gdm user
sed -i "s|:gdm:/dev/null:|:gdm:/var/lib/gdm:|" /etc/passwd
fi
exit 0
%post
if [ $1 -ge 1 ]; then
# new install or upgrade
/usr/sbin/alternatives --install \
%{_sbindir}/login_manager login_manager %{_sbindir}/gdm 15
update-desktop-database -q &>/dev/null
GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` \
gconftool-2 --makefile-install-rule \
%{_sysconfdir}/gconf/schemas/gdm-simple-greeter.schemas &> /dev/null
systemctl -q enable gdm.service || true
fi
exit 0
%postun
if [ $1 -eq 0 ]; then
/usr/sbin/update-alternatives --remove login_manager %{_sbindir}/gdm
update-desktop-database -q &>/dev/null
GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` \
gconftool-2 --makefile-uninstall-rule \
%{_sysconfdir}/gconf/schemas/gdm-simple-greeter.schemas &> /dev/null
systemctl -q disable gdm.service || true
fi
exit 0
%files -f %{name}.lang
%defattr(-,root,root)
%dir %{_sysconfdir}/dconf/db/gdm.d
%dir %{_sysconfdir}/dconf/db/gdm.d/locks
%{_sysconfdir}/dconf/db/gdm.d/00-upstream-settings
%{_sysconfdir}/dconf/db/gdm.d/locks/00-upstream-settings-locks
%{_sysconfdir}/dconf/profile/gdm
%{_sysconfdir}/dbus-1/system.d/gdm.conf
#%{_sysconfdir}/gconf/schemas/gdm-simple-greeter.schemas
%config(noreplace) %{_sysconfdir}/gdm/Init/Default
%{_sysconfdir}/gdm/PostLogin/Default.sample
%{_sysconfdir}/gdm/PostSession/Default
%{_sysconfdir}/gdm/PreSession/Default
%{_sysconfdir}/gdm/Xsession
%config(noreplace) %{_sysconfdir}/gdm/custom.conf
%{_sysconfdir}/pam.d/gdm
%{_sysconfdir}/pam.d/gdm-autologin
%{_sysconfdir}/pam.d/gdm-fingerprint
%{_sysconfdir}/pam.d/gdm-launch-environment
%{_sysconfdir}/pam.d/gdm-password
%{_sysconfdir}/pam.d/gdm-pin
%{_sysconfdir}/pam.d/gdm-smartcard
%{_bindir}/gdm-screenshot
/lib/systemd/system/gdm.service
%{_libdir}/libgdm.so.*
#%{_libdir}/libgdmsimplegreeter.so.*
%{_libdir}/girepository-1.0/Gdm-1.0.typelib
#%dir %{_libdir}/gdm
#%dir %{_libdir}/gdm/simple-greeter
#%dir %{_libdir}/gdm/simple-greeter/extensions
#%{_libdir}/gdm/simple-greeter/extensions/lib*
%{_libexecdir}/gdm-*
%{_bindir}/gdmflexiserver
%{_sbindir}/gdm
#%{_sbindir}/gdm-binary
%dir %{_datadir}/gdm
%dir %{_datadir}/gdm/greeter
%{_datadir}/gdm/greeter/*
#%dir %{_datadir}/gdm/simple-greeter
#%{_datadir}/gdm/simple-greeter/*
%{_datadir}/gdm/gdb-cmd
#%{_datadir}/gdm/gdm-greeter-login-window.ui
%{_datadir}/gdm/gdm.schemas
%{_datadir}/gdm/locale.alias
%{_datadir}/glib-2.0/schemas/org.gnome.login-screen.gschema.xml
#%{_datadir}/gnome-session/sessions/gdm-fallback.session
%{_datadir}/gnome-session/sessions/gdm-shell.session
%{_datadir}/help/C/gdm/*
%lang(ca) %{_datadir}/help/ca/gdm/*
%lang(de) %{_datadir}/help/de/gdm/*
%lang(el) %{_datadir}/help/el/gdm/*
%lang(en_GB) %{_datadir}/help/en_GB/gdm/*
%lang(es) %{_datadir}/help/es/gdm/*
%lang(fr) %{_datadir}/help/fr/gdm/*
%lang(gl) %{_datadir}/help/gl/gdm/*
%lang(id) %{_datadir}/help/id/gdm/*
%lang(it) %{_datadir}/help/it/gdm/*
%lang(ko) %{_datadir}/help/ko/gdm/*
%lang(oc) %{_datadir}/help/oc/gdm/*
%lang(pt_BR) %{_datadir}/help/pt_BR/gdm/*
%lang(ru) %{_datadir}/help/ru/gdm/*
%lang(sl) %{_datadir}/help/sl/gdm/*
%lang(sv) %{_datadir}/help/sv/gdm/*
%lang(te) %{_datadir}/help/te/gdm/*
%lang(uk) %{_datadir}/help/uk/gdm/*
%lang(zh_CN) %{_datadir}/help/zh_CN/gdm/*
%{_datadir}/icons/hicolor/*/apps/gdm-*.png
#%{_datadir}/omf/gdm/gdm-*.omf
%{_datadir}/pixmaps/gdm*.png
%{_datadir}/pixmaps/nobody.png
%{_datadir}/pixmaps/nohost.png
%attr(1770,root,gdm) %dir %{_localstatedir}/lib/gdm
#%attr(-,root,gdm) %dir %{_localstatedir}/lib/gdm/.gconf.mandatory
#%attr(-,root,gdm) %config(noreplace) %{_localstatedir}/lib/gdm/.gconf.mandatory/*
#%attr(-,root,gdm) %config(noreplace) %{_localstatedir}/lib/gdm/.gconf.path
%attr(-,gdm,gdm) %dir %{_localstatedir}/cache/gdm
%attr(-,gdm,gdm) %dir %{_localstatedir}/log/gdm
%attr(-,gdm,gdm) %dir %{_localstatedir}/run/gdm
%doc AUTHORS COPYING
%files devel
%defattr(-,root,root)
%dir %{_includedir}/gdm
%{_includedir}/gdm/*
%{_libdir}/libgdm.a
%{_libdir}/libgdm.la
%{_libdir}/libgdm.so
#%{_libdir}/libgdmsimplegreeter.a
#%{_libdir}/libgdmsimplegreeter.la
#%{_libdir}/libgdmsimplegreeter.so
%{_datadir}/gir-1.0/Gdm-1.0.gir
%{_libdir}/pkgconfig/gdm.pc
#%{_libdir}/pkgconfig/gdmsimplegreeter.pc
#%doc ChangeLog NEWS README
%changelog
* Wed Oct 16 2013 Automatic Build System <autodist@mambasoft.it> 3.10.0.1-1mamba
- automatic version update by autodist
* Tue Oct 01 2013 Automatic Build System <autodist@mambasoft.it> 3.10.0-1mamba
- automatic update by autodist
* Wed Jul 31 2013 Automatic Build System <autodist@mambasoft.it> 3.8.4-1mamba
- automatic version update by autodist
* Wed Jun 19 2013 Automatic Build System <autodist@mambasoft.it> 3.8.3.1-1mamba
- automatic version update by autodist
* Sun Jun 16 2013 Automatic Build System <autodist@mambasoft.it> 3.8.3-1mamba
- automatic version update by autodist
* Wed Apr 17 2013 Automatic Build System <autodist@mambasoft.it> 3.8.1.1-1mamba
- automatic version update by autodist
* Tue Apr 16 2013 Automatic Build System <autodist@mambasoft.it> 3.8.1-1mamba
- automatic version update by autodist
* Sat Apr 13 2013 Automatic Build System <autodist@mambasoft.it> 3.8.0-1mamba
- automatic version update by autodist
* Sat Mar 23 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.6.2-2mamba
- rebuilt with systemd support; enable gdm service on install
* Wed Nov 14 2012 Automatic Build System <autodist@mambasoft.it> 3.6.2-1mamba
- automatic version update by autodist
* Mon Nov 05 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 3.6.1-3mamba
- patch more pam configuration files for openmamba
* Sun Oct 21 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 3.6.1-2mamba
- configure with redhat style pam files
* Tue Oct 16 2012 Automatic Build System <autodist@mambasoft.it> 3.6.1-1mamba
- automatic version update by autodist
* Thu Oct 04 2012 Automatic Build System <autodist@mambasoft.it> 3.6.0-1mamba
- automatic version update by autodist
* Sun Jul 29 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.1-2mamba
- added plymouth patch
* Sat Apr 14 2012 Automatic Build System <autodist@mambasoft.it> 3.4.1-1mamba
- automatic version update by autodist
* Sun Apr 01 2012 Automatic Build System <autodist@mambasoft.it> 3.4.0.1-1mamba
- automatic version update by autodist
* Thu Oct 20 2011 Automatic Build System <autodist@mambasoft.it> 3.2.1.1-1mamba
- automatic version update by autodist
* Mon Oct 03 2011 Automatic Build System <autodist@mambasoft.it> 3.2.0-1mamba
- automatic version update by autodist
* Mon Sep 26 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.4-2mamba
- use /var/lib/gdm as home path for gdm user
* Thu Jul 21 2011 Automatic Build System <autodist@mambasoft.it> 3.0.4-1mamba
- update to 3.0.4
* Sun May 22 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.32.1-6mamba
- register schemas using gconftool
* Sat May 21 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.32.1-5mamba
- remove pam_console from pam files
- require ConsoleKit
- added dirs /var/cache/gdm and /var/run/gdm
* Sat May 21 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.32.1-4mamba
- add /var/log/gdm with proper permissions
* Wed May 18 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.32.1-3mamba
- set gdm group permissions for /var/lib/gdm
* Tue May 17 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.32.1-2mamba
- create gdm user and group
* Wed Mar 30 2011 Automatic Build System <autodist@mambasoft.it> 2.32.1-1mamba
- update to 2.32.1
* Sat Mar 05 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.32.0-1mamba
- package created by autospec