automatic version update by autodist [release 16.1-1mamba;Mon Jan 20 2025]
This commit is contained in:
parent
e4b3ed6df3
commit
a44c738952
@ -1,11 +0,0 @@
|
||||
--- gdb/main.c.orig 2005-04-08 18:21:50.000000000 -0400
|
||||
+++ gdb/main.c 2005-04-08 18:50:58.000000000 -0400
|
||||
@@ -693,7 +693,7 @@
|
||||
|
||||
if (!homedir
|
||||
|| memcmp ((char *) &homebuf, (char *) &cwdbuf, sizeof (struct stat)))
|
||||
- if (!inhibit_gdbinit)
|
||||
+ if (!inhibit_gdbinit && (cwdbuf.st_uid == getuid()) && (!(cwdbuf.st_mode & (S_IWOTH))))
|
||||
{
|
||||
catch_command_errors (source_command, gdbinit, 0, RETURN_MASK_ALL);
|
||||
}
|
@ -1,23 +0,0 @@
|
||||
--- bfd/elfcode.h.orig 2005-05-04 19:34:52.000000000 -0400
|
||||
+++ bfd/elfcode.h 2005-05-04 19:37:35.000000000 -0400
|
||||
@@ -640,6 +640,9 @@
|
||||
Elf_Internal_Shdr *shdrp;
|
||||
unsigned int num_sec;
|
||||
|
||||
+ if (sizeof(*i_shdrp)*i_ehdrp->e_shnum/sizeof(*i_shdrp)!=i_ehdrp->e_shnum)
|
||||
+ goto got_no_match;
|
||||
+
|
||||
amt = sizeof (*i_shdrp) * i_ehdrp->e_shnum;
|
||||
i_shdrp = bfd_alloc (abfd, amt);
|
||||
if (!i_shdrp)
|
||||
@@ -647,6 +650,10 @@
|
||||
num_sec = i_ehdrp->e_shnum;
|
||||
if (num_sec > SHN_LORESERVE)
|
||||
num_sec += SHN_HIRESERVE + 1 - SHN_LORESERVE;
|
||||
+
|
||||
+ if (sizeof (i_shdrp) * num_sec/sizeof (i_shdrp) != num_sec)
|
||||
+ goto got_no_match;
|
||||
+
|
||||
elf_numsections (abfd) = num_sec;
|
||||
amt = sizeof (i_shdrp) * num_sec;
|
||||
elf_elfsections (abfd) = bfd_alloc (abfd, amt);
|
23
gdb.spec
23
gdb.spec
@ -5,7 +5,7 @@
|
||||
%endif
|
||||
|
||||
Name: gdb
|
||||
Version: 15.2
|
||||
Version: 16.1
|
||||
Release: 1mamba
|
||||
Summary: A GNU source-level debugger for C, C++, Java and other languages
|
||||
Group: Development/Tools
|
||||
@ -14,8 +14,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.gnu.org/savannah-checkouts/gnu/gdb/index.html
|
||||
Source: http://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.xz
|
||||
Patch0: %{name}-6.3-gentoo_bfd_malloc_wrap.patch
|
||||
Patch1: %{name}-6.3-gdbinit_stat.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -39,9 +37,6 @@ BuildRequires: bash
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gcc-fortran
|
||||
#%if "%{stage1}" != "1"
|
||||
#BuildRequires: gcc-java
|
||||
#%endif
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: libobjc-devel
|
||||
BuildRequires: libreadline-devel
|
||||
@ -69,15 +64,9 @@ Summary: Development files provided with gdb
|
||||
%description devel
|
||||
Development files provided with gdb.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p0 -b .gentoo_bfd_malloc_wrap
|
||||
#%patch1 -p0 -b .gdbinit_stat
|
||||
#rm -rf ./gdb/gdbserver
|
||||
|
||||
cat > gdb/version.in << EOF
|
||||
%{version}-%{release} (%{_target_vendor})
|
||||
@ -147,11 +136,7 @@ rm -f %{buildroot}%{_infodir}/dir
|
||||
%{_bindir}/gdb
|
||||
%{_bindir}/gdb-add-index
|
||||
%{_bindir}/gdbserver
|
||||
#%{_bindir}/gdbtui
|
||||
#%ifarch aarch64
|
||||
#%{_bindir}/run
|
||||
#%{_libdir}/lib%{_host}-sim.a
|
||||
#%endif
|
||||
%{_bindir}/gstack
|
||||
%ifnarch arm
|
||||
%{_libdir}/libinproctrace.so
|
||||
%endif
|
||||
@ -176,6 +161,7 @@ rm -f %{buildroot}%{_infodir}/dir
|
||||
%{_mandir}/man1/gdb-add-index.1*
|
||||
%{_mandir}/man1/gdbserver.*
|
||||
%{_mandir}/man5/gdbinit.5*
|
||||
%{_mandir}/man1/gstack.1*
|
||||
%doc COPYING COPYING.LIB
|
||||
#README gdb/NEWS
|
||||
|
||||
@ -185,6 +171,9 @@ rm -f %{buildroot}%{_infodir}/dir
|
||||
%{_infodir}/sframe-spec.info*
|
||||
|
||||
%changelog
|
||||
* Mon Jan 20 2025 Automatic Build System <autodist@openmamba.org> 16.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Sep 29 2024 Automatic Build System <autodist@openmamba.org> 15.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user