automatic version update by autodist [release 7.7.1-1mamba;Fri May 09 2014]

This commit is contained in:
Automatic Build System 2024-01-05 22:39:22 +01:00
parent 7534018fd6
commit 2038d23a2f
4 changed files with 270 additions and 0 deletions

View File

@ -1,2 +1,13 @@
# gdb # gdb
GDB, the GNU Project debugger, allows you to see what is going on `inside' another program while it executes.
GDB can do four main kinds of things (plus other things in support of these) to help you catch bugs in the act:
* Start your program, specifying anything that might affect its behavior.
* Make your program stop on specified conditions.
* Examine what has happened, when your program has stopped.
* Change things in your program, so you can experiment with correcting the effects of one bug and go on to learn about another.
The program being debugged can be written in Ada, C, C++, Objective-C, Pascal (and many other languages).
Those programs might be executing on the same machine as GDB (native) or on another machine (remote).
If you are going to develop C and/or C++ programs and use the GNU gcc compiler, you may want to install gdb to help you debug your programs.

View File

@ -0,0 +1,11 @@
--- gdb/main.c.orig 2005-04-08 18:21:50.000000000 -0400
+++ gdb/main.c 2005-04-08 18:50:58.000000000 -0400
@@ -693,7 +693,7 @@
if (!homedir
|| memcmp ((char *) &homebuf, (char *) &cwdbuf, sizeof (struct stat)))
- if (!inhibit_gdbinit)
+ if (!inhibit_gdbinit && (cwdbuf.st_uid == getuid()) && (!(cwdbuf.st_mode & (S_IWOTH))))
{
catch_command_errors (source_command, gdbinit, 0, RETURN_MASK_ALL);
}

View File

@ -0,0 +1,23 @@
--- bfd/elfcode.h.orig 2005-05-04 19:34:52.000000000 -0400
+++ bfd/elfcode.h 2005-05-04 19:37:35.000000000 -0400
@@ -640,6 +640,9 @@
Elf_Internal_Shdr *shdrp;
unsigned int num_sec;
+ if (sizeof(*i_shdrp)*i_ehdrp->e_shnum/sizeof(*i_shdrp)!=i_ehdrp->e_shnum)
+ goto got_no_match;
+
amt = sizeof (*i_shdrp) * i_ehdrp->e_shnum;
i_shdrp = bfd_alloc (abfd, amt);
if (!i_shdrp)
@@ -647,6 +650,10 @@
num_sec = i_ehdrp->e_shnum;
if (num_sec > SHN_LORESERVE)
num_sec += SHN_HIRESERVE + 1 - SHN_LORESERVE;
+
+ if (sizeof (i_shdrp) * num_sec/sizeof (i_shdrp) != num_sec)
+ goto got_no_match;
+
elf_numsections (abfd) = num_sec;
amt = sizeof (i_shdrp) * num_sec;
elf_elfsections (abfd) = bfd_alloc (abfd, amt);

225
gdb.spec Normal file
View File

@ -0,0 +1,225 @@
%if %{_target_cpu} == %{_build_cpu}
%define name gcc
%else
%define name cross-%{_target_cpu}-gcc
%endif
Name: gdb
Version: 7.7.1
Release: 1mamba
Summary: A GNU source-level debugger for C, C++, Java and other languages
Group: Development/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Aleph0 <aleph0@openmamba.org>
URL: http://www.gnu.org/software/gdb/gdb.html
Source: http://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.bz2
Patch0: %{name}-6.3-gentoo_bfd_malloc_wrap.patch
Patch1: %{name}-6.3-gdbinit_stat.patch
License: GPL
BuildRequires: bash
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: gcc-fortran
%if "%{stage1}" != "1"
BuildRequires: gcc-java
%endif
BuildRequires: gettext-devel
BuildRequires: glibc-devel
BuildRequires: libobjc-devel
BuildRequires: libexpat-devel
BuildRequires: libncurses-devel
BuildRequires: libreadline-devel
BuildRequires: texinfo
Requires(post):%{__install_info}
Requires: glibc-debug
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
GDB, the GNU Project debugger, allows you to see what is going on `inside' another program while it executes.
GDB can do four main kinds of things (plus other things in support of these) to help you catch bugs in the act:
* Start your program, specifying anything that might affect its behavior.
* Make your program stop on specified conditions.
* Examine what has happened, when your program has stopped.
* Change things in your program, so you can experiment with correcting the effects of one bug and go on to learn about another.
The program being debugged can be written in Ada, C, C++, Objective-C, Pascal (and many other languages).
Those programs might be executing on the same machine as GDB (native) or on another machine (remote).
If you are going to develop C and/or C++ programs and use the GNU gcc compiler, you may want to install gdb to help you debug your programs.
%prep
%setup -q
#%patch0 -p0 -b .gentoo_bfd_malloc_wrap
#%patch1 -p0 -b .gdbinit_stat
#rm -rf ./gdb/gdbserver
cat > gdb/version.in << EOF
%{version}-%{release} (%{_target_vendor})
EOF
%build
%configure \
--with-separate-debug-dir=%{_prefix}/lib/debug \
--host=%{_target_platform} \
--build=%{_target_platform} \
--disable-rpath \
CFLAGS="${CFLAGS/ / }" \
CXXFLAGS="${CFLAGS/ / }" \
FFLAGS="${CFLAGS/ / }"
# --with-system-readline \
%make
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall
## install the gcore script in /usr/bin
#install -m 755 gdb/gdb_gcore.sh %{buildroot}%{_bindir}/gcore
# these are part of binutils and libbinutils
rm -f %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/{bfd,opcodes}.mo
rm -fr %{buildroot}%{_includedir}
rm -f %{buildroot}%{_infodir}/{bfd*,configure*,standard*}
rm -f %{buildroot}%{_libdir}/lib{bfd*,iberty*,opcodes*}
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%post
%install_info annotate.info
%install_info gdb.info
%install_info gdbint.info
%install_info stabs.info
exit 0
%preun
%uninstall_info annotate.info
%uninstall_info gdb.info
%uninstall_info gdbint.info
%uninstall_info stabs.info
exit 0
%files
%defattr(-,root,root)
%{_bindir}/gcore
%{_bindir}/gdb
%{_bindir}/gdbserver
#%{_bindir}/gdbtui
%ifarch arm
%{_bindir}/run
%{_mandir}/man1/run.1*
%{_libdir}/lib%{_host}-sim.a
%else
%{_libdir}/libinproctrace.so
%endif
%dir %{_datadir}/gdb
%dir %{_datadir}/gdb/python
%dir %{_datadir}/gdb/python/gdb
%{_datadir}/gdb/python/gdb/*
%dir %{_datadir}/gdb/syscalls
%{_datadir}/gdb/syscalls/amd64-linux.xml
%{_datadir}/gdb/syscalls/arm-linux.xml
%{_datadir}/gdb/syscalls/gdb-syscalls.dtd
%{_datadir}/gdb/syscalls/i386-linux.xml
%{_datadir}/gdb/syscalls/mips-n32-linux.xml
%{_datadir}/gdb/syscalls/mips-n64-linux.xml
%{_datadir}/gdb/syscalls/mips-o32-linux.xml
%{_datadir}/gdb/syscalls/ppc-linux.xml
%{_datadir}/gdb/syscalls/ppc64-linux.xml
%{_datadir}/gdb/syscalls/sparc-linux.xml
%{_datadir}/gdb/syscalls/sparc64-linux.xml
%dir %{_datadir}/gdb/system-gdbinit
%{_datadir}/gdb/system-gdbinit/elinos.py
%{_datadir}/gdb/system-gdbinit/wrs-linux.py
%{_mandir}/man1/gcore.1*
%{_mandir}/man5/gdbinit.5*
%{_infodir}/annotate.info*
%{_infodir}/gdb.info*
#%{_infodir}/gdbint.info*
%{_infodir}/stabs.info*
%{_mandir}/man1/gcore.1*
%{_mandir}/man1/gdb.*
%{_mandir}/man1/gdbserver.*
%{_mandir}/man5/gdbinit.5*
%doc COPYING COPYING.LIB
#README gdb/NEWS
%changelog
* Fri May 09 2014 Automatic Build System <autodist@mambasoft.it> 7.7.1-1mamba
- automatic version update by autodist
* Sat Feb 15 2014 Automatic Build System <autodist@mambasoft.it> 7.7-1mamba
- automatic version update by autodist
* Sun Dec 15 2013 Automatic Build System <autodist@mambasoft.it> 7.6.2-1mamba
- automatic update by autodist
* Sat Aug 31 2013 Automatic Build System <autodist@mambasoft.it> 7.6.1-1mamba
- automatic version update by autodist
* Sat Jun 01 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 7.6-2mamba
- python 2.7 mass rebuild
* Mon Apr 29 2013 Automatic Build System <autodist@mambasoft.it> 7.6-1mamba
- update to 7.6
* Sat Dec 29 2012 Automatic Build System <autodist@mambasoft.it> 7.5.1-1mamba
- automatic version update by autodist
* Sun Sep 09 2012 Automatic Build System <autodist@mambasoft.it> 7.5-1mamba
- automatic version update by autodist
* Fri Jun 15 2012 Automatic Build System <autodist@mambasoft.it> 7.4.1-1mamba
- automatic version update by autodist
* Tue Oct 04 2011 Automatic Build System <autodist@mambasoft.it> 7.3.1-1mamba
- automatic version update by autodist
* Sat Aug 13 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 7.3-2mamba
- added requirement for glibc-debug
* Sun Aug 07 2011 Automatic Build System <autodist@mambasoft.it> 7.3-1mamba
- automatic version update by autodist
* Mon Jan 31 2011 Automatic Build System <autodist@mambasoft.it> 7.2-1mamba
- automatic update by autodist
* Sat Apr 17 2010 Automatic Build System <autodist@mambasoft.it> 7.1-1mamba
- automatic update by autodist
* Wed Jan 20 2010 Automatic Build System <autodist@mambasoft.it> 7.0.1-1mamba
- automatic update by autodist
* Tue Oct 13 2009 Automatic Build System <autodist@mambasoft.it> 7.0-1mamba
- automatic update by autodist
* Wed Apr 08 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 6.8-1mamba
- automatic update by autodist
* Tue Jan 08 2008 Aleph0 <aleph0@openmamba.org> 6.7.1-1mamba
- update to 6.7.1
- new package maintainer
- do not remove gdbserver binary and related manpage
- install the gcore shell script
* Tue Mar 27 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 6.6-1qilnx
- update to version 6.6 by autospec
* Wed Jun 28 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 6.5-1qilnx
- update to version 6.5 by autospec
* Wed Nov 09 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 6.3-4qilnx
- rebuilt with gcc4
* Thu Jul 14 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 6.3-3qilnx
- rebuilt with given host platform ( = target platform)
* Wed Jun 08 2005 Davide Madrisan <davide.madrisan@qilinux.it> 6.3-2qilnx
- security fixes QSA-2005-071 (CAN-2005-1704, CAN-2005-1705)
* Tue Nov 16 2004 Davide Madrisan <davide.madrisan@qilinux.it> 6.3-1qilnx
- update to version 6.3 by autospec
* Tue Oct 19 2004 Davide Madrisan <davide.madrisan@qilinux.it> 6.2.1-1qilnx
- package created by autospec