rebuilt by autoport with build requirements: libopenjpeg-devel>=2.1.0-1mamba [release 1.11.0-2mamba;Sat Aug 09 2014]
This commit is contained in:
parent
9d0f923681
commit
d007b12d9b
92
gdal-1.11.0-json-c-0.12.patch
Normal file
92
gdal-1.11.0-json-c-0.12.patch
Normal file
@ -0,0 +1,92 @@
|
|||||||
|
--- gdal-1.11.0/frmts/mbtiles/mbtilesdataset.cpp.orig 2014-08-09 11:17:06.899414798 +0200
|
||||||
|
+++ gdal-1.11.0/frmts/mbtiles/mbtilesdataset.cpp 2014-08-09 11:18:47.629528670 +0200
|
||||||
|
@@ -620,7 +620,7 @@
|
||||||
|
{
|
||||||
|
CPLError( CE_Failure, CPLE_AppDefined,
|
||||||
|
"JSON parsing error: %s (at offset %d)",
|
||||||
|
- json_tokener_errors[jstok->err],
|
||||||
|
+ json_tokener_get_error(jstok),
|
||||||
|
jstok->char_offset);
|
||||||
|
json_tokener_free(jstok);
|
||||||
|
|
||||||
|
diff -ru gdal-1.11.0.orig/ogr/ogrsf_frmts/cartodb/ogrcartodbdatasource.cpp gdal-1.11.0/ogr/ogrsf_frmts/cartodb/ogrcartodbdatasource.cpp
|
||||||
|
--- gdal-1.11.0.orig/ogr/ogrsf_frmts/cartodb/ogrcartodbdatasource.cpp 2014-04-16 22:04:31.000000000 +0200
|
||||||
|
+++ gdal-1.11.0/ogr/ogrsf_frmts/cartodb/ogrcartodbdatasource.cpp 2014-08-09 11:29:48.651275930 +0200
|
||||||
|
@@ -504,7 +504,7 @@
|
||||||
|
{
|
||||||
|
CPLError( CE_Failure, CPLE_AppDefined,
|
||||||
|
"JSON parsing error: %s (at offset %d)",
|
||||||
|
- json_tokener_errors[jstok->err], jstok->char_offset);
|
||||||
|
+ json_tokener_get_error(jstok), jstok->char_offset);
|
||||||
|
json_tokener_free(jstok);
|
||||||
|
CPLHTTPDestroyResult(psResult);
|
||||||
|
return NULL;
|
||||||
|
diff -ru gdal-1.11.0.orig/ogr/ogrsf_frmts/couchdb/ogrcouchdbdatasource.cpp gdal-1.11.0/ogr/ogrsf_frmts/couchdb/ogrcouchdbdatasource.cpp
|
||||||
|
--- gdal-1.11.0.orig/ogr/ogrsf_frmts/couchdb/ogrcouchdbdatasource.cpp 2014-04-16 22:04:02.000000000 +0200
|
||||||
|
+++ gdal-1.11.0/ogr/ogrsf_frmts/couchdb/ogrcouchdbdatasource.cpp 2014-08-09 11:28:18.735174283 +0200
|
||||||
|
@@ -1078,7 +1078,7 @@
|
||||||
|
{
|
||||||
|
CPLError( CE_Failure, CPLE_AppDefined,
|
||||||
|
"JSON parsing error: %s (at offset %d)",
|
||||||
|
- json_tokener_errors[jstok->err], jstok->char_offset);
|
||||||
|
+ json_tokener_get_error(jstok), jstok->char_offset);
|
||||||
|
|
||||||
|
json_tokener_free(jstok);
|
||||||
|
|
||||||
|
diff -ru gdal-1.11.0.orig/ogr/ogrsf_frmts/geojson/ogresrijsonreader.cpp gdal-1.11.0/ogr/ogrsf_frmts/geojson/ogresrijsonreader.cpp
|
||||||
|
--- gdal-1.11.0.orig/ogr/ogrsf_frmts/geojson/ogresrijsonreader.cpp 2014-04-16 22:04:30.000000000 +0200
|
||||||
|
+++ gdal-1.11.0/ogr/ogrsf_frmts/geojson/ogresrijsonreader.cpp 2014-08-09 11:29:28.135252737 +0200
|
||||||
|
@@ -78,7 +78,7 @@
|
||||||
|
{
|
||||||
|
CPLError( CE_Failure, CPLE_AppDefined,
|
||||||
|
"ESRIJSON parsing error: %s (at offset %d)",
|
||||||
|
- json_tokener_errors[jstok->err], jstok->char_offset);
|
||||||
|
+ json_tokener_get_error(jstok), jstok->char_offset);
|
||||||
|
|
||||||
|
json_tokener_free(jstok);
|
||||||
|
return OGRERR_CORRUPT_DATA;
|
||||||
|
diff -ru gdal-1.11.0.orig/ogr/ogrsf_frmts/geojson/ogrgeojsonreader.cpp gdal-1.11.0/ogr/ogrsf_frmts/geojson/ogrgeojsonreader.cpp
|
||||||
|
--- gdal-1.11.0.orig/ogr/ogrsf_frmts/geojson/ogrgeojsonreader.cpp 2014-04-16 22:04:30.000000000 +0200
|
||||||
|
+++ gdal-1.11.0/ogr/ogrsf_frmts/geojson/ogrgeojsonreader.cpp 2014-08-09 11:28:50.916210662 +0200
|
||||||
|
@@ -77,7 +77,7 @@
|
||||||
|
{
|
||||||
|
CPLError( CE_Failure, CPLE_AppDefined,
|
||||||
|
"GeoJSON parsing error: %s (at offset %d)",
|
||||||
|
- json_tokener_errors[jstok->err], jstok->char_offset);
|
||||||
|
+ json_tokener_get_error(jstok), jstok->char_offset);
|
||||||
|
|
||||||
|
json_tokener_free(jstok);
|
||||||
|
return OGRERR_CORRUPT_DATA;
|
||||||
|
@@ -1516,7 +1516,7 @@
|
||||||
|
{
|
||||||
|
CPLError( CE_Failure, CPLE_AppDefined,
|
||||||
|
"GeoJSON parsing error: %s (at offset %d)",
|
||||||
|
- json_tokener_errors[jstok->err], jstok->char_offset);
|
||||||
|
+ json_tokener_get_error(jstok), jstok->char_offset);
|
||||||
|
json_tokener_free(jstok);
|
||||||
|
return NULL;
|
||||||
|
}
|
||||||
|
diff -ru gdal-1.11.0.orig/ogr/ogrsf_frmts/geojson/ogrtopojsonreader.cpp gdal-1.11.0/ogr/ogrsf_frmts/geojson/ogrtopojsonreader.cpp
|
||||||
|
--- gdal-1.11.0.orig/ogr/ogrsf_frmts/geojson/ogrtopojsonreader.cpp 2014-04-16 22:04:30.000000000 +0200
|
||||||
|
+++ gdal-1.11.0/ogr/ogrsf_frmts/geojson/ogrtopojsonreader.cpp 2014-08-09 11:29:09.560231739 +0200
|
||||||
|
@@ -74,7 +74,7 @@
|
||||||
|
{
|
||||||
|
CPLError( CE_Failure, CPLE_AppDefined,
|
||||||
|
"TopoJSON parsing error: %s (at offset %d)",
|
||||||
|
- json_tokener_errors[jstok->err], jstok->char_offset);
|
||||||
|
+ json_tokener_get_error(jstok), jstok->char_offset);
|
||||||
|
|
||||||
|
json_tokener_free(jstok);
|
||||||
|
return OGRERR_CORRUPT_DATA;
|
||||||
|
diff -ru gdal-1.11.0.orig/ogr/ogrsf_frmts/gme/ogrgmejson.cpp gdal-1.11.0/ogr/ogrsf_frmts/gme/ogrgmejson.cpp
|
||||||
|
--- gdal-1.11.0.orig/ogr/ogrsf_frmts/gme/ogrgmejson.cpp 2014-04-16 22:04:30.000000000 +0200
|
||||||
|
+++ gdal-1.11.0/ogr/ogrsf_frmts/gme/ogrgmejson.cpp 2014-08-09 11:30:02.216291264 +0200
|
||||||
|
@@ -511,7 +511,7 @@
|
||||||
|
{
|
||||||
|
CPLError( CE_Failure, CPLE_AppDefined,
|
||||||
|
"JSON parsing error: %s (at offset %d)",
|
||||||
|
- json_tokener_errors[jstok->err], jstok->char_offset);
|
||||||
|
+ json_tokener_get_error(jstok), jstok->char_offset);
|
||||||
|
|
||||||
|
json_tokener_free(jstok);
|
||||||
|
return NULL;
|
23
gdal.spec
23
gdal.spec
@ -1,6 +1,6 @@
|
|||||||
Name: gdal
|
Name: gdal
|
||||||
Version: 1.11.0
|
Version: 1.11.0
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A translator library for raster geospatial data formats
|
Summary: A translator library for raster geospatial data formats
|
||||||
Group: System/Tools
|
Group: System/Tools
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,6 +8,7 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.gdal.org/
|
URL: http://www.gdal.org/
|
||||||
Source: http://download.osgeo.org/gdal/%{version}/gdal-%{version}.tar.xz
|
Source: http://download.osgeo.org/gdal/%{version}/gdal-%{version}.tar.xz
|
||||||
|
Patch0: gdal-1.11.0-json-c-0.12.patch
|
||||||
License: MIT
|
License: MIT
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -22,35 +23,31 @@ BuildRequires: libgif-devel
|
|||||||
BuildRequires: libgpg-error-devel
|
BuildRequires: libgpg-error-devel
|
||||||
BuildRequires: libgss-devel
|
BuildRequires: libgss-devel
|
||||||
BuildRequires: libhdf5-devel
|
BuildRequires: libhdf5-devel
|
||||||
BuildRequires: libICE-devel
|
|
||||||
BuildRequires: libicu-devel
|
BuildRequires: libicu-devel
|
||||||
BuildRequires: libidn-devel
|
BuildRequires: libidn-devel
|
||||||
BuildRequires: libjasper-devel
|
BuildRequires: libjasper-devel
|
||||||
BuildRequires: libjbig-devel
|
BuildRequires: libjbig-devel
|
||||||
BuildRequires: libjpeg-devel
|
BuildRequires: libjpeg-devel
|
||||||
|
BuildRequires: libjson-c-devel
|
||||||
BuildRequires: libltdl-devel
|
BuildRequires: libltdl-devel
|
||||||
BuildRequires: liblzma-devel
|
BuildRequires: liblzma-devel
|
||||||
BuildRequires: libodbc-devel
|
BuildRequires: libodbc-devel
|
||||||
BuildRequires: libopenldap-devel
|
BuildRequires: libopenldap-devel
|
||||||
BuildRequires: libopenssl-devel
|
BuildRequires: libopenssl-devel
|
||||||
|
BuildRequires: libpcre-devel
|
||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: libpostgresql-devel
|
BuildRequires: libpostgresql-devel
|
||||||
BuildRequires: libpthread-stubs-devel
|
|
||||||
BuildRequires: librtmp-devel
|
BuildRequires: librtmp-devel
|
||||||
BuildRequires: libsasl-devel
|
BuildRequires: libsasl-devel
|
||||||
BuildRequires: libSM-devel
|
|
||||||
BuildRequires: libsqlite-devel
|
BuildRequires: libsqlite-devel
|
||||||
BuildRequires: libssh2-devel
|
BuildRequires: libssh2-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libtiff-devel
|
BuildRequires: libtiff-devel
|
||||||
BuildRequires: libuuid-devel
|
|
||||||
BuildRequires: libX11-devel
|
|
||||||
BuildRequires: libXau-devel
|
|
||||||
BuildRequires: libxcb-devel
|
|
||||||
BuildRequires: libXdmcp-devel
|
|
||||||
BuildRequires: libxerces-c-devel
|
BuildRequires: libxerces-c-devel
|
||||||
|
BuildRequires: libxml2-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libopenjpeg-devel >= 2.1.0-1mamba
|
||||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
@ -68,17 +65,16 @@ This package contains shared libraries for %{name}.
|
|||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Summary: Development files for %{name}
|
Summary: Development files for %{name}
|
||||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
## note: you can add this requirement if .pc files are provided by this package
|
Requires: pkg-config
|
||||||
#Requires: pkg-config
|
|
||||||
|
|
||||||
%description -n lib%{name}-devel
|
%description -n lib%{name}-devel
|
||||||
This package contains libraries and header files for developing applications that use %{name}.
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -140,6 +136,9 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%doc NEWS
|
%doc NEWS
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Aug 09 2014 Automatic Build System <autodist@mambasoft.it> 1.11.0-2mamba
|
||||||
|
- rebuilt by autoport with build requirements: libopenjpeg-devel>=2.1.0-1mamba
|
||||||
|
|
||||||
* Sun May 11 2014 Automatic Build System <autodist@mambasoft.it> 1.11.0-1mamba
|
* Sun May 11 2014 Automatic Build System <autodist@mambasoft.it> 1.11.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user