automatic version update by autodist [release 3.8.3-1mamba;Mon Jan 08 2024]
This commit is contained in:
parent
1fa32c5e1c
commit
502dc5d51d
@ -1,92 +0,0 @@
|
|||||||
--- gdal-1.11.0/frmts/mbtiles/mbtilesdataset.cpp.orig 2014-08-09 11:17:06.899414798 +0200
|
|
||||||
+++ gdal-1.11.0/frmts/mbtiles/mbtilesdataset.cpp 2014-08-09 11:18:47.629528670 +0200
|
|
||||||
@@ -620,7 +620,7 @@
|
|
||||||
{
|
|
||||||
CPLError( CE_Failure, CPLE_AppDefined,
|
|
||||||
"JSON parsing error: %s (at offset %d)",
|
|
||||||
- json_tokener_errors[jstok->err],
|
|
||||||
+ json_tokener_get_error(jstok),
|
|
||||||
jstok->char_offset);
|
|
||||||
json_tokener_free(jstok);
|
|
||||||
|
|
||||||
diff -ru gdal-1.11.0.orig/ogr/ogrsf_frmts/cartodb/ogrcartodbdatasource.cpp gdal-1.11.0/ogr/ogrsf_frmts/cartodb/ogrcartodbdatasource.cpp
|
|
||||||
--- gdal-1.11.0.orig/ogr/ogrsf_frmts/cartodb/ogrcartodbdatasource.cpp 2014-04-16 22:04:31.000000000 +0200
|
|
||||||
+++ gdal-1.11.0/ogr/ogrsf_frmts/cartodb/ogrcartodbdatasource.cpp 2014-08-09 11:29:48.651275930 +0200
|
|
||||||
@@ -504,7 +504,7 @@
|
|
||||||
{
|
|
||||||
CPLError( CE_Failure, CPLE_AppDefined,
|
|
||||||
"JSON parsing error: %s (at offset %d)",
|
|
||||||
- json_tokener_errors[jstok->err], jstok->char_offset);
|
|
||||||
+ json_tokener_get_error(jstok), jstok->char_offset);
|
|
||||||
json_tokener_free(jstok);
|
|
||||||
CPLHTTPDestroyResult(psResult);
|
|
||||||
return NULL;
|
|
||||||
diff -ru gdal-1.11.0.orig/ogr/ogrsf_frmts/couchdb/ogrcouchdbdatasource.cpp gdal-1.11.0/ogr/ogrsf_frmts/couchdb/ogrcouchdbdatasource.cpp
|
|
||||||
--- gdal-1.11.0.orig/ogr/ogrsf_frmts/couchdb/ogrcouchdbdatasource.cpp 2014-04-16 22:04:02.000000000 +0200
|
|
||||||
+++ gdal-1.11.0/ogr/ogrsf_frmts/couchdb/ogrcouchdbdatasource.cpp 2014-08-09 11:28:18.735174283 +0200
|
|
||||||
@@ -1078,7 +1078,7 @@
|
|
||||||
{
|
|
||||||
CPLError( CE_Failure, CPLE_AppDefined,
|
|
||||||
"JSON parsing error: %s (at offset %d)",
|
|
||||||
- json_tokener_errors[jstok->err], jstok->char_offset);
|
|
||||||
+ json_tokener_get_error(jstok), jstok->char_offset);
|
|
||||||
|
|
||||||
json_tokener_free(jstok);
|
|
||||||
|
|
||||||
diff -ru gdal-1.11.0.orig/ogr/ogrsf_frmts/geojson/ogresrijsonreader.cpp gdal-1.11.0/ogr/ogrsf_frmts/geojson/ogresrijsonreader.cpp
|
|
||||||
--- gdal-1.11.0.orig/ogr/ogrsf_frmts/geojson/ogresrijsonreader.cpp 2014-04-16 22:04:30.000000000 +0200
|
|
||||||
+++ gdal-1.11.0/ogr/ogrsf_frmts/geojson/ogresrijsonreader.cpp 2014-08-09 11:29:28.135252737 +0200
|
|
||||||
@@ -78,7 +78,7 @@
|
|
||||||
{
|
|
||||||
CPLError( CE_Failure, CPLE_AppDefined,
|
|
||||||
"ESRIJSON parsing error: %s (at offset %d)",
|
|
||||||
- json_tokener_errors[jstok->err], jstok->char_offset);
|
|
||||||
+ json_tokener_get_error(jstok), jstok->char_offset);
|
|
||||||
|
|
||||||
json_tokener_free(jstok);
|
|
||||||
return OGRERR_CORRUPT_DATA;
|
|
||||||
diff -ru gdal-1.11.0.orig/ogr/ogrsf_frmts/geojson/ogrgeojsonreader.cpp gdal-1.11.0/ogr/ogrsf_frmts/geojson/ogrgeojsonreader.cpp
|
|
||||||
--- gdal-1.11.0.orig/ogr/ogrsf_frmts/geojson/ogrgeojsonreader.cpp 2014-04-16 22:04:30.000000000 +0200
|
|
||||||
+++ gdal-1.11.0/ogr/ogrsf_frmts/geojson/ogrgeojsonreader.cpp 2014-08-09 11:28:50.916210662 +0200
|
|
||||||
@@ -77,7 +77,7 @@
|
|
||||||
{
|
|
||||||
CPLError( CE_Failure, CPLE_AppDefined,
|
|
||||||
"GeoJSON parsing error: %s (at offset %d)",
|
|
||||||
- json_tokener_errors[jstok->err], jstok->char_offset);
|
|
||||||
+ json_tokener_get_error(jstok), jstok->char_offset);
|
|
||||||
|
|
||||||
json_tokener_free(jstok);
|
|
||||||
return OGRERR_CORRUPT_DATA;
|
|
||||||
@@ -1516,7 +1516,7 @@
|
|
||||||
{
|
|
||||||
CPLError( CE_Failure, CPLE_AppDefined,
|
|
||||||
"GeoJSON parsing error: %s (at offset %d)",
|
|
||||||
- json_tokener_errors[jstok->err], jstok->char_offset);
|
|
||||||
+ json_tokener_get_error(jstok), jstok->char_offset);
|
|
||||||
json_tokener_free(jstok);
|
|
||||||
return NULL;
|
|
||||||
}
|
|
||||||
diff -ru gdal-1.11.0.orig/ogr/ogrsf_frmts/geojson/ogrtopojsonreader.cpp gdal-1.11.0/ogr/ogrsf_frmts/geojson/ogrtopojsonreader.cpp
|
|
||||||
--- gdal-1.11.0.orig/ogr/ogrsf_frmts/geojson/ogrtopojsonreader.cpp 2014-04-16 22:04:30.000000000 +0200
|
|
||||||
+++ gdal-1.11.0/ogr/ogrsf_frmts/geojson/ogrtopojsonreader.cpp 2014-08-09 11:29:09.560231739 +0200
|
|
||||||
@@ -74,7 +74,7 @@
|
|
||||||
{
|
|
||||||
CPLError( CE_Failure, CPLE_AppDefined,
|
|
||||||
"TopoJSON parsing error: %s (at offset %d)",
|
|
||||||
- json_tokener_errors[jstok->err], jstok->char_offset);
|
|
||||||
+ json_tokener_get_error(jstok), jstok->char_offset);
|
|
||||||
|
|
||||||
json_tokener_free(jstok);
|
|
||||||
return OGRERR_CORRUPT_DATA;
|
|
||||||
diff -ru gdal-1.11.0.orig/ogr/ogrsf_frmts/gme/ogrgmejson.cpp gdal-1.11.0/ogr/ogrsf_frmts/gme/ogrgmejson.cpp
|
|
||||||
--- gdal-1.11.0.orig/ogr/ogrsf_frmts/gme/ogrgmejson.cpp 2014-04-16 22:04:30.000000000 +0200
|
|
||||||
+++ gdal-1.11.0/ogr/ogrsf_frmts/gme/ogrgmejson.cpp 2014-08-09 11:30:02.216291264 +0200
|
|
||||||
@@ -511,7 +511,7 @@
|
|
||||||
{
|
|
||||||
CPLError( CE_Failure, CPLE_AppDefined,
|
|
||||||
"JSON parsing error: %s (at offset %d)",
|
|
||||||
- json_tokener_errors[jstok->err], jstok->char_offset);
|
|
||||||
+ json_tokener_get_error(jstok), jstok->char_offset);
|
|
||||||
|
|
||||||
json_tokener_free(jstok);
|
|
||||||
return NULL;
|
|
57
gdal.spec
57
gdal.spec
@ -1,5 +1,5 @@
|
|||||||
Name: gdal
|
Name: gdal
|
||||||
Version: 3.6.4
|
Version: 3.8.3
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A translator library for raster geospatial data formats
|
Summary: A translator library for raster geospatial data formats
|
||||||
Group: System/Tools
|
Group: System/Tools
|
||||||
@ -8,11 +8,10 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://gdal.org/
|
URL: https://gdal.org/
|
||||||
Source: http://download.osgeo.org/gdal/%{version}/gdal-%{version}.tar.xz
|
Source: http://download.osgeo.org/gdal/%{version}/gdal-%{version}.tar.xz
|
||||||
Patch0: gdal-1.11.0-json-c-0.12.patch
|
|
||||||
License: MIT
|
License: MIT
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libbsd-devel
|
BuildRequires: libarchive-devel
|
||||||
BuildRequires: libcfitsio-devel
|
BuildRequires: libcfitsio-devel
|
||||||
BuildRequires: libcryptopp-devel
|
BuildRequires: libcryptopp-devel
|
||||||
BuildRequires: libcurl-devel
|
BuildRequires: libcurl-devel
|
||||||
@ -41,7 +40,7 @@ BuildRequires: libpodofo-devel
|
|||||||
BuildRequires: libpoppler-devel
|
BuildRequires: libpoppler-devel
|
||||||
BuildRequires: libpostgresql-devel
|
BuildRequires: libpostgresql-devel
|
||||||
BuildRequires: libproj-devel
|
BuildRequires: libproj-devel
|
||||||
BuildRequires: libpython310-devel
|
BuildRequires: libpython311-devel
|
||||||
BuildRequires: libqhull-devel
|
BuildRequires: libqhull-devel
|
||||||
BuildRequires: libsqlite-devel
|
BuildRequires: libsqlite-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
@ -53,12 +52,16 @@ BuildRequires: libxml2-devel
|
|||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: libzstd-devel
|
BuildRequires: libzstd-devel
|
||||||
BuildRequires: mono-devel
|
BuildRequires: mono-devel
|
||||||
|
BuildRequires: ocl-icd-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libpodofo-devel >= 0.10.2-1mamba
|
||||||
BuildRequires: libjxl-devel >= 0.8.1
|
BuildRequires: libjxl-devel >= 0.8.1
|
||||||
BuildRequires: libqhull-devel >= 2015-1mamba
|
BuildRequires: libqhull-devel >= 2015-1mamba
|
||||||
BuildRequires: libopenjpeg-devel >= 2.1.0-1mamba
|
BuildRequires: libopenjpeg-devel >= 2.1.0-1mamba
|
||||||
BuildRequires: libproj-devel >= 9.1.1
|
BuildRequires: libproj-devel >= 9.1.1
|
||||||
BuildRequires: libcfitsio-devel >= 4.1.0
|
BuildRequires: libcfitsio-devel >= 4.1.0
|
||||||
|
BuildRequires: javapackages
|
||||||
|
BuildRequires: java-openjdk17
|
||||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -108,12 +111,16 @@ This package contains the C-sharp bindings to %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
#-D -T
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
export JAVA_HOME=%{_jvmdir}/java-11
|
||||||
|
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
-DCMAKE_CXX_STANDARD=17 \
|
-DCMAKE_CXX_STANDARD=17 \
|
||||||
-DCMAKE_CXX_FLAGS="%{optflags} -std=c++17" \
|
-DCMAKE_CXX_FLAGS="%{optflags} -std=c++17" \
|
||||||
|
-DPython_EXECUTABLE=%{__python3} \
|
||||||
|
-DPython_INCLUDEDIR=%{python3_inc} \
|
||||||
%ifarch %{ix86}
|
%ifarch %{ix86}
|
||||||
-DGDAL_ENABLE_DRIVER_FITS=OFF
|
-DGDAL_ENABLE_DRIVER_FITS=OFF
|
||||||
%endif
|
%endif
|
||||||
@ -156,16 +163,14 @@ This package contains the C-sharp bindings to %{name}.
|
|||||||
%{_libdir}/cmake/gdal/GDAL*.cmake
|
%{_libdir}/cmake/gdal/GDAL*.cmake
|
||||||
#%doc NEWS
|
#%doc NEWS
|
||||||
|
|
||||||
%ifnarch aarch64
|
|
||||||
%files -n python-%{name}
|
%files -n python-%{name}
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{python310_sitearch}/GDAL-%{version}-py*.egg-info
|
%dir %{python3_sitearch}/GDAL-%{version}-py*.egg-info
|
||||||
%{python310_sitearch}/GDAL-%{version}-py*.egg-info/*
|
%{python3_sitearch}/GDAL-%{version}-py*.egg-info/*
|
||||||
%dir %{python310_sitearch}/osgeo
|
%dir %{python3_sitearch}/osgeo
|
||||||
%{python310_sitearch}/osgeo/*
|
%{python3_sitearch}/osgeo/*
|
||||||
%dir %{python310_sitearch}/osgeo_utils
|
%dir %{python3_sitearch}/osgeo_utils
|
||||||
%{python310_sitearch}/osgeo_utils/*
|
%{python3_sitearch}/osgeo_utils/*
|
||||||
%endif
|
|
||||||
|
|
||||||
%files mono
|
%files mono
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -174,9 +179,33 @@ This package contains the C-sharp bindings to %{name}.
|
|||||||
%files -n java-%{name}
|
%files -n java-%{name}
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_datadir}/java/gdal*
|
%{_datadir}/java/gdal*
|
||||||
%{_datadir}/java/libgdalalljni.so
|
%{_libdir}/jni/libgdalalljni.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 08 2024 Automatic Build System <autodist@openmamba.org> 3.8.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Dec 24 2023 Automatic Build System <autodist@mambasoft.it> 3.8.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Dec 12 2023 Automatic Build System <autodist@mambasoft.it> 3.8.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Nov 09 2023 Automatic Build System <autodist@mambasoft.it> 3.7.3-2mamba
|
||||||
|
- rebuilt by autoport with build requirements: libpodofo-devel>=0.10.2-1mamba
|
||||||
|
|
||||||
|
* Sun Nov 05 2023 Automatic Build System <autodist@mambasoft.it> 3.7.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Sep 14 2023 Automatic Build System <autodist@mambasoft.it> 3.7.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Jul 13 2023 Automatic Build System <autodist@mambasoft.it> 3.7.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu May 11 2023 Automatic Build System <autodist@mambasoft.it> 3.7.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sat Apr 22 2023 Automatic Build System <autodist@mambasoft.it> 3.6.4-1mamba
|
* Sat Apr 22 2023 Automatic Build System <autodist@mambasoft.it> 3.6.4-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user