115 lines
3.1 KiB
RPMSpec
115 lines
3.1 KiB
RPMSpec
%define majversion %(echo %version | cut -d. -f 1-2)
|
|
|
|
Name: gconfmm
|
|
Version: 2.28.3
|
|
Release: 2mamba
|
|
Summary: C++ interface for the GConf package
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.gnome.org/
|
|
Source: ftp://ftp.acc.umu.se/pub/GNOME/sources/gconfmm/%{majversion}/gconfmm-%{version}.tar.bz2
|
|
Patch0: gconfmm-2.28.3-no-extern-c-glib-includes.patch
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libGConf-devel
|
|
BuildRequires: libORBit2-devel
|
|
BuildRequires: libdbus-devel
|
|
BuildRequires: libdbus-glib-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libglibmm24-devel
|
|
BuildRequires: libsigc++2-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libsystemd-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: pkgconfig >= 0.15.0
|
|
BuildRequires: libgtkmm-devel >= 2.4.8
|
|
|
|
%description
|
|
C++ interface for the GConf package.
|
|
|
|
%package devel
|
|
Summary: Devel package for %{name}
|
|
Group: Development/Libraries
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description devel
|
|
C++ interface for the GConf package.
|
|
This package contains static libraries and header files needed for development.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
%patch0 -p1
|
|
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," build/config.sub
|
|
|
|
%build
|
|
CXXFLAGS+=' -std=c++11'
|
|
%configure \
|
|
--libexecdir=%{_prefix}/sbin \
|
|
--sysconfdir=%{_sysconfdir}/gnome \
|
|
--disable-gtk-doc
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -p /sbin/ldconfig
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_libdir}/*.so.*
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%{_libdir}/*.la
|
|
%{_libdir}/*.so
|
|
%dir %{_includedir}/%{name}-?.?
|
|
%{_includedir}/%{name}-?.?/*
|
|
%dir %{_libdir}/%{name}-?.?
|
|
%{_libdir}/%{name}-?.?/*
|
|
%{_datadir}/devhelp/books/gconfmm-*/gconfmm-*.devhelp2
|
|
%{_docdir}/gconfmm-?.?
|
|
%{_libdir}/pkgconfig/*
|
|
|
|
%changelog
|
|
* Mon Nov 22 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.28.3-2mamba
|
|
- rebuilt with debug package
|
|
|
|
* Wed Oct 26 2011 Automatic Build System <autodist@mambasoft.it> 2.28.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 04 2010 Automatic Build System <autodist@mambasoft.it> 2.28.2-1mamba
|
|
- automatic update to 2.28.2 by autodist
|
|
|
|
* Fri Jun 04 2010 Automatic Build System <autodist@mambasoft.it> 2.28.1-1mamba
|
|
- automatic update to 2.28.1 by autodist
|
|
|
|
* Sat May 29 2010 Automatic Build System <autodist@mambasoft.it> 2.28.0-1mamba
|
|
- automatic update to 2.28.0 by autodist
|
|
|
|
* Wed Oct 01 2008 gil <puntogil@libero.it> 2.24.0-1mamba
|
|
- update to 2.24.0
|
|
|
|
* Thu Jun 15 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 2.12.0-1qilnx
|
|
- update to version 2.12.0 by autospec
|
|
|
|
* Mon Aug 29 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.10.0-1qilnx
|
|
- update to version 2.10.0 by autospec
|
|
|
|
* Fri Dec 17 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.1-1qilnx
|
|
- update to version 2.8.1 by autospec
|
|
|
|
* Sat Feb 29 2004 Silvan Calarco <silvan.calarco@qinet.it> 2.0.1-1qilnx
|
|
- first build
|