automatic version update by autodist [release 4.9.2-1mamba;Thu Oct 30 2014]

This commit is contained in:
Automatic Build System 2024-01-05 22:37:49 +01:00
parent e672a842ab
commit e295aa7e88
2 changed files with 26 additions and 3 deletions

View File

@ -0,0 +1,15 @@
--- trunk/gcc/lra-lives.c 2014/05/30 08:43:05 211074
+++ trunk/gcc/lra-lives.c 2014/06/16 09:58:34 211701
@@ -558,7 +558,11 @@
/* It might be 'inheritance pseudo <- reload pseudo'. */
|| (src_regno >= lra_constraint_new_regno_start
&& ((int) REGNO (SET_DEST (set))
- >= lra_constraint_new_regno_start))))
+ >= lra_constraint_new_regno_start)
+ /* Remember to skip special cases where src/dest regnos are
+ the same, e.g. insn SET pattern has matching constraints
+ like =r,0. */
+ && src_regno != (int) REGNO (SET_DEST (set)))))
{
int hard_regno = -1, regno = -1;

View File

@ -40,7 +40,7 @@
%define majver %(echo %version | cut -d. -f 1-2)
Name: gcc
Version: 4.9.1
Version: 4.9.2
Release: 1mamba
Summary: GNU Compiler Collection (C, C++, Fortran, Java, Ada)
Group: Applications/Development
@ -66,6 +66,7 @@ Patch12: %{name}-4.5.2-arm_define_ARM_PCS_and_ARM_PCS_VFP.patch
Patch13: %{name}-4.5.3-avr-new-devices.patch
Patch14: gcc-4.8.0-libffi-texinfo.patch
Patch15: gcc-4.9.0-upstream-fixes-1.patch
Patch16: gcc-4.9.2-arm-lra-bootstrap.patch
License: GPL
## AUTOBUILDREQ-BEGIN
## AUTOBUILDREQ-END
@ -469,7 +470,8 @@ AutoReqProv: no
Cross Platform gcc for %{_target_platform}.
%prep
%setup -n gcc-%{version}%{?gcc_extraver} -q
%setup -n gcc-%{version}%{?gcc_extraver}
#-q -D
#-D -T
#:<< ___EOF
%patch2 -p0
@ -493,12 +495,14 @@ sed -i -e 's/libjawt/libgcjawt/g' libjava/Makefile.{am,in}
#%patch13 -p1
#%patch14 -p1
#%patch15 -p1
%patch16 -p1
%build
#:<< ____EOF
rm -rf ../%{name}-build
#____EOF
mkdir -p ../%{name}-build &&
mkdir ../%{name}-build &&
cd ../%{name}-build
slibdir=/%{_lib}
@ -571,6 +575,7 @@ esac
--with-local-prefix=/usr/%{_target_platform} \
%endif
$ADDITIONAL_OPTS
make %{?_smp_mflags}
# all-gcc
@ -1385,6 +1390,9 @@ find %{buildroot}%{_libdir}/gcc -name lib*.a -exec chmod -w {} \;
%endif
%changelog
* Thu Oct 30 2014 Automatic Build System <autodist@mambasoft.it> 4.9.2-1mamba
- automatic version update by autodist
* Sun Jul 27 2014 Automatic Build System <autodist@mambasoft.it> 4.9.1-1mamba
- automatic version update by autodist