arm: added patch to provide futex atomic functions _M_futex_notify_all and _M_futex_wait_until (armv7) [release 10.1.0-2mamba;Mon Jun 08 2020]
This commit is contained in:
parent
fcf33b7cf9
commit
507d443445
24
gcc-10.1.0-arm-provide-futex-atomic-functions.patch
Normal file
24
gcc-10.1.0-arm-provide-futex-atomic-functions.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -ru gcc-10.1.0/libstdc++-v3/include/bits/atomic_futex.h gcc-10.1.0.patched/libstdc++-v3/include/bits/atomic_futex.h
|
||||||
|
--- gcc-10.1.0/libstdc++-v3/include/bits/atomic_futex.h 2020-05-07 12:50:02.000000000 +0200
|
||||||
|
+++ gcc-10.1.0.patched/libstdc++-v3/include/bits/atomic_futex.h 2020-06-08 18:18:38.544259479 +0200
|
||||||
|
@@ -49,7 +49,7 @@
|
||||||
|
_GLIBCXX_BEGIN_NAMESPACE_VERSION
|
||||||
|
|
||||||
|
#ifdef _GLIBCXX_HAS_GTHREADS
|
||||||
|
-#if defined(_GLIBCXX_HAVE_LINUX_FUTEX) && ATOMIC_INT_LOCK_FREE > 1
|
||||||
|
+#if defined(_GLIBCXX_HAVE_LINUX_FUTEX)
|
||||||
|
struct __atomic_futex_unsigned_base
|
||||||
|
{
|
||||||
|
// Returns false iff a timeout occurred.
|
||||||
|
diff -ru gcc-10.1.0/libstdc++-v3/src/c++11/futex.cc gcc-10.1.0.patched/libstdc++-v3/src/c++11/futex.cc
|
||||||
|
--- gcc-10.1.0/libstdc++-v3/src/c++11/futex.cc 2020-05-07 12:50:02.000000000 +0200
|
||||||
|
+++ gcc-10.1.0.patched/libstdc++-v3/src/c++11/futex.cc 2020-06-08 18:19:20.413501894 +0200
|
||||||
|
@@ -24,7 +24,7 @@
|
||||||
|
|
||||||
|
#include <bits/atomic_futex.h>
|
||||||
|
#ifdef _GLIBCXX_HAS_GTHREADS
|
||||||
|
-#if defined(_GLIBCXX_HAVE_LINUX_FUTEX) && ATOMIC_INT_LOCK_FREE > 1
|
||||||
|
+#if defined(_GLIBCXX_HAVE_LINUX_FUTEX)
|
||||||
|
#include <chrono>
|
||||||
|
#include <climits>
|
||||||
|
#include <syscall.h>
|
7
gcc.spec
7
gcc.spec
@ -40,7 +40,7 @@
|
|||||||
|
|
||||||
Name: gcc
|
Name: gcc
|
||||||
Version: 10.1.0
|
Version: 10.1.0
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: GNU Compiler Collection (C, C++, Fortran, Go, Ada)
|
Summary: GNU Compiler Collection (C, C++, Fortran, Go, Ada)
|
||||||
Group: Applications/Development
|
Group: Applications/Development
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -67,6 +67,7 @@ Patch14: gcc-4.8.0-libffi-texinfo.patch
|
|||||||
Patch15: gcc-4.9.0-upstream-fixes-1.patch
|
Patch15: gcc-4.9.0-upstream-fixes-1.patch
|
||||||
Patch16: gcc-4.9.2-arm-lra-bootstrap.patch
|
Patch16: gcc-4.9.2-arm-lra-bootstrap.patch
|
||||||
Patch19: gcc-7.1.0-cross-ftbfs-ucontet_t.patch
|
Patch19: gcc-7.1.0-cross-ftbfs-ucontet_t.patch
|
||||||
|
Patch20: gcc-10.1.0-arm-provide-futex-atomic-functions.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
@ -600,6 +601,7 @@ Cross Platform gcc for %{_target_platform}.
|
|||||||
%patch11 -p1
|
%patch11 -p1
|
||||||
|
|
||||||
%ifarch arm
|
%ifarch arm
|
||||||
|
%patch20 -p1
|
||||||
# workaround for gcc-go
|
# workaround for gcc-go
|
||||||
cp libgo/go/internal/syscall/unix/{getrandom_linux_arm.go,dummy.go}
|
cp libgo/go/internal/syscall/unix/{getrandom_linux_arm.go,dummy.go}
|
||||||
%endif
|
%endif
|
||||||
@ -1466,6 +1468,9 @@ rm -f %{buildroot}%{_infodir}/libffi.info*
|
|||||||
%endif # cross-platform
|
%endif # cross-platform
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 08 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 10.1.0-2mamba
|
||||||
|
- arm: added patch to provide futex atomic functions _M_futex_notify_all and _M_futex_wait_until (armv7)
|
||||||
|
|
||||||
* Mon May 11 2020 Automatic Build System <autodist@mambasoft.it> 10.1.0-1mamba
|
* Mon May 11 2020 Automatic Build System <autodist@mambasoft.it> 10.1.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user