patched for libgcj abi minor [release 6.1.0-2mamba;Mon May 09 2016]
This commit is contained in:
parent
824464f600
commit
4704b4a610
36
gcc-6.1.0-gcj-remove-minor-handling.patch
Normal file
36
gcc-6.1.0-gcj-remove-minor-handling.patch
Normal file
@ -0,0 +1,36 @@
|
||||
--- gcc-6.1.0/gcc/java/decl.c.orig 2016-02-08 16:36:16.000000000 +0100
|
||||
+++ gcc-6.1.0/gcc/java/decl.c 2016-05-08 13:57:25.854163381 +0200
|
||||
@@ -507,7 +507,7 @@
|
||||
parse_version (void)
|
||||
{
|
||||
const char *p = version_string;
|
||||
- unsigned int major = 0, minor = 0;
|
||||
+ unsigned int major = 0;
|
||||
unsigned int abi_version;
|
||||
|
||||
/* Skip leading junk. */
|
||||
@@ -525,13 +525,6 @@
|
||||
gcc_assert (*p == '.' && ISDIGIT (p[1]));
|
||||
++p;
|
||||
|
||||
- /* Extract minor version. */
|
||||
- while (ISDIGIT (*p))
|
||||
- {
|
||||
- minor = minor * 10 + *p - '0';
|
||||
- ++p;
|
||||
- }
|
||||
-
|
||||
if (flag_indirect_dispatch)
|
||||
{
|
||||
abi_version = GCJ_CURRENT_BC_ABI_VERSION;
|
||||
--- gcc-6.1.0/gcc/java/decl.c.orig 2016-05-08 17:15:16.964134546 +0200
|
||||
+++ gcc-6.1.0/gcc/java/decl.c 2016-05-08 17:15:25.304134521 +0200
|
||||
@@ -535,7 +535,7 @@
|
||||
/* Implicit in this computation is the idea that we won't break the
|
||||
old-style binary ABI in a sub-minor release (e.g., from 4.0.0 to
|
||||
4.0.1). */
|
||||
- abi_version = 100000 * major + 1000 * minor;
|
||||
+ abi_version = 100000 * major;
|
||||
}
|
||||
if (flag_bootstrap_classes)
|
||||
abi_version |= FLAG_BOOTSTRAP_LOADER;
|
68
gcc.spec
68
gcc.spec
@ -42,8 +42,8 @@
|
||||
%define majver %(echo %version | cut -d. -f 1-2)
|
||||
|
||||
Name: gcc
|
||||
Version: 5.3.0
|
||||
Release: 1mamba
|
||||
Version: 6.1.0
|
||||
Release: 2mamba
|
||||
Summary: GNU Compiler Collection (C, C++, Fortran, Java, Ada)
|
||||
Group: Applications/Development
|
||||
Vendor: openmamba
|
||||
@ -70,6 +70,7 @@ Patch14: gcc-4.8.0-libffi-texinfo.patch
|
||||
Patch15: gcc-4.9.0-upstream-fixes-1.patch
|
||||
Patch16: gcc-4.9.2-arm-lra-bootstrap.patch
|
||||
Patch17: gcc-5.2.0-libjava-disable-multilib.patch
|
||||
Patch18: gcc-6.1.0-gcj-remove-minor-handling.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
## AUTOBUILDREQ-END
|
||||
@ -369,6 +370,24 @@ Requires: libobjc = %{version}-%{release}
|
||||
%description -n libobjc-devel
|
||||
This package contains Objective-C static library and includes which are needed to build Objective-C statically linked programs.
|
||||
|
||||
#
|
||||
# libmpx packages
|
||||
#
|
||||
%package -n libmpx
|
||||
Summary: GCC MPX library
|
||||
Group: System/Libraries
|
||||
|
||||
%description -n libmpx
|
||||
This package contains the GCC MPX library.
|
||||
|
||||
%package -n libmpx-devel
|
||||
Summary: libmpx development libraries and headers
|
||||
Group: Development/Libraries
|
||||
Requires: libmpx = %{version}-%{release}
|
||||
|
||||
%description -n libmpx-devel
|
||||
This package contains static libraries and headers to be used for development.
|
||||
|
||||
#
|
||||
# libssp packages
|
||||
#
|
||||
@ -446,7 +465,7 @@ Group: System/Libraries
|
||||
This package contains the GCC Atomic library.
|
||||
|
||||
%package -n libatomic-devel
|
||||
Summary: libatimic development libraries and headers
|
||||
Summary: libatomic development libraries and headers
|
||||
Group: Development/Libraries
|
||||
Requires: libatomic = %{version}-%{release}
|
||||
|
||||
@ -548,6 +567,7 @@ sed -i -e 's/libjawt/libgcjawt/g' libjava/Makefile.{am,in}
|
||||
#%patch15 -p1
|
||||
#%patch16 -p1
|
||||
%patch17 -p1
|
||||
%patch18 -p1
|
||||
|
||||
%build
|
||||
#:<< ____EOF
|
||||
@ -950,7 +970,7 @@ find %{buildroot}%{_libdir}/gcc -name lib*.a -exec chmod -w {} \;
|
||||
%files -n libgomp
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libgomp.so.*
|
||||
%{_libdir}/libgomp-plugin-host_nonshm.so.*
|
||||
#%{_libdir}/libgomp-plugin-host_nonshm.so.*
|
||||
%ifarch ppc
|
||||
%{_libdir}/nof/libgomp.so.*
|
||||
%endif
|
||||
@ -960,8 +980,8 @@ find %{buildroot}%{_libdir}/gcc -name lib*.a -exec chmod -w {} \;
|
||||
%{_libdir}/libgomp.a
|
||||
%{_libdir}/libgomp.la
|
||||
%{_libdir}/libgomp.so
|
||||
%{_libdir}/libgomp-plugin-host_nonshm.la
|
||||
%{_libdir}/libgomp-plugin-host_nonshm.so
|
||||
#%{_libdir}/libgomp-plugin-host_nonshm.la
|
||||
#%{_libdir}/libgomp-plugin-host_nonshm.so
|
||||
%{_libdir}/libgomp.spec
|
||||
%ifarch ppc
|
||||
%{_libdir}/nof/libgomp.a
|
||||
@ -1069,6 +1089,23 @@ find %{buildroot}%{_libdir}/gcc -name lib*.a -exec chmod -w {} \;
|
||||
%{_libdir}/libcilkrts.spec
|
||||
%endif
|
||||
|
||||
%ifnarch arm
|
||||
%files -n libmpx
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libmpx.so.*
|
||||
%{_libdir}/libmpxwrappers.so.*
|
||||
|
||||
%files -n libmpx-devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libmpx.a
|
||||
%{_libdir}/libmpx.la
|
||||
%{_libdir}/libmpx.so
|
||||
%{_libdir}/libmpx.spec
|
||||
%{_libdir}/libmpxwrappers.a
|
||||
%{_libdir}/libmpxwrappers.la
|
||||
%{_libdir}/libmpxwrappers.so
|
||||
%endif
|
||||
|
||||
%files -n libubsan
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libubsan.so.*
|
||||
@ -1080,7 +1117,6 @@ find %{buildroot}%{_libdir}/gcc -name lib*.a -exec chmod -w {} \;
|
||||
%{_libdir}/libubsan.so
|
||||
%{_libdir}/libsanitizer.spec
|
||||
|
||||
%ifnarch arm
|
||||
%files -n libvtv
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libvtv.so.*
|
||||
@ -1090,7 +1126,6 @@ find %{buildroot}%{_libdir}/gcc -name lib*.a -exec chmod -w {} \;
|
||||
%{_libdir}/libvtv.a
|
||||
%{_libdir}/libvtv.la
|
||||
%{_libdir}/libvtv.so
|
||||
%endif
|
||||
|
||||
%if "%{disable_cpp}" != "1"
|
||||
#
|
||||
@ -1457,14 +1492,19 @@ find %{buildroot}%{_libdir}/gcc -name lib*.a -exec chmod -w {} \;
|
||||
%{_prefix}/lib/libgomp.so
|
||||
%{_prefix}/lib/libgomp.so.*
|
||||
%{_prefix}/lib/libgomp.spec
|
||||
%{_prefix}/lib/libgomp-plugin-host_nonshm.la
|
||||
%{_prefix}/lib/libgomp-plugin-host_nonshm.so
|
||||
%{_prefix}/lib/libgomp-plugin-host_nonshm.so.*
|
||||
#%{_prefix}/lib/libgomp-plugin-host_nonshm.la
|
||||
#%{_prefix}/lib/libgomp-plugin-host_nonshm.so
|
||||
#%{_prefix}/lib/libgomp-plugin-host_nonshm.so.*
|
||||
/usr/lib/libitm.a
|
||||
/usr/lib/libitm.la
|
||||
/usr/lib/libitm.so
|
||||
/usr/lib/libitm.so.*
|
||||
/usr/lib/libitm.spec
|
||||
/usr/lib/libmpx*.a
|
||||
/usr/lib/libmpx*.la
|
||||
/usr/lib/libmpx*.so
|
||||
/usr/lib/libmpx*.so.*
|
||||
/usr/lib/libmpx.spec
|
||||
/usr/lib/libobjc.a
|
||||
/usr/lib/libobjc.la
|
||||
/usr/lib/libobjc.so
|
||||
@ -1535,6 +1575,12 @@ find %{buildroot}%{_libdir}/gcc -name lib*.a -exec chmod -w {} \;
|
||||
%endif # cross-platform
|
||||
|
||||
%changelog
|
||||
* Mon May 09 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 6.1.0-2mamba
|
||||
- patched for libgcj abi minor
|
||||
|
||||
* Wed May 04 2016 Automatic Build System <autodist@mambasoft.it> 6.1.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Dec 11 2015 Automatic Build System <autodist@mambasoft.it> 5.3.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user