gambas3-ide: require gambas3-gb-jit [release 3.14.3-3mamba;Thu May 28 2020]
This commit is contained in:
parent
67620de04b
commit
ec8fc4dd8d
29
gambas3-3.14.3-poppler-0.83.patch
Normal file
29
gambas3-3.14.3-poppler-0.83.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From 36c093cb21d9dab3aae35f64d44e5883eefe020e Mon Sep 17 00:00:00 2001
|
||||
From: Laurent Carlier <lordheavym@gmail.com>
|
||||
Date: Thu, 23 Jan 2020 18:02:44 +0100
|
||||
Subject: [PATCH] Fix segfault with poppler>0.83
|
||||
|
||||
[GB.PDF]
|
||||
* BUG: Fix segfault with poppler > 0.83
|
||||
|
||||
Signed-off-by: Laurent Carlier <lordheavym@gmail.com>
|
||||
---
|
||||
gb.pdf/src/main.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gb.pdf/src/main.cpp b/gb.pdf/src/main.cpp
|
||||
index 2d7f02ca0..62923cc34 100644
|
||||
--- a/gb.pdf/src/main.cpp
|
||||
+++ b/gb.pdf/src/main.cpp
|
||||
@@ -56,7 +56,7 @@ int EXPORT GB_INIT(void)
|
||||
if (!globalParams)
|
||||
{
|
||||
#if POPPLER_VERSION_0_83
|
||||
- globalParams = std::unique_ptr<GlobalParams>();
|
||||
+ globalParams = std::unique_ptr<GlobalParams>(new GlobalParams());
|
||||
#else
|
||||
globalParams = new GlobalParams();
|
||||
#endif
|
||||
--
|
||||
2.25.0
|
||||
|
54
gambas3-3.14.3-poppler-0.85.patch
Normal file
54
gambas3-3.14.3-poppler-0.85.patch
Normal file
@ -0,0 +1,54 @@
|
||||
From 6a16e02ee3a0f05cd70876d76f807ab5076440b1 Mon Sep 17 00:00:00 2001
|
||||
From: Evangelos Foutras <evangelos@foutrelis.com>
|
||||
Date: Thu, 30 Jan 2020 21:08:47 +0200
|
||||
Subject: [PATCH] Use GlobalParams::getUtf8Map() found in poppler 0.85
|
||||
|
||||
[GB.PDF]
|
||||
* BUG: Make 'gb.pdf' compile with poppler >= 0.85.
|
||||
---
|
||||
gb.pdf/configure.ac | 2 ++
|
||||
gb.pdf/src/CPdfDocument.cpp | 7 +++++--
|
||||
2 files changed, 7 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/gb.pdf/configure.ac b/gb.pdf/configure.ac
|
||||
index 691e3088a..1dd10b455 100644
|
||||
--- a/gb.pdf/configure.ac
|
||||
+++ b/gb.pdf/configure.ac
|
||||
@@ -29,6 +29,8 @@ if test "$have_poppler" = "yes"; then
|
||||
AC_DEFINE_UNQUOTED(POPPLER_VERSION_0_76, $((1-$?)), Poppler version >= 0.76)
|
||||
pkg-config --atleast-version=0.83.0 poppler
|
||||
AC_DEFINE_UNQUOTED(POPPLER_VERSION_0_83, $((1-$?)), Poppler version >= 0.83)
|
||||
+ pkg-config --atleast-version=0.85.0 poppler
|
||||
+ AC_DEFINE_UNQUOTED(POPPLER_VERSION_0_85, $((1-$?)), Poppler version >= 0.85)
|
||||
fi
|
||||
|
||||
AC_OUTPUT( \
|
||||
diff --git a/gb.pdf/src/CPdfDocument.cpp b/gb.pdf/src/CPdfDocument.cpp
|
||||
index 9522d15db..4b53fd50d 100644
|
||||
--- a/gb.pdf/src/CPdfDocument.cpp
|
||||
+++ b/gb.pdf/src/CPdfDocument.cpp
|
||||
@@ -104,12 +104,14 @@ END_PROPERTY
|
||||
|
||||
static void return_unicode_string(const Unicode *unicode, int len)
|
||||
{
|
||||
- static UnicodeMap *uMap = NULL;
|
||||
-
|
||||
GooString gstr;
|
||||
char buf[8]; /* 8 is enough for mapping an unicode char to a string */
|
||||
int i, n;
|
||||
|
||||
+#if POPPLER_VERSION_0_85
|
||||
+ const UnicodeMap *uMap = globalParams->getUtf8Map();
|
||||
+#else
|
||||
+ static UnicodeMap *uMap = NULL;
|
||||
if (uMap == NULL)
|
||||
{
|
||||
GooString *enc = new GooString("UTF-8");
|
||||
@@ -117,6 +119,7 @@ static void return_unicode_string(const Unicode *unicode, int len)
|
||||
uMap->incRefCnt();
|
||||
delete enc;
|
||||
}
|
||||
+#endif
|
||||
|
||||
for (i = 0; i < len; ++i) {
|
||||
n = uMap->mapUnicode(unicode[i], buf, sizeof(buf));
|
38
gambas3-3.14.3-poppler-0.86.patch
Normal file
38
gambas3-3.14.3-poppler-0.86.patch
Normal file
@ -0,0 +1,38 @@
|
||||
diff --git a/gb.pdf/src/CPdfDocument.cpp b/gb.pdf/src/CPdfDocument.cpp
|
||||
index 4b53fd50d..58a51aecf 100644
|
||||
--- a/gb.pdf/src/CPdfDocument.cpp
|
||||
+++ b/gb.pdf/src/CPdfDocument.cpp
|
||||
@@ -256,7 +256,7 @@ static uint32_t aux_get_page_from_action(void *_object, const_LinkAction *act)
|
||||
name = ((LinkGoTo*)act)->getNamedDest();
|
||||
if (name) {
|
||||
#if POPPLER_VERSION_0_64
|
||||
- dest = THIS->doc->findDest(name);
|
||||
+ dest = THIS->doc->findDest(name).get();
|
||||
#else
|
||||
dest = THIS->doc->findDest((GooString *) name);
|
||||
#endif
|
||||
@@ -307,6 +307,7 @@ static char* aux_get_target_from_action(const_LinkAction *act)
|
||||
char *vl=NULL;
|
||||
char *uni=NULL;
|
||||
const_GooString *tmp=NULL;
|
||||
+ GooString gstr;
|
||||
|
||||
switch (act->getKind())
|
||||
{
|
||||
@@ -317,13 +318,13 @@ static char* aux_get_target_from_action(const_LinkAction *act)
|
||||
tmp=((LinkLaunch*)act)->getFileName(); break;
|
||||
|
||||
case actionURI:
|
||||
- tmp=((LinkURI*)act)->getURI(); break;
|
||||
+ gstr=GooString(((LinkURI*)act)->getURI()); tmp=&gstr; break;
|
||||
|
||||
case actionNamed:
|
||||
- tmp=((LinkNamed*)act)->getName(); break;
|
||||
+ gstr=GooString(((LinkNamed*)act)->getName()); tmp=&gstr; break;
|
||||
|
||||
case actionMovie:
|
||||
- tmp=((LinkMovie*)act)->getAnnotTitle(); break;
|
||||
+ gstr=GooString(((LinkMovie*)act)->getAnnotTitle()); tmp=&gstr; break;
|
||||
|
||||
default:
|
||||
break;
|
157
gambas3.spec
157
gambas3.spec
@ -1,26 +1,33 @@
|
||||
%define with_v4l 1
|
||||
|
||||
Name: gambas3
|
||||
Version: 3.10.0
|
||||
Release: 1mamba
|
||||
Version: 3.14.3
|
||||
Release: 3mamba
|
||||
Summary: A development environment based on a BASIC interpreter with object extensions
|
||||
Group: Applications/Development
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://gambas.sourceforge.net/
|
||||
Source: http://download.sourceforge.net/sourceforge/gambas/gambas3-%{version}.tar.bz2
|
||||
Source: https://gitlab.com/gambas/gambas/-/archive/%{version}/gambas-%{version}.tar.bz2
|
||||
#Source: http://download.sourceforge.net/sourceforge/gambas/gambas3-%{version}.tar.bz2
|
||||
Patch0: gambas3-3.5.4-llvm-3.5.patch
|
||||
Patch1: gambas3-3.8.4-gcc-6.1.0-2.patch
|
||||
Patch2: gambas3-3.8.4-gcc-6.1.0.patch
|
||||
Patch3: gambas3-3.14.3-poppler-0.86.patch
|
||||
Patch4: gambas3-3.14.3-poppler-0.83.patch
|
||||
Patch5: gambas3-3.14.3-poppler-0.85.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libQt5WebKit-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libSDL2-devel
|
||||
BuildRequires: libSDL2_ttf-devel
|
||||
BuildRequires: libSDL_mixer-devel
|
||||
BuildRequires: libSDL_ttf-devel
|
||||
BuildRequires: libSM-devel
|
||||
@ -31,7 +38,6 @@ BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXi-devel
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libXmu-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libXt-devel
|
||||
@ -39,15 +45,15 @@ BuildRequires: libXtst-devel
|
||||
BuildRequires: libassuan-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libblkid-devel
|
||||
BuildRequires: libbrotli-devel
|
||||
BuildRequires: libbsd-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libcap-devel
|
||||
BuildRequires: libcares-devel
|
||||
BuildRequires: libcroco-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libdw-devel
|
||||
BuildRequires: libe2fs-devel
|
||||
BuildRequires: libelf-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libffi-devel
|
||||
@ -67,18 +73,15 @@ BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgsl-devel
|
||||
BuildRequires: libgss-devel
|
||||
BuildRequires: libgst-plugins-base-devel
|
||||
BuildRequires: libgst-plugins-base010-devel
|
||||
BuildRequires: libgstreamer-devel
|
||||
BuildRequires: libgstreamer010-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libgtkglext-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libidn-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: libimlib2-devel
|
||||
BuildRequires: libjbig-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: liblcms2-devel
|
||||
BuildRequires: libkrb5-devel
|
||||
BuildRequires: libltdl-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libmount-devel
|
||||
@ -86,29 +89,27 @@ BuildRequires: libmysqlclient-devel
|
||||
BuildRequires: libncurses-devel
|
||||
BuildRequires: libnsl-devel
|
||||
BuildRequires: libodbc-devel
|
||||
BuildRequires: libopenjpeg1-devel
|
||||
BuildRequires: libopenldap-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpangox-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpoppler-devel
|
||||
BuildRequires: libpostgresql-devel
|
||||
BuildRequires: libqt-mobility-devel
|
||||
BuildRequires: libpsl-devel
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libqt5-devel
|
||||
BuildRequires: librsvg-devel
|
||||
BuildRequires: librtmp-devel
|
||||
BuildRequires: libsasl2-devel
|
||||
BuildRequires: libsdl2_image-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libsepol-devel
|
||||
BuildRequires: libsqlite-devel
|
||||
BuildRequires: libsqlite2-devel
|
||||
BuildRequires: libssh2-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libthai-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libsystemd-devel
|
||||
BuildRequires: libunwind-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libv4l-devel
|
||||
@ -117,9 +118,7 @@ BuildRequires: libxml2-devel
|
||||
BuildRequires: libxslt-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
%ifnarch arm
|
||||
BuildRequires: libllvm-devel >= 3.8.0-2mamba
|
||||
%endif
|
||||
BuildRequires: libSDL_gfx-devel >= 2.0.13
|
||||
BuildRequires: libsmpeg-devel >= 0.4.5
|
||||
BuildRequires: pkgconfig >= 0.9
|
||||
@ -174,14 +173,14 @@ Requires: gambas3-gb-form-dialog = %{version}-%{release}
|
||||
Requires: gambas3-gb-gmp = %{version}-%{release}
|
||||
Requires: gambas3-gb-gui = %{version}-%{release}
|
||||
Requires: gambas3-gb-image = %{version}-%{release}
|
||||
Requires: gambas3-gb-jit = %{version}-%{release}
|
||||
Requires: gambas3-gb-net = %{version}-%{release}
|
||||
Requires: gambas3-gb-net-curl = %{version}-%{release}
|
||||
Requires: gambas3-gb-option = %{version}-%{release}
|
||||
Requires: gambas3-gb-openssl = %{version}-%{release}
|
||||
Requires: gambas3-gb-pcre = %{version}-%{release}
|
||||
Requires: gambas3-gb-qt = %{version}-%{release}
|
||||
Requires: gambas3-gb-qt-ext = %{version}-%{release}
|
||||
Requires: gambas3-gb-qt-webkit = %{version}-%{release}
|
||||
Requires: gambas3-gb-qt5 = %{version}-%{release}
|
||||
Requires: gambas3-gb-qt5-webkit = %{version}-%{release}
|
||||
Requires: gambas3-gb-signal = %{version}-%{release}
|
||||
Requires: gambas3-gb-vb = %{version}-%{release}
|
||||
|
||||
@ -697,6 +696,17 @@ With Gambas, you can quickly design your program GUI, access MySQL or PostgreSQL
|
||||
|
||||
This component allow you to use the SDL libraries in Gambas.
|
||||
|
||||
%package gb-sdl2
|
||||
Summary: The Gambas SDL2 component
|
||||
Group: Applications/Development
|
||||
Requires: %{name}-runtime = %{version}-%{release}
|
||||
|
||||
%description gb-sdl2
|
||||
Gambas is a free development environment based on a Basic interpreter with object extensions, like Visual Basic(tm) (but it is NOT a clone!).
|
||||
With Gambas, you can quickly design your program GUI, access MySQL or PostgreSQL databases, control KDE applications with DCOP, translate your program into many languages, create network applications easily, build RPMs of your apps automatically, and so on...
|
||||
|
||||
This component allow you to use the SDL libraries in Gambas.
|
||||
|
||||
%package gb-vb
|
||||
Summary: The Gambas Visual Basic(tm) compatibility component
|
||||
Group: Applications/Development
|
||||
@ -878,18 +888,19 @@ With Gambas, you can quickly design your program GUI, access MySQL or PostgreSQL
|
||||
|
||||
This component provides the Gambas WEB component.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%setup -q -n gambas-%{version}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p1
|
||||
#%patch2 -p3
|
||||
#%patch1 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
./reconf
|
||||
#_EOF
|
||||
|
||||
%configure \
|
||||
--enable-bzlib2 \
|
||||
@ -908,7 +919,9 @@ This component provides the Gambas WEB component.
|
||||
--enable-smtp \
|
||||
--enable-curl \
|
||||
--enable-pcre \
|
||||
--enable-qt \
|
||||
--enable-qt4 \
|
||||
--disable-qtwebkit \
|
||||
--enable-qt5 \
|
||||
--disable-qte \
|
||||
--enable-sdl \
|
||||
--enable-xml \
|
||||
@ -925,12 +938,11 @@ This component provides the Gambas WEB component.
|
||||
--enable-pdf \
|
||||
--disable-firebird \
|
||||
--disable-corba \
|
||||
%ifarch arm
|
||||
--disable-jit \
|
||||
%endif
|
||||
--disable-gtksvg \
|
||||
CXX
|
||||
|
||||
#_EOF
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
@ -1014,6 +1026,8 @@ install -D -m0644 app/desktop/gambas3.svg %{buildroot}%{_datadir}/pixmaps/gambas
|
||||
%{_datadir}/%{name}/control/gb.report2/*
|
||||
%dir %{_datadir}/gambas3/control/gb.util.web
|
||||
%{_datadir}/gambas3/control/gb.util.web/*
|
||||
%dir %{_datadir}/gambas3/control/gb.term.form/
|
||||
%{_datadir}/gambas3/control/gb.term.form/*
|
||||
%{_datadir}/%{name}/info/gb.args.*
|
||||
%{_datadir}/%{name}/info/gb.map.*
|
||||
%{_datadir}/%{name}/info/gb.markdown.*
|
||||
@ -1032,6 +1046,7 @@ install -D -m0644 app/desktop/gambas3.svg %{buildroot}%{_datadir}/pixmaps/gambas
|
||||
%{_bindir}/gbs3
|
||||
%{_bindir}/gbs3.gambas
|
||||
%{_datadir}/appdata/gambas3.appdata.xml
|
||||
%{_datadir}/metainfo/gambas3.appdata.xml
|
||||
%{_datadir}/applications/%{name}.desktop
|
||||
%{_datadir}/pixmaps/gambas3.png
|
||||
%{_datadir}/pixmaps/gambas3.svg
|
||||
@ -1186,10 +1201,10 @@ install -D -m0644 app/desktop/gambas3.svg %{buildroot}%{_datadir}/pixmaps/gambas
|
||||
%{_datadir}/%{name}/info/gb.gui.*
|
||||
%{_libdir}/%{name}/gb.gui.*
|
||||
|
||||
#%files gb-jit
|
||||
#%defattr(-,root,root)
|
||||
#%{_datadir}/%{name}/info/gb.jit.*
|
||||
#%{_libdir}/%{name}/gb.jit.*
|
||||
%files gb-jit
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/%{name}/info/gb.jit.*
|
||||
%{_libdir}/%{name}/gb.jit.*
|
||||
|
||||
%files gb-httpd
|
||||
%defattr(-,root,root)
|
||||
@ -1272,18 +1287,6 @@ install -D -m0644 app/desktop/gambas3.svg %{buildroot}%{_datadir}/pixmaps/gambas
|
||||
%{_libdir}/%{name}/gb.qt4.so*
|
||||
%{_libdir}/%{name}/gb.qt4.component
|
||||
|
||||
%files gb-qt5
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/%{name}/gb.qt5.la
|
||||
%{_libdir}/%{name}/gb.qt5.so*
|
||||
%{_libdir}/%{name}/gb.qt5.component
|
||||
%{_libdir}/gambas3/gb.qt5.ext.la
|
||||
%{_libdir}/gambas3/gb.qt5.ext.so*
|
||||
%{_libdir}/gambas3/gb.qt5.ext.component
|
||||
%{_datadir}/%{name}/info/gb.qt5.info
|
||||
%{_datadir}/%{name}/info/gb.qt5.list
|
||||
%{_datadir}/%{name}/info/gb.qt5.ext.*
|
||||
|
||||
%files gb-qt-ext
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/%{name}/info/gb.qt4.ext.info
|
||||
@ -1300,27 +1303,40 @@ install -D -m0644 app/desktop/gambas3.svg %{buildroot}%{_datadir}/pixmaps/gambas
|
||||
#%{_libdir}/%{name}/gb.qt.kde.so*
|
||||
#%{_libdir}/%{name}/gb.qt.kde.component
|
||||
|
||||
%files gb-qt-webkit
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/%{name}/info/gb.qt4.webkit.info
|
||||
%{_datadir}/%{name}/info/gb.qt4.webkit.list
|
||||
%{_libdir}/%{name}/gb.qt4.webkit.la
|
||||
%{_libdir}/%{name}/gb.qt4.webkit.so*
|
||||
%{_libdir}/%{name}/gb.qt4.webkit.component
|
||||
|
||||
%files gb-qt5-webkit
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/%{name}/info/gb.qt5.webkit.info
|
||||
%{_datadir}/%{name}/info/gb.qt5.webkit.list
|
||||
%{_libdir}/%{name}/gb.qt5.webkit.la
|
||||
%{_libdir}/%{name}/gb.qt5.webkit.so*
|
||||
%{_libdir}/%{name}/gb.qt5.webkit.component
|
||||
#%files gb-qt-webkit
|
||||
#%defattr(-,root,root)
|
||||
#%{_datadir}/%{name}/info/gb.qt4.webkit.info
|
||||
#%{_datadir}/%{name}/info/gb.qt4.webkit.list
|
||||
#%{_libdir}/%{name}/gb.qt4.webkit.la
|
||||
#%{_libdir}/%{name}/gb.qt4.webkit.so*
|
||||
#%{_libdir}/%{name}/gb.qt4.webkit.component
|
||||
|
||||
%files gb-qt-opengl
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/%{name}/info/gb.qt4.opengl.*
|
||||
%{_libdir}/%{name}/gb.qt4.opengl.*
|
||||
|
||||
%files gb-qt5
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/%{name}/gb.qt5.la
|
||||
%{_libdir}/%{name}/gb.qt5.so*
|
||||
%{_libdir}/%{name}/gb.qt5.component
|
||||
%{_libdir}/gambas3/gb.qt5.ext.la
|
||||
%{_libdir}/gambas3/gb.qt5.ext.so*
|
||||
%{_libdir}/gambas3/gb.qt5.ext.component
|
||||
%{_datadir}/%{name}/info/gb.qt5.info
|
||||
%{_datadir}/%{name}/info/gb.qt5.list
|
||||
%{_datadir}/%{name}/info/gb.qt5.ext.*
|
||||
|
||||
%files gb-qt5-webkit
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/%{name}/info/gb.qt5.webkit.info
|
||||
%{_datadir}/%{name}/info/gb.qt5.webkit.list
|
||||
%{_datadir}/%{name}/control/gb.qt5.webkit/webview.png
|
||||
%{_libdir}/%{name}/gb.qt5.webkit.la
|
||||
%{_libdir}/%{name}/gb.qt5.webkit.so*
|
||||
%{_libdir}/%{name}/gb.qt5.webkit.component
|
||||
|
||||
%files gb-qt5-opengl
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/%{name}/info/gb.qt5.opengl.*
|
||||
@ -1355,6 +1371,14 @@ install -D -m0644 app/desktop/gambas3.svg %{buildroot}%{_datadir}/pixmaps/gambas
|
||||
%{_libdir}/%{name}/gb.sdl.so*
|
||||
%{_libdir}/%{name}/gb.sdl.component
|
||||
|
||||
%files gb-sdl2
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/gambas3/gb.sdl2.component
|
||||
%{_libdir}/gambas3/gb.sdl2.la
|
||||
%{_libdir}/gambas3/gb.sdl2.so
|
||||
%{_libdir}/gambas3/gb.sdl2.so.*
|
||||
%{_datadir}/gambas3/info/gb.sdl2.*
|
||||
|
||||
%files gb-signal
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/%{name}/info/gb.signal.*
|
||||
@ -1395,6 +1419,15 @@ install -D -m0644 app/desktop/gambas3.svg %{buildroot}%{_datadir}/pixmaps/gambas
|
||||
%{_libdir}/%{name}/gb.libxml.*
|
||||
|
||||
%changelog
|
||||
* Thu May 28 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 3.14.3-3mamba
|
||||
- gambas3-ide: require gambas3-gb-jit
|
||||
|
||||
* Wed May 27 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 3.14.3-2mamba
|
||||
- gambas-ide: fix requirements
|
||||
|
||||
* Wed May 27 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 3.14.3-1mamba
|
||||
- update to 3.14.3
|
||||
|
||||
* Fri Dec 01 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 3.10.0-1mamba
|
||||
- update to 3.10.0
|
||||
|
||||
@ -1494,7 +1527,7 @@ install -D -m0644 app/desktop/gambas3.svg %{buildroot}%{_datadir}/pixmaps/gambas
|
||||
* Thu Nov 09 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.46-1qilnx
|
||||
- update to version 1.9.46.svn20061110
|
||||
|
||||
* Wed Oct 26 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.44-1qilnx
|
||||
* Thu Oct 26 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.44-1qilnx
|
||||
- update to version 1.9.44
|
||||
|
||||
* Tue Sep 26 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.43-1qilnx
|
||||
|
Loading…
Reference in New Issue
Block a user