automatic version update by autodist [release 3.19.1-1mamba;Fri Mar 29 2024]

This commit is contained in:
Automatic Build System 2024-04-02 19:05:07 +02:00
parent 1981fcda86
commit 3515f1649c
2 changed files with 6 additions and 93 deletions

View File

@ -1,70 +0,0 @@
From: Amin Bandali <bandali@canonical.com>
Date: Wed, 14 Feb 2024 09:56:10 -0500
Subject: make 'gb.pdf' compile with poppler 24.02.0
Forwarded: https://gitlab.com/gambas/gambas/-/merge_requests/330
---
gb.pdf/configure.ac | 2 ++
gb.pdf/src/CPdfDocument.cpp | 21 +++++++++++++++++++++
2 files changed, 23 insertions(+)
diff --git a/gb.pdf/configure.ac b/gb.pdf/configure.ac
index 6931e2c48..6e612e40a 100644
--- a/gb.pdf/configure.ac
+++ b/gb.pdf/configure.ac
@@ -34,6 +34,8 @@ if test "$have_poppler" = "yes"; then
AC_DEFINE_UNQUOTED(POPPLER_VERSION_21_06_0, $((1-$?)), Poppler version >= 21.06.0)
$PKG_CONFIG --atleast-version=22.06.0 poppler
AC_DEFINE_UNQUOTED(POPPLER_VERSION_22_06_0, $((1-$?)), Poppler version >= 22.06.0)
+ $PKG_CONFIG --atleast-version=24.02.0 poppler
+ AC_DEFINE_UNQUOTED(POPPLER_VERSION_24_02_0, $((1-$?)), Poppler version >= 24.02.0)
fi
AC_CONFIG_FILES([\
diff --git a/gb.pdf/src/CPdfDocument.cpp b/gb.pdf/src/CPdfDocument.cpp
index 8f4aac7fb..5dfbfefc1 100644
--- a/gb.pdf/src/CPdfDocument.cpp
+++ b/gb.pdf/src/CPdfDocument.cpp
@@ -102,6 +102,22 @@ END_PROPERTY
****************************************************************************/
+#if POPPLER_VERSION_24_02_0
+static void return_unicode_string(const std::vector<Unicode> &unicode)
+{
+ GooString gstr;
+ char buf[8]; /* 8 is enough for mapping an unicode char to a string */
+ int n;
+
+ const UnicodeMap *uMap = globalParams->getUtf8Map();
+ for (const auto &c : unicode) {
+ n = uMap->mapUnicode(c, buf, sizeof(buf));
+ gstr.append(buf, n);
+ }
+
+ GB.ReturnNewZeroString(gstr.getCString());
+}
+#else
static void return_unicode_string(const Unicode *unicode, int len)
{
GooString gstr;
@@ -128,6 +144,7 @@ static void return_unicode_string(const Unicode *unicode, int len)
GB.ReturnNewZeroString(gstr.getCString());
}
+#endif
static void aux_return_string_info(void *_object, const char *key)
@@ -776,7 +793,11 @@ END_PROPERTY
BEGIN_PROPERTY(PDFINDEX_title)
OutlineItem *item = CPDF_index_get(THIS->currindex);
+#if POPPLER_VERSION_24_02_0
+ return_unicode_string(item->getTitle());
+#else
return_unicode_string(item->getTitle(), item->getTitleLength());
+#endif
END_PROPERTY

View File

@ -1,7 +1,7 @@
%define with_v4l 1 %define with_v4l 1
Name: gambas3 Name: gambas3
Version: 3.19.0 Version: 3.19.1
Release: 2mamba Release: 1mamba
Summary: A development environment based on a BASIC interpreter with object extensions Summary: A development environment based on a BASIC interpreter with object extensions
Group: Applications/Development Group: Applications/Development
Vendor: openmamba Vendor: openmamba
@ -9,7 +9,6 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://gambas.sourceforge.net/en/main.html URL: https://gambas.sourceforge.net/en/main.html
Source: https://gitlab.com/gambas/gambas/-/archive/%{version}/gambas-%{version}.tar.bz2 Source: https://gitlab.com/gambas/gambas/-/archive/%{version}/gambas-%{version}.tar.bz2
Patch0: gambas3-3.19.0-poppler-24.02.0.patch
License: GPL License: GPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
@ -18,9 +17,6 @@ BuildRequires: libICE-devel
BuildRequires: libQt5Positioning-devel BuildRequires: libQt5Positioning-devel
BuildRequires: libQt5Svg-devel BuildRequires: libQt5Svg-devel
BuildRequires: libQt5WebChannel-devel BuildRequires: libQt5WebChannel-devel
%ifnarch arm
BuildRequires: libQt5WebEngine-devel
%endif
%ifnarch aarch64 %ifnarch aarch64
BuildRequires: libQt5WebKit-devel BuildRequires: libQt5WebKit-devel
%endif %endif
@ -107,25 +103,12 @@ BuildRequires: qt5-qtdeclarative-devel
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
BuildRequires: libpoppler-devel >= 24.02.0-1mamba BuildRequires: libpoppler-devel >= 24.02.0-1mamba
BuildRequires: libllvm-devel >= 3.8.0-2mamba BuildRequires: libllvm-devel >= 3.8.0-2mamba
#BuildRequires: libSDL_gfx-devel >= 2.0.13
#BuildRequires: libsmpeg-devel >= 0.4.5
BuildRequires: pkgconfig >= 0.9 BuildRequires: pkgconfig >= 0.9
BuildRequires: libvorbis-devel >= 1.1.2 BuildRequires: libvorbis-devel >= 1.1.2
BuildRequires: libogg-devel >= 1.1.3 BuildRequires: libogg-devel >= 1.1.3
#BuildRequires: libmikmod-devel >= 3.1.11
BuildRequires: libopenjpeg-devel BuildRequires: libopenjpeg-devel
#Provides: gambas
#Obsoletes: gambas
Requires(post):%{__install_info} Requires(post):%{__install_info}
# THESE COMPONENTS ARE DISABLED:
#
# - gb.corba
# need: omniORB4 core, libomniorb4, libomniorb4-devel, libomniorb4-nameserver
# --> CORBA.h, libomniORB4.so, libomniDynamic4.so
# - gb.db.firebird
# need: firebird-devel and ibpp 2.4 (www.ibpp.org) are needed
%description %description
Gambas is a free development environment based on a Basic interpreter with object extensions, like Visual Basic(tm) (but it is NOT a clone!). Gambas is a free development environment based on a Basic interpreter with object extensions, like Visual Basic(tm) (but it is NOT a clone!).
With Gambas, you can quickly design your program GUI, access MySQL or PostgreSQL databases, control KDE applications with DCOP, translate your program into many languages, create network applications easily, build RPMs of your apps automatically, and so on... With Gambas, you can quickly design your program GUI, access MySQL or PostgreSQL databases, control KDE applications with DCOP, translate your program into many languages, create network applications easily, build RPMs of your apps automatically, and so on...
@ -143,8 +126,6 @@ This package includes the Gambas interpreter needed to run Gambas applications.
%package ide %package ide
Summary: The Gambas IDE Summary: The Gambas IDE
Group: Graphical Desktop/Applications/Development Group: Graphical Desktop/Applications/Development
#Provides: gambas-ide
#Obsoletes: gambas-ide
Requires: %{name}-runtime = %{version}-%{release} Requires: %{name}-runtime = %{version}-%{release}
Requires: gambas3-gb-complex = %{version}-%{release} Requires: gambas3-gb-complex = %{version}-%{release}
Requires: gambas3-gb-data = %{version}-%{release} Requires: gambas3-gb-data = %{version}-%{release}
@ -878,7 +859,6 @@ This component provides the Gambas WEB component.
%setup -q -n gambas-%{version} %setup -q -n gambas-%{version}
#-D -T #-D -T
#:<< _EOF #:<< _EOF
%patch 0 -p1 -b .poppler-24.02.0
./reconf ./reconf
%build %build
@ -925,7 +905,7 @@ This component provides the Gambas WEB component.
--disable-gtksvg \ --disable-gtksvg \
CXX CXX
#_EOF _EOF
%make %make
@ -1468,6 +1448,9 @@ install -D -m0644 app/desktop/gambas3.svg %{buildroot}%{_datadir}/pixmaps/gambas
%{_libdir}/%{name}/gb.libxml.* %{_libdir}/%{name}/gb.libxml.*
%changelog %changelog
* Fri Mar 29 2024 Automatic Build System <autodist@openmamba.org> 3.19.1-1mamba
- automatic version update by autodist
* Sun Feb 25 2024 Automatic Build System <autodist@mambasoft.it> 3.19.0-2mamba * Sun Feb 25 2024 Automatic Build System <autodist@mambasoft.it> 3.19.0-2mamba
- rebuilt by autoport with build requirements: libpoppler-devel>=24.02.0-1mamba - rebuilt by autoport with build requirements: libpoppler-devel>=24.02.0-1mamba