added patch for aarch64; remove initscript [release 2.9.9-3mamba;Thu Dec 03 2020]
This commit is contained in:
parent
007cc9b61f
commit
3569c231c3
16
fuse-2.9.9-aarch64.patch
Normal file
16
fuse-2.9.9-aarch64.patch
Normal file
@ -0,0 +1,16 @@
|
||||
--- a/include/fuse_kernel.h
|
||||
+++ b/include/fuse_kernel.h
|
||||
@@ -88,12 +88,7 @@
|
||||
#ifndef _LINUX_FUSE_H
|
||||
#define _LINUX_FUSE_H
|
||||
|
||||
-#include <sys/types.h>
|
||||
-#define __u64 uint64_t
|
||||
-#define __s64 int64_t
|
||||
-#define __u32 uint32_t
|
||||
-#define __s32 int32_t
|
||||
-#define __u16 uint16_t
|
||||
+#include <linux/types.h>
|
||||
|
||||
/*
|
||||
* Version negotiation:
|
56
fuse.spec
56
fuse.spec
@ -2,7 +2,7 @@
|
||||
%define gitver %(echo %version | tr . _)
|
||||
Name: fuse
|
||||
Version: 2.9.9
|
||||
Release: 2mamba
|
||||
Release: 3mamba
|
||||
Summary: File System in Userspace (FUSE) utilities
|
||||
Group: System/Tools
|
||||
Vendor: openmamba
|
||||
@ -13,6 +13,7 @@ Source: https://github.com/libfuse/libfuse.git/fuse-%{version}/libfuse-%{
|
||||
#Source: http://downloads.sourceforge.net/fuse/fuse-%{version}.tar.gz
|
||||
Source1: %{name}-initscript
|
||||
Patch0: %{name}-2.8.7-fix_linking_issues_with_gold_linker.patch
|
||||
Patch1: fuse-2.9.9-aarch64.patch
|
||||
License: GPL, LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -54,6 +55,9 @@ This package contains static libraries and header files need for development.
|
||||
%setup -q -n libfuse-%{version}
|
||||
%define _default_patch_fuzz 1
|
||||
%patch0 -p1
|
||||
%ifarch aarch64
|
||||
%patch1 -p1
|
||||
%endif
|
||||
sh ./makeconf.sh
|
||||
|
||||
%build
|
||||
@ -73,8 +77,9 @@ sh ./makeconf.sh
|
||||
# change permission to allow stripping
|
||||
chmod 0755 %{buildroot}/bin/%{name}rmount
|
||||
|
||||
install -D -m 755 %{S:1} \
|
||||
%{buildroot}%{_initrddir}/%{name}
|
||||
#install -D -m 755 %{S:1} \
|
||||
# %{buildroot}%{_initrddir}/%{name}
|
||||
rm -f %{buildroot}%{_initrddir}/%{name}
|
||||
|
||||
# create compatibility symlinks
|
||||
install -d %{buildroot}%{_bindir}
|
||||
@ -84,34 +89,6 @@ ln -s /bin/ulockmgr_server %{buildroot}%{_bindir}/ulockmgr_server
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%post
|
||||
# new install
|
||||
if [ $1 -eq 1 ]; then
|
||||
/sbin/chkconfig --add %{name}
|
||||
service %{name} start
|
||||
fi
|
||||
:
|
||||
|
||||
%preun
|
||||
# erase
|
||||
if [ $1 -eq 0 ]; then
|
||||
service %{name} stop
|
||||
/sbin/chkconfig --del %{name}
|
||||
fi
|
||||
:
|
||||
|
||||
%postun
|
||||
# upgrade
|
||||
if [ $1 -eq 1 ]; then
|
||||
if [ -e %{_sysconfdir}/modules.d/%{name} ]; then
|
||||
rm -f %{_sysconfdir}/modules.d/%{name}
|
||||
/sbin/chkconfig --add %{name}
|
||||
fi
|
||||
/sbin/chkconfig %{name}
|
||||
[ $? -eq 0 ] && service %{name} restart
|
||||
fi
|
||||
:
|
||||
|
||||
%post -n %{libname} -p /sbin/ldconfig
|
||||
%postun -n %{libname} -p /sbin/ldconfig
|
||||
|
||||
@ -123,7 +100,7 @@ fi
|
||||
/bin/ulockmgr_server
|
||||
%{_bindir}/fusermount
|
||||
%{_bindir}/ulockmgr_server
|
||||
%{_initrddir}/fuse
|
||||
#%{_initrddir}/fuse
|
||||
%{_mandir}/man1/fusermount.1*
|
||||
%{_mandir}/man1/ulockmgr_server.1*
|
||||
%{_mandir}/man8/mount.fuse.8*
|
||||
@ -131,7 +108,8 @@ fi
|
||||
|
||||
%files -n %{libname}
|
||||
%defattr(-,root,root)
|
||||
/%{_lib}/*.so.*
|
||||
/%{_lib}/libfuse.so.*
|
||||
/%{_lib}/libulockmgr.so.*
|
||||
%doc AUTHORS COPYING.LIB
|
||||
|
||||
%files -n %{libname}-devel
|
||||
@ -139,13 +117,19 @@ fi
|
||||
%dir %{_includedir}/%{name}
|
||||
%{_includedir}/%{name}/*.h
|
||||
%{_includedir}/*.h
|
||||
/%{_lib}/*.a
|
||||
/%{_lib}/*.la
|
||||
/%{_lib}/*.so
|
||||
/%{_lib}/libfuse.a
|
||||
/%{_lib}/libfuse.la
|
||||
/%{_lib}/libfuse.so
|
||||
/%{_lib}/libulockmgr.a
|
||||
/%{_lib}/libulockmgr.la
|
||||
/%{_lib}/libulockmgr.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%doc ChangeLog NEWS README.NFS
|
||||
|
||||
%changelog
|
||||
* Thu Dec 03 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.9.9-3mamba
|
||||
- added patch for aarch64; remove initscript
|
||||
|
||||
* Tue Jul 23 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 2.9.9-2mamba
|
||||
- restore the installation of custom initscript with chkconfig support
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user