160 lines
5.3 KiB
RPMSpec
160 lines
5.3 KiB
RPMSpec
%define pkgver %(echo %version | tr _ -)
|
|
Name: frozen-bubble
|
|
Version: 2.2.1_beta1
|
|
Release: 3mamba
|
|
Summary: Frozen Bubble arcade game
|
|
Group: Graphical Desktop/Applications/Games
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.frozen-bubble.org/
|
|
Source0: http://www.frozen-bubble.org/data/frozen-bubble-%{pkgver}.tar.bz2
|
|
Source1: %{name}-desktop
|
|
Patch0: frozen-bubble-2.2.1_beta1-glibc-2.37.patch
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libSDL-devel
|
|
BuildRequires: libSDL_Pango-devel
|
|
BuildRequires: libSDL_mixer-devel
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libperl
|
|
BuildRequires: perl-Alien-SDL
|
|
BuildRequires: perl-File-ShareDir
|
|
BuildRequires: perl-File-Which
|
|
BuildRequires: perl-SDL
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl >= 2:5.36.0
|
|
BuildRequires: perl-Gimp
|
|
BuildRequires: perl-IPC-System-Simple
|
|
BuildRequires: perl-Locale-Maketext-Lexicon
|
|
BuildRequires: perl-SDL >= 2.546
|
|
Requires: libSDL_Pango
|
|
Requires: perl-SDL >= 2.546
|
|
|
|
%description
|
|
Colorful 3D rendered penguin animations, 100 levels of 1p game, hours and hours of 2p game, nights and nights of 2p/3p/4p/5p game over LAN or Internet, a level-editor, 3 professional quality digital soundtracks, 15 stereo sound effects, 8 unique graphical transition effects, 8 unique logo eye-candies.
|
|
|
|
%prep
|
|
%setup -q -n %{name}-%{pkgver}
|
|
%patch0 -p1 -b .glibc-2.37
|
|
|
|
sed -e 's|-Werror||' -i inc/My/Builder.pm
|
|
|
|
%build
|
|
%{__perl} Build.PL installdirs=vendor
|
|
|
|
./Build
|
|
./Build test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
./Build install destdir=%{buildroot}
|
|
|
|
find %{buildroot} -name .xvpics | xargs rm -rf
|
|
rm -f `find %{buildroot} -name perllocal.pod 2>/dev/null`
|
|
rm -f %{buildroot}%{perl_vendorarch}/auto/fb_c_stuff/.packlist
|
|
|
|
for r in 16 32 48 64; do
|
|
%{__install} -D -m 0644 share/icons/frozen-bubble-icon-${r}x${r}.png \
|
|
%{buildroot}%{_datadir}/icons/hicolor/${r}x${r}/apps/frozen-bubble.png
|
|
done
|
|
|
|
install -D -m644 %{SOURCE1} \
|
|
%{buildroot}%{_datadir}/applications/%{name}.desktop
|
|
|
|
find %{buildroot} -name *.so -exec chmod u+w {} \;
|
|
|
|
chmod u+w %{buildroot}%{_bindir}/fb-server
|
|
#%find_lang %{name}
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post
|
|
touch --no-create %{_datadir}/icons/hicolor || :
|
|
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
|
|
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
|
|
fi
|
|
exit 0
|
|
|
|
%postun
|
|
touch --no-create %{_datadir}/icons/hicolor || :
|
|
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
|
|
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
|
|
fi
|
|
exit 0
|
|
|
|
%files
|
|
#-f %{name}.lang
|
|
%defattr(-, root, root)
|
|
%{_bindir}/*
|
|
%{_datadir}/applications/%{name}.desktop
|
|
%{_datadir}/icons/hicolor/*/apps/frozen-bubble.png
|
|
%dir %{perl_vendorarch}/Games/FrozenBubble
|
|
%{perl_vendorarch}/Games/FrozenBubble.pm
|
|
%{perl_vendorarch}/Games/FrozenBubble/*.pm
|
|
%{perl_vendorarch}/auto/Games/FrozenBubble/.packlist
|
|
%dir %{perl_vendorarch}/auto/Games/FrozenBubble/CStuff
|
|
%{perl_vendorarch}/auto/Games/FrozenBubble/CStuff/CStuff.*
|
|
%dir %{perl_vendorarch}/auto/share/dist/Games-FrozenBubble
|
|
%{perl_vendorarch}/auto/share/dist/Games-FrozenBubble/*
|
|
%{_mandir}/man1/frozen-bubble-editor.1*
|
|
%{_mandir}/man1/frozen-bubble.1*
|
|
%{_mandir}/man3/Games::FrozenBubble.3pm*
|
|
%{_mandir}/man3/Games::FrozenBubble::LevelEditor.3pm*
|
|
%{_mandir}/man3/Games::FrozenBubble::MDKCommon.3pm*
|
|
%{_mandir}/man3/Games::FrozenBubble::Net.3pm*
|
|
%{_mandir}/man3/Games::FrozenBubble::NetDiscover.3pm*
|
|
%{_mandir}/man3/Games::FrozenBubble::Stuff.3pm*
|
|
%doc AUTHORS COPYING
|
|
#README
|
|
|
|
%changelog
|
|
* Wed Apr 19 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.1_beta1-3mamba
|
|
- rebuilt with perl 5.36.0
|
|
|
|
* Sat Nov 26 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.1_beta1-2mamba
|
|
- rebuilt with perl 5.24
|
|
|
|
* Wed Jul 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.1_beta1-1mamba
|
|
- update to 2.2.1_beta1
|
|
- require perl-SDL >= 2.541
|
|
|
|
* Thu Nov 15 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.0-3mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Sun Oct 24 2010 Davide Madrisan <davide.madrisan@gmail.com> 2.2.0-2mamba
|
|
- install modules with INSTALLDIRS=vendor
|
|
- install 16 and 32 pixels icons
|
|
- move icons to %{_datadir}/icons/hicolor and run gtk-update-icon-cache
|
|
|
|
* Fri Dec 19 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.0-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon Jul 14 2008 gil <puntogil@libero.it> 2.1.0-2mamba
|
|
- rebuild with updated perl-SDL (2.1.3) and libSDL (1.2.13) packages
|
|
|
|
* Tue Aug 14 2007 Tiziana Ferro <tiziana.ferro@email.it> 2.1.0-1mamba
|
|
- update to 2.1.0
|
|
|
|
* Wed Nov 09 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.0-6qilnx
|
|
- new desktop file
|
|
|
|
* Fri Sep 23 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.0-5qilnx
|
|
- rebuilt
|
|
|
|
* Fri Sep 09 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.0-4qilnx
|
|
- fixed the "Not a HASH reference at /usr/bin/frozen-bubble line 310" error
|
|
- specfiles updates
|
|
|
|
* Mon Jan 24 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.0-3qilnx
|
|
- rebuild with updated perl (5.8.6) and SDL_Perl (2.1.2) packages
|
|
|
|
* Thu Nov 11 2004 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 1.0.0-2qilnx
|
|
- rebuilt and moved from devel-contrib repository to devel repository
|
|
|
|
* Wed Sep 08 2004 Matteo Bernasconi <voyagernm@virgilio.it> 1.0.0-1qilnx
|
|
- first build
|