update to 13.4 [release 13.4-1mamba;Mon Feb 26 2024]

This commit is contained in:
Silvan Calarco 2024-04-09 11:07:26 +02:00
parent 6d72853b4d
commit 8e3aa41d2e
3 changed files with 43 additions and 88 deletions

View File

@ -1,34 +0,0 @@
--- freefilesync-7.5/FreeFileSync/Source/Makefile 2015-10-02 14:59:20.000000000 +0200
+++ FreeFileSync_-7.5/FreeFileSync/Source/Makefile 2015-10-25 12:27:19.487259334 +0100
@@ -8,11 +8,11 @@
CXXFLAGS = -std=c++14 -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" -Wall \
-O3 -DNDEBUG `wx-config --cxxflags --debug=no` -DZEN_LINUX -pthread
-LINKFLAGS = -s `wx-config --libs std, aui --debug=no` -lboost_thread -lboost_chrono -lboost_system -lz -pthread
+LINKFLAGS = -s `wx-config --libs std, aui --debug=no` `wx-config --libs` -lz -pthread
#Gtk - support recycler/icon loading/no button border/grid scrolling
-CXXFLAGS += `pkg-config --cflags gtk+-2.0`
-LINKFLAGS += `pkg-config --libs gtk+-2.0`
+CXXFLAGS += `pkg-config --cflags gtk+-3.0`
+LINKFLAGS += `pkg-config --libs gtk+-3.0`
#support for SELinux (optional)
SELINUX_EXISTING=$(shell pkg-config --exists libselinux && echo YES)
--- freefilesync-7.5/FreeFileSync/Source/RealtimeSync/Makefile.orig 2015-10-25 12:38:41.648664477 +0100
+++ freefilesync-7.5/FreeFileSync/Source/RealtimeSync/Makefile 2015-10-25 12:39:01.622499777 +0100
@@ -5,11 +5,11 @@
CXXFLAGS = -std=c++14 -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" -Wall \
-O3 -DNDEBUG `wx-config --cxxflags --debug=no` -DZEN_LINUX -pthread
-LINKFLAGS = -s `wx-config --libs std, aui --debug=no` -lboost_thread -lboost_chrono -lboost_system -lz -pthread
+LINKFLAGS = -s `wx-config --libs std, aui --debug=no` -lz -pthread
#Gtk - support "no button border"
-CXXFLAGS += `pkg-config --cflags gtk+-2.0`
-LINKFLAGS += `pkg-config --libs gtk+-2.0`
+CXXFLAGS += `pkg-config --cflags gtk+-3.0`
+LINKFLAGS += `pkg-config --libs gtk+-3.0`
CPP_LIST=
CPP_LIST+=application.cpp

View File

@ -1,11 +0,0 @@
--- freefilesync-7.5/FreeFileSync/Source/ui/version_check.cpp.orig 2015-10-25 17:30:38.221440957 +0100
+++ freefilesync-7.5/FreeFileSync/Source/ui/version_check.cpp 2015-10-25 17:30:50.654429151 +0100
@@ -410,7 +410,7 @@
{
if (updateCheckActive(lastUpdateCheck))
{
- static_assert(sizeof(time_t) >= 8, "Still using 32-bit time_t? WTF!!");
+ //static_assert(sizeof(time_t) >= 8, "Still using 32-bit time_t? WTF!!");
const time_t now = std::time(nullptr);
return numeric::dist(now, lastUpdateCheck) >= 7 * 24 * 3600; //check weekly
}

View File

@ -1,40 +1,38 @@
Name: freefilesync Name: freefilesync
Version: 7.5 Version: 13.4
Release: 1mamba Release: 1mamba
Summary: A software that helps you synchronize files and synchronize folders Summary: A software that helps you synchronize files and synchronize folders
Group: Graphical Desktop/Applications/Utilities Group: Graphical Desktop/Applications/Utilities
Vendor: openmamba Vendor: openmamba
Distribution: openmamba Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.freefilesync.org/ URL: https://freefilesync.org/
# FIXME: needs manual download Source: https://github.com/hkneptune/FreeFileSync.git/v%{version}/FreeFileSync-%{version}.tar.bz2
Source: http://www.freefilesync.org/download/5qlb1c8ltns7obk/FreeFileSync_%{version}_Source.zip
Source1: freefilesync.desktop Source1: freefilesync.desktop
Source2: ffsicon.png Source2: ffsicon.png
Source3: realtimesync.desktop Source3: realtimesync.desktop
Source4: rtsicon.png Source4: rtsicon.png
Patch0: freefilesync-7.5-Makefile.patch
Patch1: freefilesync-7.5-version_check_32bit.patch
License: GPL License: GPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
BuildRequires: libatk-devel BuildRequires: libat-spi2-core-devel
BuildRequires: libcairo-devel BuildRequires: libcairo-devel
BuildRequires: libcurl-devel
BuildRequires: libgcc BuildRequires: libgcc
BuildRequires: libgdk-pixbuf-devel BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel BuildRequires: libglib-devel
BuildRequires: libgtk-devel BuildRequires: libgtk3-devel
BuildRequires: libharfbuzz-devel
BuildRequires: libopenssl-devel
BuildRequires: libpango-devel BuildRequires: libpango-devel
BuildRequires: libpcre-devel
BuildRequires: libselinux-devel BuildRequires: libselinux-devel
BuildRequires: libsepol-devel BuildRequires: libssh2-devel
BuildRequires: libstdc++6-devel BuildRequires: libstdc++6-devel
BuildRequires: libwx_baseu-devel
BuildRequires: libwx_gtk3u-devel
BuildRequires: libz-devel BuildRequires: libz-devel
BuildRequires: wxwidgets-devel
BuildRequires: wxwidgets-gtk3-devel
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
BuildRequires: libzenxml-devel BuildRequires: libzenxml-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description %description
FreeFileSync is a free Open Source software that helps you synchronize files and synchronize folders for Windows, Linux and Mac OS X. It is designed to save your time setting up and running backup jobs while having nice visual feedback along the way. FreeFileSync is a free Open Source software that helps you synchronize files and synchronize folders for Windows, Linux and Mac OS X. It is designed to save your time setting up and running backup jobs while having nice visual feedback along the way.
@ -42,25 +40,35 @@ FreeFileSync is a free Open Source software that helps you synchronize files and
%debug_package %debug_package
%prep %prep
%setup -q -c %setup -q -n FreeFileSync-%{version}
%patch0 -p1 bsdunzip FreeFileSync/Build/Resources/Icons.zip {FreeFileSync,RealTimeSync}.png
%ifarch %{ix86} sed -i 's|-2|-3|' FreeFileSync/Source/{Makefile,RealTimeSync/Makefile}
%patch1 -p1 sed -i 's| -s | |' FreeFileSync/Source/{Makefile,RealTimeSync/Makefile}
%endif sed -i 's|#error|//#error|' FreeFileSync/Source/{application.cpp,RealTimeSync/application.cpp} zen/{string_tools.h,globals.h}
sed -i 's|::g_object_ref|g_object_ref|' FreeFileSync/Source/base/icon_loader.cpp
%build %build
export CXXFLAGS="%{optflags} -DMAX_SFTP_READ_SIZE=30000 -DMAX_SFTP_OUTGOING_SIZE=30000"
export LDFLAGS="%{optflags} `pkg-config --libs gtk+-3.0` -lz"
%make -C FreeFileSync/Source %make -C FreeFileSync/Source
%make -C FreeFileSync/Source/RealtimeSync %make -C FreeFileSync/Source/RealTimeSync
%install %install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}" [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C FreeFileSync/Source
%makeinstall -C FreeFileSync/Source/RealtimeSync
install -Dm644 %{SOURCE1} %{buildroot}%{_datadir}/applications/freefilesync.desktop install -d -m0755 %{buildroot}%{_datadir}/FreeFileSync
install -Dm644 %{SOURCE2} %{buildroot}%{_datadir}/pixmaps/ffsicon.png cp -a FreeFileSync/Build/{Bin,Resources} %{buildroot}%{_datadir}/FreeFileSync/
install -Dm644 %{SOURCE3} %{buildroot}%{_datadir}/applications/RealtimeSync.desktop
install -Dm644 %{SOURCE4} %{buildroot}%{_datadir}/pixmaps/rtsicon.png install -d -m0755 %{buildroot}%{_bindir}
ln -s ../share/FreeFileSync/Bin/{FreeFileSync,RealTimeSync} %{buildroot}%{_bindir}/
install -d -m0755 %{buildroot}%{_datadir}/pixmaps
install -Dm644 -t "%{buildroot}%{_datadir}/pixmaps" FreeFileSync.png RealTimeSync.png
install -Dm644 %{SOURCE1} %{buildroot}%{_datadir}/applications/FreeFileSync.desktop
install -Dm644 %{SOURCE3} %{buildroot}%{_datadir}/applications/RealTimeSync.desktop
%clean %clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}" [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
@ -68,26 +76,18 @@ install -Dm644 %{SOURCE4} %{buildroot}%{_datadir}/pixmaps/rtsicon.png
%files %files
%defattr(-,root,root) %defattr(-,root,root)
%{_bindir}/FreeFileSync %{_bindir}/FreeFileSync
%{_bindir}/RealtimeSync %{_bindir}/RealTimeSync
%{_datadir}/applications/RealTimeSync.desktop
%{_datadir}/applications/FreeFileSync.desktop
%dir %{_datadir}/FreeFileSync %dir %{_datadir}/FreeFileSync
%dir %{_datadir}/FreeFileSync/Help %{_datadir}/FreeFileSync/*
%{_datadir}/FreeFileSync/Help/FreeFileSync.hh* #%{_docdir}/FreeFileSync/changelog.gz
%dir %{_datadir}/FreeFileSync/Help/html %{_datadir}/pixmaps/*.png
%{_datadir}/FreeFileSync/Help/html/* %doc License.txt
%dir %{_datadir}/FreeFileSync/Help/images
%{_datadir}/FreeFileSync/Help/images/*
%dir %{_datadir}/FreeFileSync/Languages
%{_datadir}/FreeFileSync/Languages/*
%{_datadir}/FreeFileSync/Resources.zip
%{_datadir}/FreeFileSync/Sync_Complete.wav
%{_datadir}/FreeFileSync/styles.gtk_rc
%{_datadir}/applications/RealtimeSync.desktop
%{_datadir}/applications/freefilesync.desktop
%{_datadir}/doc/FreeFileSync/changelog.gz
%{_datadir}/pixmaps/ffsicon.png
%{_datadir}/pixmaps/rtsicon.png
%doc LICENSE
%changelog %changelog
* Mon Feb 26 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 13.4-1mamba
- update to 13.4
* Sat Oct 24 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 7.5-1mamba * Sat Oct 24 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 7.5-1mamba
- package created by autospec - package created by autospec