package created by autospec [release 7.5-1mamba;Sat Oct 24 2015]

This commit is contained in:
Silvan Calarco 2024-01-05 22:33:03 +01:00
parent 198e40dd52
commit 6d72853b4d
8 changed files with 170 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# freefilesync # freefilesync
FreeFileSync is a free Open Source software that helps you synchronize files and synchronize folders for Windows, Linux and Mac OS X. It is designed to save your time setting up and running backup jobs while having nice visual feedback along the way.

BIN
ffsicon.png Normal file

Binary file not shown.

After

Width:  |  Height:  |  Size: 12 KiB

View File

@ -0,0 +1,34 @@
--- freefilesync-7.5/FreeFileSync/Source/Makefile 2015-10-02 14:59:20.000000000 +0200
+++ FreeFileSync_-7.5/FreeFileSync/Source/Makefile 2015-10-25 12:27:19.487259334 +0100
@@ -8,11 +8,11 @@
CXXFLAGS = -std=c++14 -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" -Wall \
-O3 -DNDEBUG `wx-config --cxxflags --debug=no` -DZEN_LINUX -pthread
-LINKFLAGS = -s `wx-config --libs std, aui --debug=no` -lboost_thread -lboost_chrono -lboost_system -lz -pthread
+LINKFLAGS = -s `wx-config --libs std, aui --debug=no` `wx-config --libs` -lz -pthread
#Gtk - support recycler/icon loading/no button border/grid scrolling
-CXXFLAGS += `pkg-config --cflags gtk+-2.0`
-LINKFLAGS += `pkg-config --libs gtk+-2.0`
+CXXFLAGS += `pkg-config --cflags gtk+-3.0`
+LINKFLAGS += `pkg-config --libs gtk+-3.0`
#support for SELinux (optional)
SELINUX_EXISTING=$(shell pkg-config --exists libselinux && echo YES)
--- freefilesync-7.5/FreeFileSync/Source/RealtimeSync/Makefile.orig 2015-10-25 12:38:41.648664477 +0100
+++ freefilesync-7.5/FreeFileSync/Source/RealtimeSync/Makefile 2015-10-25 12:39:01.622499777 +0100
@@ -5,11 +5,11 @@
CXXFLAGS = -std=c++14 -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" -Wall \
-O3 -DNDEBUG `wx-config --cxxflags --debug=no` -DZEN_LINUX -pthread
-LINKFLAGS = -s `wx-config --libs std, aui --debug=no` -lboost_thread -lboost_chrono -lboost_system -lz -pthread
+LINKFLAGS = -s `wx-config --libs std, aui --debug=no` -lz -pthread
#Gtk - support "no button border"
-CXXFLAGS += `pkg-config --cflags gtk+-2.0`
-LINKFLAGS += `pkg-config --libs gtk+-2.0`
+CXXFLAGS += `pkg-config --cflags gtk+-3.0`
+LINKFLAGS += `pkg-config --libs gtk+-3.0`
CPP_LIST=
CPP_LIST+=application.cpp

View File

@ -0,0 +1,11 @@
--- freefilesync-7.5/FreeFileSync/Source/ui/version_check.cpp.orig 2015-10-25 17:30:38.221440957 +0100
+++ freefilesync-7.5/FreeFileSync/Source/ui/version_check.cpp 2015-10-25 17:30:50.654429151 +0100
@@ -410,7 +410,7 @@
{
if (updateCheckActive(lastUpdateCheck))
{
- static_assert(sizeof(time_t) >= 8, "Still using 32-bit time_t? WTF!!");
+ //static_assert(sizeof(time_t) >= 8, "Still using 32-bit time_t? WTF!!");
const time_t now = std::time(nullptr);
return numeric::dist(now, lastUpdateCheck) >= 7 * 24 * 3600; //check weekly
}

15
freefilesync.desktop Normal file
View File

@ -0,0 +1,15 @@
[Desktop Entry]
Comment=
Exec=FreeFileSync
GenericName=Folder Comparison and Synchronization
Icon=/usr/share/pixmaps/ffsicon.png
Name=FreeFileSync
NoDisplay=false
StartupNotify=true
Categories=GTK;Application;Utility;
Terminal=0
TerminalOptions=
Type=Application
X-KDE-SubstituteUID=false
X-KDE-Username=

93
freefilesync.spec Normal file
View File

@ -0,0 +1,93 @@
Name: freefilesync
Version: 7.5
Release: 1mamba
Summary: A software that helps you synchronize files and synchronize folders
Group: Graphical Desktop/Applications/Utilities
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.freefilesync.org/
# FIXME: needs manual download
Source: http://www.freefilesync.org/download/5qlb1c8ltns7obk/FreeFileSync_%{version}_Source.zip
Source1: freefilesync.desktop
Source2: ffsicon.png
Source3: realtimesync.desktop
Source4: rtsicon.png
Patch0: freefilesync-7.5-Makefile.patch
Patch1: freefilesync-7.5-version_check_32bit.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libatk-devel
BuildRequires: libcairo-devel
BuildRequires: libgcc
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel
BuildRequires: libgtk-devel
BuildRequires: libpango-devel
BuildRequires: libpcre-devel
BuildRequires: libselinux-devel
BuildRequires: libsepol-devel
BuildRequires: libstdc++6-devel
BuildRequires: libwx_baseu-devel
BuildRequires: libwx_gtk3u-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: libzenxml-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
FreeFileSync is a free Open Source software that helps you synchronize files and synchronize folders for Windows, Linux and Mac OS X. It is designed to save your time setting up and running backup jobs while having nice visual feedback along the way.
%debug_package
%prep
%setup -q -c
%patch0 -p1
%ifarch %{ix86}
%patch1 -p1
%endif
%build
%make -C FreeFileSync/Source
%make -C FreeFileSync/Source/RealtimeSync
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C FreeFileSync/Source
%makeinstall -C FreeFileSync/Source/RealtimeSync
install -Dm644 %{SOURCE1} %{buildroot}%{_datadir}/applications/freefilesync.desktop
install -Dm644 %{SOURCE2} %{buildroot}%{_datadir}/pixmaps/ffsicon.png
install -Dm644 %{SOURCE3} %{buildroot}%{_datadir}/applications/RealtimeSync.desktop
install -Dm644 %{SOURCE4} %{buildroot}%{_datadir}/pixmaps/rtsicon.png
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/FreeFileSync
%{_bindir}/RealtimeSync
%dir %{_datadir}/FreeFileSync
%dir %{_datadir}/FreeFileSync/Help
%{_datadir}/FreeFileSync/Help/FreeFileSync.hh*
%dir %{_datadir}/FreeFileSync/Help/html
%{_datadir}/FreeFileSync/Help/html/*
%dir %{_datadir}/FreeFileSync/Help/images
%{_datadir}/FreeFileSync/Help/images/*
%dir %{_datadir}/FreeFileSync/Languages
%{_datadir}/FreeFileSync/Languages/*
%{_datadir}/FreeFileSync/Resources.zip
%{_datadir}/FreeFileSync/Sync_Complete.wav
%{_datadir}/FreeFileSync/styles.gtk_rc
%{_datadir}/applications/RealtimeSync.desktop
%{_datadir}/applications/freefilesync.desktop
%{_datadir}/doc/FreeFileSync/changelog.gz
%{_datadir}/pixmaps/ffsicon.png
%{_datadir}/pixmaps/rtsicon.png
%doc LICENSE
%changelog
* Sat Oct 24 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 7.5-1mamba
- package created by autospec

15
realtimesync.desktop Normal file
View File

@ -0,0 +1,15 @@
[Desktop Entry]
Comment=
Exec=RealtimeSync
GenericName=Automated Synchronization
Icon=/usr/share/pixmaps/rtsicon.png
Name=RealtimeSync
NoDisplay=false
StartupNotify=true
Categories=GTK;Application;Utility;
Terminal=0
TerminalOptions=
Type=Application
X-KDE-SubstituteUID=false
X-KDE-Username=

BIN
rtsicon.png Normal file

Binary file not shown.

After

Width:  |  Height:  |  Size: 11 KiB