automatic update by autodist [release 4.0.13-1mamba;Wed Dec 28 2022]
This commit is contained in:
parent
8ccc0d9c69
commit
5c35366252
@ -1,2 +1,4 @@
|
||||
# foomatic-db-engine
|
||||
|
||||
Printers, drivers, and driver options in XML files, used by foomatic-db-engine to generate PPD files.
|
||||
|
||||
|
14
foomatic-4.0.8-cat-ppd.patch
Normal file
14
foomatic-4.0.8-cat-ppd.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- foomatic-db-engine-4.0.7/foomatic-ppdfile.in.fix 2011-02-18 15:30:22.000000000 +0300
|
||||
+++ foomatic-db-engine-4.0.7/foomatic-ppdfile.in 2011-08-09 17:52:11.296266684 +0400
|
||||
@@ -195,9 +195,9 @@ sub generateppd {
|
||||
unshift(@drivercomponents, pop(@poidcomponents));
|
||||
$driver = join('-', @drivercomponents);
|
||||
$printer = join('-', @poidcomponents);
|
||||
- next if (!Foomatic::DB::member($driver, @drivers) or
|
||||
+ next if (!Foomatic::DB::member($driver, @drivers) and
|
||||
!Foomatic::DB::member($printer, @printers));
|
||||
- $poid = $printer;
|
||||
+ $poid = join('-', @poidcomponents);
|
||||
last;
|
||||
}
|
||||
die "ERROR: Could not determine driver name for $ppdname.ppd!\n"
|
244
foomatic-db-engine.spec
Normal file
244
foomatic-db-engine.spec
Normal file
@ -0,0 +1,244 @@
|
||||
Name: foomatic-db-engine
|
||||
Version: 4.0.13
|
||||
Epoch: 3
|
||||
Release: 1mamba
|
||||
Summary: Printers, drivers, and driver options in XML files, used by foomatic-db-engine to generate PPD files
|
||||
Group: System/Spooling
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
Source0: http://www.openprinting.org/download/foomatic/foomatic-db-engine-%{version}.tar.gz
|
||||
Patch0: foomatic-4.0.8-cat-ppd.patch
|
||||
URL: https://wiki.linuxfoundation.org/openprinting/database/foomatic
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libperl
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: perl-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libcups-devel >= 1.1.20
|
||||
Requires: hplip >= 0.9.7
|
||||
Requires: gutenprint
|
||||
Requires: foo2zjs
|
||||
Requires: libpoppler-tools
|
||||
Requires: foomatic-filters
|
||||
Requires: foomatic-db
|
||||
Requires: foomatic-db-nonfree
|
||||
Requires: ghostscript-cups
|
||||
Requires: pnm2ppa
|
||||
Provides: postscript-driver
|
||||
Provides: foomatic
|
||||
Obsoletes: foomatic < 3:4.0.13
|
||||
|
||||
%description
|
||||
Printers, drivers, and driver options in XML files, used by foomatic-db-engine to generate PPD files.
|
||||
|
||||
%package -n perl-foomatic
|
||||
Summary: Perl library for Foomatic
|
||||
Group: System/Spooling
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n perl-foomatic
|
||||
Perl library for Foomatic.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
chmod +x mkinstalldirs
|
||||
%configure \
|
||||
--libdir=%{_prefix}/lib
|
||||
%make -j1 PREFIX=%{_prefix} PERL_INSTALLDIRS=vendor
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall
|
||||
|
||||
# Use relative symlink
|
||||
ln -sf ../../../bin/foomatic-ppdfile %{buildroot}%{_prefix}/lib/cups/driver/foomatic
|
||||
|
||||
install -d %{buildroot}%{_var}/cache/foomatic
|
||||
|
||||
rm -f %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample
|
||||
|
||||
packlist=`find %{buildroot} -name .packlist`
|
||||
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
||||
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" | \
|
||||
sort -u > .packlist && rm -f $packlist
|
||||
|
||||
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
||||
for dir in `find %{buildroot} -type d | grep $strid`; do
|
||||
echo "%dir ${dir#%buildroot}" >> .packlist
|
||||
done
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%pre
|
||||
# If %{_datadir}/cups/model/foomatic-ppds is a directory,
|
||||
# it will be removed avoiding installation problem
|
||||
[ -d %{_datadir}/cups/model/foomatic-ppds ] && \
|
||||
rm -rf %{_datadir}/cups/model/foomatic-ppds
|
||||
exit 0
|
||||
|
||||
%post
|
||||
# new install
|
||||
if [ $1 -eq 1 ]; then
|
||||
chkconfig cups
|
||||
[ $? -eq 0 ] && service cups restart &>/dev/null
|
||||
fi
|
||||
/bin/rm -f /var/cache/foomatic/*/*
|
||||
exit 0
|
||||
|
||||
%postun
|
||||
# upgrade
|
||||
if [ $1 -eq 1 ]; then
|
||||
chkconfig cups
|
||||
[ $? -eq 0 ] && service cups restart &>/dev/null
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%preun
|
||||
# erase
|
||||
if [ $1 -eq 0 ]; then
|
||||
chkconfig cups
|
||||
[ $? -eq 0 ] && service cups restart &>/dev/null
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%dir %{_sysconfdir}/foomatic
|
||||
%{_bindir}/foomatic-*
|
||||
%{_sbindir}/foomatic-*
|
||||
%dir %{_datadir}/foomatic
|
||||
%{_datadir}/foomatic/templates/*.xml
|
||||
%{_prefix}/lib/cups/driver/foomatic
|
||||
%dir %{_var}/cache/foomatic
|
||||
%{_mandir}/man1/foomatic-*
|
||||
%{_mandir}/man8/foomatic-*
|
||||
|
||||
%files -n perl-foomatic -f .packlist
|
||||
%defattr(-,root,root)
|
||||
|
||||
%changelog
|
||||
* Wed Dec 28 2022 Automatic Build System <autodist@mambasoft.it> 4.0.13-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Feb 24 2014 Automatic Build System <autodist@mambasoft.it> 4.0.10-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Mar 19 2013 Automatic Build System <autodist@mambasoft.it> 4.0.9-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Nov 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.8-5mamba
|
||||
- perl 5.16 mass rebuild
|
||||
|
||||
* Sat Sep 29 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.8-4mamba
|
||||
- added a patch to fix ppd autogeneration for some printers when calling cups-driverd
|
||||
|
||||
* Wed Aug 08 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.8-3mamba
|
||||
- provide postscript-driver as required by apper printers installation interface
|
||||
|
||||
* Thu Feb 16 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.8-2mamba
|
||||
- require foomatic-filters, packaged apart
|
||||
- added requirement for pnm2ppa
|
||||
|
||||
* Fri Aug 05 2011 Automatic Build System <autodist@mambasoft.it> 4.0.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Feb 22 2011 Automatic Build System <autodist@mambasoft.it> 4.0.7-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Dec 23 2010 Automatic Build System <autodist@mambasoft.it> 4.0.6-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Oct 25 2010 Davide Madrisan <davide.madrisan@gmail.com> 4.0.5-1mamba
|
||||
- update to 4.0.5
|
||||
- rebuilt with PERL_INSTALLDIRS=vendor
|
||||
- do not provide %{_sysconfdir}/foomatic/filter.conf.sample
|
||||
- create and own %{_var}/cache/foomatic
|
||||
|
||||
* Thu Apr 15 2010 Automatic Build System <autodist@mambasoft.it> 4.0.4-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Jan 07 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.3-2mamba
|
||||
- added requirement for ghostscript-cups
|
||||
|
||||
* Sat Dec 05 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.3-1mamba
|
||||
- update to 4.0.3
|
||||
|
||||
* Tue Dec 01 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.20091201-1mamba
|
||||
- update to 4.0.20091201
|
||||
- added requirement for libpoppler-tools
|
||||
|
||||
* Tue Jun 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.20090616-1mamba
|
||||
- update to 4.0.20090616
|
||||
|
||||
* Thu May 14 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.20090514-1mamba
|
||||
- update to 4.0.20090514
|
||||
|
||||
* Thu Nov 06 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.20080608-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Mon Jun 09 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.20080608-1mamba
|
||||
- update to 3.0.20080608
|
||||
- excluded gutenprint drivers definition files gutenprint.xml and gutenprint52.xml
|
||||
|
||||
* Thu Mar 27 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.20080327-1mamba
|
||||
- update to 3.0.20080327
|
||||
|
||||
* Tue Mar 25 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.20080325-1mamba
|
||||
- update to 3.0.20080325
|
||||
- removed ppd from foomatic-filters-ppds
|
||||
|
||||
* Sun Oct 14 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.20071012-2mamba
|
||||
- update to 3.0.20071012
|
||||
- epoch incremented because of major release download (3.1 is unstable)
|
||||
- removed lx x74 driver (it is partially supported by foomatic)
|
||||
|
||||
* Sun Mar 19 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.20060319-1qilnx
|
||||
- update to version 20060319 by autospec
|
||||
- removed foomatic-db sources from target package
|
||||
- specfile architectural changes (build under single foomatic dir)
|
||||
- fixed lxx74 driver packaging
|
||||
- change versioning to include big version of foomatic (and increment epoch)
|
||||
- patch Generic Postscript driver name so it works in KDE
|
||||
|
||||
* Wed Feb 22 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 20060221-2qilnx
|
||||
- add a patch to fix a perl error on DB.pm
|
||||
|
||||
* Tue Feb 21 2006 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 20060221-1qilnx
|
||||
- update to version 20060221 by autospec
|
||||
|
||||
* Thu Jan 26 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 20060126-1qilnx
|
||||
- update to version 20060126 by autospec
|
||||
- fixed %pre script (ad exit 0 to the end)
|
||||
|
||||
* Thu Nov 24 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 20051124-1qilnx
|
||||
- update to version 20051124 by autospec
|
||||
|
||||
* Tue Aug 30 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 20050830-1qilnx
|
||||
- update to version 20050830 by autospec
|
||||
|
||||
* Mon May 02 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 20050502-1qilnx
|
||||
- new version build
|
||||
|
||||
* Tue Oct 12 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 20040926-2qilnx
|
||||
- added missing symlinks in /usr/lib/cups/filters, ppr/lib, ppr/interfaces
|
||||
|
||||
* Mon Sep 27 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 20040926-1qilnx
|
||||
- new drivers version build
|
||||
- added lxx74 drivers for Lexmark printers
|
||||
|
||||
* Wed Aug 11 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 20040811-1qilnx
|
||||
- new version build
|
||||
|
||||
* Fri May 21 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 20040521-1qilnx
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user