automatic rebuild by autodist [release 3.0a-2mamba;Sun Sep 08 2013]

This commit is contained in:
Automatic Build System 2024-01-05 22:30:07 +01:00
parent 429ca12ddb
commit 1613b928c5
4 changed files with 119 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# foobillard # foobillard
FooBillard is an attempt to create a free OpenGL-billard for Linux. Why foo? Well, actually I had this logo (F.B.-Florian Berger) and then foo sounds a bit like pool (Somehow I wasn't quite attracted by the name FoolBillard) Actually FooBillard is still under development but the main physics is implemented. If you are a billard-pro and you're missing some physics, please tell me. Cause I've implemented it like I think it should work, which might differ from reality.

View File

@ -0,0 +1,11 @@
--- foobillard-3.0a/src/bumpref.c.orig 2013-09-08 15:40:08.662309957 +0200
+++ foobillard-3.0a/src/bumpref.c 2013-09-08 15:39:42.883548953 +0200
@@ -32,6 +32,8 @@
#include "vmath.h"
+#define NO_NV_BUMPREF /* force not to use bumpref */
+
#ifndef NO_NV_BUMPREF /* force not to use bumpref */
#ifdef GL_NV_register_combiners

View File

@ -0,0 +1,18 @@
--- foobillard-3.0a/src/ball.c.mitr 2004-02-23 02:09:01.000000000 +0100
+++ foobillard-3.0a/src/ball.c 2004-04-29 22:35:12.000000000 +0200
@@ -1821,6 +1821,7 @@
} else if( options_cuberef && cuberef_binds!=0 ){
glBindTexture(GL_TEXTURE_CUBE_MAP_ARB, cuberef_binds[i]);
#ifdef GL_VERTEX_PROGRAM_NV
+#ifdef USE_BALL_FRESNEL
{
myvec cam_pos2;
// cam_pos2=vec_scale(vec_unit(vec_diff(cam_pos,balls.ball[i].r)),BALL_D/2.5);
@@ -1829,6 +1830,7 @@
BALL_D/2.0,BALL_D/2.5,0,0 );
}
#endif
+#endif
draw_ball(&balls.ball[i],cam_pos,cam_FOV,win_width,0);
}else{
draw_ball(&balls.ball[i],cam_pos,cam_FOV,win_width,0);

88
foobillard.spec Normal file
View File

@ -0,0 +1,88 @@
Name: foobillard
Version: 3.0a
Release: 2mamba
Summary: A free OpenGl billard game for linux.
Group: Graphical Desktop/Applications/Games
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://foobillard.sunsite.dk/
Source: http://foobillard.sunsite.dk/dnl/foobillard-%{version}.tar.gz
Patch: %{name}-3.0a-nonv.patch
Patch1: foobillard-3.0a-no-nv-bumpref.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libfreetype-devel
BuildRequires: libGL-devel
BuildRequires: libGLU-devel
BuildRequires: libICE-devel
BuildRequires: libpng-devel
BuildRequires: libSDL-devel
BuildRequires: libSM-devel
BuildRequires: libXaw-devel
BuildRequires: libXi-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
FooBillard is an attempt to create a free OpenGL-billard for Linux. Why foo? Well, actually I had this logo (F.B.-Florian Berger) and then foo sounds a bit like pool (Somehow I wasn't quite attracted by the name FoolBillard) Actually FooBillard is still under development but the main physics is implemented. If you are a billard-pro and you're missing some physics, please tell me. Cause I've implemented it like I think it should work, which might differ from reality.
%prep
%setup -q
%patch -p1
%patch1 -p1
%build
%configure \
--prefix=%{_prefix} \
--datadir=%{_datadir}/games \
--enable-SDL \
--enable-debug \
# --x-includes=%{_includedir}/X11 \
#--x-libraries=%{_prefix}/X11R6/%{_lib}
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall DESTDIR=%{buildroot}
mkdir -p %{buildroot}%{_datadir}/applications
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
[Desktop Entry]
Encoding=UTF-8
Name=FooBillard
GenericName=Billard
GenericName[it]=Biliardo
Comment=OpenGL Billard game
Comment[it]=Gioco del Biliardo
Exec=%{_bindir}/foobillard
Icon=%{_datadir}/games/foobillard/foobillard.png
Terminal=false
Type=Application
Categories=Game;ArcadeGame;
EOF
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/foobillard
%{_datadir}/applications/foobillard.desktop
%dir %{_datadir}/games/foobillard
%{_datadir}/games/foobillard/ball_ball.raw
%{_datadir}/games/foobillard/foobillard.gif
%{_datadir}/games/foobillard/*.png
%{_datadir}/games/foobillard/*.ttf
%doc AUTHORS COPYING
#ChangeLog README README.FONTS TODO
%changelog
* Sun Sep 08 2013 Automatic Build System <autodist@mambasoft.it> 3.0a-2mamba
- automatic rebuild by autodist
* Sun Aug 31 2008 gil <puntogil@libero.it> 3.0a-1mamba
- added desktop file