333 lines
11 KiB
RPMSpec
333 lines
11 KiB
RPMSpec
%define libname lib%{name}
|
|
%define pkgver %(echo %version | tr _ -)
|
|
Name: fontforge
|
|
Epoch: 1
|
|
Version: 20190801
|
|
Release: 2mamba
|
|
Summary: An outline font editor
|
|
Group: Applications/Fonts
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://fontforge.sourceforge.net/
|
|
Source: https://github.com/fontforge/fontforge.git/%{version}/fontforge-%{version}.tar.bz2
|
|
#Source: http://downloads.sourceforge.net/fontforge/fontforge_full-%{pkgver}.tar.bz2
|
|
#Source1: http://downloads.sourceforge.net/fontforge/fontforge_htdocs-%{pkgver}.tar.bz2
|
|
Source2: %{name}-desktop
|
|
Patch0: fontforge-20150228-add_gunicode_to_pkgconfig.patch
|
|
License: BSD
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libICE-devel
|
|
BuildRequires: libSM-devel
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libXau-devel
|
|
BuildRequires: libXdmcp-devel
|
|
BuildRequires: libXext-devel
|
|
BuildRequires: libXft-devel
|
|
BuildRequires: libXi-devel
|
|
BuildRequires: libXrender-devel
|
|
BuildRequires: libbsd-devel
|
|
BuildRequires: libbzip2-devel
|
|
BuildRequires: libcairo-devel
|
|
BuildRequires: libexpat-devel
|
|
BuildRequires: libffi-devel
|
|
BuildRequires: libfontconfig-devel
|
|
BuildRequires: libfreetype-devel
|
|
BuildRequires: libgif-devel
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libgraphite2-devel
|
|
BuildRequires: libharfbuzz-devel
|
|
BuildRequires: libjbig-devel
|
|
BuildRequires: libjpeg-devel
|
|
BuildRequires: libltdl-devel
|
|
BuildRequires: liblzma-devel
|
|
BuildRequires: libpango-devel
|
|
BuildRequires: libpng-devel
|
|
BuildRequires: libpython-devel
|
|
BuildRequires: libpython27-devel
|
|
BuildRequires: libreadline-devel
|
|
BuildRequires: libselinux-devel
|
|
BuildRequires: libspiro-devel
|
|
BuildRequires: libtermcap-devel
|
|
BuildRequires: libtiff-devel
|
|
BuildRequires: libuninameslist-devel
|
|
BuildRequires: libuuid-devel
|
|
BuildRequires: libxcb-devel
|
|
BuildRequires: libxml2-devel
|
|
BuildRequires: libz-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: libuninameslist-devel >= 20200413
|
|
BuildConflicts: libfontforge-devel
|
|
Requires: potrace
|
|
Requires: xdg-utils
|
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
FontForge is an outline font editor that lets you create your own postscript, truetype, opentype, cid-keyed, multi-master, cff, svg and bitmap (bdf) fonts, or edit existing ones. Also lets you convert one format to another.
|
|
FontForge has support for many macintosh font formats.
|
|
|
|
%package -n %{libname}
|
|
Group: System/Libraries
|
|
Summary: The libraries for FontForge
|
|
|
|
%description -n %{libname}
|
|
FontForge is an outline font editor that lets you create your own postscript, truetype, opentype, cid-keyed, multi-master, cff, svg and bitmap (bdf) fonts, or edit existing ones. Also lets you convert one format to another.
|
|
FontForge has support for many macintosh font formats.
|
|
This package contains shared libraries needed for FontForge.
|
|
|
|
%package -n %{libname}-devel
|
|
Group: Development/Libraries
|
|
Summary: Devel files for FontForge
|
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n %{libname}-devel
|
|
FontForge is an outline font editor that lets you create your own postscript, truetype, opentype, cid-keyed, multi-master, cff, svg and bitmap (bdf) fonts, or edit existing ones. Also lets you convert one format to another.
|
|
FontForge has support for many macintosh font formats.
|
|
This package contains static libraries and header files needed for development.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n %{name}-%{pkgver}
|
|
#%patch0 -p1
|
|
|
|
#mkdir docs
|
|
#tar xjf %{S:1} -C docs
|
|
#rm -rf docs/scripts
|
|
#chmod 644 docs/*.gif docs/*.html docs/*.png
|
|
#rm -rf docs/flags/CVS
|
|
#sed -i -e "s,\r,," docs/Big5.txt
|
|
#sed -i -e "s,\r,," docs/corpchar.txt
|
|
|
|
#tar xzf docs/cidmaps.tgz
|
|
|
|
%build
|
|
./bootstrap
|
|
#export CFLAGS='-DDOCDIR=\"%{_defaultdocdir}/%{name}-%{version}/docs\"'
|
|
export LIBS="-lspiro -ltermcap"
|
|
%configure \
|
|
--without-freetype-bytecode \
|
|
--with-regular-link \
|
|
--with-python=%{__python} \
|
|
PYTHON=%{__python}
|
|
# --with-freetype-src=%{_builddir}/freetype-%{freetype_ver}
|
|
# --with-multilayer \
|
|
|
|
%make LDFLAGS="`pkg-config --libs libpng`"
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
%makeinstall
|
|
|
|
# FIXME: add a wrapper that sets XLIB_SKIP_ARGB_VISUALS=1 before
|
|
# calling fontforge to make it work with Xgl
|
|
mv %{buildroot}%{_bindir}/%{name} %{buildroot}%{_bindir}/%{name}.bin
|
|
|
|
cat > %{buildroot}%{_bindir}/%{name} << _EOF
|
|
#!/bin/bash
|
|
|
|
# Copyright (c) 2007 by Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
# Copyright (c) 2007 by Davide Madrisan <davide.madrisan@gmail.com>
|
|
|
|
XLIB_SKIP_ARGB_VISUALS=1 %{name}.bin \$@
|
|
_EOF
|
|
|
|
chmod 775 %{buildroot}%{_bindir}/%{name}
|
|
|
|
## install CMaps
|
|
#install -m 644 Adobe* %{buildroot}%{_datadir}/%{name}
|
|
|
|
%find_lang FontForge
|
|
|
|
## install icon
|
|
#install -d -m0755 %{buildroot}%{_datadir}/icons/hicolor/
|
|
#cp -a desktop/icons/* %{buildroot}%{_datadir}/icons/hicolor/
|
|
|
|
## install desktop file
|
|
#install -D -m 644 desktop/fontforge.desktop \
|
|
# %{buildroot}%{_datadir}/applications/%{name}.desktop
|
|
|
|
%post -n %{libname} -p /sbin/ldconfig
|
|
%postun -n %{libname} -p /sbin/ldconfig
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
|
|
%files -f FontForge.lang
|
|
%defattr(-,root,root)
|
|
%{_bindir}/%{name}
|
|
%{_bindir}/%{name}.bin
|
|
%{_bindir}/fontimage
|
|
%{_bindir}/fontlint
|
|
%{_bindir}/sfddiff
|
|
%dir %{_datadir}/%{name}
|
|
%{_datadir}/%{name}/*
|
|
%{_datadir}/appdata/org.fontforge.FontForge.appdata.xml
|
|
%{_datadir}/applications/org.fontforge.FontForge.desktop
|
|
%{_datadir}/icons/hicolor/*/apps/org.fontforge.FontForge.png
|
|
%{_datadir}/icons/hicolor/scalable/apps/org.fontforge.FontForge.svg
|
|
%{_datadir}/metainfo/org.fontforge.FontForge.*.xml
|
|
%{_datadir}/pixmaps/org.fontforge.FontForge.*
|
|
%{_datadir}/mime/packages/fontforge.xml
|
|
%{_mandir}/man1/%{name}.*
|
|
%{_mandir}/man1/fontimage.*
|
|
%{_mandir}/man1/fontlint.*
|
|
%{_mandir}/man1/sfddiff.*
|
|
%{python_sitearch}/fontforge.*
|
|
%{python_sitearch}/psMat.*
|
|
|
|
%files -n %{libname}
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libfontforge.so.*
|
|
%{_libdir}/libfontforgeexe.so.*
|
|
%{_libdir}/libgdraw.so.*
|
|
#%{_libdir}/libgioftp.so.*
|
|
%{_libdir}/libgunicode.so.*
|
|
%{_libdir}/libgutils.so.*
|
|
%doc AUTHORS LICENSE
|
|
|
|
%files -n %{libname}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/fontforge
|
|
%{_includedir}/fontforge/*.h
|
|
%{_libdir}/libfontforge.a
|
|
%{_libdir}/libfontforge.la
|
|
%{_libdir}/libfontforge.so
|
|
%{_libdir}/libfontforgeexe.a
|
|
%{_libdir}/libfontforgeexe.la
|
|
%{_libdir}/libfontforgeexe.so
|
|
%{_libdir}/libgdraw.a
|
|
%{_libdir}/libgdraw.la
|
|
%{_libdir}/libgdraw.so
|
|
#%{_libdir}/libgioftp.a
|
|
#%{_libdir}/libgioftp.la
|
|
#%{_libdir}/libgioftp.so
|
|
%{_libdir}/libgunicode.a
|
|
%{_libdir}/libgunicode.la
|
|
%{_libdir}/libgunicode.so
|
|
%{_libdir}/libgutils.a
|
|
%{_libdir}/libgutils.la
|
|
%{_libdir}/libgutils.so
|
|
%dir %{_docdir}/fontforge
|
|
%{_docdir}/fontforge/*
|
|
%{_docdir}/fontforge/.htaccess
|
|
%{_libdir}/pkgconfig/lib%{name}.pc
|
|
%{_libdir}/pkgconfig/lib%{name}exe.pc
|
|
#%doc README-unix README-Unix.html
|
|
|
|
%changelog
|
|
* Sat Dec 05 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 20190801-2mamba
|
|
- rebuilt with libuninameslist-devel 20200413
|
|
|
|
* Sun Aug 18 2019 Automatic Build System <autodist@mambasoft.it> 20190801-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat May 11 2019 Automatic Build System <autodist@mambasoft.it> 20190413-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Apr 26 2019 Automatic Build System <autodist@mambasoft.it> 20190317-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Aug 06 2017 Automatic Build System <autodist@mambasoft.it> 20170731-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 17 2016 Automatic Build System <autodist@mambasoft.it> 20161012-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Oct 05 2016 Automatic Build System <autodist@mambasoft.it> 20161004-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat May 28 2016 Automatic Build System <autodist@mambasoft.it> 20160404-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 01 2015 Automatic Build System <autodist@mambasoft.it> 20150824-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jun 25 2015 Automatic Build System <autodist@mambasoft.it> 20150612-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 07 2015 Automatic Build System <autodist@mambasoft.it> 20150430-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Apr 03 2015 Automatic Build System <autodist@mambasoft.it> 20150330-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 24 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 20150228-2mamba
|
|
- upstream patch to fix pkgconfig and make install
|
|
|
|
* Sun Mar 08 2015 Automatic Build System <autodist@mambasoft.it> 20150228-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Nov 27 2014 Automatic Build System <autodist@mambasoft.it> 20141126-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Oct 26 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 20141014-1mamba
|
|
- update to 20141014
|
|
|
|
* Sun Jul 27 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 20140101-2mamba
|
|
- rebuilt with -ltermcap to fix link with readline
|
|
|
|
* Sat Feb 01 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 20140101-1mamba
|
|
- update to 20140101
|
|
|
|
* Thu May 23 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 20120731_b-3mamba
|
|
- python 2.7 mass rebuild
|
|
|
|
* Wed Jan 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 20120731_b-2mamba
|
|
- bump epoch up
|
|
|
|
* Sat Dec 08 2012 Automatic Build System <autodist@mambasoft.it> 20120731_b-1mamba
|
|
- update to 20120731_b
|
|
|
|
* Sun Aug 19 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 20120731-1mamba
|
|
- update to 20120731
|
|
|
|
* Sat Mar 26 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 20110222-1mamba
|
|
- update to 20110222
|
|
|
|
* Tue May 11 2010 Automatic Build System <autodist@mambasoft.it> 20100501-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Jul 10 2009 Automatic Build System <autodist@mambasoft.it> 20090622-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu Dec 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20081115-1mamba
|
|
- update to 20081115
|
|
|
|
* Fri Nov 23 2007 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 20071110-2mamba
|
|
- added missing build requirements
|
|
- rebuilt with regular link to shared libraries
|
|
- added desktop file
|
|
- added documentation files
|
|
|
|
* Mon Nov 19 2007 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 20071110-1mamba
|
|
- update to 20071110
|
|
|
|
* Mon Jun 18 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 20070511-2mamba
|
|
- remove duplicated libraries in fontforge package
|
|
|
|
* Wed Jun 06 2007 Aleph0 <aleph0@openmamba.org> 20070511-1mamba
|
|
- update to 20070511
|
|
|
|
* Thu Feb 15 2007 Davide Madrisan <davide.madrisan@qilinux.it> 20061220-2qilnx
|
|
- update ldconfig cache
|
|
- package locale files using %%find_lang
|
|
- do not ignore command line args in the wrapper for fontforge
|
|
- created the library packages
|
|
- build requires libxkbfile-devel
|
|
|
|
* Tue Feb 13 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 20061220-1qilnx
|
|
- update to version 20061220 by autospec
|
|
- added a wrapper to display correctly under Xgl
|
|
|
|
* Mon Sep 18 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 20060822-1qilnx
|
|
- update to version 20060822 by autospec
|
|
|
|
* Tue May 09 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 20060413-1qilnx
|
|
- new version build
|
|
|
|
* Thu Dec 09 2004 Davide Madrisan <davide.madrisan@qilinux.it> 20041203-1qilnx
|
|
- package created by autospec
|