added upstream patch to fix a cxx-style comment in c code compiler warning [release 2.6.0-2mamba;Sat Dec 26 2015]
This commit is contained in:
parent
ab98ff98d3
commit
7c95a84267
22
flex-2.6.0-gcc-5.3.0-c-comment.patch
Normal file
22
flex-2.6.0-gcc-5.3.0-c-comment.patch
Normal file
@ -0,0 +1,22 @@
|
||||
From 07d89829cce4527c7614a34642d4b2c2ef5d6005 Mon Sep 17 00:00:00 2001
|
||||
From: Will Estes <westes575@gmail.com>
|
||||
Date: Fri, 11 Dec 2015 09:45:14 -0500
|
||||
Subject: [PATCH] Commented in C style in skeleton; fixed sf#195
|
||||
|
||||
---
|
||||
src/flex.skl | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/flex.skl b/src/flex.skl
|
||||
index b63c8c8..40287b6 100644
|
||||
--- a/src/flex.skl
|
||||
+++ b/src/flex.skl
|
||||
@@ -2350,7 +2350,7 @@ void yyFlexLexer::yyensure_buffer_stack(void)
|
||||
* scanner will even need a stack. We use 2 instead of 1 to avoid an
|
||||
* immediate realloc on the next call.
|
||||
*/
|
||||
- num_to_alloc = 1; // After all that talk, this was set to 1 anyways...
|
||||
+ num_to_alloc = 1; /* After all that talk, this was set to 1 anyways... */
|
||||
YY_G(yy_buffer_stack) = (struct yy_buffer_state**)yyalloc
|
||||
(num_to_alloc * sizeof(struct yy_buffer_state*)
|
||||
M4_YY_CALL_LAST_ARG);
|
11
flex.spec
11
flex.spec
@ -1,6 +1,6 @@
|
||||
Name: flex
|
||||
Version: 2.6.0
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: A tool for creating scanners (loxical pattern recognizers)
|
||||
Group: Development/Tools
|
||||
Vendor: openmamba
|
||||
@ -8,12 +8,13 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://flex.sourceforge.net/
|
||||
Source: http://downloads.sourceforge.net/sourceforge/flex/flex-%{version}.tar.bz2
|
||||
Patch0: flex-2.6.0-gcc-5.3.0-c-comment.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: bash
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: texinfo
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: bash
|
||||
BuildRequires: texinfo
|
||||
%if "%{stage1}" != "1"
|
||||
BuildRequires: indent >= 2.2.9
|
||||
BuildRequires: help2man >= 1.33.1
|
||||
@ -51,6 +52,7 @@ This package contains libraries and header files for developing applications tha
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -111,6 +113,9 @@ exit 0
|
||||
#%doc COPYING NEWS README* TODO THANKS
|
||||
|
||||
%changelog
|
||||
* Sat Dec 26 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.0-2mamba
|
||||
- added upstream patch to fix a cxx-style comment in c code compiler warning
|
||||
|
||||
* Sat Nov 21 2015 Automatic Build System <autodist@mambasoft.it> 2.6.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user