remove conflicting info dir file [release 2.6.4-6mamba;Thu Apr 18 2024]
This commit is contained in:
parent
5bfb86a888
commit
00274dec2e
@ -1,22 +0,0 @@
|
|||||||
From 07d89829cce4527c7614a34642d4b2c2ef5d6005 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Will Estes <westes575@gmail.com>
|
|
||||||
Date: Fri, 11 Dec 2015 09:45:14 -0500
|
|
||||||
Subject: [PATCH] Commented in C style in skeleton; fixed sf#195
|
|
||||||
|
|
||||||
---
|
|
||||||
src/flex.skl | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/flex.skl b/src/flex.skl
|
|
||||||
index b63c8c8..40287b6 100644
|
|
||||||
--- a/src/flex.skl
|
|
||||||
+++ b/src/flex.skl
|
|
||||||
@@ -2350,7 +2350,7 @@ void yyFlexLexer::yyensure_buffer_stack(void)
|
|
||||||
* scanner will even need a stack. We use 2 instead of 1 to avoid an
|
|
||||||
* immediate realloc on the next call.
|
|
||||||
*/
|
|
||||||
- num_to_alloc = 1; // After all that talk, this was set to 1 anyways...
|
|
||||||
+ num_to_alloc = 1; /* After all that talk, this was set to 1 anyways... */
|
|
||||||
YY_G(yy_buffer_stack) = (struct yy_buffer_state**)yyalloc
|
|
||||||
(num_to_alloc * sizeof(struct yy_buffer_state*)
|
|
||||||
M4_YY_CALL_LAST_ARG);
|
|
28
flex.spec
28
flex.spec
@ -1,15 +1,14 @@
|
|||||||
Name: flex
|
Name: flex
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.6.4
|
Version: 2.6.4
|
||||||
Release: 4mamba
|
Release: 6mamba
|
||||||
Summary: A tool for creating scanners (loxical pattern recognizers)
|
Summary: A tool for creating scanners (loxical pattern recognizers)
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://flex.sourceforge.net/
|
URL: https://github.com/westes/flex
|
||||||
Source: https://github.com/westes/flex.git/v%{version}/flex-%{version}.tar.bz2
|
Source: https://github.com/westes/flex.git/v%{version}/flex-%{version}.tar.bz2
|
||||||
Patch0: flex-2.6.0-gcc-5.3.0-c-comment.patch
|
|
||||||
Patch1: flex-2.6.4-glibc-2.26.patch
|
Patch1: flex-2.6.4-glibc-2.26.patch
|
||||||
License: BSD
|
License: BSD
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
@ -22,7 +21,6 @@ BuildRequires: indent >= 2.2.9
|
|||||||
BuildRequires: help2man >= 1.33.1
|
BuildRequires: help2man >= 1.33.1
|
||||||
%endif
|
%endif
|
||||||
Requires(post):%{__install_info}
|
Requires(post):%{__install_info}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The flex program generates scanners.
|
The flex program generates scanners.
|
||||||
@ -54,8 +52,8 @@ This package contains libraries and header files for developing applications tha
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
%patch 1 -p1
|
||||||
%patch1 -p1
|
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -71,7 +69,8 @@ sed -i "/#define realloc rpl_realloc/d" config.h
|
|||||||
%makeinstall
|
%makeinstall
|
||||||
|
|
||||||
ln -s flex %{buildroot}/%{_bindir}/lex
|
ln -s flex %{buildroot}/%{_bindir}/lex
|
||||||
#ln -s flex %{buildroot}/%{_bindir}/flex++
|
|
||||||
|
rm -f %{buildroot}%{_datadir}/info/dir
|
||||||
|
|
||||||
%find_lang %{name}
|
%find_lang %{name}
|
||||||
|
|
||||||
@ -90,28 +89,29 @@ exit 0
|
|||||||
%{_bindir}/flex
|
%{_bindir}/flex
|
||||||
%{_bindir}/flex++
|
%{_bindir}/flex++
|
||||||
%{_bindir}/lex
|
%{_bindir}/lex
|
||||||
%{_datadir}/info/*
|
%{_datadir}/info/%{name}.info*
|
||||||
%{_datadir}/man/man1/*
|
%{_datadir}/man/man1/*
|
||||||
|
|
||||||
%files -n libfl
|
%files -n libfl
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/libfl.so.*
|
%{_libdir}/libfl.so.*
|
||||||
#%{_libdir}/libfl_pic.so.*
|
%doc COPYING
|
||||||
|
|
||||||
%files -n libfl-devel
|
%files -n libfl-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_includedir}/FlexLexer.h
|
%{_includedir}/FlexLexer.h
|
||||||
%{_libdir}/libfl.a
|
%{_libdir}/libfl.a
|
||||||
%{_libdir}/libfl.la
|
|
||||||
%{_libdir}/libfl.so
|
%{_libdir}/libfl.so
|
||||||
#%{_libdir}/libfl_pic.a
|
|
||||||
#%{_libdir}/libfl_pic.la
|
|
||||||
#%{_libdir}/libfl_pic.so
|
|
||||||
%dir %{_datadir}/doc/flex
|
%dir %{_datadir}/doc/flex
|
||||||
%{_datadir}/doc/flex/*
|
%{_datadir}/doc/flex/*
|
||||||
#%doc COPYING NEWS README* TODO THANKS
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 18 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.4-6mamba
|
||||||
|
- remove conflicting info dir file
|
||||||
|
|
||||||
|
* Wed Apr 17 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.4-5mamba
|
||||||
|
- URL updated (closes #1)
|
||||||
|
|
||||||
* Fri Nov 27 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.4-4mamba
|
* Fri Nov 27 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.4-4mamba
|
||||||
- rebuilt with debug package
|
- rebuilt with debug package
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user