automatic version update by autodist [release 70.0-1mamba;Wed Oct 30 2019]

This commit is contained in:
Automatic Build System 2024-01-05 22:19:11 +01:00
parent 06d7f89a32
commit ff7b13afad
4 changed files with 267 additions and 227 deletions

View File

@ -0,0 +1,56 @@
From 1cab10b39cfda068100cab8c598f1ca0f50e4131 Mon Sep 17 00:00:00 2001
Message-Id: <1cab10b39cfda068100cab8c598f1ca0f50e4131.1553597287.git.jan.steffens@gmail.com>
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Mon, 25 Mar 2019 20:30:11 +0100
Subject: [PATCH] Use remoting name for GDK application names
---
toolkit/xre/nsAppRunner.cpp | 6 +-----
widget/gtk/nsAppShell.cpp | 7 +++----
2 files changed, 4 insertions(+), 9 deletions(-)
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
index 0b808ef215f06..28911c0ffeaec 100644
--- a/toolkit/xre/nsAppRunner.cpp
+++ b/toolkit/xre/nsAppRunner.cpp
@@ -3728,11 +3728,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
// consistently.
// Set program name to the one defined in application.ini.
- {
- nsAutoCString program(gAppData->name);
- ToLowerCase(program);
- g_set_prgname(program.get());
- }
+ g_set_prgname(gAppData->remotingName);
// Initialize GTK here for splash.
diff --git a/widget/gtk/nsAppShell.cpp b/widget/gtk/nsAppShell.cpp
index 0686ff814916b..ae4a4ea55f420 100644
--- a/widget/gtk/nsAppShell.cpp
+++ b/widget/gtk/nsAppShell.cpp
@@ -24,6 +24,7 @@
# include "WakeLockListener.h"
#endif
#include "gfxPlatform.h"
+#include "nsAppRunner.h"
#include "ScreenHelperGTK.h"
#include "HeadlessScreenHelper.h"
#include "mozilla/widget/ScreenManager.h"
@@ -171,10 +172,8 @@ nsresult nsAppShell::Init() {
// option when program uses gdk_set_program_class().
//
// See https://bugzilla.gnome.org/show_bug.cgi?id=747634
- nsAutoString brandName;
- mozilla::widget::WidgetUtils::GetBrandShortName(brandName);
- if (!brandName.IsEmpty()) {
- gdk_set_program_class(NS_ConvertUTF16toUTF8(brandName).get());
+ if (gAppData) {
+ gdk_set_program_class(gAppData->remotingName);
}
}
--
2.21.0

View File

@ -0,0 +1,41 @@
# HG changeset patch
# User Mike Shal <mshal@mozilla.com>
# Date 1570127498 25200
# Node ID b8bc2504f108d8a2216ee11405cbbe4cf7a0eaec
# Parent 9a4d6aacc48080f019024c02ac7da1fd576b39fe
Bug XYZ - Only force re-linking on 1-tier PGO builds; r?#firefox-build-system-reviewers
diff --git a/config/rules.mk b/config/rules.mk
--- a/config/rules.mk
+++ b/config/rules.mk
@@ -465,25 +465,27 @@ ifeq ($(OS_ARCH)_$(GNU_CC), WINNT_)
$(foreach pgd,$(wildcard *.pgd),pgomgr -clear $(pgd);)
else
ifdef GNU_CC
-$(RM) *.gcda
endif
endif
endif
+ifdef MOZ_1TIER_PGO
ifneq (,$(MOZ_PROFILE_GENERATE)$(MOZ_PROFILE_USE))
ifneq (,$(filter target,$(MAKECMDGOALS)))
ifdef GNU_CC
# Force rebuilding libraries and programs in both passes because each
# pass uses different object files.
$(PROGRAM) $(SHARED_LIBRARY) $(LIBRARY): FORCE
endif
endif
endif
+endif
endif # NO_PROFILE_GUIDED_OPTIMIZE
##############################################
clean clobber realclean clobber_all::
-$(RM) $(ALL_TRASH)
-$(RM) -r $(ALL_TRASH_DIRS)

View File

@ -0,0 +1,11 @@
--- mozilla-release-FIREFOX_70_0_RELEASE/media/ffvpx/libavcodec/utils.c.orig 2019-10-31 09:15:24.819410877 +0100
+++ mozilla-release-FIREFOX_70_0_RELEASE/media/ffvpx/libavcodec/utils.c 2019-10-31 09:13:52.736038110 +0100
@@ -421,7 +421,7 @@
if (desc->comp[0].depth >= 9) {
for (x = 0; x<bytes; x++)
((uint16_t*)dst)[x] = c[p];
- }else
+ }else if (bytes>0)
memset(dst, c[p], bytes);
dst += frame->linesize[p];
}

View File

@ -17,7 +17,7 @@
%define pkgver %(echo %version | tr . _)
Name: firefox
Version: 64.0
Version: 70.0
Release: 1mamba
Epoch: 1
Summary: The next generation browsing technology from mozilla.org
@ -52,6 +52,9 @@ Patch9: firefox-42.0-build-add-freetype-system-wrapper.patch
Patch10: firefox-43.0.4-fix-missing-PR_snprint.patch
Patch11: firefox-47.0-gcc-6.1.0.patch
Patch12: firefox-48.0.1-install_dir.patch
Patch13: firefox-69.0-use-remoting-names-for-gdk-application-names.patch
Patch14: firefox-69.0.2-no-relinking.patch
Patch15: firefox-70.0-fix-__warn_memset_zero_len.patch
License: GPL, LGPL, MPL 1.1
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -69,7 +72,6 @@ BuildRequires: libatk-devel
BuildRequires: libcairo-devel
BuildRequires: libdbus-devel
BuildRequires: libdbus-glib-devel
BuildRequires: libffi-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgcc
@ -77,19 +79,14 @@ BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel
BuildRequires: libgtk-devel
BuildRequires: libgtk2-devel
BuildRequires: libicu-devel
BuildRequires: libjpeg-devel
BuildRequires: libharfbuzz-devel
BuildRequires: libnspr-devel
BuildRequires: libnss-devel
BuildRequires: libpango-devel
BuildRequires: libsqlite-devel
BuildRequires: libstartup-notification-devel
BuildRequires: libstdc++6-devel
BuildRequires: libvpx-devel
BuildRequires: libxcb-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
#BuildRequires: xulrunner-devel = %{version}
BuildRequires: GConf-devel
BuildRequires: libart_lgpl-devel
BuildRequires: libbonoboui-devel
@ -108,7 +105,6 @@ BuildRequires: libxml2-devel
BuildRequires: libdbus-glib-devel
BuildRequires: libcurl-devel
BuildRequires: libz-devel
#BuildRequires: mozldap-devel
BuildRequires: pkgconfig
BuildRequires: libXext-devel
BuildRequires: xorg-proto-devel
@ -123,7 +119,8 @@ BuildRequires: bash
BuildRequires: yasm
BuildRequires: rust-bin
BuildRequires: cbindgen
#Requires: xulrunner = %{version}
BuildRequires: cbindgen
BuildRequires: xorg-server-xvfb
Provides: xulrunner
Obsoletes: xulrunner
BuildRoot: %{_tmppath}/firefox-%{version}-root
@ -143,8 +140,9 @@ Mofilla Firefox is the next generation browsing technology from mozilla.org.
This package contains static libraries and header files need for development.
%prep
%setup -q -n mozilla-release-FIREFOX_%{pkgver}_RELEASE -D -T
:<< ___EOF
%setup -q -n mozilla-release-FIREFOX_%{pkgver}_RELEASE
#-D -T
#:<< ___EOF
#cd %{source_dir}
# See http://gcc.gnu.org/bugzilla/show_bug.cgi?id=20297
@ -173,151 +171,124 @@ sed -e 's|__RPM_VERSION_INTERNAL__|%{firefox_internal_version}|' %{PATCH0} | pat
# TODO: temporary disabled patch
#%patch12 -p1
#% define _use_internal_dependency_generator 0
#% define __find_provides %{_builddir}/firefox-%{version}/%{source_dir}/find_provides.sh
#
#cat > %{_builddir}/firefox-%{version}/%{source_dir}/find_provides.sh <<_EOF
##! /bin/sh
#grep -v %{buildroot}%{_libdir}/firefox- | \
#%{_prefix}/lib/rpm/find-provides %{buildroot} %{_target_cpu}
#_EOF
#chmod +x %{_builddir}/firefox-%{version}/%{source_dir}/find_provides.sh
#
#% define __find_requires %{_builddir}/firefox-%{version}/%{source_dir}/find_requires.sh
#cat > %{_builddir}/firefox-%{version}/%{source_dir}/find_requires.sh <<_EOF
##! /bin/sh
#%{_prefix}/lib/rpm/find-requires %{buildroot} %{_target_cpu} 2>/dev/null |
#while read line; do
# [ ! -f %{buildroot}%{firefoxappdir}/\$line ] && echo "\$line"
#done
#_EOF
#chmod +x %{_builddir}/firefox-%{version}/%{source_dir}/find_requires.sh
%patch13 -p1
%patch14 -p1
%ifarch %{ix86}
%patch15 -p1
%endif
echo -n "AIzaSyBT3wXwxmFuUQcyeMyp0MbHHhhFwNfWKTc" >google-api-key
#echo -n "$_mozilla_api_key" >mozilla-api-key
#___EOF
cat > mozconfig.base <<END
ac_add_options --enable-application=browser
ac_add_options --prefix=%{_prefix}
ac_add_options --libdir=%{_libdir}
ac_add_options --enable-release
ac_add_options --enable-hardening
%ifarch %{ix86}
ac_add_options --disable-debug-symbols
ac_add_options --enable-optimize="-O2"
%else
ac_add_options --enable-optimize
%endif
ac_add_options --enable-rust-simd
#ac_add_options --enable-linker=gold
#ac_add_options --enable-lto
export MOZ_PGO=1
export CC=clang
export CXX=clang++
export AR=llvm-ar
export NM=llvm-nm
export RANLIB=llvm-ranlib
# Branding
ac_add_options --enable-official-branding
ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=org.openmamba
ac_add_options --with-unsigned-addon-scopes=app,system
export MOZILLA_OFFICIAL=1
export MOZ_APP_REMOTINGNAME=%{name}
unset MOZ_TELEMETRY_REPORTING
export MOZ_REQUIRE_SIGNING=1
## Keys
ac_add_options --with-google-location-service-api-keyfile=$PWD/google-api-key
ac_add_options --with-google-safebrowsing-api-keyfile=$PWD/google-api-key
#ac_add_options --with-mozilla-api-keyfile=`pwd`/mozilla-api-key
# System libraries
#ac_add_options --enable-system-ffi
#ac_add_options --enable-system-sqlite
#ac_add_options --with-system-bz2
#ac_add_options --with-system-icu
#ac_add_options --with-system-jpeg
#ac_add_options --with-system-libvpx # (69.0)
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
#ac_add_options --with-system-zlib
# Features
ac_add_options --with-user-appdir=.firefox
ac_add_options --enable-alsa
ac_add_options --enable-jack
ac_add_options --enable-startup-notification
ac_add_options --enable-crashreporter
ac_add_options --disable-gconf
ac_add_options --disable-updater
ac_add_options --disable-strip
ac_add_options --disable-tests
END
mkdir mozbuild
%build
#:<< ___EOF
export LDFLAGS='-lX11 -lXrender' PYTHON=%{__python}
export MOZILLA_OFFICIAL=1
export MOZ_TELEMETRY_REPORTING=1
export MOZ_ADDON_SIGNING=1
export MOZ_REQUIRE_SIGNING=1
export MOZ_SOURCE_REPO=https://hg.mozilla.org/mozilla-unified
export MOZ_SOURCE_CHANGESET=1
#export MOZ_SOURCE_REPO=https://hg.mozilla.org/mozilla-unified
export MOZ_NOSPAM=1
export MOZBUILD_STATE_PATH="`pwd`/mozbuild"
#export MOZ_SOURCE_CHANGESET=dummy
./mach configure \
--prefix=%{_prefix} \
--libdir=%{_libdir} \
--enable-release \
--enable-linker=gold \
--enable-hardening \
--enable-optimize="-O2" \
--enable-rust-simd \
--enable-official-branding \
--enable-update-channel=release \
--with-distribution-id=org.openmamba \
--with-google-api-keyfile=`pwd`/google-api-key \
--with-system-zlib \
--with-system-bz2 \
--with-system-icu \
--with-system-jpeg \
--with-system-libvpx \
--with-system-nspr \
--with-system-nss \
--enable-system-sqlite \
--enable-system-ffi \
--enable-alsa \
--enable-jack \
--enable-startup-notification \
--enable-crashreporter \
--disable-updater \
--disable-elf-hack \
--with-user-appdir=.firefox \
--enable-accessibility \
--enable-extensions=default \
--disable-strip \
%ifarch %{ix86}
--disable-debug-symbols \
%endif
%if %{testing}
--enable-image-decoders=all \
--enable-image-encoders=all \
%endif
# LTO needs more open files
ulimit -n 4096
# --enable-pie \
#xvfb-run -a -n 97 -s "-screen 0 1600x1200x24"
# --disable-necko-wifi
# --enable-chrome-format=omni
# Do 3-tier PGO
## Building instrumented browser
#cat >.mozconfig mozconfig.base - <<END
# ac_add_options --enable-profile-generate
#END
# --with-x \
# --with-pthreads \
# --enable-default-toolkit=cairo-gtk3 \
# --enable-application=browser \
# --disable-debug \
# --disable-tests \
xvfb-run -a -n 92 -s "-screen 0 1600x1200x24" \
./mach build
# --host=%{_host} \
# --target=%{_target_platform} \
:<< ___DISABLED
# Profiling instrumented browser
./mach package
LLVM_PROFDATA=llvm-profdata \
JARLOG_FILE="$PWD/jarlog" \
xvfb-run -a -n 92 -s "-screen 0 1600x1200x24" \
./mach python build/pgo/profileserver.py
# Removed since 60.0.2:
# --enable-system-cairo \
# Removed since 59.0.1:
# --enable-gio
# Removed since 50.0.1:
# --with-default-mozilla-five-home=%{firefoxappdir} \
# --enable-necko-protocols=all \
# Removed since 50.1.0:
# --with-qtdir=%{_qt3_prefix} \
# Removed since 48.0:
# --build=%{_build} \
# --bindir=%{_bindir} \
# --libdir=%{_libdir} \
# --mandir=%{_mandir} \
# --with-system-libxul \
# --with-system-mng \
# --enable-canvas \
# --enable-svg \
# --enable-svg-renderer=cairo \
# --disable-composer \
# --disable-mailnews \
# --with-embedding-profile=default \
# --disable-freetype2 \
# --disable-xprint \
# --enable-pango \
# --enable-crypto \
# --enable-single-profile \
# --disable-profilesharing \
# --enable-xinerama \
# --enable-xft \
# --disable-installer \
# --enable-reorder \
# --disable-pedantic \
# --enable-jsd \
# --enable-storage \
# --enable-libnotify \
# --disable-gnomevfs
# --disable-logging \
# --with-system-mozldap \ --program-suffix=4
#%ifarch ppc
#%define makeflags -j1
#%else
#%define makeflags %{?_smp_mflags}
#%endif
# Removing instrumented browser
./mach clobber
# Building optimized browser
cat >.mozconfig mozconfig.base - <<END
ac_add_options --enable-lto=cross
ac_add_options --enable-profile-use
ac_add_options --with-pgo-profile-path=$PWD
ac_add_options --with-pgo-jarlog=$PWD/jarlog
END
./mach build
___DISABLED
./mach buildsymbols
#% make %{makeflags} MOZ_SERVICES_SYNC="1"
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
@ -410,10 +381,8 @@ done
rm -rf %{buildroot}%{firefoxappdir}/firefox
ln -s firefox-bin %{buildroot}%{firefoxappdir}/firefox
#ln -s %{xul_lib_dir} %{buildroot}%{firefoxappdir}/xulrunner
# install langpacks
install -d %{buildroot}%{firefoxappdir}/browser/extensions
install -d firefox-langpacks && tar -C firefox-langpacks -xjf %{S:1}
@ -461,7 +430,7 @@ includedir=%{firefoxincludedir}
Name: Mozilla Plug-In API
Description: Mozilla Plug-In API
Version: 64.0
Version: 70.0
Cflags: -I\${includedir} -DXP_UNIX
_EOF
@ -529,59 +498,25 @@ fi
%dir %{firefoxappdir}
%{firefoxappdir}/*.ini
%{firefoxappdir}/firefox
#%{firefoxappdir}/run-mozilla.sh
%{firefoxappdir}/browser/chrome.manifest
%{firefoxappdir}/browser/omni.ja
%dir %{firefoxappdir}/distribution
%{firefoxappdir}/distribution/distribution.ini
%attr(644, root, root) %{firefoxappdir}/browser/blocklist.xml
%dir %{firefoxappdir}/browser
#%dir %{firefoxappdir}/browser/components
#%{firefoxappdir}/browser/components/*.so
#%{firefoxappdir}/browser/components/*.manifest
#%ghost %{firefoxappdir}/browser/components/compreg.dat
#%ghost %{firefoxappdir}/browser/components/xpti.dat
%dir %{firefoxappdir}/browser/chrome
%dir %{firefoxappdir}/browser/chrome/icons
%dir %{firefoxappdir}/browser/chrome/icons/default
%{firefoxappdir}/browser/crashreporter-override.ini
%attr(644, root, root) %{firefoxappdir}/browser/chrome/icons/default/default*.png
#%{firefoxappdir}/defaults
%dir %{firefoxappdir}/browser/extensions
#%{firefoxappdir}/browser/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
%{firefoxappdir}/browser/features/*.xpi
%exclude %{firefoxappdir}/browser/extensions/langpack-*
#%dir %{firefoxappdir}/browser/icons
#%{firefoxappdir}/browser/icons/*.png
#%dir %{firefoxappdir}/browser/searchplugins
#%{firefoxappdir}/browser/searchplugins/*
%{firefoxappdir}/firefox-bin
#%{firefoxappdir}/webapprt-stub
#%dir %{firefoxappdir}/webapprt
#%{firefoxappdir}/webapprt/omni.ja
#%{firefoxappdir}/webapprt/webapprt.ini
#%dir %{firefoxappdir}/modules
#%dir %{firefoxappdir}/modules/services-aitc
#%{firefoxappdir}/modules/services-aitc/.mkdir.done
#%dir %{firefoxappdir}/modules/services-common
#%{firefoxappdir}/modules/services-common/.mkdir.done
#%dir %{firefoxappdir}/modules/services-crypto
#%{firefoxappdir}/modules/services-crypto/.mkdir.done
#%dir %{firefoxappdir}/modules/services-notifications
#%{firefoxappdir}/modules/services-notifications/.mkdir.done
#%dir %{firefoxappdir}/modules/services-sync
#%{firefoxappdir}/modules/services-sync/.mkdir.done
#%dir %{firefoxappdir}/modules/services-sync/engines
#%{firefoxappdir}/modules/services-sync/engines/.mkdir.done
#%dir %{firefoxappdir}/modules/sessionstore
#%{firefoxappdir}/modules/sessionstore/.mkdir.done
%{firefoxappdir}/chrome.manifest
%{firefoxappdir}/libmozsandbox.so
%{firefoxappdir}/minidump-analyzer
%{firefoxappdir}/pingsender
#%{_libdir}/firefox-*/chrome.manifest
#%dir %{_libdir}/firefox-*/components
#%{_libdir}/firefox-*/components/*
%{firefoxappdir}/crashreporter
%{firefoxappdir}/defaults/pref/channel-prefs.js
%{firefoxappdir}/browser/defaults/preferences/vendor.js
@ -594,15 +529,11 @@ fi
%dir %{firefoxappdir}/gmp-clearkey/0.1
%{firefoxappdir}/gmp-clearkey/0.1/*
%{firefoxappdir}/Throbber-small.gif
#%{firefoxappdir}/icons/updater.png
#%{firefoxappdir}/icudt56l.dat
#%{_libdir}/firefox-*/libmozalloc.so
%{firefoxappdir}/gtk2/libmozgtk.so
%{firefoxappdir}/liblgpllibs.so
%{firefoxappdir}/libmozavcodec.so
%{firefoxappdir}/libmozavutil.so
%{firefoxappdir}/libmozgtk.so
#%{firefoxappdir}/libmozsqlite3.so
%{firefoxappdir}/libxul.so
%{firefoxappdir}/omni.ja
%{firefoxappdir}/plugin-container
@ -610,17 +541,12 @@ fi
%{_libdir}/firefox/libnssutil3.so
%{_libdir}/firefox/libplc4.so
%{_libdir}/firefox/libplds4.so
#%{firefoxappdir}/updater
#%dir %{_datadir}/idl/firefox-*
#%{_datadir}/idl/firefox-*/*
%{_libdir}/firefox/libmozsqlite3.so
%{_libdir}/firefox/libmozwayland.so
%doc LICENSE
%files devel
%defattr(-,root,root)
#%dir %{_includedir}/firefox-*
#%{_includedir}/firefox-*/*
#%dir %{_libdir}/firefox-devel-*
#%{_libdir}/firefox-devel-*/*
%{_libdir}/pkgconfig/mozilla-plugin.pc
%package i18n-ach
@ -648,14 +574,14 @@ Afrikaans language support for Firefox.
%defattr(-,root,root)
%{firefoxappdir}/browser/extensions/langpack-af@firefox.mozilla.org.xpi
#%package i18n-ak
#Summary: Akan language support for Firefox
#Group: System/Internationalization
#Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
##Requires: hunspell-ak
%package i18n-ak
Summary: Akan language support for Firefox
Group: System/Internationalization
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
#Requires: hunspell-ak
#%description i18n-ak
#Akan language support for Firefox.
%description i18n-ak
Akan language support for Firefox.
#%files i18n-ak
#%defattr(-,root,root)
@ -706,9 +632,9 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description i18n-as
Assamese language support for Firefox.
%files i18n-as
%defattr(-,root,root)
%{firefoxappdir}/browser/extensions/langpack-as@firefox.mozilla.org.xpi
#%files i18n-as
#%defattr(-,root,root)
#%{firefoxappdir}/browser/extensions/langpack-as@firefox.mozilla.org.xpi
%package i18n-az
Summary: Azerbaijani language support for Firefox
@ -755,9 +681,9 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description i18n-bn-BD
Bengali (Bangladesh) language support for Firefox.
%files i18n-bn-BD
%defattr(-,root,root)
%{firefoxappdir}/browser/extensions/langpack-bn-BD@firefox.mozilla.org.xpi
#%files i18n-bn-BD
#%defattr(-,root,root)
#%{firefoxappdir}/browser/extensions/langpack-bn-BD@firefox.mozilla.org.xpi
%package i18n-bn-IN
Summary: Bengali (India) language support for Firefox
@ -767,9 +693,9 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description i18n-bn-IN
Bengali (India) language support for Firefox.
%files i18n-bn-IN
%defattr(-,root,root)
%{firefoxappdir}/browser/extensions/langpack-bn-IN@firefox.mozilla.org.xpi
#%files i18n-bn-IN
#%defattr(-,root,root)
#%{firefoxappdir}/browser/extensions/langpack-bn-IN@firefox.mozilla.org.xpi
%package i18n-br
Summary: Breton language support for Firefox
@ -831,13 +757,13 @@ Czech language support for Firefox.
%defattr(-,root,root)
%{firefoxappdir}/browser/extensions/langpack-cs@firefox.mozilla.org.xpi
#%package i18n-csb
#Summary: Kashubian language support for Firefox
#Group: System/Internationalization
#Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%package i18n-csb
Summary: Kashubian language support for Firefox
Group: System/Internationalization
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
#%description i18n-csb
#Kashubian language support for Firefox.
%description i18n-csb
Kashubian language support for Firefox.
#%files i18n-csb
#%defattr(-,root,root)
@ -951,9 +877,9 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description i18n-en-ZA
English (South Africa) language support for Firefox.
%files i18n-en-ZA
%defattr(-,root,root)
%{firefoxappdir}/browser/extensions/langpack-en-ZA@firefox.mozilla.org.xpi
#%files i18n-en-ZA
#%defattr(-,root,root)
#%{firefoxappdir}/browser/extensions/langpack-en-ZA@firefox.mozilla.org.xpi
%package i18n-eo
Summary: Esperanto language support for Firefox
@ -1443,9 +1369,9 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description i18n-mai
Maithili language support for Firefox.
%files i18n-mai
%defattr(-,root,root)
%{firefoxappdir}/browser/extensions/langpack-mai@firefox.mozilla.org.xpi
#%files i18n-mai
#%defattr(-,root,root)
#%{firefoxappdir}/browser/extensions/langpack-mai@firefox.mozilla.org.xpi
%package i18n-mk
Summary: Macedonian language support for Firefox
@ -1467,17 +1393,17 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description i18n-ml
Malayalam (IN) language support for Firefox.
%files i18n-ml
%defattr(-,root,root)
%{firefoxappdir}/browser/extensions/langpack-ml@firefox.mozilla.org.xpi
#%files i18n-ml
#%defattr(-,root,root)
#%{firefoxappdir}/browser/extensions/langpack-ml@firefox.mozilla.org.xpi
#%package i18n-mn
#Summary: Mongolian language support for Firefox
#Group: System/Internationalization
#Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%package i18n-mn
Summary: Mongolian language support for Firefox
Group: System/Internationalization
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
#%description i18n-mn
#Mongolian language support for Firefox.
%description i18n-mn
Mongolian language support for Firefox.
#%files i18n-mn
#%defattr(-,root,root)
@ -1605,9 +1531,9 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description i18n-or
Oriya (OR) language support for Firefox.
%files i18n-or
%defattr(-,root,root)
%{firefoxappdir}/browser/extensions/langpack-or@firefox.mozilla.org.xpi
#%files i18n-or
#%defattr(-,root,root)
#%{firefoxappdir}/browser/extensions/langpack-or@firefox.mozilla.org.xpi
%package i18n-pa-IN
Summary: Punjabi (IN) language support for Firefox
@ -1946,6 +1872,12 @@ Zulu language support for Firefox.
#%{firefoxappdir}/browser/extensions/langpack-zu@firefox.mozilla.org.xpi
%changelog
* Wed Oct 30 2019 Automatic Build System <autodist@mambasoft.it> 70.0-1mamba
- automatic version update by autodist
* Sun Jan 13 2019 Automatic Build System <autodist@mambasoft.it> 64.0.2-1mamba
- automatic version update by autodist
* Sun Jan 06 2019 Automatic Build System <autodist@mambasoft.it> 64.0-1mamba
- automatic version update by autodist
@ -2415,7 +2347,7 @@ Zulu language support for Firefox.
* Tue Nov 09 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0-1qilnx
- new version build
* Mon Oct 28 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0rc1-1qilnx
* Thu Oct 28 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0rc1-1qilnx
- new version build
* Mon Oct 04 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.1-1qilnx