automatic version update by autodist [release 47.0-1mamba;Wed Jun 22 2016]
This commit is contained in:
parent
9eed3eeef3
commit
f9a7adaae4
71
firefox-47.0-gcc-6.1.0.patch
Normal file
71
firefox-47.0-gcc-6.1.0.patch
Normal file
@ -0,0 +1,71 @@
|
||||
diff -r 34544e6dfc19 -r 55212130f19d config/gcc-stl-wrapper.template.h
|
||||
--- a/config/gcc-stl-wrapper.template.h Fri Mar 11 11:45:09 2016 +0800
|
||||
+++ b/config/gcc-stl-wrapper.template.h Thu Mar 10 16:54:05 2016 +0900
|
||||
@@ -12,33 +12,40 @@
|
||||
// compiling ObjC.
|
||||
#if defined(__EXCEPTIONS) && __EXCEPTIONS && !(__OBJC__ && __GNUC__ && XP_IOS)
|
||||
# error "STL code can only be used with -fno-exceptions"
|
||||
#endif
|
||||
|
||||
// Silence "warning: #include_next is a GCC extension"
|
||||
#pragma GCC system_header
|
||||
|
||||
+// Don't include mozalloc for cstdlib. See bug 1245076.
|
||||
+#ifndef moz_dont_include_mozalloc_for_cstdlib
|
||||
+# define moz_dont_include_mozalloc_for_cstdlib
|
||||
+#endif
|
||||
+#ifndef moz_dont_include_mozalloc_for_${HEADER}
|
||||
// mozalloc.h wants <new>; break the cycle by always explicitly
|
||||
// including <new> here. NB: this is a tad sneaky. Sez the gcc docs:
|
||||
//
|
||||
// `#include_next' does not distinguish between <file> and "file"
|
||||
// inclusion, nor does it check that the file you specify has the
|
||||
// same name as the current file. It simply looks for the file
|
||||
// named, starting with the directory in the search path after the
|
||||
// one where the current file was found.
|
||||
-#include_next <new>
|
||||
+# include_next <new>
|
||||
|
||||
// See if we're in code that can use mozalloc. NB: this duplicates
|
||||
// code in nscore.h because nscore.h pulls in prtypes.h, and chromium
|
||||
// can't build with that being included before base/basictypes.h.
|
||||
-#if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
|
||||
-# include "mozilla/mozalloc.h"
|
||||
-#else
|
||||
-# error "STL code can only be used with infallible ::operator new()"
|
||||
+# if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
|
||||
+# include "mozilla/mozalloc.h"
|
||||
+# else
|
||||
+# error "STL code can only be used with infallible ::operator new()"
|
||||
+# endif
|
||||
+
|
||||
#endif
|
||||
|
||||
#if defined(DEBUG) && !defined(_GLIBCXX_DEBUG)
|
||||
// Enable checked iterators and other goodies
|
||||
//
|
||||
// FIXME/bug 551254: gcc's debug STL implementation requires -frtti.
|
||||
// Figure out how to resolve this with -fno-rtti. Maybe build with
|
||||
// -frtti in DEBUG builds?
|
||||
diff -r 34544e6dfc19 -r 55212130f19d gfx/graphite2/src/Collider.cpp
|
||||
--- a/gfx/graphite2/src/Collider.cpp Fri Mar 11 11:45:09 2016 +0800
|
||||
+++ b/gfx/graphite2/src/Collider.cpp Thu Mar 10 16:54:05 2016 +0900
|
||||
@@ -21,17 +21,17 @@
|
||||
|
||||
Alternatively, the contents of this file may be used under the terms of the
|
||||
Mozilla Public License (http://mozilla.org/MPL) or the GNU General Public
|
||||
License, as published by the Free Software Foundation, either version 2
|
||||
of the License or (at your option) any later version.
|
||||
*/
|
||||
#include <algorithm>
|
||||
#include <limits>
|
||||
-#include <math.h>
|
||||
+#include <cmath>
|
||||
#include <string>
|
||||
#include <functional>
|
||||
#include "inc/Collider.h"
|
||||
#include "inc/Segment.h"
|
||||
#include "inc/Slot.h"
|
||||
#include "inc/GlyphCache.h"
|
||||
#include "inc/Sparse.h"
|
||||
|
25
firefox.spec
25
firefox.spec
@ -15,7 +15,7 @@
|
||||
#% define source_dir mozilla-%{mozilla_version}
|
||||
|
||||
Name: firefox
|
||||
Version: 45.0.2
|
||||
Version: 47.0
|
||||
Release: 1mamba
|
||||
Epoch: 1
|
||||
Summary: The next generation browsing technology from mozilla.org
|
||||
@ -47,6 +47,7 @@ Patch7: firefox-36.0.3-fix-build-upstream.patch
|
||||
Patch8: firefox-39.0-openmamba-prefs.patch
|
||||
Patch9: firefox-42.0-build-add-freetype-system-wrapper.patch
|
||||
Patch10: firefox-43.0.4-fix-missing-PR_snprint.patch
|
||||
Patch11: firefox-47.0-gcc-6.1.0.patch
|
||||
License: GPL, LGPL, MPL 1.1
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -153,6 +154,7 @@ sed -e 's|__RPM_VERSION_INTERNAL__|%{firefox_internal_version}|' %{PATCH0} | pat
|
||||
%patch8 -p1
|
||||
#%patch9 -p1
|
||||
#%patch10 -p1
|
||||
%patch11 -p1
|
||||
#% define _use_internal_dependency_generator 0
|
||||
#% define __find_provides %{_builddir}/firefox-%{version}/%{source_dir}/find_provides.sh
|
||||
#
|
||||
@ -367,7 +369,7 @@ includedir=%{firefoxincludedir}
|
||||
|
||||
Name: Mozilla Plug-In API
|
||||
Description: Mozilla Plug-In API
|
||||
Version: 45.0.2
|
||||
Version: 47.0
|
||||
|
||||
Cflags: -I\${includedir} -DXP_UNIX
|
||||
_EOF
|
||||
@ -443,7 +445,7 @@ fi
|
||||
#%{firefoxappdir}/defaults
|
||||
%dir %{firefoxappdir}/browser/extensions
|
||||
%{firefoxappdir}/browser/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
|
||||
%{firefoxappdir}/browser/features/loop@mozilla.org.xpi
|
||||
%{firefoxappdir}/browser/features/*.xpi
|
||||
%exclude %{firefoxappdir}/browser/extensions/langpack-*
|
||||
%dir %{firefoxappdir}/browser/icons
|
||||
%{firefoxappdir}/browser/icons/*.png
|
||||
@ -484,6 +486,8 @@ fi
|
||||
%{_libdir}/firefox-*/icons/updater.png
|
||||
#%{_libdir}/firefox-*/libmozalloc.so
|
||||
%{_libdir}/firefox-*/liblgpllibs.so
|
||||
%{_libdir}/firefox-*/libmozavcodec.so
|
||||
%{_libdir}/firefox-*/libmozavutil.so
|
||||
%{_libdir}/firefox-*/libmozsqlite3.so
|
||||
%{_libdir}/firefox-*/libxul.so
|
||||
%{_libdir}/firefox-*/omni.ja
|
||||
@ -684,6 +688,18 @@ Catalan language support for Firefox.
|
||||
%defattr(-,root,root)
|
||||
%{firefoxappdir}/browser/extensions/langpack-ca@firefox.mozilla.org/
|
||||
|
||||
%package i18n-cak
|
||||
Summary: Kaqchikel language support for Firefox
|
||||
Group: System/Internationalization
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description i18n-cak
|
||||
Kaqchikel language support for Firefox.
|
||||
|
||||
%files i18n-cak
|
||||
%defattr(-,root,root)
|
||||
%{firefoxappdir}/browser/extensions/langpack-cak@firefox.mozilla.org/
|
||||
|
||||
%package i18n-cs
|
||||
Summary: Czech language support for Firefox
|
||||
Group: System/Internationalization
|
||||
@ -1737,6 +1753,9 @@ Zulu language support for Firefox.
|
||||
#%{firefoxappdir}/browser/extensions/langpack-zu@firefox.mozilla.org/
|
||||
|
||||
%changelog
|
||||
* Wed Jun 22 2016 Automatic Build System <autodist@mambasoft.it> 47.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Apr 12 2016 Automatic Build System <autodist@mambasoft.it> 45.0.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user