update to 36.0.3 [release 36.0.3-1mamba;Sat Mar 21 2015]
This commit is contained in:
parent
4a552926a4
commit
a04b3afe63
42
firefox-36.0.3-fix-build-upstream.patch
Normal file
42
firefox-36.0.3-fix-build-upstream.patch
Normal file
@ -0,0 +1,42 @@
|
|||||||
|
|
||||||
|
# HG changeset patch
|
||||||
|
# User Chris Double <chris.double@double.co.nz>
|
||||||
|
# Date 1422915617 -46800
|
||||||
|
# Node ID 8061d4f8d716e828f80f62d0423cd2d33e923744
|
||||||
|
# Parent 9a2113fcfa398066998755efbf8d6f35602283bc
|
||||||
|
Bug 1128161 - Fix build error when logging is disabled. r=ajones, a=sledru
|
||||||
|
|
||||||
|
diff --git a/dom/media/mediasource/MediaSourceUtils.cpp b/dom/media/mediasource/MediaSourceUtils.cpp
|
||||||
|
--- a/dom/media/mediasource/MediaSourceUtils.cpp
|
||||||
|
+++ b/dom/media/mediasource/MediaSourceUtils.cpp
|
||||||
|
@@ -6,17 +6,16 @@
|
||||||
|
#include "MediaSourceUtils.h"
|
||||||
|
|
||||||
|
#include "prlog.h"
|
||||||
|
#include "mozilla/dom/TimeRanges.h"
|
||||||
|
#include "nsPrintfCString.h"
|
||||||
|
|
||||||
|
namespace mozilla {
|
||||||
|
|
||||||
|
-#if defined(PR_LOGGING)
|
||||||
|
nsCString
|
||||||
|
DumpTimeRanges(dom::TimeRanges* aRanges)
|
||||||
|
{
|
||||||
|
nsCString dump;
|
||||||
|
|
||||||
|
dump = "[";
|
||||||
|
|
||||||
|
for (uint32_t i = 0; i < aRanges->Length(); ++i) {
|
||||||
|
@@ -26,11 +25,10 @@ DumpTimeRanges(dom::TimeRanges* aRanges)
|
||||||
|
ErrorResult dummy;
|
||||||
|
dump += nsPrintfCString("(%f, %f)", aRanges->Start(i, dummy), aRanges->End(i, dummy));
|
||||||
|
}
|
||||||
|
|
||||||
|
dump += "]";
|
||||||
|
|
||||||
|
return dump;
|
||||||
|
}
|
||||||
|
-#endif
|
||||||
|
|
||||||
|
} // namespace mozilla
|
||||||
|
|
552
firefox.spec
552
firefox.spec
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user