automatic version update by autodist [release 104.0-1mamba;Wed Aug 24 2022]
This commit is contained in:
parent
f57fdbaff4
commit
81bc5d993d
33
firefox-103.0.2-arc4random.patch
Normal file
33
firefox-103.0.2-arc4random.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
diff --git i/ipc/chromium/src/third_party/libevent/linux/event2/event-config.h w/ipc/chromium/src/third_party/libevent/linux/event2/event-config.h
|
||||||
|
index 101d39d455107..3764806240f9f 100644
|
||||||
|
--- i/ipc/chromium/src/third_party/libevent/linux/event2/event-config.h
|
||||||
|
+++ w/ipc/chromium/src/third_party/libevent/linux/event2/event-config.h
|
||||||
|
@@ -30,13 +30,13 @@
|
||||||
|
/* #undef EVENT__HAVE_AFUNIX_H 1 */
|
||||||
|
|
||||||
|
/* Define to 1 if you have the `arc4random' function. */
|
||||||
|
-/* #undef EVENT__HAVE_ARC4RANDOM */
|
||||||
|
+#define EVENT__HAVE_ARC4RANDOM 1
|
||||||
|
|
||||||
|
/* Define to 1 if you have the `arc4random_addrandom' function. */
|
||||||
|
/* #undef EVENT__HAVE_ARC4RANDOM_ADDRANDOM */
|
||||||
|
|
||||||
|
/* Define to 1 if you have the `arc4random_buf' function. */
|
||||||
|
-/* #undef EVENT__HAVE_ARC4RANDOM_BUF */
|
||||||
|
+#define EVENT__HAVE_ARC4RANDOM_BUF 1
|
||||||
|
|
||||||
|
/* Define to 1 if you have the <arpa/inet.h> header file. */
|
||||||
|
#define EVENT__HAVE_ARPA_INET_H 1
|
||||||
|
diff --git i/toolkit/crashreporter/client/ping.cpp w/toolkit/crashreporter/client/ping.cpp
|
||||||
|
index 57cf85de80b79..93a2f6e80ad0b 100644
|
||||||
|
--- i/toolkit/crashreporter/client/ping.cpp
|
||||||
|
+++ w/toolkit/crashreporter/client/ping.cpp
|
||||||
|
@@ -53,7 +53,7 @@ static string GenerateUUID() {
|
||||||
|
|
||||||
|
CFRelease(uuid);
|
||||||
|
#elif defined(HAVE_ARC4RANDOM_BUF) // Android, BSD, ...
|
||||||
|
- arc4random_buf(id, sizeof(UUID));
|
||||||
|
+ arc4random_buf(&id, sizeof(UUID));
|
||||||
|
#else // Linux
|
||||||
|
int fd = open("/dev/urandom", O_RDONLY);
|
||||||
|
|
13
firefox.spec
13
firefox.spec
@ -17,7 +17,7 @@
|
|||||||
%define pkgver %(echo %version | tr . _)
|
%define pkgver %(echo %version | tr . _)
|
||||||
|
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 102.0.1
|
Version: 104.0
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Summary: The next generation browsing technology from mozilla.org
|
Summary: The next generation browsing technology from mozilla.org
|
||||||
@ -58,6 +58,7 @@ Patch16: firefox-91.0-glibc-2.34.patch
|
|||||||
Patch17: firefox-91.0-rustc-1.54.patch
|
Patch17: firefox-91.0-rustc-1.54.patch
|
||||||
Patch18: firefox-98.0.2-aarch64-update-crossbeam-channel.patch
|
Patch18: firefox-98.0.2-aarch64-update-crossbeam-channel.patch
|
||||||
Patch19: firefox-101.0.1-fix-ftbfs-newer-cbindgen.patch
|
Patch19: firefox-101.0.1-fix-ftbfs-newer-cbindgen.patch
|
||||||
|
Patch20: firefox-103.0.2-arc4random.patch
|
||||||
License: GPL, LGPL, MPL 1.1
|
License: GPL, LGPL, MPL 1.1
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -294,7 +295,7 @@ sed -e 's|__RPM_VERSION_INTERNAL__|%{firefox_internal_version}|' %{PATCH0} | pat
|
|||||||
#%patch18 -p1 -b .aarch64-update-crossbeam-channel
|
#%patch18 -p1 -b .aarch64-update-crossbeam-channel
|
||||||
#%endif
|
#%endif
|
||||||
|
|
||||||
%patch19 -p1 -b .fix-ftbfs-newer-cbindgen
|
%patch20 -p1 -b .arc4random
|
||||||
|
|
||||||
#___EOF
|
#___EOF
|
||||||
|
|
||||||
@ -527,7 +528,7 @@ includedir=%{firefoxincludedir}
|
|||||||
|
|
||||||
Name: Mozilla Plug-In API
|
Name: Mozilla Plug-In API
|
||||||
Description: Mozilla Plug-In API
|
Description: Mozilla Plug-In API
|
||||||
Version: 102.0.1
|
Version: 104.0
|
||||||
|
|
||||||
Cflags: -I\${includedir} -DXP_UNIX
|
Cflags: -I\${includedir} -DXP_UNIX
|
||||||
_EOF
|
_EOF
|
||||||
@ -648,6 +649,12 @@ fi
|
|||||||
%{_libdir}/pkgconfig/mozilla-plugin.pc
|
%{_libdir}/pkgconfig/mozilla-plugin.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 24 2022 Automatic Build System <autodist@mambasoft.it> 104.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Aug 10 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 103.0.2-1mamba
|
||||||
|
- update to 103.0.2
|
||||||
|
|
||||||
* Wed Jul 06 2022 Automatic Build System <autodist@mambasoft.it> 102.0.1-1mamba
|
* Wed Jul 06 2022 Automatic Build System <autodist@mambasoft.it> 102.0.1-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user