require xulrunner
fixed startup script %{_bindir}/firefox for x86_64 [release 17.0.1-2mamba;Wed Sep 25 2013]
This commit is contained in:
parent
255623a772
commit
4a552926a4
BIN
48278-firefox_mond.png
Normal file
BIN
48278-firefox_mond.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 69 KiB |
@ -1,2 +1,4 @@
|
||||
# firefox
|
||||
|
||||
Mofilla Firefox is the next generation browsing technology from mozilla.org.
|
||||
|
||||
|
200
firefox-17.0-script
Normal file
200
firefox-17.0-script
Normal file
@ -0,0 +1,200 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
# The contents of this file are subject to the Netscape Public
|
||||
# License Version 1.1 (the "License"); you may not use this file
|
||||
# except in compliance with the License. You may obtain a copy of
|
||||
# the License at http://www.mozilla.org/NPL/
|
||||
#
|
||||
# Software distributed under the License is distributed on an "AS
|
||||
# IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or
|
||||
# implied. See the License for the specific language governing
|
||||
# rights and limitations under the License.
|
||||
#
|
||||
# The Original Code is mozilla.org code.
|
||||
#
|
||||
# The Initial Developer of the Original Code is Netscape
|
||||
# Communications Corporation. Portions created by Netscape are
|
||||
# Copyright (C) 1998 Netscape Communications Corporation. All
|
||||
# Rights Reserved.
|
||||
#
|
||||
# Contributor(s):
|
||||
#
|
||||
|
||||
##
|
||||
## Usage:
|
||||
##
|
||||
## $ firefox
|
||||
##
|
||||
## This script is meant to run a mozilla program from the mozilla
|
||||
## rpm installation.
|
||||
##
|
||||
## The script will setup all the environment voodoo needed to make
|
||||
## mozilla work.
|
||||
|
||||
cmdname=`basename $0`
|
||||
|
||||
##
|
||||
## Variables
|
||||
##
|
||||
MOZ_ARCH=$(uname -m)
|
||||
case $MOZ_ARCH in
|
||||
x86_64 | s390x | sparc64)
|
||||
MOZ_LIB_DIR="/usr/lib64"
|
||||
SECONDARY_LIB_DIR="/usr/lib"
|
||||
;;
|
||||
* )
|
||||
MOZ_LIB_DIR="/usr/lib"
|
||||
SECONDARY_LIB_DIR="/usr/lib64"
|
||||
;;
|
||||
esac
|
||||
|
||||
if [ ! -x $MOZ_LIB_DIR/firefox-FIREFOX_VERSION/firefox ]; then
|
||||
if [ ! -x $SECONDARY_LIB_DIR/firefox-FIREFOX_VERSION/firefox ]; then
|
||||
echo "Error: $MOZ_LIB_DIR/firefox-FIREFOX_VERSION/firefox not found"
|
||||
if [ -d $SECONDARY_LIB_DIR ]; then
|
||||
echo " $SECONDARY_LIB_DIR/firefox-FIREFOX_VERSION/firefox not found"
|
||||
fi
|
||||
exit 1
|
||||
fi
|
||||
MOZ_LIB_DIR="$SECONDARY_LIB_DIR"
|
||||
fi
|
||||
MOZ_DIST_BIN="$MOZ_LIB_DIR/firefox-FIREFOX_VERSION"
|
||||
#MOZ_XUL_DIR="XULRUNNER_DIRECTORY"
|
||||
#MOZ_LANGPACKS_DIR="$MOZ_DIST_BIN/langpacks"
|
||||
MOZ_EXTENSIONS_DIR="$MOZ_DIST_BIN/extensions"
|
||||
MOZ_EXTENSIONS_PROFILE_DIR="$HOME/.mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"
|
||||
MOZ_PROGRAM="$MOZ_DIST_BIN/firefox -app $MOZ_DIST_BIN/application.ini"
|
||||
MOZ_LAUCHER="$MOZ_DIST_BIN/run-mozilla.sh"
|
||||
|
||||
##
|
||||
## Set MOZ_GRE_CONF
|
||||
##
|
||||
MOZ_GRE_CONF=/etc/gre.d/gre.conf
|
||||
#if [ "$MOZ_LIB_DIR" == "/usr/lib64" ]; then
|
||||
# MOZ_GRE_CONF=/etc/gre.d/gre64.conf
|
||||
#fi
|
||||
export MOZ_GRE_CONF
|
||||
|
||||
##
|
||||
## Set MOZILLA_FIVE_HOME
|
||||
##
|
||||
MOZILLA_FIVE_HOME="$MOZ_DIST_BIN"
|
||||
|
||||
export MOZILLA_FIVE_HOME
|
||||
|
||||
##
|
||||
## Select the propper plugin dir
|
||||
## Wrapped plug-ins are located in /lib/mozilla/plugins-wrapped
|
||||
##
|
||||
if [ -x "/usr/bin/mozilla-plugin-config" ]
|
||||
then
|
||||
MOZ_PLUGIN_DIR="plugins-wrapped"
|
||||
else
|
||||
MOZ_PLUGIN_DIR="plugins"
|
||||
fi
|
||||
|
||||
##
|
||||
## Make sure that we set the plugin path
|
||||
##
|
||||
if [ "$MOZ_PLUGIN_PATH" ]
|
||||
then
|
||||
MOZ_PLUGIN_PATH=$MOZ_PLUGIN_PATH:$MOZ_LIB_DIR/mozilla/$MOZ_PLUGIN_DIR:$MOZ_DIST_BIN/$MOZ_PLUGIN_DIR
|
||||
else
|
||||
MOZ_PLUGIN_PATH=$MOZ_LIB_DIR/mozilla/$MOZ_PLUGIN_DIR:$MOZ_DIST_BIN/$MOZ_PLUGIN_DIR
|
||||
fi
|
||||
export MOZ_PLUGIN_PATH
|
||||
|
||||
##
|
||||
## Set MOZ_APP_LAUNCHER for gnome-session
|
||||
##
|
||||
export MOZ_APP_LAUNCHER="/usr/bin/firefox"
|
||||
|
||||
##
|
||||
## If plugins are wrapped, check them
|
||||
##
|
||||
if [ -x "/usr/bin/mozilla-plugin-config" ]
|
||||
then
|
||||
/usr/bin/mozilla-plugin-config
|
||||
fi
|
||||
|
||||
##
|
||||
## Set FONTCONFIG_PATH for Xft/fontconfig
|
||||
##
|
||||
FONTCONFIG_PATH="/etc/fonts:${MOZILLA_FIVE_HOME}/res/Xft"
|
||||
export FONTCONFIG_PATH
|
||||
|
||||
##
|
||||
## In order to better support certain scripts (such as Indic and some CJK
|
||||
## scripts), Fedora builds its Firefox, with permission from the Mozilla
|
||||
## Corporation, with the Pango system as its text renderer. This change
|
||||
## may negatively impact performance on some pages. To disable the use of
|
||||
## Pango, set MOZ_DISABLE_PANGO=1 in your environment before launching
|
||||
## Firefox.
|
||||
##
|
||||
#
|
||||
# MOZ_DISABLE_PANGO=1
|
||||
# export MOZ_DISABLE_PANGO
|
||||
#
|
||||
|
||||
##
|
||||
## Disable the GNOME crash dialog, Moz has it's own
|
||||
##
|
||||
GNOME_DISABLE_CRASH_DIALOG=1
|
||||
export GNOME_DISABLE_CRASH_DIALOG
|
||||
|
||||
# OK, here's where all the real work gets done
|
||||
|
||||
|
||||
##
|
||||
## To disable the use of Firefox localization, set MOZ_DISABLE_LANGPACKS=1
|
||||
## in your environment before launching Firefox.
|
||||
##
|
||||
#
|
||||
# MOZ_DISABLE_LANGPACKS=1
|
||||
# export MOZ_DISABLE_LANGPACKS
|
||||
#
|
||||
|
||||
MOZARGS=
|
||||
SHORTMOZLOCALE=`echo $LANG | sed "s|_\([^.]*\).*||g"`
|
||||
[ -f $MOZ_EXTENSIONS_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org/chrome/$SHORTMOZLOCALE.jar ] && MOZARGS="-UILocale $SHORTMOZLOCALE"
|
||||
|
||||
MOZLOCALE=`echo $LANG | sed "s|_\([^.]*\).*|-\1|g"`
|
||||
[ -f $MOZ_EXTENSIONS_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org/chrome/$MOZLOCALE.jar ] && MOZARGS="-UILocale $MOZLOCALE"
|
||||
|
||||
# Prepare command line arguments
|
||||
script_args=""
|
||||
pass_arg_count=0
|
||||
while [ $# -gt $pass_arg_count ]
|
||||
do
|
||||
case "$1" in
|
||||
-g | --debug)
|
||||
script_args="$script_args -g"
|
||||
debugging=1
|
||||
shift
|
||||
;;
|
||||
-d | --debugger)
|
||||
if [ $# -gt 1 ]; then
|
||||
script_args="$script_args -d $2"
|
||||
shift 2
|
||||
else
|
||||
shift
|
||||
fi
|
||||
;;
|
||||
*)
|
||||
# Move the unrecognized argument to the end of the list.
|
||||
arg="$1"
|
||||
shift
|
||||
set -- "$@" "$arg"
|
||||
pass_arg_count=`expr $pass_arg_count + 1`
|
||||
;;
|
||||
esac
|
||||
done
|
||||
|
||||
# Run the browser
|
||||
debugging=0
|
||||
if [ $debugging = 1 ]
|
||||
then
|
||||
echo $MOZ_LAUCHER $script_args $MOZ_PROGRAM $MOZARGS "$@"
|
||||
fi
|
||||
|
||||
exec $MOZ_LAUCHER $script_args $MOZ_PROGRAM $MOZARGS "$@"
|
91
firefox-4.0-01-default.patch
Normal file
91
firefox-4.0-01-default.patch
Normal file
@ -0,0 +1,91 @@
|
||||
diff -Nru browser/components/preferences/advanced.xul browser/components-gil/preferences/advanced.xul
|
||||
--- browser/components/preferences/advanced.xul 2011-01-22 01:24:21.000000000 +0100
|
||||
+++ browser/components-gil/preferences/advanced.xul 2011-01-26 07:42:03.000000000 +0100
|
||||
@@ -194,10 +194,11 @@
|
||||
</groupbox>
|
||||
|
||||
#ifdef HAVE_SHELL_SERVICE
|
||||
+#ifdef MOZ_CRASHREPORTER
|
||||
<!-- System Defaults -->
|
||||
<groupbox id="systemDefaultsGroup" orient="vertical">
|
||||
<caption label="&systemDefaults.label;"/>
|
||||
-
|
||||
+#ifdef 0
|
||||
<hbox id="checkDefaultBox" align="center" flex="1">
|
||||
<checkbox id="alwaysCheckDefault" preference="browser.shell.checkDefaultBrowser"
|
||||
label="&alwaysCheckDefault.label;" accesskey="&alwaysCheckDefault.accesskey;"
|
||||
@@ -207,6 +208,7 @@
|
||||
oncommand="gAdvancedPane.checkNow()"
|
||||
preference="pref.general.disable_button.default_browser"/>
|
||||
</hbox>
|
||||
+#endif
|
||||
#ifdef MOZ_CRASHREPORTER
|
||||
<checkbox id="submitCrashesBox" flex="1"
|
||||
oncommand="gAdvancedPane.updateSubmitCrashes();"
|
||||
@@ -214,6 +216,7 @@
|
||||
#endif
|
||||
</groupbox>
|
||||
#endif
|
||||
+#endif
|
||||
</tabpanel>
|
||||
|
||||
<!-- Network -->
|
||||
diff -Nru browser/components/shell/src/nsGNOMEShellService.cpp browser/components-gil/shell/src/nsGNOMEShellService.cpp
|
||||
--- browser/components/shell/src/nsGNOMEShellService.cpp 2011-01-22 01:24:22.000000000 +0100
|
||||
+++ browser/components-gil/shell/src/nsGNOMEShellService.cpp 2011-01-26 07:51:36.000000000 +0100
|
||||
@@ -140,27 +140,21 @@
|
||||
PRBool
|
||||
nsGNOMEShellService::KeyMatchesAppName(const char *aKeyValue) const
|
||||
{
|
||||
+ nsCAutoString appName;
|
||||
|
||||
- gchar *commandPath;
|
||||
if (mUseLocaleFilenames) {
|
||||
gchar *nativePath = g_filename_from_utf8(aKeyValue, -1, NULL, NULL, NULL);
|
||||
if (!nativePath) {
|
||||
NS_ERROR("Error converting path to filesystem encoding");
|
||||
return PR_FALSE;
|
||||
}
|
||||
-
|
||||
- commandPath = g_find_program_in_path(nativePath);
|
||||
+ appName.Assign(nativePath);
|
||||
g_free(nativePath);
|
||||
} else {
|
||||
- commandPath = g_find_program_in_path(aKeyValue);
|
||||
+ appName.Assign(aKeyValue);
|
||||
}
|
||||
-
|
||||
- if (!commandPath)
|
||||
- return PR_FALSE;
|
||||
-
|
||||
- PRBool matches = mAppPath.Equals(commandPath);
|
||||
- g_free(commandPath);
|
||||
- return matches;
|
||||
+ // Compare default browser command retrieved from gconf with MOZ_APP_NAME
|
||||
+ return appName.EqualsLiteral(MOZ_APP_NAME);
|
||||
}
|
||||
|
||||
NS_IMETHODIMP
|
||||
@@ -215,8 +209,8 @@
|
||||
|
||||
nsCOMPtr<nsIGConfService> gconf = do_GetService(NS_GCONFSERVICE_CONTRACTID);
|
||||
if (gconf) {
|
||||
- nsCAutoString appKeyValue(mAppPath);
|
||||
- appKeyValue.Append(" \"%s\"");
|
||||
+ nsCAutoString appKeyValue(MOZ_APP_NAME);
|
||||
+ appKeyValue.Append(" %s");
|
||||
for (unsigned int i = 0; i < NS_ARRAY_LENGTH(appProtocols); ++i) {
|
||||
if (appProtocols[i].essential || aClaimAllTypes) {
|
||||
gconf->SetAppForProtocol(nsDependentCString(appProtocols[i].name),
|
||||
diff -Nru browser/components/shell/src/nsGNOMEShellService.h browser/components-gil/shell/src/nsGNOMEShellService.h
|
||||
--- browser/components/shell/src/nsGNOMEShellService.h 2011-01-22 01:24:22.000000000 +0100
|
||||
+++ browser/components-gil/shell/src/nsGNOMEShellService.h 2011-01-26 07:39:05.000000000 +0100
|
||||
@@ -43,7 +43,7 @@
|
||||
class nsGNOMEShellService : public nsIShellService
|
||||
{
|
||||
public:
|
||||
- nsGNOMEShellService() : mCheckedThisSession(PR_FALSE) { }
|
||||
+ nsGNOMEShellService() : mCheckedThisSession(PR_TRUE) { }
|
||||
|
||||
NS_DECL_ISUPPORTS
|
||||
NS_DECL_NSISHELLSERVICE
|
11
firefox-4.0-build-throw.patch
Normal file
11
firefox-4.0-build-throw.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- memory/mozalloc/mozalloc.h 2010-09-14 16:14:54.000000000 +0200
|
||||
+++ memory/mozalloc/mozalloc.h-gil 2010-10-05 00:45:01.000000000 +0200
|
||||
@@ -214,7 +214,7 @@
|
||||
#define MOZALLOC_THROW_IF_HAS_EXCEPTIONS throw()
|
||||
#endif
|
||||
|
||||
-#ifdef MOZ_CPP_EXCEPTIONS
|
||||
+#if 1
|
||||
#define MOZALLOC_THROW_BAD_ALLOC throw(std::bad_alloc)
|
||||
#else
|
||||
#define MOZALLOC_THROW_BAD_ALLOC MOZALLOC_THROW_IF_HAS_EXCEPTIONS
|
11
firefox-4.0-disable-checkupdates.patch
Normal file
11
firefox-4.0-disable-checkupdates.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- browser/base/content/utilityOverlay.js 2010-09-14 16:15:11.000000000 +0200
|
||||
+++ browser/base/content/utilityOverlay.js-gil 2010-10-05 00:48:51.000000000 +0200
|
||||
@@ -502,7 +502,7 @@
|
||||
// Disable the UI if the update enabled pref has been locked by the
|
||||
// administrator or if we cannot update for some other reason
|
||||
var checkForUpdates = document.getElementById("checkForUpdates");
|
||||
- var canCheckForUpdates = updates.canCheckForUpdates;
|
||||
+ var canCheckForUpdates = updates.canCheckForUpdates && updates.canApplyUpdates;
|
||||
checkForUpdates.setAttribute("disabled", !canCheckForUpdates);
|
||||
if (!canCheckForUpdates)
|
||||
return;
|
21
firefox-4.0-jemalloc.patch
Normal file
21
firefox-4.0-jemalloc.patch
Normal file
@ -0,0 +1,21 @@
|
||||
--- memory/jemalloc/jemalloc.h 2010-09-14 16:14:54.000000000 +0200
|
||||
+++ memory/jemalloc/jemalloc.h-gil 2010-10-05 00:42:25.000000000 +0200
|
||||
@@ -42,12 +42,12 @@
|
||||
|
||||
/* Darwin and Linux already have memory allocation functions */
|
||||
#if (!defined(MOZ_MEMORY_DARWIN) && !defined(MOZ_MEMORY_LINUX))
|
||||
-void *malloc(size_t size);
|
||||
-void *valloc(size_t size);
|
||||
-void *calloc(size_t num, size_t size);
|
||||
-void *realloc(void *ptr, size_t size);
|
||||
-void free(void *ptr);
|
||||
-int posix_memalign(void **memptr, size_t alignment, size_t size);
|
||||
+void *malloc(size_t size) __THROW __attribute_malloc__ __wur;
|
||||
+void *valloc(size_t size) __THROW __attribute_malloc__ __wur;
|
||||
+void *calloc(size_t num, size_t size) __THROW __attribute_malloc__ __wur;
|
||||
+void *realloc(void *ptr, size_t size) __THROW __attribute_malloc__ __wur;
|
||||
+void free(void *ptr) __THROW __attribute_malloc__ __wur;
|
||||
+int posix_memalign(void **memptr, size_t alignment, size_t size) __THROW __attribute_malloc__ __wur;
|
||||
#endif /* MOZ_MEMORY_DARWIN, MOZ_MEMORY_LINUX */
|
||||
|
||||
#if defined(MOZ_MEMORY_ANDROID) || defined(WRAP_MALLOC)
|
11
firefox-4.0-version.patch
Normal file
11
firefox-4.0-version.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- browser/installer/Makefile.in 2010-09-14 16:14:29.000000000 +0200
|
||||
+++ browser/installer/Makefile.in-gil 2010-10-05 00:37:41.000000000 +0200
|
||||
@@ -45,6 +45,8 @@
|
||||
|
||||
include $(topsrcdir)/config/rules.mk
|
||||
|
||||
+MOZ_APP_VERSION="__RPM_VERSION_INTERNAL__"
|
||||
+
|
||||
MOZ_PKG_REMOVALS = $(srcdir)/removed-files.in
|
||||
|
||||
ifdef MOZ_ENABLE_LIBXUL
|
53
firefox-7.0-cache-build.patch
Normal file
53
firefox-7.0-cache-build.patch
Normal file
@ -0,0 +1,53 @@
|
||||
diff -up firefox-7.0/mozilla-beta/browser/installer/Makefile.in.cache firefox-7.0/mozilla-beta/browser/installer/Makefile.in
|
||||
--- firefox-7.0/mozilla-beta/browser/installer/Makefile.in.cache 2011-09-06 10:43:04.421293791 +0200
|
||||
+++ firefox-7.0/mozilla-beta/browser/installer/Makefile.in 2011-09-06 10:43:04.422293805 +0200
|
||||
@@ -114,19 +114,6 @@ ifndef LIBXUL_SDK
|
||||
INSTALL_SDK = 1
|
||||
endif
|
||||
|
||||
-ifneq (1_,$(if $(CROSS_COMPILE),1,0)_$(UNIVERSAL_BINARY))
|
||||
-ifdef RUN_TEST_PROGRAM
|
||||
-_ABS_RUN_TEST_PROGRAM = $(call core_abspath,$(RUN_TEST_PROGRAM))
|
||||
-endif
|
||||
-
|
||||
-GENERATE_CACHE = \
|
||||
- $(_ABS_RUN_TEST_PROGRAM) $(LIBXUL_DIST)/bin/xpcshell$(BIN_SUFFIX) -g "$$PWD" -a "$$PWD" -f $(topsrcdir)/browser/installer/precompile_cache.js -e 'populate_startupcache("omni.jar", "startupCache.zip");' && \
|
||||
- rm -rf jsloader && \
|
||||
- $(UNZIP) startupCache.zip && \
|
||||
- rm startupCache.zip && \
|
||||
- $(ZIP) -r9m omni.jar jsloader
|
||||
-endif
|
||||
-
|
||||
include $(topsrcdir)/toolkit/mozapps/installer/packager.mk
|
||||
|
||||
ifeq (bundle, $(MOZ_FS_LAYOUT))
|
||||
diff -up firefox-7.0/mozilla-beta/browser/installer/package-manifest.in.cache firefox-7.0/mozilla-beta/browser/installer/package-manifest.in
|
||||
--- firefox-7.0/mozilla-beta/browser/installer/package-manifest.in.cache 2011-08-31 21:16:05.000000000 +0200
|
||||
+++ firefox-7.0/mozilla-beta/browser/installer/package-manifest.in 2011-09-06 10:43:04.423293819 +0200
|
||||
@@ -91,6 +91,7 @@
|
||||
|
||||
[browser]
|
||||
; [Base Browser Files]
|
||||
+@BINPATH@/jsloader/
|
||||
#ifndef XP_UNIX
|
||||
@BINPATH@/@MOZ_APP_NAME@.exe
|
||||
#else
|
||||
diff -up firefox-7.0/mozilla-beta/toolkit/mozapps/installer/packager.mk.cache firefox-7.0/mozilla-beta/toolkit/mozapps/installer/packager.mk
|
||||
--- firefox-7.0/mozilla-beta/toolkit/mozapps/installer/packager.mk.cache 2011-08-31 21:16:34.000000000 +0200
|
||||
+++ firefox-7.0/mozilla-beta/toolkit/mozapps/installer/packager.mk 2011-09-06 10:43:52.861924899 +0200
|
||||
@@ -383,7 +383,6 @@ MAKE_SDK = $(CREATE_FINAL_TAR) - $(MOZ_A
|
||||
endif
|
||||
|
||||
ifdef MOZ_OMNIJAR
|
||||
-GENERATE_CACHE ?= true
|
||||
|
||||
OMNIJAR_FILES = \
|
||||
chrome \
|
||||
@@ -413,7 +412,6 @@ PACK_OMNIJAR = \
|
||||
mv tmp.manifest $$m; \
|
||||
done; \
|
||||
$(ZIP) -r9m omni.jar $(OMNIJAR_FILES) -x $(NON_OMNIJAR_FILES) && \
|
||||
- $(GENERATE_CACHE) && \
|
||||
$(OPTIMIZE_JARS_CMD) --optimize $(JARLOG_DIR_AB_CD) ./ ./ && \
|
||||
mv binary.manifest components && \
|
||||
printf "manifest components/binary.manifest\n" > chrome.manifest
|
16
firefox-lang.sh
Normal file
16
firefox-lang.sh
Normal file
@ -0,0 +1,16 @@
|
||||
#!/bin/sh
|
||||
# gil
|
||||
FIREFOX_VERSION=$1
|
||||
|
||||
if [ -z "$FIREFOX_VERSION" ]; then
|
||||
echo "Usage: $0 <version>"
|
||||
exit 2
|
||||
fi
|
||||
|
||||
rm -rf firefox-$FIREFOX_VERSION
|
||||
mkdir firefox-$FIREFOX_VERSION
|
||||
cd firefox-$FIREFOX_VERSION
|
||||
wget -r -N -l 1 -np -nd -A "*.xpi" ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$FIREFOX_VERSION/linux-i686/xpi/*.xpi
|
||||
rm -f robots.txt
|
||||
tar -cj *.xpi > ../firefox-$FIREFOX_VERSION-langpacks.tar.bz2
|
||||
#rm -rf firefox-$FIREFOX_VERSION
|
41
firefox-openmamba-bookmarks-html
Normal file
41
firefox-openmamba-bookmarks-html
Normal file
@ -0,0 +1,41 @@
|
||||
<!DOCTYPE NETSCAPE-Bookmark-file-1>
|
||||
<!-- This is an automatically generated file.
|
||||
It will be read and overwritten.
|
||||
DO NOT EDIT! -->
|
||||
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=UTF-8">
|
||||
<TITLE>Bookmarks</TITLE>
|
||||
<H1>Bookmarks</H1>
|
||||
|
||||
<DL><p>
|
||||
<DT><H3 PERSONAL_TOOLBAR_FOLDER="true" ID="rdf:#$FvPhC3">Bookmarks Toolbar Folder</H3>
|
||||
<DD>Add bookmarks to this folder to see them displayed on the Bookmarks Toolbar
|
||||
<DL><p>
|
||||
<DT><A HREF="http://www.openmamba.org/">openmamba.org</A>
|
||||
<DT><A HREF="http://www.mozilla.com/en-US/firefox/central/" ID="rdf:#$GvPhC3">Getting Started</A>
|
||||
<DT><A HREF="http://fxfeeds.mozilla.com/en-US/firefox/livebookmarks/" FEEDURL="http://fxfeeds.mozilla.com/en-US/firefox/headlines.xml" ID="rdf:#$HvPhC3">Latest Headlines</A>
|
||||
</DL><p>
|
||||
<DT><H3 ID="rdf:#$ZvPhC3">Mozilla Firefox</H3>
|
||||
<DL><p>
|
||||
<DT><A HREF="http://www.mozilla.com/en-US/firefox/help/" ICON="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAABGdBTUEAAK/INwWK6QAAABl0RVh0U29mdHdhcmUAQWRvYmUgSW1hZ2VSZWFkeXHJZTwAAAHWSURBVHjaYvz//z8DJQAggJiQOe/fv2fv7Oz8rays/N+VkfG/iYnJfyD/1+rVq7ffu3dPFpsBAAHEAHIBCJ85c8bN2Nj4vwsDw/8zQLwKiO8CcRoQu0DxqlWrdsHUwzBAAIGJmTNnPgYa9j8UqhFElwPxf2MIDeIrKSn9FwSJoRkAEEAM0DD4DzMAyPi/G+QKY4hh5WAXGf8PDQ0FGwJ22d27CjADAAIIrLmjo+MXA9R2kAHvGBA2wwx6B8W7od6CeQcggKCmCEL8bgwxYCbUIGTDVkHDBia+CuotgACCueD3TDQN75D4xmAvCoK9ARMHBzAw0AECiBHkAlC0Mdy7x9ABNA3obAZXIAa6iKEcGlMVQHwWyjYuL2d4v2cPg8vZswx7gHyAAAK7AOif7SAbOqCmn4Ha3AHFsIDtgPq/vLz8P4MSkJ2W9h8ggBjevXvHDo4FQUQg/kdypqCg4H8lUIACnQ/SOBMYI8bAsAJFPcj1AAEEjwVQqLpAbXmH5BJjqI0gi9DTAAgDBBCcAVLkgmQ7yKCZxpCQxqUZhAECCJ4XgMl493ug21ZD+aDAXH0WLM4A9MZPXJkJIIAwTAR5pQMalaCABQUULttBGCCAGCnNzgABBgAMJ5THwGvJLAAAAABJRU5ErkJggg==" ID="rdf:#$22iCK1">Help and Tutorials</A>
|
||||
<DT><A HREF="http://www.mozilla.com/en-US/firefox/customize/" ICON="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAABGdBTUEAAK/INwWK6QAAABl0RVh0U29mdHdhcmUAQWRvYmUgSW1hZ2VSZWFkeXHJZTwAAAHWSURBVHjaYvz//z8DJQAggJiQOe/fv2fv7Oz8rays/N+VkfG/iYnJfyD/1+rVq7ffu3dPFpsBAAHEAHIBCJ85c8bN2Nj4vwsDw/8zQLwKiO8CcRoQu0DxqlWrdsHUwzBAAIGJmTNnPgYa9j8UqhFElwPxf2MIDeIrKSn9FwSJoRkAEEAM0DD4DzMAyPi/G+QKY4hh5WAXGf8PDQ0FGwJ22d27CjADAAIIrLmjo+MXA9R2kAHvGBA2wwx6B8W7od6CeQcggKCmCEL8bgwxYCbUIGTDVkHDBia+CuotgACCueD3TDQN75D4xmAvCoK9ARMHBzAw0AECiBHkAlC0Mdy7x9ABNA3obAZXIAa6iKEcGlMVQHwWyjYuL2d4v2cPg8vZswx7gHyAAAK7AOif7SAbOqCmn4Ha3AHFsIDtgPq/vLz8P4MSkJ2W9h8ggBjevXvHDo4FQUQg/kdypqCg4H8lUIACnQ/SOBMYI8bAsAJFPcj1AAEEjwVQqLpAbXmH5BJjqI0gi9DTAAgDBBCcAVLkgmQ7yKCZxpCQxqUZhAECCJ4XgMl493ug21ZD+aDAXH0WLM4A9MZPXJkJIIAwTAR5pQMalaCABQUULttBGCCAGCnNzgABBgAMJ5THwGvJLAAAAABJRU5ErkJggg==" ID="rdf:#$32iCK1">Customize Firefox</A>
|
||||
<DT><A HREF="http://www.mozilla.com/en-US/firefox/community/" ICON="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAABGdBTUEAAK/INwWK6QAAABl0RVh0U29mdHdhcmUAQWRvYmUgSW1hZ2VSZWFkeXHJZTwAAAHWSURBVHjaYvz//z8DJQAggJiQOe/fv2fv7Oz8rays/N+VkfG/iYnJfyD/1+rVq7ffu3dPFpsBAAHEAHIBCJ85c8bN2Nj4vwsDw/8zQLwKiO8CcRoQu0DxqlWrdsHUwzBAAIGJmTNnPgYa9j8UqhFElwPxf2MIDeIrKSn9FwSJoRkAEEAM0DD4DzMAyPi/G+QKY4hh5WAXGf8PDQ0FGwJ22d27CjADAAIIrLmjo+MXA9R2kAHvGBA2wwx6B8W7od6CeQcggKCmCEL8bgwxYCbUIGTDVkHDBia+CuotgACCueD3TDQN75D4xmAvCoK9ARMHBzAw0AECiBHkAlC0Mdy7x9ABNA3obAZXIAa6iKEcGlMVQHwWyjYuL2d4v2cPg8vZswx7gHyAAAK7AOif7SAbOqCmn4Ha3AHFsIDtgPq/vLz8P4MSkJ2W9h8ggBjevXvHDo4FQUQg/kdypqCg4H8lUIACnQ/SOBMYI8bAsAJFPcj1AAEEjwVQqLpAbXmH5BJjqI0gi9DTAAgDBBCcAVLkgmQ7yKCZxpCQxqUZhAECCJ4XgMl493ug21ZD+aDAXH0WLM4A9MZPXJkJIIAwTAR5pQMalaCABQUULttBGCCAGCnNzgABBgAMJ5THwGvJLAAAAABJRU5ErkJggg==" ID="rdf:#$42iCK1">Get Involved</A>
|
||||
<DT><A HREF="http://www.mozilla.com/en-US/about/" ICON="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAABGdBTUEAAK/INwWK6QAAABl0RVh0U29mdHdhcmUAQWRvYmUgSW1hZ2VSZWFkeXHJZTwAAAHWSURBVHjaYvz//z8DJQAggJiQOe/fv2fv7Oz8rays/N+VkfG/iYnJfyD/1+rVq7ffu3dPFpsBAAHEAHIBCJ85c8bN2Nj4vwsDw/8zQLwKiO8CcRoQu0DxqlWrdsHUwzBAAIGJmTNnPgYa9j8UqhFElwPxf2MIDeIrKSn9FwSJoRkAEEAM0DD4DzMAyPi/G+QKY4hh5WAXGf8PDQ0FGwJ22d27CjADAAIIrLmjo+MXA9R2kAHvGBA2wwx6B8W7od6CeQcggKCmCEL8bgwxYCbUIGTDVkHDBia+CuotgACCueD3TDQN75D4xmAvCoK9ARMHBzAw0AECiBHkAlC0Mdy7x9ABNA3obAZXIAa6iKEcGlMVQHwWyjYuL2d4v2cPg8vZswx7gHyAAAK7AOif7SAbOqCmn4Ha3AHFsIDtgPq/vLz8P4MSkJ2W9h8ggBjevXvHDo4FQUQg/kdypqCg4H8lUIACnQ/SOBMYI8bAsAJFPcj1AAEEjwVQqLpAbXmH5BJjqI0gi9DTAAgDBBCcAVLkgmQ7yKCZxpCQxqUZhAECCJ4XgMl493ug21ZD+aDAXH0WLM4A9MZPXJkJIIAwTAR5pQMalaCABQUULttBGCCAGCnNzgABBgAMJ5THwGvJLAAAAABJRU5ErkJggg==" ID="rdf:#$52iCK1">About Us</A>
|
||||
</DL><p>
|
||||
<DT><H3>openmamba Project</H3>
|
||||
<DL><p>
|
||||
<DT><H3>openmamba.org</H3>
|
||||
<DL><p>
|
||||
<DT><A HREF="http://www.openmamba.org/">The openmamba Organization</A>
|
||||
<DT><A HREF="http://www.openmamba.org/products.html">openmamba: Products</A>
|
||||
<DT><A HREF="http://www.openmamba.org/events.html">openmamba: Events</A>
|
||||
</DL><p>
|
||||
<DT><H3>Community & Support</H3>
|
||||
<DL><p>
|
||||
<DT><A HREF="http://www.openmamba.org/community//">openmamba: Community</A>
|
||||
<DT><A HREF="http://forum.openmamba.org/">openmamba: Forum</A>
|
||||
<DT><A HREF="http://wiki.openmamba.org/it/index.php/Pagina_principale">openmamba: Wiki</A>
|
||||
<DT><A HREF="http://bugs.openmamba.org/my_view_page.php/">openmamba: Support</A>
|
||||
</DL><p>
|
||||
<HR>
|
||||
</DL><p>
|
||||
</DL><p>
|
BIN
firefox.png
Normal file
BIN
firefox.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 143 KiB |
1944
firefox.spec
Normal file
1944
firefox.spec
Normal file
File diff suppressed because it is too large
Load Diff
83
mozilla-firefox-safemode.desktop
Normal file
83
mozilla-firefox-safemode.desktop
Normal file
@ -0,0 +1,83 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Exec=firefox --safe-mode %u
|
||||
Icon=firefox.png
|
||||
Type=Application
|
||||
Name=Firefox (safe mode)
|
||||
Name[it]=Firefox (modo sicuro)
|
||||
GenericName=Web Browser
|
||||
GenericName[af]=Web Blaaier
|
||||
GenericName[ar]=متصفح ويب
|
||||
GenericName[az]=Veb Səyyahı
|
||||
GenericName[bg]=Браузър
|
||||
GenericName[bn]=ওয়েব ব্রাউজার
|
||||
GenericName[br]=Furcher ar Gwiad
|
||||
GenericName[bs]=WWW Preglednik
|
||||
GenericName[ca]=Fullejador web
|
||||
GenericName[cs]=WWW prohlížeč
|
||||
GenericName[cy]=Porydd Gwe
|
||||
GenericName[da]=Browser
|
||||
GenericName[de]=Web-Browser
|
||||
GenericName[el]=Περιηγητής Ιστού
|
||||
GenericName[eo]=TTT-legilo
|
||||
GenericName[es]=Navegador web
|
||||
GenericName[et]=Veebilehitseja
|
||||
GenericName[eu]=Web arakatzailea
|
||||
GenericName[fa]=مرورگر وب
|
||||
GenericName[fi]=WWW-selain
|
||||
GenericName[fo]=Alnótsfar
|
||||
GenericName[fr]=Navigateur web
|
||||
GenericName[fy]=Webblêdzjer
|
||||
GenericName[ga]=Brabhsálaí Lín
|
||||
GenericName[gl]=Navegador Web
|
||||
GenericName[he]=דפדפן אינטרנט
|
||||
GenericName[hi]=वेब ब्राउज़र
|
||||
GenericName[hr]=Web preglednik
|
||||
GenericName[hu]=Webböngésző
|
||||
GenericName[is]=Vafri
|
||||
GenericName[it]=Browser Web
|
||||
GenericName[ja]=ウェブブラウザ
|
||||
GenericName[km]=កម្មវិធីរុករកបណ្ដាញ
|
||||
GenericName[ko]=웹 브라우저
|
||||
GenericName[lo]=ເວັບບຣາວເຊີ
|
||||
GenericName[lt]=Žiniatinklio naršyklė
|
||||
GenericName[lv]=Tīmekļa Pārlūks
|
||||
GenericName[mk]=Прелистувач на Интернет
|
||||
GenericName[mn]=Веб-Хөтөч
|
||||
GenericName[ms]=Pelayar Web
|
||||
GenericName[nb]=Nettleser
|
||||
GenericName[nds]=Nettkieker
|
||||
GenericName[nl]=Webbrowser
|
||||
GenericName[nn]=Nettlesar
|
||||
GenericName[nso]=Seinyakisi sa Web
|
||||
GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
|
||||
GenericName[pl]=Przeglądarka WWW
|
||||
GenericName[pt]=Navegador Web
|
||||
GenericName[pt_BR]=Navegador Web
|
||||
GenericName[ro]=Navigator de web
|
||||
GenericName[ru]=Веб-браузер
|
||||
GenericName[rw]=Mucukumbuzi Urubuga
|
||||
GenericName[se]=Fierpmádatlogan
|
||||
GenericName[sk]=Webový prehliadač
|
||||
GenericName[sl]=Spletni brskalnik
|
||||
GenericName[sr]=Веб прегледач
|
||||
GenericName[sr@Latn]=Veb pregledač
|
||||
GenericName[ss]=Ibrawuza yeWeb
|
||||
GenericName[sv]=Webbläsare
|
||||
GenericName[ta]=வலை உலாவி
|
||||
GenericName[tg]=Тафсиргари вэб
|
||||
GenericName[th]=เว็บบราวเซอร์
|
||||
GenericName[tr]=Web Tarayıcı
|
||||
GenericName[uk]=Навігатор Тенет
|
||||
GenericName[uz]=Веб-браузер
|
||||
GenericName[ven]=Buronza ya Webu
|
||||
GenericName[vi]=Trình duyệt Web
|
||||
GenericName[wa]=Betchteu waibe
|
||||
GenericName[xh]=Umkhangeli zincwadi we Web
|
||||
GenericName[xx]=xxWeb Browserxx
|
||||
GenericName[zh_CN]=Web 浏览器
|
||||
GenericName[zh_TW]=網頁瀏覽器
|
||||
GenericName[zu]=Umcingi we-Web
|
||||
Categories=Network;
|
||||
MimeType=text/html
|
||||
X-KDE-StartupNotify=true
|
91
mozilla-firefox.desktop
Normal file
91
mozilla-firefox.desktop
Normal file
@ -0,0 +1,91 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Exec=firefox %u
|
||||
Icon=firefox.png
|
||||
Type=Application
|
||||
Name=Firefox
|
||||
Name[bn]=ফায়ারফক্স
|
||||
Name[eo]=Mozilo Fajrovulpo
|
||||
Name[fi]=Mozilla Firefox
|
||||
Name[hi]=फ़ायरफॉक्स
|
||||
Name[km]=មេខលា
|
||||
Name[pa]=ਫਾਇਰਫਾਕਸ
|
||||
Name[th]=ไฟร์ฟอกซ์
|
||||
Name[xx]=xxFirefoxxx
|
||||
Name[zh_TW]=火狐貍
|
||||
GenericName=Web Browser
|
||||
GenericName[af]=Web Blaaier
|
||||
GenericName[ar]=متصفح ويب
|
||||
GenericName[az]=Veb Səyyahı
|
||||
GenericName[bg]=Браузър
|
||||
GenericName[bn]=ওয়েব ব্রাউজার
|
||||
GenericName[br]=Furcher ar Gwiad
|
||||
GenericName[bs]=WWW Preglednik
|
||||
GenericName[ca]=Fullejador web
|
||||
GenericName[cs]=WWW prohlížeč
|
||||
GenericName[cy]=Porydd Gwe
|
||||
GenericName[da]=Browser
|
||||
GenericName[de]=Web-Browser
|
||||
GenericName[el]=Περιηγητής Ιστού
|
||||
GenericName[eo]=TTT-legilo
|
||||
GenericName[es]=Navegador web
|
||||
GenericName[et]=Veebilehitseja
|
||||
GenericName[eu]=Web arakatzailea
|
||||
GenericName[fa]=مرورگر وب
|
||||
GenericName[fi]=WWW-selain
|
||||
GenericName[fo]=Alnótsfar
|
||||
GenericName[fr]=Navigateur web
|
||||
GenericName[fy]=Webblêdzjer
|
||||
GenericName[ga]=Brabhsálaí Lín
|
||||
GenericName[gl]=Navegador Web
|
||||
GenericName[he]=דפדפן אינטרנט
|
||||
GenericName[hi]=वेब ब्राउज़र
|
||||
GenericName[hr]=Web preglednik
|
||||
GenericName[hu]=Webböngésző
|
||||
GenericName[is]=Vafri
|
||||
GenericName[it]=Browser Web
|
||||
GenericName[ja]=ウェブブラウザ
|
||||
GenericName[km]=កម្មវិធីរុករកបណ្ដាញ
|
||||
GenericName[ko]=웹 브라우저
|
||||
GenericName[lo]=ເວັບບຣາວເຊີ
|
||||
GenericName[lt]=Žiniatinklio naršyklė
|
||||
GenericName[lv]=Tīmekļa Pārlūks
|
||||
GenericName[mk]=Прелистувач на Интернет
|
||||
GenericName[mn]=Веб-Хөтөч
|
||||
GenericName[ms]=Pelayar Web
|
||||
GenericName[nb]=Nettleser
|
||||
GenericName[nds]=Nettkieker
|
||||
GenericName[nl]=Webbrowser
|
||||
GenericName[nn]=Nettlesar
|
||||
GenericName[nso]=Seinyakisi sa Web
|
||||
GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
|
||||
GenericName[pl]=Przeglądarka WWW
|
||||
GenericName[pt]=Navegador Web
|
||||
GenericName[pt_BR]=Navegador Web
|
||||
GenericName[ro]=Navigator de web
|
||||
GenericName[ru]=Веб-браузер
|
||||
GenericName[rw]=Mucukumbuzi Urubuga
|
||||
GenericName[se]=Fierpmádatlogan
|
||||
GenericName[sk]=Webový prehliadač
|
||||
GenericName[sl]=Spletni brskalnik
|
||||
GenericName[sr]=Веб прегледач
|
||||
GenericName[sr@Latn]=Veb pregledač
|
||||
GenericName[ss]=Ibrawuza yeWeb
|
||||
GenericName[sv]=Webbläsare
|
||||
GenericName[ta]=வலை உலாவி
|
||||
GenericName[tg]=Тафсиргари вэб
|
||||
GenericName[th]=เว็บบราวเซอร์
|
||||
GenericName[tr]=Web Tarayıcı
|
||||
GenericName[uk]=Навігатор Тенет
|
||||
GenericName[uz]=Веб-браузер
|
||||
GenericName[ven]=Buronza ya Webu
|
||||
GenericName[vi]=Trình duyệt Web
|
||||
GenericName[wa]=Betchteu waibe
|
||||
GenericName[xh]=Umkhangeli zincwadi we Web
|
||||
GenericName[xx]=xxWeb Browserxx
|
||||
GenericName[zh_CN]=Web 浏览器
|
||||
GenericName[zh_TW]=網頁瀏覽器
|
||||
GenericName[zu]=Umcingi we-Web
|
||||
Categories=Network;
|
||||
MimeType=text/html
|
||||
X-KDE-StartupNotify=true
|
1
mozilla-wrapper
Normal file
1
mozilla-wrapper
Normal file
@ -0,0 +1 @@
|
||||
firefox $@
|
14
xulrunner-2.0-os2cc.patch
Normal file
14
xulrunner-2.0-os2cc.patch
Normal file
@ -0,0 +1,14 @@
|
||||
https://bugzilla.mozilla.org/show_bug.cgi?id=628252
|
||||
|
||||
diff --git a/gfx/ots/src/os2.cc b/gfx/ots/src/os2.cc
|
||||
--- a/gfx/ots/src/os2.cc
|
||||
+++ b/gfx/ots/src/os2.cc
|
||||
@@ -3,4 +3,6 @@
|
||||
// found in the LICENSE file.
|
||||
|
||||
+#include <stddef.h>
|
||||
+
|
||||
#include "os2.h"
|
||||
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user