automatic version update by autodist [release 84.0.1-1mamba;Thu Dec 24 2020]
This commit is contained in:
parent
99f83221e5
commit
37013f4e1e
@ -1,56 +0,0 @@
|
||||
From 1cab10b39cfda068100cab8c598f1ca0f50e4131 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <1cab10b39cfda068100cab8c598f1ca0f50e4131.1553597287.git.jan.steffens@gmail.com>
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Mon, 25 Mar 2019 20:30:11 +0100
|
||||
Subject: [PATCH] Use remoting name for GDK application names
|
||||
|
||||
---
|
||||
toolkit/xre/nsAppRunner.cpp | 6 +-----
|
||||
widget/gtk/nsAppShell.cpp | 7 +++----
|
||||
2 files changed, 4 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
|
||||
index 0b808ef215f06..28911c0ffeaec 100644
|
||||
--- a/toolkit/xre/nsAppRunner.cpp
|
||||
+++ b/toolkit/xre/nsAppRunner.cpp
|
||||
@@ -3728,11 +3728,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
|
||||
// consistently.
|
||||
|
||||
// Set program name to the one defined in application.ini.
|
||||
- {
|
||||
- nsAutoCString program(gAppData->name);
|
||||
- ToLowerCase(program);
|
||||
- g_set_prgname(program.get());
|
||||
- }
|
||||
+ g_set_prgname(gAppData->remotingName);
|
||||
|
||||
// Initialize GTK here for splash.
|
||||
|
||||
diff --git a/widget/gtk/nsAppShell.cpp b/widget/gtk/nsAppShell.cpp
|
||||
index 0686ff814916b..ae4a4ea55f420 100644
|
||||
--- a/widget/gtk/nsAppShell.cpp
|
||||
+++ b/widget/gtk/nsAppShell.cpp
|
||||
@@ -24,6 +24,7 @@
|
||||
# include "WakeLockListener.h"
|
||||
#endif
|
||||
#include "gfxPlatform.h"
|
||||
+#include "nsAppRunner.h"
|
||||
#include "ScreenHelperGTK.h"
|
||||
#include "HeadlessScreenHelper.h"
|
||||
#include "mozilla/widget/ScreenManager.h"
|
||||
@@ -171,10 +172,8 @@ nsresult nsAppShell::Init() {
|
||||
// option when program uses gdk_set_program_class().
|
||||
//
|
||||
// See https://bugzilla.gnome.org/show_bug.cgi?id=747634
|
||||
- nsAutoString brandName;
|
||||
- mozilla::widget::WidgetUtils::GetBrandShortName(brandName);
|
||||
- if (!brandName.IsEmpty()) {
|
||||
- gdk_set_program_class(NS_ConvertUTF16toUTF8(brandName).get());
|
||||
+ if (gAppData) {
|
||||
+ gdk_set_program_class(gAppData->remotingName);
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
2.21.0
|
||||
|
@ -0,0 +1,59 @@
|
||||
From 5025aab61517c8608b555ba929c61eb0706bd6bd Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Mon, 25 Mar 2019 20:30:11 +0100
|
||||
Subject: [PATCH] Use remoting name for GDK application names
|
||||
|
||||
---
|
||||
toolkit/xre/nsAppRunner.cpp | 6 +-----
|
||||
widget/gtk/nsAppShell.cpp | 11 ++++-------
|
||||
2 files changed, 5 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
|
||||
index da8289200e72..452195b146f3 100644
|
||||
--- a/toolkit/xre/nsAppRunner.cpp
|
||||
+++ b/toolkit/xre/nsAppRunner.cpp
|
||||
@@ -3785,11 +3785,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
|
||||
// consistently.
|
||||
|
||||
// Set program name to the one defined in application.ini.
|
||||
- {
|
||||
- nsAutoCString program(gAppData->name);
|
||||
- ToLowerCase(program);
|
||||
- g_set_prgname(program.get());
|
||||
- }
|
||||
+ g_set_prgname(gAppData->remotingName);
|
||||
|
||||
// Initialize GTK here for splash.
|
||||
|
||||
diff --git a/widget/gtk/nsAppShell.cpp b/widget/gtk/nsAppShell.cpp
|
||||
index 163a93e2d1a4..4b6d45217671 100644
|
||||
--- a/widget/gtk/nsAppShell.cpp
|
||||
+++ b/widget/gtk/nsAppShell.cpp
|
||||
@@ -24,6 +24,7 @@
|
||||
# include "WakeLockListener.h"
|
||||
#endif
|
||||
#include "gfxPlatform.h"
|
||||
+#include "nsAppRunner.h"
|
||||
#include "ScreenHelperGTK.h"
|
||||
#include "HeadlessScreenHelper.h"
|
||||
#include "mozilla/widget/ScreenManager.h"
|
||||
@@ -175,13 +176,9 @@ nsresult nsAppShell::Init() {
|
||||
// See https://bugzilla.gnome.org/show_bug.cgi?id=747634
|
||||
//
|
||||
// Only bother doing this for the parent process, since it's the one
|
||||
- // creating top-level windows. (At this point, a child process hasn't
|
||||
- // received the list of registered chrome packages, so the
|
||||
- // GetBrandShortName call would fail anyway.)
|
||||
- nsAutoString brandName;
|
||||
- mozilla::widget::WidgetUtils::GetBrandShortName(brandName);
|
||||
- if (!brandName.IsEmpty()) {
|
||||
- gdk_set_program_class(NS_ConvertUTF16toUTF8(brandName).get());
|
||||
+ // creating top-level windows.
|
||||
+ if (gAppData) {
|
||||
+ gdk_set_program_class(gAppData->remotingName);
|
||||
}
|
||||
}
|
||||
}
|
||||
--
|
||||
2.26.1
|
||||
|
86
firefox.spec
86
firefox.spec
@ -17,7 +17,7 @@
|
||||
%define pkgver %(echo %version | tr . _)
|
||||
|
||||
Name: firefox
|
||||
Version: 76.0.1
|
||||
Version: 84.0.1
|
||||
Release: 1mamba
|
||||
Epoch: 1
|
||||
Summary: The next generation browsing technology from mozilla.org
|
||||
@ -52,7 +52,7 @@ Patch9: firefox-42.0-build-add-freetype-system-wrapper.patch
|
||||
Patch10: firefox-43.0.4-fix-missing-PR_snprint.patch
|
||||
Patch11: firefox-47.0-gcc-6.1.0.patch
|
||||
Patch12: firefox-48.0.1-install_dir.patch
|
||||
Patch13: firefox-69.0-use-remoting-names-for-gdk-application-names.patch
|
||||
Patch13: firefox-77.0.1-use-remoting-names-for-gdk-application-names.patch
|
||||
Patch14: firefox-69.0.2-no-relinking.patch
|
||||
Patch15: firefox-70.0-fix-__warn_memset_zero_len.patch
|
||||
License: GPL, LGPL, MPL 1.1
|
||||
@ -116,10 +116,11 @@ BuildRequires: zip
|
||||
BuildRequires: unzip
|
||||
BuildRequires: bash
|
||||
BuildRequires: yasm
|
||||
BuildRequires: rust-bin
|
||||
BuildRequires: rustc
|
||||
BuildRequires: cbindgen
|
||||
BuildRequires: cbindgen
|
||||
BuildRequires: xorg-server-xvfb
|
||||
BuildRequires: python-zstandard-py3
|
||||
#BuildRequires: python-pygments252
|
||||
BuildRequires: libcxx-devel
|
||||
Provides: xulrunner
|
||||
@ -140,6 +141,8 @@ Obsoletes: xulrunner-devel
|
||||
Mofilla Firefox is the next generation browsing technology from mozilla.org.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
#% debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n mozilla-release-FIREFOX_%{pkgver}_RELEASE
|
||||
#-D -T
|
||||
@ -161,24 +164,27 @@ echo -n "AIzaSyBT3wXwxmFuUQcyeMyp0MbHHhhFwNfWKTc" >google-api-key
|
||||
|
||||
cat > .mozconfig <<END
|
||||
ac_add_options --enable-application=browser
|
||||
mk_add_options MOZ_OBJDIR=${PWD@Q}/obj
|
||||
|
||||
ac_add_options --prefix=%{_prefix}
|
||||
ac_add_options --libdir=%{_libdir}
|
||||
ac_add_options --enable-release
|
||||
ac_add_options --enable-hardening
|
||||
%ifarch %{ix86}
|
||||
%ifarch %{ix86} aarch64
|
||||
ac_add_options --disable-debug-symbols
|
||||
ac_add_options --disable-elf-hack
|
||||
ac_add_options --enable-optimize="-O2"
|
||||
%else
|
||||
ac_add_options --enable-optimize
|
||||
%endif
|
||||
ac_add_options --enable-rust-simd
|
||||
#ac_add_options --enable-linker=gold
|
||||
ac_add_options --enable-linker=lld
|
||||
%ifarch %{ix86} x86_64
|
||||
ac_add_options --disable-elf-hack
|
||||
%endif
|
||||
#ac_add_options --enable-lto
|
||||
export MOZ_PGO=1
|
||||
export CC=clang
|
||||
export CXX=clang++
|
||||
#export MOZ_PGO=1
|
||||
export CC="clang --target=%{_target_platform}"
|
||||
export CXX="clang++ --target=%{_target_platform}"
|
||||
export AR=llvm-ar
|
||||
export NM=llvm-nm
|
||||
export RANLIB=llvm-ranlib
|
||||
@ -190,7 +196,7 @@ ac_add_options --with-distribution-id=org.openmamba
|
||||
ac_add_options --with-unsigned-addon-scopes=app,system
|
||||
export MOZILLA_OFFICIAL=1
|
||||
export MOZ_APP_REMOTINGNAME=%{name}
|
||||
unset MOZ_TELEMETRY_REPORTING
|
||||
export MOZ_TELEMETRY_REPORTING=1
|
||||
export MOZ_REQUIRE_SIGNING=1
|
||||
|
||||
## Keys
|
||||
@ -199,74 +205,36 @@ ac_add_options --with-google-safebrowsing-api-keyfile=$PWD/google-api-key
|
||||
#ac_add_options --with-mozilla-api-keyfile=`pwd`/mozilla-api-key
|
||||
|
||||
# System libraries
|
||||
#ac_add_options --enable-system-ffi
|
||||
#ac_add_options --enable-system-sqlite
|
||||
#ac_add_options --with-system-bz2
|
||||
#ac_add_options --with-system-icu
|
||||
#ac_add_options --with-system-jpeg
|
||||
#ac_add_options --with-system-libvpx # (69.0)
|
||||
ac_add_options --with-system-nspr
|
||||
ac_add_options --with-system-nss
|
||||
#ac_add_options --with-system-zlib
|
||||
|
||||
# Features
|
||||
ac_add_options --with-user-appdir=.firefox
|
||||
ac_add_options --enable-alsa
|
||||
ac_add_options --enable-jack
|
||||
ac_add_options --enable-startup-notification
|
||||
ac_add_options --enable-crashreporter
|
||||
ac_add_options --disable-gconf
|
||||
ac_add_options --disable-updater
|
||||
ac_add_options --disable-strip
|
||||
ac_add_options --disable-tests
|
||||
END
|
||||
|
||||
mkdir mozbuild
|
||||
mkdir -p mozbuild
|
||||
|
||||
%build
|
||||
#:<< ___EOF
|
||||
|
||||
#export MOZ_SOURCE_REPO=https://hg.mozilla.org/mozilla-unified
|
||||
export MOZ_NOSPAM=1
|
||||
export MOZBUILD_STATE_PATH="`pwd`/mozbuild"
|
||||
export MOZ_ENABLE_FULL_SYMBOLS=1
|
||||
export MACH_USE_SYSTEM_PYTHON=1
|
||||
#export MOZ_SOURCE_CHANGESET=dummy
|
||||
#export CFLAGS="${CFLAGS/-fno-plt/}"
|
||||
#export CXXFLAGS="-I/usr/include/c++/v1"
|
||||
export CXXFLAGS="-I/usr/include/c++/10.2.0/"
|
||||
|
||||
# LTO needs more open files
|
||||
ulimit -n 4096
|
||||
|
||||
#xvfb-run -a -n 97 -s "-screen 0 1600x1200x24"
|
||||
|
||||
# Do 3-tier PGO
|
||||
## Building instrumented browser
|
||||
#cat >.mozconfig mozconfig.base - <<END
|
||||
# ac_add_options --enable-profile-generate
|
||||
#END
|
||||
|
||||
xvfb-run -a -n 92 -s "-screen 0 1600x1200x24" \
|
||||
./mach build
|
||||
|
||||
:<< ___DISABLED
|
||||
# Profiling instrumented browser
|
||||
./mach package
|
||||
LLVM_PROFDATA=llvm-profdata \
|
||||
JARLOG_FILE="$PWD/jarlog" \
|
||||
xvfb-run -a -n 92 -s "-screen 0 1600x1200x24" \
|
||||
./mach python build/pgo/profileserver.py
|
||||
|
||||
# Removing instrumented browser
|
||||
./mach clobber
|
||||
|
||||
# Building optimized browser
|
||||
cat >.mozconfig mozconfig.base - <<END
|
||||
ac_add_options --enable-lto=cross
|
||||
ac_add_options --enable-profile-use
|
||||
ac_add_options --with-pgo-profile-path=$PWD
|
||||
ac_add_options --with-pgo-jarlog=$PWD/jarlog
|
||||
END
|
||||
./mach build
|
||||
___DISABLED
|
||||
|
||||
./mach buildsymbols
|
||||
|
||||
@ -274,10 +242,10 @@ ___DISABLED
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
#cd build
|
||||
|
||||
OBJDIR=obj-%{_target_cpu}-pc-linux-gnu
|
||||
%ifarch %{ix86}
|
||||
OBJDIR=obj-i686-pc-linux-gnu
|
||||
%endif
|
||||
export MOZ_NOSPAM=1
|
||||
export MOZBUILD_STATE_PATH="`pwd`/mozbuild"
|
||||
export MOZ_ENABLE_FULL_SYMBOLS=1
|
||||
export MACH_USE_SYSTEM_PYTHON=1
|
||||
|
||||
#cat > ${OBJDIR}/dist/bin/browser/chrome/en-US/locale/branding/browserconfig.properties << EOF
|
||||
#browser.startup.homepage=%{default_browser_homepage}
|
||||
@ -355,6 +323,7 @@ done
|
||||
# | %{__sed} -e "s,XULRUNNER_DIRECTORY,$(pkg-config --variable=libdir libxul),g" > \
|
||||
# %{buildroot}%{_bindir}/firefox
|
||||
#
|
||||
chmod 755 %{buildroot}%{firefoxappdir}/libxul.so
|
||||
#chmod 755 %{buildroot}%{_bindir}/firefox
|
||||
|
||||
#install -pm 644 ./LICENSE %{buildroot}%{firefoxappdir}/
|
||||
@ -410,7 +379,7 @@ includedir=%{firefoxincludedir}
|
||||
|
||||
Name: Mozilla Plug-In API
|
||||
Description: Mozilla Plug-In API
|
||||
Version: 76.0.1
|
||||
Version: 84.0.1
|
||||
|
||||
Cflags: -I\${includedir} -DXP_UNIX
|
||||
_EOF
|
||||
@ -1852,6 +1821,9 @@ Zulu language support for Firefox.
|
||||
#%{firefoxappdir}/browser/extensions/langpack-zu@firefox.mozilla.org.xpi
|
||||
|
||||
%changelog
|
||||
* Thu Dec 24 2020 Automatic Build System <autodist@mambasoft.it> 84.0.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon May 18 2020 Automatic Build System <autodist@mambasoft.it> 76.0.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user