provide mozilla-plugin.pc [release 39.0-2mamba;Fri Jul 03 2015]
This commit is contained in:
parent
9e2b26bccf
commit
1eac92caab
20
firefox-39.0-openmamba-prefs.patch
Normal file
20
firefox-39.0-openmamba-prefs.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- mozilla-release/modules/libpref/init/all.js.orig 2015-07-03 23:53:37.346065372 +0200
|
||||||
|
+++ mozilla-release/modules/libpref/init/all.js 2015-07-03 23:56:39.783125671 +0200
|
||||||
|
@@ -198,7 +198,7 @@
|
||||||
|
// 1 = always
|
||||||
|
// 2 = never
|
||||||
|
pref("browser.display.document_color_use", 0);
|
||||||
|
-pref("browser.display.use_system_colors", false);
|
||||||
|
+pref("browser.display.use_system_colors", true);
|
||||||
|
pref("browser.display.foreground_color", "#000000");
|
||||||
|
pref("browser.display.background_color", "#FFFFFF");
|
||||||
|
pref("browser.display.force_inline_alttext", false); // true = force ALT text for missing images to be layed out inline
|
||||||
|
@@ -1741,7 +1741,7 @@
|
||||||
|
pref("intl.charset.fallback.override", "");
|
||||||
|
pref("intl.charset.fallback.tld", true);
|
||||||
|
pref("intl.ellipsis", "chrome://global-platform/locale/intl.properties");
|
||||||
|
-pref("intl.locale.matchOS", false);
|
||||||
|
+pref("intl.locale.matchOS", true);
|
||||||
|
// fallback charset list for Unicode conversion (converting from Unicode)
|
||||||
|
// currently used for mail send only to handle symbol characters (e.g Euro, trademark, smartquotes)
|
||||||
|
// for ISO-8859-1
|
42
firefox.spec
42
firefox.spec
@ -8,17 +8,15 @@
|
|||||||
%define xulrunner_ver %(echo %version | cut -d. -f 1)
|
%define xulrunner_ver %(echo %version | cut -d. -f 1)
|
||||||
%define firefox_internal_version %(echo %version | cut -d. -f1)
|
%define firefox_internal_version %(echo %version | cut -d. -f1)
|
||||||
%define firefoxappdir %{_libdir}/firefox-%{firefox_internal_version}
|
%define firefoxappdir %{_libdir}/firefox-%{firefox_internal_version}
|
||||||
|
%define firefoxsdkdir %{_libdir}/firefox-devel-%{firefox_internal_version}
|
||||||
%define xul_sdk_dir %(pkg-config --variable=sdkdir libxul)
|
%define firefoxincludedir %{_includedir}/firefox-%{version}
|
||||||
#%define xul_lib_dir %(pkg-config --variable=libdir libxul)
|
|
||||||
%define xul_lib_dir %{_libdir}/xulrunner-%{xulrunner_ver}
|
|
||||||
#%define mozilla_version central
|
#%define mozilla_version central
|
||||||
%define mozilla_version release
|
%define mozilla_version release
|
||||||
%define source_dir mozilla-%{mozilla_version}
|
%define source_dir mozilla-%{mozilla_version}
|
||||||
|
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 38.0.6
|
Version: 39.0
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Summary: The next generation browsing technology from mozilla.org
|
Summary: The next generation browsing technology from mozilla.org
|
||||||
Group: Graphical Desktop/Applications/Internet
|
Group: Graphical Desktop/Applications/Internet
|
||||||
@ -46,6 +44,7 @@ Patch4: firefox-4.0-01-default.patch
|
|||||||
Patch5: xulrunner-2.0-os2cc.patch
|
Patch5: xulrunner-2.0-os2cc.patch
|
||||||
Patch6: firefox-7.0-cache-build.patch
|
Patch6: firefox-7.0-cache-build.patch
|
||||||
Patch7: firefox-36.0.3-fix-build-upstream.patch
|
Patch7: firefox-36.0.3-fix-build-upstream.patch
|
||||||
|
Patch8: firefox-39.0-openmamba-prefs.patch
|
||||||
License: GPL, LGPL, MPL 1.1
|
License: GPL, LGPL, MPL 1.1
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -149,6 +148,7 @@ sed -e 's|__RPM_VERSION_INTERNAL__|%{firefox_internal_version}|' %{PATCH0} | pat
|
|||||||
%patch5 -p1 -b .os2cc
|
%patch5 -p1 -b .os2cc
|
||||||
#%patch6 -p2
|
#%patch6 -p2
|
||||||
#%patch7 -p1
|
#%patch7 -p1
|
||||||
|
%patch8 -p1
|
||||||
|
|
||||||
#% define _use_internal_dependency_generator 0
|
#% define _use_internal_dependency_generator 0
|
||||||
#% define __find_provides %{_builddir}/firefox-%{version}/%{source_dir}/find_provides.sh
|
#% define __find_provides %{_builddir}/firefox-%{version}/%{source_dir}/find_provides.sh
|
||||||
@ -173,9 +173,9 @@ sed -e 's|__RPM_VERSION_INTERNAL__|%{firefox_internal_version}|' %{PATCH0} | pat
|
|||||||
#___EOF
|
#___EOF
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
#:<< ___EOF
|
||||||
mkdir -p build
|
mkdir -p build
|
||||||
cd build
|
cd build
|
||||||
#:<< ___EOF
|
|
||||||
ln -sf ../%{source_dir}/configure configure
|
ln -sf ../%{source_dir}/configure configure
|
||||||
|
|
||||||
export LDFLAGS='-lX11 -lXrender' PYTHON=%{__python}
|
export LDFLAGS='-lX11 -lXrender' PYTHON=%{__python}
|
||||||
@ -272,7 +272,7 @@ browser.startup.homepage=%{default_browser_homepage}
|
|||||||
browser.startup.homepage_reset=%{default_browser_homepage}
|
browser.startup.homepage_reset=%{default_browser_homepage}
|
||||||
EOF
|
EOF
|
||||||
|
|
||||||
cat > dist/bin/browser/defaults/preferences/all-redhat.js << _EOF
|
cat > ../mozilla-release/modules/libpref/init/all-openmamba.js << _EOF
|
||||||
pref("app.update.auto", false);
|
pref("app.update.auto", false);
|
||||||
pref("app.update.enabled", false);
|
pref("app.update.enabled", false);
|
||||||
pref("app.update.autoInstallEnabled", false);
|
pref("app.update.autoInstallEnabled", false);
|
||||||
@ -287,7 +287,8 @@ pref("general.useragent.vendorSub", "%{version}-%{release}");
|
|||||||
pref("intl.locale.matchOS", true);
|
pref("intl.locale.matchOS", true);
|
||||||
_EOF
|
_EOF
|
||||||
|
|
||||||
sed -i -e 's|@BINPATH@/browser/@PREF_DIR@/firefox.js|@BINPATH@/browser/@PREF_DIR@/all-redhat.js\n&|' ../mozilla-release/browser/installer/package-manifest.in
|
sed -i -e 's|@BINPATH@/browser/@PREF_DIR@/firefox.js|@BINPATH@/browser/@PREF_DIR@/all-openmamba.js\n&|' \
|
||||||
|
../mozilla-release/browser/installer/package-manifest.in
|
||||||
|
|
||||||
cp -p %{SOURCE10} dist/bin/browser/defaults/profile/bookmarks.html
|
cp -p %{SOURCE10} dist/bin/browser/defaults/profile/bookmarks.html
|
||||||
|
|
||||||
@ -319,7 +320,7 @@ install -pm 644 ../mozilla-release/LICENSE %{buildroot}%{firefoxappdir}/
|
|||||||
|
|
||||||
rm -rf %{buildroot}%{firefoxappdir}/firefox
|
rm -rf %{buildroot}%{firefoxappdir}/firefox
|
||||||
ln -s firefox-bin %{buildroot}%{firefoxappdir}/firefox
|
ln -s firefox-bin %{buildroot}%{firefoxappdir}/firefox
|
||||||
ln -s %{xul_lib_dir} %{buildroot}%{firefoxappdir}/xulrunner
|
#ln -s %{xul_lib_dir} %{buildroot}%{firefoxappdir}/xulrunner
|
||||||
|
|
||||||
# install langpacks
|
# install langpacks
|
||||||
|
|
||||||
@ -356,6 +357,19 @@ echo "%{firefoxappdir}" > \
|
|||||||
|
|
||||||
rm -rf %{buildroot}%{firefoxappdir}/removed-files
|
rm -rf %{buildroot}%{firefoxappdir}/removed-files
|
||||||
|
|
||||||
|
install -d -m0755 %{buildroot}%{_libdir}/pkgconfig
|
||||||
|
cat > %{buildroot}%{_libdir}/pkgconfig/mozilla-plugin.pc << _EOF
|
||||||
|
prefix=%{_prefix}
|
||||||
|
sdkdir=%{firefoxsdkdir}
|
||||||
|
includedir=%{firefoxincludedir}
|
||||||
|
|
||||||
|
Name: Mozilla Plug-In API
|
||||||
|
Description: Mozilla Plug-In API
|
||||||
|
Version: %{version}
|
||||||
|
|
||||||
|
Cflags: -I\${includedir} -DXP_UNIX
|
||||||
|
_EOF
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
@ -434,7 +448,6 @@ fi
|
|||||||
%dir %{firefoxappdir}/browser/searchplugins
|
%dir %{firefoxappdir}/browser/searchplugins
|
||||||
%{firefoxappdir}/browser/searchplugins/*
|
%{firefoxappdir}/browser/searchplugins/*
|
||||||
%{firefoxappdir}/firefox-bin
|
%{firefoxappdir}/firefox-bin
|
||||||
%{firefoxappdir}/xulrunner
|
|
||||||
%{firefoxappdir}/webapprt-stub
|
%{firefoxappdir}/webapprt-stub
|
||||||
%dir %{firefoxappdir}/webapprt
|
%dir %{firefoxappdir}/webapprt
|
||||||
%{firefoxappdir}/webapprt/omni.ja
|
%{firefoxappdir}/webapprt/omni.ja
|
||||||
@ -482,6 +495,7 @@ fi
|
|||||||
%{_includedir}/firefox-*/*
|
%{_includedir}/firefox-*/*
|
||||||
%dir %{_libdir}/firefox-devel-*
|
%dir %{_libdir}/firefox-devel-*
|
||||||
%{_libdir}/firefox-devel-*/*
|
%{_libdir}/firefox-devel-*/*
|
||||||
|
%{_libdir}/pkgconfig/mozilla-plugin.pc
|
||||||
|
|
||||||
%package i18n-ach
|
%package i18n-ach
|
||||||
Summary: Acholi language support for Firefox
|
Summary: Acholi language support for Firefox
|
||||||
@ -1708,6 +1722,12 @@ Zulu language support for Firefox.
|
|||||||
#%{firefoxappdir}/browser/extensions/langpack-zu@firefox.mozilla.org/
|
#%{firefoxappdir}/browser/extensions/langpack-zu@firefox.mozilla.org/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 03 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 39.0-2mamba
|
||||||
|
- provide mozilla-plugin.pc
|
||||||
|
|
||||||
|
* Fri Jul 03 2015 Automatic Build System <autodist@mambasoft.it> 39.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Tue Jun 09 2015 Automatic Build System <autodist@mambasoft.it> 38.0.6-1mamba
|
* Tue Jun 09 2015 Automatic Build System <autodist@mambasoft.it> 38.0.6-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user