update to 3.0.3.32900 [release 3.0.3.32900-1mamba;Fri May 04 2018]
This commit is contained in:
parent
ea7044f634
commit
0131e154e2
12
firebird-3.0.1.32609-gcc-6.2.0.patch
Normal file
12
firebird-3.0.1.32609-gcc-6.2.0.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- Firebird-3.0.1.32609-0/src/common/classes/init.h.orig 2016-10-07 00:30:20.110681159 +0200
|
||||
+++ Firebird-3.0.1.32609-0/src/common/classes/init.h 2016-10-07 00:27:47.820536592 +0200
|
||||
@@ -121,7 +121,8 @@
|
||||
public:
|
||||
void dtor()
|
||||
{
|
||||
- delete instance;
|
||||
+ if (instance)
|
||||
+ delete instance;
|
||||
instance = 0;
|
||||
}
|
||||
|
16
firebird-3.0.2.32703-c++11.patch
Normal file
16
firebird-3.0.2.32703-c++11.patch
Normal file
@ -0,0 +1,16 @@
|
||||
# -*- Mode: Diff -*-
|
||||
--- firebird/src/dudley/exe.epp
|
||||
+++ firebird/src/dudley/exe.epp
|
||||
@@ -2884,9 +2884,9 @@
|
||||
blr_parameter, 0, 0, 0,
|
||||
blr_parameter, 0, 1, 0,
|
||||
blr_parameter, 1, 0, 0,
|
||||
- blr_end,
|
||||
- blr_end,
|
||||
- blr_end,
|
||||
+ SCHAR(blr_end),
|
||||
+ SCHAR(blr_end),
|
||||
+ SCHAR(blr_end),
|
||||
blr_eoc
|
||||
};
|
||||
static FB_API_HANDLE req_handle;
|
30
firebird-3.0.2.32703-c++14.patch
Normal file
30
firebird-3.0.2.32703-c++14.patch
Normal file
@ -0,0 +1,30 @@
|
||||
--- src/common/classes/alloc.cpp
|
||||
+++ src/common/classes/alloc.cpp
|
||||
@@ -2121,3 +2121,11 @@
|
||||
{
|
||||
Firebird::MemoryPool::globalFree(mem);
|
||||
}
|
||||
+void operator delete(void* mem, size_t) throw()
|
||||
+{
|
||||
+ Firebird::MemoryPool::globalFree(mem);
|
||||
+}
|
||||
+void operator delete[](void* mem, size_t) throw()
|
||||
+{
|
||||
+ Firebird::MemoryPool::globalFree(mem);
|
||||
+}
|
||||
--- src/common/classes/alloc.h
|
||||
+++ src/common/classes/alloc.h
|
||||
@@ -491,13 +491,6 @@
|
||||
|
||||
inline static MemoryPool* getDefaultMemoryPool() { return Firebird::MemoryPool::processMemoryPool; }
|
||||
|
||||
-// Global versions of operators new and delete
|
||||
-void* operator new(size_t s) THROW_BAD_ALLOC;
|
||||
-void* operator new[](size_t s) THROW_BAD_ALLOC;
|
||||
-
|
||||
-void operator delete(void* mem) throw();
|
||||
-void operator delete[](void* mem) throw();
|
||||
-
|
||||
#ifdef DEBUG_GDS_ALLOC
|
||||
inline void* operator new(size_t s, Firebird::MemoryPool& pool, const char* file, int line)
|
||||
{
|
63
firebird-3.0.3.32900-icu-60.patch
Normal file
63
firebird-3.0.3.32900-icu-60.patch
Normal file
@ -0,0 +1,63 @@
|
||||
From a4cb621bf55ef2101e22b1e7da5c458a1e0cc2ab Mon Sep 17 00:00:00 2001
|
||||
From: AlexPeshkoff <alexander.peshkoff@gmail.com>
|
||||
Date: Sat, 10 Feb 2018 19:43:26 +0300
|
||||
Subject: [PATCH] Make it build with icu60
|
||||
|
||||
---
|
||||
src/common/common.h | 3 +++
|
||||
src/common/unicode_util.h | 4 ++++
|
||||
src/intl/cs_icu.cpp | 1 -
|
||||
src/intl/cv_icu.cpp | 1 -
|
||||
4 files changed, 7 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/common/common.h b/src/common/common.h
|
||||
index 2cf877a804..58abaaf695 100644
|
||||
--- a/src/common/common.h
|
||||
+++ b/src/common/common.h
|
||||
@@ -997,4 +997,7 @@ namespace Firebird {
|
||||
static IMessageMetadata* const DELAYED_OUT_FORMAT = reinterpret_cast<IMessageMetadata*>(1);
|
||||
}
|
||||
|
||||
+#undef UCHAR_TYPE
|
||||
+#define UCHAR_TYPE uint16_t
|
||||
+
|
||||
#endif /* COMMON_COMMON_H */
|
||||
diff --git a/src/common/unicode_util.h b/src/common/unicode_util.h
|
||||
index 001d3d8283..03d48f9419 100644
|
||||
--- a/src/common/unicode_util.h
|
||||
+++ b/src/common/unicode_util.h
|
||||
@@ -31,6 +31,10 @@
|
||||
#include "../common/IntlUtil.h"
|
||||
#include "../common/os/mod_loader.h"
|
||||
#include "../common/classes/fb_string.h"
|
||||
+
|
||||
+#undef U_SHOW_CPLUSPLUS_API
|
||||
+#define U_SHOW_CPLUSPLUS_API 0
|
||||
+
|
||||
#include <unicode/ucnv.h>
|
||||
|
||||
struct UCollator;
|
||||
diff --git a/src/intl/cs_icu.cpp b/src/intl/cs_icu.cpp
|
||||
index 76f15a2e68..bc3b48b44f 100644
|
||||
--- a/src/intl/cs_icu.cpp
|
||||
+++ b/src/intl/cs_icu.cpp
|
||||
@@ -28,7 +28,6 @@
|
||||
#include "../intl/ldcommon.h"
|
||||
#include "cs_icu.h"
|
||||
#include "cv_icu.h"
|
||||
-#include <unicode/ucnv.h>
|
||||
#include "../common/unicode_util.h"
|
||||
|
||||
|
||||
diff --git a/src/intl/cv_icu.cpp b/src/intl/cv_icu.cpp
|
||||
index b1ac01fce5..82262d9b4d 100644
|
||||
--- a/src/intl/cv_icu.cpp
|
||||
+++ b/src/intl/cv_icu.cpp
|
||||
@@ -28,7 +28,6 @@
|
||||
#include "../intl/ldcommon.h"
|
||||
#include "ld_proto.h"
|
||||
#include "cv_icu.h"
|
||||
-#include <unicode/ucnv.h>
|
||||
#include "../common/unicode_util.h"
|
||||
|
||||
|
6
firebird-default.password
Normal file
6
firebird-default.password
Normal file
@ -0,0 +1,6 @@
|
||||
# This is the default password
|
||||
# You should change this password at the earliest oportunity
|
||||
# Your password can be changed to a more suitable one using the
|
||||
# /usr/bin/gsec utility
|
||||
ISC_USER=SYSDBA
|
||||
ISC_PASSWD=masterkey
|
1
firebird-sysusers.conf
Normal file
1
firebird-sysusers.conf
Normal file
@ -0,0 +1 @@
|
||||
u firebird 65055 "Firebird Database Owner" /var/lib/firebird
|
3
firebird-tmpfiles.conf
Normal file
3
firebird-tmpfiles.conf
Normal file
@ -0,0 +1,3 @@
|
||||
d /run/firebird 0755 firebird firebird -
|
||||
d /tmp/firebird 0770 firebird firebird -
|
||||
d /var/log/firebird 0770 firebird firebird -
|
14
firebird.service
Normal file
14
firebird.service
Normal file
@ -0,0 +1,14 @@
|
||||
[Unit]
|
||||
Description=Firebird Database Service (SuperServer)
|
||||
After=syslog.target network.target
|
||||
|
||||
[Service]
|
||||
User=firebird
|
||||
Group=firebird
|
||||
Type=forking
|
||||
PIDFile=/run/firebird/default.pid
|
||||
ExecStart=/usr/lib/firebird/bin/fbguard -pidfile /run/firebird/default.pid -daemon -forever
|
||||
SyslogIdentifier=firebird
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
438
firebird.spec
438
firebird.spec
@ -2,9 +2,10 @@
|
||||
%define userid 65055
|
||||
%define pkg_name %{name}-%{version}-0
|
||||
%define major %(echo %version | cut -d. -f 1-3)
|
||||
%define major_ %(echo %version | cut -d. -f 1-3 | tr . _)
|
||||
%define majver %(echo %version | cut -d. -f 1-2)
|
||||
Name: firebird
|
||||
Version: 2.5.6.27020
|
||||
Version: 3.0.3.32900
|
||||
Release: 1mamba
|
||||
Summary: SQL Relational Database
|
||||
Group: Applications/Databases
|
||||
@ -12,11 +13,14 @@ Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.firebirdsql.org/
|
||||
Source0: http://downloads.sourceforge.net/project/firebird/firebird/%{major}-Release/Firebird-%{version}-0.tar.bz2
|
||||
#Source0: http://downloads.sourceforge.net/project/firebird/firebird/%{majver}-Release/Firebird-%{version}-0.tar.bz2
|
||||
Source0: https://github.com/FirebirdSQL/firebird/releases/download/R%{major_}/Firebird-%{version}-0.tar.bz2
|
||||
Source1: Firebird-2.1.2.18118.0-profile.sh
|
||||
Source2: Firebird-2.1.2.18118.0-profile.csh
|
||||
Source3: Firebird-2.1.2.18118.0-logrotate
|
||||
Source4: firebird.service
|
||||
Source5: firebird-tmpfiles.conf
|
||||
Source6: firebird-sysusers.conf
|
||||
Source7: firebird-default.password
|
||||
Patch0: Firebird-2.1.3.18185-fix-initscript.patch
|
||||
Patch1: Firebird-2.1.2.18118.0-doc.patch
|
||||
Patch2: Firebird-2.1.2.18118.0-mcpu-to-mtune.patch
|
||||
@ -26,22 +30,31 @@ Patch5: %{name}-2.1.4.18393-gcc45.patch
|
||||
Patch6: firebird-2.1.4-gcc-4.7.patch
|
||||
Patch7: firebird-2.1.5-system-icu.patch
|
||||
Patch8: firebird-2.5.2.26540-makeInstallImage-noroot.patch
|
||||
Patch9: firebird-3.0.1.32609-gcc-6.2.0.patch
|
||||
Patch10: firebird-3.0.2.32703-c++11.patch
|
||||
Patch11: firebird-3.0.2.32703-c++14.patch
|
||||
Patch12: firebird-3.0.3.32900-icu-60.patch
|
||||
License: MPL 1.1
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libedit-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libncurses-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtommath-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: bison
|
||||
BuildRequires: libtool
|
||||
BuildRequires: libtermcap-devel
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: libncurses-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: libfbclient-%{name}
|
||||
BuildConflicts: libfbclient < 3.0
|
||||
#BuildConflicts: libfbembed-firebird
|
||||
Requires: libfbclient = %{version}-%{release}
|
||||
Provides: Firebird
|
||||
Obsoletes: Firebird
|
||||
%systemd_requires
|
||||
Provides: firebird-classic
|
||||
Obsoletes: firebird-classic
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
@ -54,7 +67,7 @@ Summary: Classic (xinetd) server for %{name} SQL RDBMS
|
||||
Requires: xinetd
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Conflicts: %{name}-superserver
|
||||
Requires: libfbembed-%{name} = %{version}-%{release}
|
||||
#Requires: libfbembed-%{name} = %{version}-%{release}
|
||||
Provides: Firebird-classic
|
||||
Obsoletes: Firebird-classic
|
||||
|
||||
@ -66,8 +79,8 @@ This is the classic (xinetd) server %{name} SQL RDBMS. It can also be used as an
|
||||
%package devel
|
||||
Group: Applications/Databases
|
||||
Summary: Development Libraries for %{name} SQL RDBMS
|
||||
Requires: libfbclient-%{name} = %{version}-%{release}
|
||||
Requires: libfbembed-%{name} = %{version}-%{release}
|
||||
Requires: libfbclient = %{version}-%{release}
|
||||
#Requires: libfbembed-%{name} = %{version}-%{release}
|
||||
Provides: Firebird-devel
|
||||
Obsoletes: Firebird-devel
|
||||
|
||||
@ -88,24 +101,28 @@ Obsoletes: Firebird-doc
|
||||
|
||||
This package contains documentation for %{name}.
|
||||
|
||||
%package -n libfbclient-%{name}
|
||||
%package -n libfbclient
|
||||
Group: System/Libraries
|
||||
Summary: Multi-threaded, non-local client libraries for Firebird SQL RDBMS
|
||||
Provides: libfbclient-Firebird
|
||||
Obsoletes: libfbclient-Firebird
|
||||
Provides: libfbclient-firebird
|
||||
Obsoletes: libfbclient-firebird
|
||||
|
||||
%description -n libfbclient-%{name}
|
||||
%description -n libfbclient
|
||||
%{name} is a relational database offering many ANSI SQL standard features that runs on Linux, Windows, and a variety of Unix platforms.
|
||||
|
||||
This package contains multi-threaded, non-local client libraries for Firebird SQL Database
|
||||
|
||||
%package -n libfbembed-%{name}
|
||||
%package -n libfbembed
|
||||
Group: System/Libraries
|
||||
Summary: Multi-process, local client libraries for Firebird SQL RDBMS
|
||||
Provides: libfbembed-Firebird
|
||||
Obsoletes: libfbembed-Firebird
|
||||
Provides: libfbembed-firebird
|
||||
Obsoletes: libfbembed-firebird
|
||||
|
||||
%description -n libfbembed-%{name}
|
||||
%description -n libfbembed
|
||||
%{name} is a relational database offering many ANSI SQL standard features that runs on Linux, Windows, and a variety of Unix platforms.
|
||||
|
||||
This package contains multi-process, local client libraries for Firebird SQL RDBMS
|
||||
@ -114,7 +131,7 @@ This package contains multi-process, local client libraries for Firebird SQL RDB
|
||||
Group: Applications/Databases
|
||||
Summary: Superserver (single process) server for %{name} SQL RDBMS
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Conflicts: %{name}-classic
|
||||
#Conflicts: %{name}-classic
|
||||
Provides: Firebird-superserver
|
||||
Obsoletes: Firebird-superserver
|
||||
|
||||
@ -125,178 +142,80 @@ This is the Superserver (single process) %{name} SQL RDBMS.
|
||||
|
||||
|
||||
%prep
|
||||
#:<< __EOF
|
||||
[ -e Firebird-%{version}-0 ] && chmod u+w Firebird-%{version}-0/* -R
|
||||
%setup -q -n Firebird-%{version}-0
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
iconv -f ISO-8859-1 -t utf-8 -c doc/README.intl -o doc/README.intl
|
||||
#%patch0 -p0
|
||||
#%patch1 -p1
|
||||
#%patch2 -p1
|
||||
#%patch3 -p1
|
||||
#%patch4 -p0
|
||||
#%patch5 -p1
|
||||
#%patch6 -p1
|
||||
#%patch7 -p1
|
||||
%patch8 -p1
|
||||
#:<< __EOF
|
||||
#%patch10 -p1
|
||||
#%patch11 -p0
|
||||
%patch12 -p1
|
||||
|
||||
%build
|
||||
#:<< __EOF
|
||||
# build classic
|
||||
#./autogen.sh
|
||||
#autoreconf -vfi
|
||||
autoreconf
|
||||
%configure \
|
||||
--prefix=%{_libdir}/firebird \
|
||||
--with-system-icu
|
||||
|
||||
chmod u+w gen/* -R
|
||||
|
||||
#__EOF
|
||||
|
||||
# parallel build is broken
|
||||
make -j1 CXXFLAGS='-std=gnu++98 -flifetime-dse=1' || make CXXFLAGS='-std=gnu++98 -flifetime-dse=1'
|
||||
|
||||
cd gen
|
||||
./install/makeInstallImage.sh
|
||||
mv ./buildroot buildroot-classic
|
||||
chmod 644 ./buildroot-classic%{_libdir}/firebird/help/help.fdb
|
||||
cd ..
|
||||
|
||||
# build superserver
|
||||
./autogen.sh
|
||||
#autoreconf -vfi
|
||||
#autoreconf
|
||||
%configure \
|
||||
--prefix=%{_libdir}/firebird \
|
||||
--prefix=%{_prefix} \
|
||||
--with-fbbin=%{_bindir} \
|
||||
--with-fbconf=%{_sysconfdir}/firebird \
|
||||
--with-fbdoc=%{_docdir}/firebird \
|
||||
--with-fbglock=/run/firebird \
|
||||
--with-fbhelp=%{_docdir}/firebird/help \
|
||||
--with-fbinclude=%{_includedir}/firebird \
|
||||
--with-fblib=%{_libdir} \
|
||||
--with-fblock=/run/firebird \
|
||||
--with-fblog=/var/log/ \
|
||||
--with-fbmsg=%{_libdir}/firebird/msg \
|
||||
--with-fbplugins=%{_libdir}/firebird/plugins \
|
||||
--with-fbsbin=%{_libdir}/firebird/bin \
|
||||
--with-fbudf=%{_libdir}/firebird/UDF \
|
||||
--with-fbsecure-db=/var/lib/firebird/system \
|
||||
--with-fbintl=%{_libdir}/firebird/intl \
|
||||
--without-fbmisc \
|
||||
--without-fbsample \
|
||||
--without-fbsample-db \
|
||||
--enable-superserver \
|
||||
--with-system-icu
|
||||
--with-system-icu \
|
||||
--with-system-editline
|
||||
|
||||
# parallel build is broken
|
||||
make CXXFLAGS='-std=gnu++98 -flifetime-dse=1' || make CXXFLAGS='-std=gnu++98 -flifetime-dse=1'
|
||||
#chmod u+w gen/* -R
|
||||
|
||||
cd gen
|
||||
./install/makeInstallImage.sh
|
||||
mv ./buildroot/ buildroot-superserver
|
||||
chmod 644 ./buildroot-superserver%{_libdir}/firebird/help/help.fdb
|
||||
# FIXME: 3.0.1.32609 segfaults when creating fdb files
|
||||
%make -j1 CXXFLAGS='-flifetime-dse=1'
|
||||
|
||||
%install
|
||||
install -d %{buildroot}
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
chmod u+w gen/* -R
|
||||
cp -a gen/buildroot-superserver/* %{buildroot}/
|
||||
cp -a gen/buildroot-classic/* %{buildroot}/
|
||||
sed -i "s|whoami|echo root|;s|chown|#chown|;" gen/install/makeInstallImage.sh
|
||||
cd gen
|
||||
./install/makeInstallImage.sh
|
||||
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/firebird
|
||||
mkdir -p %{buildroot}%{_initrddir}
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/xinetd.d
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/profile.d
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
|
||||
mkdir -p %{buildroot}%{_var}/run/firebird
|
||||
mkdir -p %{buildroot}%{_localstatedir}/lib/firebird/data
|
||||
mkdir -p %{buildroot}%{_localstatedir}/log/firebird
|
||||
mkdir -p %{buildroot}%{_includedir}/firebird
|
||||
mkdir -p %{buildroot}%{_libdir}/firebird/help
|
||||
mkdir -p %{buildroot}%{_libdir}/firebird/intl
|
||||
mkdir -p %{buildroot}%{_libdir}/firebird/lib
|
||||
mkdir -p %{buildroot}%{_libdir}/firebird/include
|
||||
mkdir -p %{buildroot}%{_libdir}/firebird/bin-classic
|
||||
mkdir -p %{buildroot}%{_libdir}/firebird/UDF-classic
|
||||
mkdir -p %{buildroot}%{_libdir}/firebird/bin-superserver
|
||||
mkdir -p %{buildroot}%{_libdir}/firebird/UDF-superserver
|
||||
mkdir -p %{buildroot}%{_bindir}
|
||||
cd ..
|
||||
install -d -m0755 %{buildroot}
|
||||
cp -av gen/buildroot/* %{buildroot}/
|
||||
|
||||
install gen/firebird/bin/fb_config %{buildroot}%{_bindir}/fb_config
|
||||
install -Dm644 %{SOURCE5} %{buildroot}%{_tmpfilesdir}/firebird.conf
|
||||
install -Dm644 %{SOURCE6} %{buildroot}%{_sysusersdir}/firebird.conf
|
||||
install -Dm644 %{SOURCE4} %{buildroot}%{_unitdir}/firebird.service
|
||||
install -Dm440 %{SOURCE7} %{builroott}/var/lib/firebird/system/SYSDBA.password
|
||||
install -Dm644 %{buildroot}%{_sysconfdir}/firebird/I{,D}PLicense.txt -t %{buildroot}%{_datadir}/licenses/%{name}
|
||||
|
||||
pushd %{_builddir}/Firebird-%{version}-0/gen
|
||||
pushd buildroot-classic%{_libdir}/firebird
|
||||
#cp examples/empbuild/employee.fdb %{buildroot}%{_localstatedir}/lib/firebird/data/employee.fdb
|
||||
cp help/help.fdb %{buildroot}%{_libdir}/firebird/help/help.fdb
|
||||
cp *.msg %{buildroot}%{_libdir}/firebird
|
||||
cp intl/fbintl %{buildroot}%{_libdir}/firebird/intl/fbintl
|
||||
cp lib/libib_util.so %{buildroot}%{_libdir}/firebird/lib/
|
||||
cp lib/libfbclient.so.%{major} %{buildroot}%{_libdir}/firebird/lib/
|
||||
cp lib/libfbembed.so.%{major} %{buildroot}%{_libdir}/firebird/lib/
|
||||
cp bin/* %{buildroot}%{_libdir}/firebird/bin-classic/
|
||||
cp UDF/* %{buildroot}%{_libdir}/firebird/UDF-classic/
|
||||
popd
|
||||
pushd buildroot-superserver%{_libdir}/firebird
|
||||
cp bin/* %{buildroot}%{_libdir}/firebird/bin-superserver/
|
||||
cp UDF/* %{buildroot}%{_libdir}/firebird/UDF-superserver/
|
||||
popd
|
||||
popd
|
||||
# Remove unused files and dirs
|
||||
rm %{buildroot}%{_sysconfdir}/firebird/I{,D}PLicense.txt
|
||||
rm %{buildroot}%{_sysconfdir}/firebird/README
|
||||
rm %{buildroot}%{_sysconfdir}/firebird/WhatsNew
|
||||
rm -rf %{buildroot}/var/log
|
||||
rm -rf %{buuildroot}/run
|
||||
|
||||
(
|
||||
cd %{buildroot}%{_libdir}/firebird/bin-superserver/
|
||||
ln -s /fbmgr.bin ./fbmgr
|
||||
)
|
||||
#(
|
||||
# cd %{buildroot}%{_libdir}/firebird/lib/
|
||||
# ln -s libfbembed.so.%{major} %{buildroot}%{_libdir}/firebird/lib/libfbembed.so.2.1
|
||||
# ln -s libfbembed.so.2.1 %{buildroot}%{_libdir}/firebird/lib/libfbembed.so
|
||||
# ln -s libfbclient.so.%{major} %{buildroot}%{_libdir}/firebird/lib/libfbclient.so.2
|
||||
# ln -s libfbclient.so.2 %{buildroot}%{_libdir}/firebird/lib/libfbclient.so
|
||||
#)
|
||||
#
|
||||
#(
|
||||
# cd %{buildroot}%{_libdir}/firebird/lib
|
||||
# ln -s libfbembed.so %{buildroot}%{_libdir}/libfbembed.so
|
||||
# ln -s libfbembed.so.2.1 %{buildroot}%{_libdir}/libfbembed.so.2.1
|
||||
# ln -s libfbembed.so.%{major} %{buildroot}%{_libdir}/libfbembed.so.%{major}
|
||||
# ln -s libfbclient.so %{buildroot}%{_libdir}/libfbclient.so
|
||||
# ln -s libfbclient.so.2 %{buildroot}%{_libdir}/libfbclient.so.2
|
||||
# ln -s libfbclient.so.%{major} %{buildroot}%{_libdir}/libfbclient.so.%{major}
|
||||
# ln -s libib_util.so %{buildroot}%{_libdir}/libib_util.so
|
||||
#)
|
||||
mv %{buildroot}%{_bindir}/isql{,-fb}
|
||||
|
||||
echo 1 > %{buildroot}%{_localstatedir}/log/firebird/firebird.log
|
||||
ln -s %{_localstatedir}/log/firebird/firebird.log %{buildroot}%{_libdir}/firebird/firebird.log
|
||||
sed "s@firebird.log@%{_localstatedir}/log/firebird/firebird.log@g" %{SOURCE3} > %{buildroot}%{_sysconfdir}/logrotate.d/firebird
|
||||
chmod -R ugo-w %{buildroot}%{_docdir}/firebird
|
||||
chmod -R o= %{buildroot}/var/lib/firebird
|
||||
chmod u+w -R %{buildroot}%{_docdir}/firebird
|
||||
#chown -R 184:184 $pkgdir/var/lib/firebird
|
||||
|
||||
|
||||
cp %{_builddir}/Firebird-%{version}-0/gen/buildroot-classic%{_libdir}/firebird/include/* %{buildroot}%{_includedir}/firebird/
|
||||
|
||||
#(
|
||||
# cd %{buildroot}%{_includedir}/firebird
|
||||
# ln -s ibase.h %{buildroot}%{_libdir}/firebird/include/ibase.h
|
||||
# ln -s iberror.h %{buildroot}%{_libdir}/firebird/include/iberror.h
|
||||
# ln -s ib_util.h %{buildroot}%{_libdir}/firebird/include/ib_util.h
|
||||
# ln -s perf.h %{buildroot}%{_libdir}/firebird/include/perf.h
|
||||
#)
|
||||
pushd %{_builddir}/Firebird-%{version}-0/gen
|
||||
cp buildroot-classic%{_libdir}/firebird/aliases.conf %{buildroot}%{_sysconfdir}/firebird/aliases.conf
|
||||
sed "s@%{_libdir}/firebird/examples/empbuild@%{_localstatedir}/lib/firebird/data@" -i %{buildroot}%{_sysconfdir}/firebird/aliases.conf
|
||||
cp buildroot-classic%{_libdir}/firebird/firebird.conf %{buildroot}%{_sysconfdir}/firebird/firebird.conf
|
||||
cp buildroot-classic%{_libdir}/firebird/intl/fbintl.conf %{buildroot}%{_sysconfdir}/firebird/fbintl.conf
|
||||
cp buildroot-classic%{_libdir}/firebird/security2.fdb %{buildroot}%{_sysconfdir}/firebird/security2.fdb
|
||||
|
||||
# ln -s %{_sysconfdir}/firebird/aliases.conf %{buildroot}%{_libdir}/firebird/aliases.conf
|
||||
# ln -s %{_sysconfdir}/firebird/firebird.conf %{buildroot}%{_libdir}/firebird/firebird.conf
|
||||
# ln -s %{_sysconfdir}/firebird/security2.fdb %{buildroot}%{_libdir}/firebird/security2.fdb
|
||||
# ln -s %{_sysconfdir}/firebird/fbintl.conf %{buildroot}%{_libdir}/firebird/intl/fbintl.conf
|
||||
popd
|
||||
|
||||
sed "s@__FIRE_DIR__@%{_libdir}/firebird@g" %{SOURCE1} > %{buildroot}%{_sysconfdir}/profile.d/firebird.sh
|
||||
|
||||
pushd %{_builddir}/Firebird-%{version}-0/gen
|
||||
cp buildroot-classic%{_libdir}/firebird/misc/firebird.xinetd \
|
||||
%{buildroot}%{_sysconfdir}/xinetd.d/firebird
|
||||
cp buildroot-superserver%{_libdir}/firebird/misc/firebird.init.d.mandrake \
|
||||
%{buildroot}%{_initrddir}/firebird
|
||||
popd
|
||||
|
||||
sed "s@chkconfig: 345@chkconfig: -@" -i %{buildroot}%{_initrddir}/firebird
|
||||
(
|
||||
cd %{buildroot}
|
||||
ln -s bin-superserver %{buildroot}%{_libdir}/firebird/bin
|
||||
ln -s %{_var}/run/firebird %{buildroot}%{_libdir}/firebird/run
|
||||
ln -s %{_libdir}/firebird/bin/isql %{buildroot}%{_bindir}/fbsql
|
||||
ln -s %{_libdir}/firebird/bin/gbak %{buildroot}%{_bindir}/gbak
|
||||
ln -s %{_libdir}/firebird/bin/gfix %{buildroot}%{_bindir}/gfix
|
||||
ln -s %{_libdir}/firebird/bin/gsec %{buildroot}%{_bindir}/gsec
|
||||
ln -s %{_libdir}/firebird/bin/nbackup %{buildroot}%{_bindir}/nbackup
|
||||
ln -s %{_libdir}/firebird/bin/gstat %{buildroot}%{_bindir}/gstat
|
||||
)
|
||||
|
||||
rm -f %{buildroot}%{_sysconfdir}/profile.d/firebird.csh
|
||||
ln -s %{_libdir}/firebird/bin/fb_config %{buildroot}%{_bindir}/fb_config
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -319,113 +238,116 @@ exit 0
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%dir %{_libdir}/firebird
|
||||
%dir %{_libdir}/firebird/lib
|
||||
%dir %{_sysconfdir}/firebird
|
||||
%config(noreplace) %attr(664,firebird,firebird) %{_sysconfdir}/firebird/aliases.conf
|
||||
%config(noreplace) %attr(664,firebird,firebird) %{_sysconfdir}/firebird/fbintl.conf
|
||||
%config %{_sysconfdir}/firebird/databases.conf
|
||||
%config %{_sysconfdir}/firebird/plugins.conf
|
||||
%config %{_sysconfdir}/firebird/fbtrace.conf
|
||||
%config(noreplace) %attr(664,firebird,firebird) %{_sysconfdir}/firebird/firebird.conf
|
||||
%config(noreplace) %attr(660,firebird,firebird) %{_sysconfdir}/firebird/security2.fdb
|
||||
%config(noreplace) %attr(644,root,root) %{_sysconfdir}/logrotate.d/firebird
|
||||
%attr(755,root,root) %{_sysconfdir}/profile.d/firebird.sh
|
||||
%dir %{_localstatedir}/log/firebird
|
||||
%attr(664,firebird,firebird) %{_localstatedir}/log/firebird/firebird.log
|
||||
%dir %attr(770,firebird,firebird) %{_localstatedir}/lib/firebird/data
|
||||
#%attr(660,firebird,firebird) %{_localstatedir}/lib/firebird/data/employee.fdb
|
||||
%attr(755,root,root) %{_bindir}/fbsql
|
||||
%attr(755,root,root) %{_bindir}/gbak
|
||||
%attr(755,root,root) %{_bindir}/gfix
|
||||
%attr(755,root,root) %{_bindir}/gsec
|
||||
%attr(755,root,root) %{_bindir}/gstat
|
||||
%attr(755,root,root) %{_bindir}/nbackup
|
||||
%attr(755,root,root) %{_libdir}/firebird/intl/fbintl
|
||||
%attr(644,root,root) %{_libdir}/firebird/aliases.conf
|
||||
%attr(644,root,root) %{_libdir}/firebird/firebird.conf
|
||||
%attr(644,root,root) %{_libdir}/firebird/intl/fbintl.conf
|
||||
%attr(644,root,root) %{_libdir}/firebird/firebird.log
|
||||
%attr(644,root,root) %{_libdir}/firebird/firebird.msg
|
||||
%attr(644,root,root) %{_libdir}/firebird/help/help.fdb
|
||||
%attr(644,root,root) %{_libdir}/libib_util.so
|
||||
%attr(644,root,root) %{_libdir}/firebird/lib/libib_util.so
|
||||
%attr(660,root,root) %{_libdir}/firebird/security2.fdb
|
||||
%{_libdir}/firebird/fbtrace.conf
|
||||
%{_bindir}/fbsvcmgr
|
||||
%{_bindir}/fbtracemgr
|
||||
#%{_bindir}/gdef
|
||||
%{_bindir}/gpre
|
||||
%{_bindir}/gsplit
|
||||
%{_bindir}/isql-fb
|
||||
%{_bindir}/qli
|
||||
%{_bindir}/gbak
|
||||
%{_bindir}/gfix
|
||||
%{_bindir}/gsec
|
||||
%{_bindir}/gstat
|
||||
%{_bindir}/nbackup
|
||||
#%{_unitdir}/firebird-classic.socket
|
||||
#%{_unitdir}/firebird-classic@.service
|
||||
%dir %{_libdir}/firebird
|
||||
#%{_libdir}/firebird/databases.conf
|
||||
#%{_libdir}/firebird/firebird.conf
|
||||
%{_libdir}/firebird/intl/fbintl.conf
|
||||
#%{_libdir}/firebird/plugins.conf
|
||||
#%dir %{_libdir}/firebird/lib
|
||||
#%{_libdir}/firebird/fbtrace.conf
|
||||
%dir %{_libdir}/firebird/UDF
|
||||
%{_libdir}/firebird/UDF/fbudf.so
|
||||
#%{_libdir}/firebird/UDF/fbudf.so
|
||||
%{_libdir}/firebird/UDF/fbudf.sql
|
||||
%{_libdir}/firebird/UDF/ib_udf.so
|
||||
#%{_libdir}/firebird/UDF/ib_udf.so
|
||||
%{_libdir}/firebird/UDF/ib_udf.sql
|
||||
%{_libdir}/firebird/UDF/ib_udf2.sql
|
||||
%{_libdir}/firebird/de_DE.msg
|
||||
%{_libdir}/firebird/fr_FR.msg
|
||||
%dir %{_libdir}/firebird/misc
|
||||
%{_libdir}/firebird/misc/*
|
||||
%{_libdir}/firebird/plugins/libfbtrace.so
|
||||
%doc ChangeLog doc/license/IDPL.txt
|
||||
%doc doc/license/README.license.usage.txt
|
||||
|
||||
%files classic
|
||||
#%files classic
|
||||
#%defattr(-,root,root)
|
||||
#%config(noreplace) %{_sysconfdir}/xinetd.d/firebird
|
||||
#%dir %{_libdir}/firebird/bin-classic
|
||||
#%dir %{_libdir}/firebird/UDF-classic
|
||||
#%attr(755,root,root) %{_libdir}/firebird/bin-classic/*
|
||||
#%attr(755,root,root) %{_libdir}/firebird/UDF-classic/*.so
|
||||
#%attr(755,root,root) %{_libdir}/firebird/UDF-classic/*.sql
|
||||
#%doc doc/license/IDPL.txt
|
||||
#%doc doc/license/README.license.usage.txt
|
||||
|
||||
%files -n libfbclient
|
||||
%defattr(-,root,root)
|
||||
%config(noreplace) %{_sysconfdir}/xinetd.d/firebird
|
||||
%dir %{_libdir}/firebird/bin-classic
|
||||
%dir %{_libdir}/firebird/UDF-classic
|
||||
%attr(755,root,root) %{_libdir}/firebird/bin-classic/*
|
||||
%attr(755,root,root) %{_libdir}/firebird/UDF-classic/*.so
|
||||
%attr(755,root,root) %{_libdir}/firebird/UDF-classic/*.sql
|
||||
%doc doc/license/IDPL.txt
|
||||
%doc doc/license/README.license.usage.txt
|
||||
%attr(755,root,root) %{_libdir}/libfbclient.so.*
|
||||
%dir %{_libdir}/firebird
|
||||
%dir %{_libdir}/firebird/plugins
|
||||
%{_libdir}/firebird/plugins/*.so
|
||||
%dir %{_libdir}/firebird/plugins/udr
|
||||
%{_libdir}/firebird/plugins/udr/*.so
|
||||
%{_libdir}/firebird/plugins/udr_engine.conf
|
||||
%dir %{_libdir}/firebird/UDF
|
||||
%{_libdir}/firebird/UDF/*.so
|
||||
%{_libdir}/firebird/intl/fbintl
|
||||
#%{_libdir}/firebird/msg/de_DE.msg
|
||||
%{_libdir}/firebird/msg/firebird.msg
|
||||
#%{_libdir}/firebird/msg/fr_FR.msg
|
||||
%dir %{_libdir}/firebird/bin
|
||||
%{_libdir}/firebird/bin/*
|
||||
##%doc doc/license/IDPL.txt
|
||||
##%doc doc/license/README.license.usage.txt
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%attr(0755,root,root) %{_bindir}/fb_config
|
||||
%dir %{_libdir}/firebird/include
|
||||
%attr(644,root,root) %{_libdir}/firebird/include/*
|
||||
%attr(644,root,root) %{_includedir}/*
|
||||
%attr(644,root,root) %{_libdir}/firebird/lib/libfbclient.so
|
||||
%attr(644,root,root) %{_libdir}/firebird/lib/libfbembed.so
|
||||
%attr(644,root,root) %{_libdir}/libfbclient.so
|
||||
%attr(644,root,root) %{_libdir}/libfbembed.so
|
||||
%{_bindir}/fb_config
|
||||
%{_includedir}/*.h
|
||||
%dir %{_includedir}/firebird
|
||||
%{_includedir}/firebird/*
|
||||
%{_libdir}/libfbclient.so
|
||||
%{_libdir}/libib_util.so
|
||||
|
||||
%files doc
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/firebird/IDPLicense.txt
|
||||
%{_libdir}/firebird/IPLicense.txt
|
||||
%{_libdir}/firebird/README
|
||||
%{_libdir}/firebird/WhatsNew
|
||||
%dir %{_libdir}/firebird/examples
|
||||
%{_libdir}/firebird/examples/*
|
||||
%dir %{_libdir}/firebird/doc
|
||||
%{_libdir}/firebird/doc/*
|
||||
%dir %{_datadir}/licenses/firebird
|
||||
%{_datadir}/licenses/firebird/*
|
||||
%dir %{_datadir}/doc/firebird
|
||||
%{_datadir}/doc/firebird/*
|
||||
|
||||
%files -n libfbclient-%{name}
|
||||
%defattr(-,root,root)
|
||||
%attr(755,root,root) %{_libdir}/libfbclient.so.*
|
||||
%attr(755,root,root) %{_libdir}/firebird/lib/libfbclient.so.*
|
||||
%doc doc/license/IDPL.txt
|
||||
%doc doc/license/README.license.usage.txt
|
||||
|
||||
%files -n libfbembed-%{name}
|
||||
%defattr(-,root,root)
|
||||
%attr(755,root,root) %{_libdir}/libfbembed.so.*
|
||||
%attr(755,root,root) %{_libdir}/firebird/lib/libfbembed.so.*
|
||||
%doc doc/license/IDPL.txt
|
||||
%doc doc/license/README.license.usage.txt
|
||||
#%files -n libfbembed
|
||||
#%defattr(-,root,root)
|
||||
#%attr(755,root,root) %{_libdir}/libfbembed.so.*
|
||||
#%attr(755,root,root) %{_libdir}/firebird/lib/libfbembed.so.*
|
||||
#%doc doc/license/IDPL.txt
|
||||
#%doc doc/license/README.license.usage.txt
|
||||
|
||||
%files superserver
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/firebird/bin
|
||||
%dir %{_libdir}/firebird/bin-superserver
|
||||
%dir %{_libdir}/firebird/UDF-superserver
|
||||
%attr(755,root,root) %{_initrddir}/firebird
|
||||
%attr(755,root,root) %{_libdir}/firebird/bin-superserver/*
|
||||
%attr(755,root,root) %{_libdir}/firebird/UDF-superserver/*.so
|
||||
%attr(644,root,root) %{_libdir}/firebird/UDF-superserver/*.sql
|
||||
%attr(755,root,root) %{_libdir}/firebird/run
|
||||
%doc doc/license/IDPL.txt
|
||||
%doc doc/license/README.license.usage.txt
|
||||
%{_unitdir}/firebird.service
|
||||
%{_sysusersdir}/firebird.conf
|
||||
%{_tmpfilesdir}/firebird.conf
|
||||
%attr(660,firebird,firebird) %{_localstatedir}/lib/firebird/system/security3.fdb
|
||||
#%doc doc/license/IDPL.txt
|
||||
#%doc doc/license/README.license.usage.txt
|
||||
|
||||
%changelog
|
||||
* Mon Oct 24 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.5.6.27020-1mamba
|
||||
- update to 2.5.6.27020
|
||||
* Fri May 04 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.3.32900-1mamba
|
||||
- update to 3.0.3.32900
|
||||
|
||||
* Fri May 04 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.2.32703-1mamba
|
||||
- update to 3.0.2.32703
|
||||
|
||||
* Wed May 02 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 2.5.7.27050-2mamba
|
||||
- move %{_libdir}/firebird/bin/* from -superserver to libfbclient
|
||||
|
||||
* Sat Jan 06 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 2.5.7.27050-1mamba
|
||||
- update to 2.5.7.27050
|
||||
|
||||
* Tue Jun 04 2013 Automatic Build System <autodist@mambasoft.it> 2.5.2.26540-1mamba
|
||||
- update to 2.5.2.26540
|
||||
|
Loading…
Reference in New Issue
Block a user