879 lines
28 KiB
RPMSpec
879 lines
28 KiB
RPMSpec
%define enable_gpl 1
|
|
%define enable_non_free 1
|
|
#% define buildyear %(echo %{version} | cut -b 7-10)
|
|
#% define buildmonth %(echo %{version} | cut -b 11-12)
|
|
#% define buildday %(echo %{version} | cut -b 13-14)
|
|
%define buildver %{version}
|
|
#% define buildver export-%{buildyear}-%{buildmonth}-%{buildday}
|
|
|
|
Name: ffmpeg2
|
|
Epoch: 1
|
|
Version: 2.3.3
|
|
Release: 4mamba
|
|
Summary: Hyper fast MPEG1/MPEG4/H263/RV and AC3/MPEG audio encoder
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://ffmpeg.mplayerhq.hu/
|
|
Source: http://ffmpeg.mplayerhq.hu/releases/ffmpeg-%{version}.tar.bz2
|
|
#Source: http://ffmpeg.mplayerhq.hu/releases/ffmpeg-export-snapshot.tar.bz2
|
|
# Source now taken from exported snapshot
|
|
# Source chekout from SVN:
|
|
# svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg && find ffmpeg -name .svn | xargs rm -rf && tar cjvf ffmpeg-`date '+%Y%m%d'`svn.tar.bz2 ffmpeg
|
|
Patch1: ffmpeg-0.4.9-pic.patch
|
|
Patch2: ffmpeg-20080820svn-libx264.patch
|
|
Patch3: ffmpeg-0.5-x264.patch
|
|
Patch4: ffmpeg-0.11-install_url_h.patch
|
|
Patch5: ffmpeg2-2.3.3-libvpx-1.5.0.patch
|
|
Patch6: ffmpeg-2.3.3-x86-asm-impossible-contraints-fix.patch
|
|
License: LGPL, GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libSDL-devel
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libXext-devel
|
|
BuildRequires: libXfixes-devel
|
|
BuildRequires: libXv-devel
|
|
BuildRequires: libalsa-devel
|
|
BuildRequires: libass-devel
|
|
BuildRequires: libbluray-devel
|
|
BuildRequires: libbzip2-devel
|
|
%ifarch %{ix86} x86_64
|
|
BuildRequires: libcrystalhd-devel
|
|
%endif
|
|
BuildRequires: libdc1394-devel
|
|
BuildRequires: libfaac-devel
|
|
BuildRequires: libfontconfig-devel
|
|
BuildRequires: libfreetype-devel
|
|
BuildRequires: libgnutls-devel
|
|
BuildRequires: libgsm-devel
|
|
BuildRequires: libjack-devel
|
|
BuildRequires: liblame-devel
|
|
BuildRequires: libmodplug-devel
|
|
BuildRequires: libopencore-amr-devel
|
|
BuildRequires: libopenjpeg1-devel
|
|
BuildRequires: libopus-devel
|
|
BuildRequires: libpulseaudio-devel
|
|
BuildRequires: librtmp-devel
|
|
BuildRequires: libschroedinger-devel
|
|
BuildRequires: libspeex-devel
|
|
BuildRequires: libtheora-devel
|
|
BuildRequires: libv4l-devel
|
|
BuildRequires: libva-devel
|
|
BuildRequires: libvdpau-devel
|
|
BuildRequires: libvorbis-devel
|
|
BuildRequires: libvpx-devel
|
|
BuildRequires: libx264-devel
|
|
BuildRequires: libxvidcore-devel
|
|
BuildRequires: libz-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: liborc-devel
|
|
BuildRequires: libopenjpeg-devel
|
|
BuildRequires: libogg-devel
|
|
BuildRequires: libfaad2-devel
|
|
BuildRequires: libraw1394-devel
|
|
BuildRequires: liba52dec-devel
|
|
BuildRequires: yasm-devel
|
|
BuildRequires: ldconfig
|
|
# texi2html required
|
|
BuildRequires: tetex >= 3.0
|
|
BuildRequires: libass-devel
|
|
BuildRequires: libenca-devel
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
FFmpeg is a very fast video and audio converter.
|
|
It can also grab from a live audio/video source.
|
|
The command line interface is designed to be intuitive, in the sense that ffmpeg tries to figure out all the parameters, when possible.
|
|
You have usually to give only the target bitrate you want.
|
|
FFmpeg can also convert from any sample rate to any other, and resize video on the fly with a high quality polyphase filter.
|
|
|
|
%package examples
|
|
Summary: ffmpeg coding examples
|
|
Group: Development/Libraries
|
|
|
|
%description examples
|
|
ffmpeg coding examples.
|
|
|
|
%package presets
|
|
Summary: Preset configuration files used by libavcodec
|
|
Group: System/Libraries
|
|
Provides: ffmpegpresets
|
|
|
|
%description presets
|
|
Preset configuration files used by libavcodec.
|
|
|
|
%package -n libswscale-%{name}
|
|
Summary: ffmpeg video scaling library
|
|
Group: System/Libraries
|
|
|
|
%description -n libswscale-%{name}
|
|
ffmpeg video scaling library.
|
|
|
|
%package -n libswscale-%{name}-devel
|
|
Summary: Shared header files and static libraries part of ffmpeg
|
|
Group: Development/Libraries
|
|
Requires: libswscale-%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n libswscale-%{name}-devel
|
|
ffmpeg video scaling library.
|
|
|
|
This package contains the header files and static libraries needed to compile applications or shared objects that use libswscale
|
|
|
|
%package -n libswresample-%{name}
|
|
Summary: ffmpeg resampling library
|
|
Group: System/Libraries
|
|
|
|
%description -n libswresample-%{name}
|
|
ffmpeg resampling library.
|
|
|
|
%package -n libswresample-%{name}-devel
|
|
Summary: Shared header files and static libraries part of ffmpeg
|
|
Group: Development/Libraries
|
|
Requires: libswresample-%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n libswresample-%{name}-devel
|
|
ffmpeg resampling library.
|
|
|
|
This package contains the header files and static libraries needed to compile applications or shared objects that use libswscale
|
|
|
|
%package -n libavcodec-%{name}
|
|
Summary: ffmpeg library implementing various Audio/Video codecs
|
|
Group: System/Libraries
|
|
Requires: ffmpegpresets
|
|
|
|
%description -n libavcodec-%{name}
|
|
ffmpeg library implementing various Audio/Video codecs.
|
|
|
|
%package -n libavcodec-%{name}-devel
|
|
Summary: Shared header files and static libraries part of ffmpeg
|
|
Group: Development/Libraries
|
|
Requires: libavcodec-%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n libavcodec-%{name}-devel
|
|
ffmpeg library implementing various Audio/Video codecs.
|
|
This package contains the header files and static libraries needed to compile applications or shared objects that use libavcodec
|
|
|
|
%package -n libavdevice-%{name}
|
|
Summary: ffmpeg device handling library
|
|
Group: System/Libraries
|
|
|
|
%description -n libavdevice-%{name}
|
|
ffmpeg device handling library.
|
|
|
|
%package -n libavdevice-%{name}-devel
|
|
Summary: Shared header files and static libraries part of ffmpeg
|
|
Group: Development/Libraries
|
|
Requires: libavdevice-%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n libavdevice-%{name}-devel
|
|
ffmpeg device handling library.
|
|
|
|
This package contains the header files and static libraries needed to compile applications or shared objects that use libavdevice.
|
|
|
|
%package -n libavfilter-%{name}
|
|
Summary: ffmpeg filtering library
|
|
Group: System/Libraries
|
|
|
|
%description -n libavfilter-%{name}
|
|
ffmpeg filtering library.
|
|
|
|
%package -n libavfilter-%{name}-devel
|
|
Summary: Shared header files and static libraries part of ffmpeg
|
|
Group: Development/Libraries
|
|
Requires: libavfilter-%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n libavfilter-%{name}-devel
|
|
ffmpeg filtering library.
|
|
|
|
This package contains the header files and static libraries needed to compile applications or shared objects that use libavformat
|
|
|
|
%package -n libavformat-%{name}
|
|
Summary: ffmpeg format library
|
|
Group: System/Libraries
|
|
|
|
%description -n libavformat-%{name}
|
|
ffmpeg format library.
|
|
|
|
%package -n libavformat-%{name}-devel
|
|
Summary: Shared header files and static libraries part of ffmpeg
|
|
Group: Development/Libraries
|
|
Requires: libavformat-%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n libavformat-%{name}-devel
|
|
ffmpeg format library.
|
|
|
|
This package contains the header files and static libraries needed to compile applications or shared objects that use libavformat
|
|
|
|
%package -n libavutil-%{name}
|
|
Summary: Shared library part of ffmpeg
|
|
Group: System/Libraries
|
|
|
|
%description -n libavutil-%{name}
|
|
Shared library part of ffmpeg
|
|
|
|
%package -n libavutil-%{name}-devel
|
|
Summary: Shared header files and static libraries part of ffmpeg
|
|
Group: Development/Libraries
|
|
Requires: libavutil-%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n libavutil-%{name}-devel
|
|
This is the common utility library from the ffmpeg project.
|
|
It is required by all other ffmpeg libraries.
|
|
|
|
This package contains the header files and static libraries needed to compile applications or shared objects that use libavutil
|
|
|
|
%package -n libpostproc-%{name}
|
|
Summary: Video postprocessing library from ffmpeg
|
|
Group: System/Libraries
|
|
|
|
%description -n libpostproc-%{name}
|
|
FFmpeg is a very fast video and audio converter. It can also grab from a live audio/video source.
|
|
|
|
This package contains only ffmpeg's postproc post-processing library which other projects such as transcode may use. Install this package if you intend to use MPlayer, transcode or other similar programs.
|
|
|
|
%package -n libpostproc-%{name}-devel
|
|
Summary: Video postprocessing library from ffmpeg
|
|
Group: Development/Libraries
|
|
Requires: libpostproc-%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n libpostproc-%{name}-devel
|
|
FFmpeg is a very fast video and audio converter. It can also grab from a live audio/video source.
|
|
|
|
This package contains only ffmpeg's postproc post-processing headers and static libraries which other projects such as transcode may use. Install this package if you intend to use MPlayer, transcode or other similar programs.
|
|
|
|
%package -n libavresample-%{name}
|
|
Summary: ffmpeg resample library
|
|
Group: System/Libraries
|
|
|
|
%description -n libavresample-%{name}
|
|
FFmpeg resample library.
|
|
|
|
%package -n libavresample-%{name}-devel
|
|
Summary: Shared header files and static libraries part of ffmpeg libavresample
|
|
Group: System/Libraries
|
|
Requires: libavresample-%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n libavresample-%{name}-devel
|
|
FFmpeg resample library.
|
|
|
|
This package contains the header files and static libraries needed to compile applications or shared objects that use libavutil
|
|
|
|
%package devel
|
|
Summary: Virtual package that installs all the FFmpeg development packages
|
|
Group: Development/Libraries
|
|
Requires: libavcodec-%{name}-devel
|
|
Requires: libavdevice-%{name}-devel
|
|
Requires: libavfilter-%{name}-devel
|
|
Requires: libavformat-%{name}-devel
|
|
Requires: libavutil-%{name}-devel
|
|
Requires: libpostproc-%{name}-devel
|
|
Requires: libswscale-%{name}-devel
|
|
Requires: libswresample-%{name}-devel
|
|
|
|
%description devel
|
|
This is a virtual package that contains the dependencies necessary for installing all the FFmpeg development packages.
|
|
|
|
%prep
|
|
%setup -q -n ffmpeg-%{buildver}
|
|
#-D -T
|
|
#:<< _EOF
|
|
%patch4 -p1
|
|
%patch5 -p1
|
|
%ifarch %{ix86}
|
|
%patch6 -p1
|
|
%endif
|
|
|
|
%build
|
|
#:<< _EOF
|
|
# configure not generated by autoconf
|
|
# -D__LINUX_USER__ is required by crystalhd
|
|
export CFLAGS="%{optflags} -fno-unit-at-a-time -D__LINUX_USER__"
|
|
./configure \
|
|
--prefix="%{_prefix}" \
|
|
--libdir="%{_libdir}/ffmpeg2" \
|
|
--incdir="%{_includedir}/ffmpeg2" \
|
|
--shlibdir="%{_libdir}/ffmpeg2" \
|
|
--mandir="%{_mandir}" \
|
|
--enable-libmp3lame \
|
|
--enable-libvorbis \
|
|
--enable-libtheora \
|
|
--enable-libfaac \
|
|
--enable-libgsm \
|
|
--enable-libdc1394 \
|
|
--enable-libschroedinger \
|
|
--enable-shared \
|
|
--enable-pthreads \
|
|
--disable-stripping \
|
|
--enable-libopenjpeg \
|
|
--enable-libspeex \
|
|
--enable-swscale \
|
|
--enable-x11grab \
|
|
--enable-avresample \
|
|
--enable-dxva2 \
|
|
--enable-libass \
|
|
--enable-libbluray \
|
|
--enable-libfreetype \
|
|
--enable-libmodplug \
|
|
--enable-libopenjpeg \
|
|
--enable-libopus \
|
|
--enable-libpulse \
|
|
--enable-librtmp \
|
|
--enable-libv4l2 \
|
|
--enable-libvpx \
|
|
--enable-libxvid \
|
|
--enable-pic \
|
|
--enable-postproc \
|
|
--enable-runtime-cpudetect \
|
|
--enable-shared \
|
|
--enable-swresample \
|
|
--enable-vdpau \
|
|
%if %enable_gpl
|
|
--enable-gpl \
|
|
--enable-fontconfig \
|
|
--enable-gnutls \
|
|
--enable-version3 \
|
|
--enable-libxvid \
|
|
--enable-postproc \
|
|
--enable-libx264 \
|
|
--enable-libopencore-amrnb \
|
|
--enable-libopencore-amrwb \
|
|
%if %enable_non_free
|
|
--enable-nonfree \
|
|
%endif
|
|
|
|
%endif
|
|
|
|
# --enable-libx265 \
|
|
# --enable-libfaad \
|
|
# --enable-avfilter-lavf \
|
|
# --enable-libfaadbin \
|
|
|
|
# --cpu=%{_target_cpu} \
|
|
# --enable-swscale \
|
|
## --incdir="%{_includedir}/ffmpeg" \
|
|
# FIXME:
|
|
# software scaler enabled no
|
|
# Sun medialib support no
|
|
# AVISynth enabled no
|
|
# liba52 dlopened no
|
|
# enable non free (libamrnb, libamrwb) License: unredistributable
|
|
# libamr-nb support no
|
|
# libamr-wb support no
|
|
# libgsm enabled no
|
|
# libnut enabled no
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall \
|
|
shlibdir="%{buildroot}%{_libdir}/ffmpeg2" \
|
|
libdir="%{buildroot}%{_libdir}/ffmpeg2"
|
|
|
|
install -d -m 0755 %{buildroot}%{_sysconfdir}/ld.so.conf.d
|
|
echo -e '%{_libdir}\n%{_libdir}/ffmpeg2/' > %{buildroot}%{_sysconfdir}/ld.so.conf.d/ffmpeg2-%{_arch}.conf
|
|
|
|
rm -f %{buildroot}%{_mandir}/man3/*
|
|
|
|
rm -rf %{buildroot}%{_docdir}/ffmpeg
|
|
|
|
#\
|
|
# incdir="%{buildroot}%{_includedir}/ffmpeg" \
|
|
# shlibdir="%{buildroot}%{_libdir}" \
|
|
# libdir="%{buildroot}%{_libdir}"
|
|
# Remove unwanted files from the included docs
|
|
#%{__cp} -a doc _docs
|
|
#%{__rm} -rf _docs/{Makefile,*.texi,*.pl}
|
|
|
|
# make installlib is broken, so we do it by hand
|
|
#install -m 644 libavcodec/libavcodec.a %{buildroot}%{_libdir}
|
|
#install -m 644 libavformat/libavformat.a %{buildroot}%{_libdir}
|
|
|
|
## create compat symlink
|
|
#install -d %{buildroot}%{_libdir}/libavcodec
|
|
#ln -s ../libavcodec.a %{buildroot}%{_libdir}/libavcodec/libavcodec.a
|
|
|
|
#install -d %{buildroot}%{_includedir}/ffmpeg
|
|
#cp -a %{buildroot}%{_includedir}/libavcodec/*.h \
|
|
# %{buildroot}%{_includedir}/libavdevice/*.h \
|
|
# %{buildroot}%{_includedir}/libavformat/*.h \
|
|
# %{buildroot}%{_includedir}/libavutil/*.h \
|
|
# %{buildroot}%{_includedir}/libswscale/*.h \
|
|
# %{buildroot}%{_includedir}/ffmpeg
|
|
#install -d %{buildroot}%{_includedir}/postproc
|
|
#cp -a %{buildroot}%{_includedir}/libpostproc/*.h \
|
|
# %{buildroot}%{_includedir}/postproc
|
|
|
|
# The <postproc/postprocess.h> is now at <ffmpeg/postprocess.h>, so provide
|
|
# a compatibility symlink
|
|
#%{__mkdir_p} %{buildroot}%{_includedir}/postproc/
|
|
#%{__mkdir_p} %{buildroot}%{_includedir}/libswscale/
|
|
#%{__ln_s} ../ffmpeg/postprocess.h \
|
|
# %{buildroot}%{_includedir}/postproc/postprocess.h
|
|
#%{__ln_s} ../ffmpeg/rgb2rgb.h\
|
|
# %{buildroot}%{_includedir}/libswscale/rgb2rgb.h
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n libavcodec-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%postun -n libavcodec-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%post -n libavdevice-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%postun -n libavdevice-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%post -n libavfilter-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%postun -n libavfilter-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%post -n libavformat-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%postun -n libavformat-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%post -n libavresample-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%postun -n libavresample-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%post -n libavutil-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%postun -n libavutil-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%post -n libpostproc-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%postun -n libpostproc-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%post -n libswscale-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%postun -n libswscale-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%post -n libswresample-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%postun -n libswresample-%{name}
|
|
/sbin/ldconfig
|
|
:
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/ffmpeg
|
|
%{_bindir}/ffplay
|
|
%{_bindir}/ffprobe
|
|
%{_bindir}/ffserver
|
|
%{_datadir}/ffmpeg/ffprobe.xsd
|
|
%{_mandir}/man1/ffmpeg.1*
|
|
%{_mandir}/man1/ffplay.1*
|
|
%{_mandir}/man1/ffprobe.1*
|
|
%{_mandir}/man1/ffserver.1*
|
|
%{_mandir}/man1/ffmpeg-all.1*
|
|
%{_mandir}/man1/ffplay-all.1*
|
|
%{_mandir}/man1/ffprobe-all.1*
|
|
%{_mandir}/man1/ffserver-all.1*
|
|
%{_mandir}/man1/ffmpeg-bitstream-filters.1*
|
|
%{_mandir}/man1/ffmpeg-codecs.1*
|
|
%{_mandir}/man1/ffmpeg-devices.1*
|
|
%{_mandir}/man1/ffmpeg-filters.1*
|
|
%{_mandir}/man1/ffmpeg-formats.1*
|
|
%{_mandir}/man1/ffmpeg-protocols.1*
|
|
%{_mandir}/man1/ffmpeg-resampler.1*
|
|
%{_mandir}/man1/ffmpeg-scaler.1*
|
|
%{_mandir}/man1/ffmpeg-utils.1*
|
|
%doc CREDITS
|
|
|
|
%files examples
|
|
%defattr(-,root,root)
|
|
%dir %{_datadir}/ffmpeg/examples
|
|
%{_datadir}/ffmpeg/examples/Makefile
|
|
%{_datadir}/ffmpeg/examples/*.c
|
|
|
|
%files presets
|
|
%defattr(-,root,root)
|
|
%dir %{_datadir}/ffmpeg
|
|
#%{_datadir}/ffmpeg/libx264-*.ffpreset
|
|
%{_datadir}/ffmpeg/libvpx-*.ffpreset
|
|
|
|
%files -n libavcodec-%{name}
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/ld.so.conf.d/ffmpeg2-%{_arch}.conf
|
|
%{_libdir}/ffmpeg2/libavcodec.so.*
|
|
|
|
%files -n libavcodec-%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/ffmpeg2/libavcodec
|
|
%{_includedir}/ffmpeg2/libavcodec/*
|
|
%{_libdir}/ffmpeg2/libavcodec.a
|
|
%{_libdir}/ffmpeg2/libavcodec.so
|
|
%{_libdir}/ffmpeg2/pkgconfig/libavcodec.pc
|
|
#%{_mandir}/man3/libavcodec.3.gz
|
|
|
|
%files -n libavdevice-%{name}
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/ld.so.conf.d/ffmpeg2-%{_arch}.conf
|
|
%{_libdir}/ffmpeg2/libavdevice.so.*
|
|
|
|
%files -n libavdevice-%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/ffmpeg2/libavdevice
|
|
%{_includedir}/ffmpeg2/libavdevice/avdevice.h
|
|
%{_includedir}/ffmpeg2/libavdevice/version.h
|
|
%{_libdir}/ffmpeg2/libavdevice.a
|
|
%{_libdir}/ffmpeg2/libavdevice.so
|
|
%{_libdir}/ffmpeg2/pkgconfig/libavdevice.pc
|
|
#%{_mandir}/man3/libavdevice.3.gz
|
|
|
|
%files -n libavfilter-%{name}
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/ld.so.conf.d/ffmpeg2-%{_arch}.conf
|
|
%{_libdir}/ffmpeg2/libavfilter.so.*
|
|
|
|
%files -n libavfilter-%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/ffmpeg2/libavfilter
|
|
%{_includedir}/ffmpeg2/libavfilter/*.h
|
|
%{_libdir}/ffmpeg2/libavfilter.a
|
|
%{_libdir}/ffmpeg2/libavfilter.so
|
|
%{_libdir}/ffmpeg2/pkgconfig/libavfilter.pc
|
|
#%{_mandir}/man3/libavfilter.3.gz
|
|
|
|
%files -n libavformat-%{name}
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/ld.so.conf.d/ffmpeg2-%{_arch}.conf
|
|
%{_libdir}/ffmpeg2/libavformat.so.*
|
|
|
|
%files -n libavformat-%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/ffmpeg2/libavformat
|
|
%{_includedir}/ffmpeg2/libavformat/*.h
|
|
%{_libdir}/ffmpeg2/libavformat.a
|
|
%{_libdir}/ffmpeg2/libavformat.so
|
|
%{_libdir}/ffmpeg2/pkgconfig/libavformat.pc
|
|
#%{_mandir}/man3/libavformat.3.gz
|
|
|
|
%files -n libavresample-%{name}
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/ld.so.conf.d/ffmpeg2-%{_arch}.conf
|
|
%{_libdir}/ffmpeg2/libavresample.so.*
|
|
|
|
%files -n libavresample-%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/ffmpeg2/libavresample
|
|
%{_includedir}/ffmpeg2/libavresample/avresample.h
|
|
%{_includedir}/ffmpeg2/libavresample/version.h
|
|
%{_libdir}/ffmpeg2/libavresample.a
|
|
%{_libdir}/ffmpeg2/libavresample.so
|
|
%{_libdir}/ffmpeg2/pkgconfig/libavresample.pc
|
|
|
|
%files -n libavutil-%{name}
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/ld.so.conf.d/ffmpeg2-%{_arch}.conf
|
|
%{_libdir}/ffmpeg2/libavutil.so.*
|
|
|
|
%files -n libavutil-%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/ffmpeg2/libavutil
|
|
%{_includedir}/ffmpeg2/libavutil/*.h
|
|
%{_libdir}/ffmpeg2/libavutil.a
|
|
%{_libdir}/ffmpeg2/libavutil.so
|
|
%{_libdir}/ffmpeg2/pkgconfig/libavutil.pc
|
|
#%{_mandir}/man3/libavutil.3.gz
|
|
|
|
%files -n libpostproc-%{name}
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/ld.so.conf.d/ffmpeg2-%{_arch}.conf
|
|
%{_libdir}/ffmpeg2/libpostproc.so.*
|
|
|
|
%files -n libpostproc-%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/ffmpeg2/libpostproc
|
|
%{_includedir}/ffmpeg2/libpostproc/postprocess.h
|
|
%{_includedir}/ffmpeg2/libpostproc/version.h
|
|
%{_libdir}/ffmpeg2/libpostproc.a
|
|
%{_libdir}/ffmpeg2/libpostproc.so
|
|
%{_libdir}/ffmpeg2/pkgconfig/libpostproc.pc
|
|
%{_datadir}/ffmpeg/examples/README
|
|
|
|
%files -n libswscale-%{name}
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/ld.so.conf.d/ffmpeg2-%{_arch}.conf
|
|
%{_libdir}/ffmpeg2/libswscale.so.*
|
|
|
|
%files -n libswscale-%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/ffmpeg2/libswscale
|
|
%{_includedir}/ffmpeg2/libswscale/*.h
|
|
%{_libdir}/ffmpeg2/libswscale.a
|
|
%{_libdir}/ffmpeg2/libswscale.so
|
|
%{_libdir}/ffmpeg2/pkgconfig/libswscale.pc
|
|
#%{_mandir}/man3/libswscale.3*
|
|
|
|
%files -n libswresample-%{name}
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/ld.so.conf.d/ffmpeg2-%{_arch}.conf
|
|
%{_libdir}/ffmpeg2/libswresample.so.*
|
|
|
|
%files -n libswresample-%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/ffmpeg2/libswresample
|
|
%{_includedir}/ffmpeg2/libswresample/*.h
|
|
%{_libdir}/ffmpeg2/libswresample.a
|
|
%{_libdir}/ffmpeg2/libswresample.so
|
|
%{_libdir}/ffmpeg2/pkgconfig/libswresample.pc
|
|
#%{_mandir}/man3/libswresample.3*
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Thu Apr 14 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.3-4mamba
|
|
- ffmpeg2-devel: remove conflicting docdir
|
|
|
|
* Fri Mar 25 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.3-3mamba
|
|
- allow cohexistence of devel packages with ffmpeg 3.0
|
|
|
|
* Sat Mar 12 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.3-2mamba
|
|
- legacy package
|
|
|
|
* Mon Aug 18 2014 Automatic Build System <autodist@mambasoft.it> 2.3.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Aug 11 2014 Automatic Build System <autodist@mambasoft.it> 2.3.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jul 31 2014 Automatic Build System <autodist@mambasoft.it> 2.3.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jul 22 2014 Automatic Build System <autodist@mambasoft.it> 2.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jul 15 2014 Automatic Build System <autodist@mambasoft.it> 2.2.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jun 24 2014 Automatic Build System <autodist@mambasoft.it> 2.2.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jun 05 2014 Automatic Build System <autodist@mambasoft.it> 2.2.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed May 14 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.2-2mamba
|
|
- obsolete packages with same library version coming from legacy ffmpeg1
|
|
|
|
* Tue May 06 2014 Automatic Build System <autodist@mambasoft.it> 2.2.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 10 2014 Automatic Build System <autodist@mambasoft.it> 2.2.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 25 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2-2mamba
|
|
- enable build of libavresample and many other support options
|
|
|
|
* Mon Mar 24 2014 Automatic Build System <autodist@mambasoft.it> 2.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Feb 24 2014 Automatic Build System <autodist@mambasoft.it> 2.1.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 16 2014 Automatic Build System <autodist@mambasoft.it> 2.1.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jan 14 2014 Automatic Build System <autodist@mambasoft.it> 2.1.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 20 2013 Automatic Build System <autodist@mambasoft.it> 2.1.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Oct 29 2013 Automatic Build System <autodist@mambasoft.it> 2.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Oct 09 2013 Automatic Build System <autodist@mambasoft.it> 2.0.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Aug 11 2013 Automatic Build System <autodist@mambasoft.it> 2.0.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jul 11 2013 Automatic Build System <autodist@mambasoft.it> 2.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jun 23 2013 openmamba WebBuild System <webbuild@openmamba.org> 1.2.1-2mamba
|
|
- add a virtual package that help installing all the ffmpeg development packages
|
|
|
|
* Wed May 29 2013 Automatic Build System <autodist@mambasoft.it> 1.2.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 19 2013 Automatic Build System <autodist@mambasoft.it> 1.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Feb 27 2013 Automatic Build System <autodist@mambasoft.it> 1.1.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Feb 12 2013 Automatic Build System <autodist@mambasoft.it> 1.1.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Dec 07 2012 Automatic Build System <autodist@mambasoft.it> 1.0.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 28 2012 Automatic Build System <autodist@mambasoft.it> 1.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Sep 19 2012 Automatic Build System <autodist@mambasoft.it> 0.11.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 08 2012 Automatic Build System <autodist@mambasoft.it> 0.11.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 06 2012 Automatic Build System <autodist@mambasoft.it> 0.10.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Apr 02 2012 Automatic Build System <autodist@mambasoft.it> 0.10.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Apr 01 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.1-1mamba
|
|
- update to 0.10.1
|
|
|
|
* Wed Mar 28 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.08.10-2mamba
|
|
- added --enable-x11grab option
|
|
|
|
* Fri Mar 16 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.10-1mamba
|
|
- update to 0.8.10
|
|
- added libavformat/url.h as required by recent chromium
|
|
|
|
* Tue Nov 22 2011 Automatic Build System <autodist@mambasoft.it> 0.8.7-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Nov 05 2011 Automatic Build System <autodist@mambasoft.it> 0.8.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Oct 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.5-2mamba
|
|
- obsolete libav*
|
|
|
|
* Tue Oct 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.5-1mamba
|
|
- update to 0.8.5
|
|
|
|
* Mon Oct 18 2010 Automatic Build System <autodist@mambasoft.it> 0.6.1-1mamba
|
|
- automatic update to 0.6.1 by autodist
|
|
|
|
* Tue Jun 22 2010 Automatic Build System <autodist@mambasoft.it> 0.6-1mamba
|
|
- automatic update to 0.6 by autodist
|
|
|
|
* Tue May 25 2010 Automatic Build System <autodist@mambasoft.it> 0.5.2-1mamba
|
|
- automatic update to 0.5.2 by autodist
|
|
|
|
* Tue Mar 16 2010 Automatic Build System <autodist@mambasoft.it> 0.5.1-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Fri Mar 05 2010 Automatic Build System <autodist@mambasoft.it> 0.5.1-1mamba
|
|
- automatic update to 0.5.1 by autodist
|
|
|
|
* Thu Nov 19 2009 Automatic Build System <autodist@mambasoft.it> 0.5.0.20091119-1mamba
|
|
- update to 0.5.snapshot20091119
|
|
|
|
* Wed Aug 12 2009 Automatic Build System <autodist@mambasoft.it> 0.5-3mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Fri Jul 10 2009 Automatic Build System <autodist@mambasoft.it> 0.5-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Mon Apr 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5-1mamba
|
|
- update to 0.5
|
|
- removed compatibility headers as complained by libxine 1.1.16.3
|
|
|
|
* Mon Dec 01 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20081113-5mamba
|
|
- remove provides for libffmpeg and libffmpeg-devel
|
|
|
|
* Thu Nov 20 2008 gil <puntogil@libero.it> 20081113-4mamba
|
|
- rebuilt with new libdc1394 2.0.2
|
|
|
|
* Thu Nov 20 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20081113-3mamba
|
|
- add obsoletes for libffmpeg and libffmpeg to all subpackages
|
|
|
|
* Wed Nov 19 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20081113-2mamba
|
|
- ffmpeg: don't obsolete libpostproc
|
|
|
|
* Fri Nov 14 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20081113-1mamba
|
|
- package renamed to ffmpeg; rename libraries to standard names and add proper provides and obsoletes for upgrade
|
|
|
|
* Wed Aug 20 2008 gil <puntogil@libero.it> 20080820-1mamba
|
|
- update to 20080820
|
|
- edit configure options
|
|
- added patch
|
|
- rebuilt with: libschroedinger, libamrnb, libamrwb, ffmpeg-checkout-snapshot.tar.bz2,
|
|
- enable non free (libamrnb, libamrwb) License: unredistributable
|
|
|
|
* Mon Jun 02 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20080504-2mamba
|
|
- rebuilt with recent libdc1394
|
|
|
|
* Mon May 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20080504-1mamba
|
|
- update to 20080505
|
|
|
|
* Wed Apr 02 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20080402-1mamba
|
|
- update to 20080402
|
|
|
|
* Fri Feb 29 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20080229-1mamba
|
|
- update to 20080229
|
|
- set exported-snapshot as source instead of svn
|
|
|
|
* Sun Feb 03 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20080203-1mamba
|
|
- update to 20080203
|
|
|
|
* Thu Dec 13 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 20071213-1mamba
|
|
- update to 20071213
|
|
- enabled pthread support
|
|
- changed package maintainer
|
|
- enabled support for libtheora and libx264
|
|
|
|
* Fri Jan 19 2007 Davide Madrisan <davide.madrisan@qilinux.it> 20070119-1qilnx
|
|
- updated to subversion 20070119
|
|
- dropped patch against CVE-2005-4048 (merged upstream)
|
|
- the shared libraries are now compiled with the -fPIC option: dropped patch
|
|
|
|
* Mon Dec 19 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.4.9-2qilnx
|
|
- fixed security issue CVE-2005-4048 (qibug#97)
|
|
- gcc4 fixes; compile the library with -fPIC
|
|
- HTML documentation moved to devel package
|
|
|
|
* Fri Jun 17 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.4.9-pre1-1qilnx
|
|
- update to version 0.4.9-pre1 by autospec
|
|
|
|
* Sun Oct 03 2004 Davide Madrisan <davide.madrisan@qilinux.it> 0.4.8-2qilnx
|
|
- specfile modified to match QiLinux standards
|
|
- library name modified (was ffmpeg)
|
|
- added a path to fix the broken configure check for the imlib2 library
|
|
|
|
* Mon Sep 13 2004 Matteo Bernasconi <voyagernm@virgilio.it> 0.4.8-1qilnx
|
|
- first build
|