reapply add-av_stream_get_first_dts-for-chromium patch for 5.1 [release 5.1-2mamba;Tue Aug 30 2022]
This commit is contained in:
parent
0ce7a68b1b
commit
80962455f9
@ -1,44 +0,0 @@
|
|||||||
From 95aab0fd83619408995720ce53d7a74790580220 Mon Sep 17 00:00:00 2001
|
|
||||||
From: "liberato@chromium.org" <liberato@chromium.org>
|
|
||||||
Date: Wed, 7 Jul 2021 19:01:22 -0700
|
|
||||||
Subject: [PATCH] Add av_stream_get_first_dts for Chromium
|
|
||||||
|
|
||||||
[foutrelis: adjust for new FFStream struct replacing AVStreamInternal]
|
|
||||||
---
|
|
||||||
libavformat/avformat.h | 4 ++++
|
|
||||||
libavformat/utils.c | 7 +++++++
|
|
||||||
2 files changed, 11 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/libavformat/avformat.h b/libavformat/avformat.h
|
|
||||||
index cd7b0d941c..b4a6dce885 100644
|
|
||||||
--- a/libavformat/avformat.h
|
|
||||||
+++ b/libavformat/avformat.h
|
|
||||||
@@ -1010,6 +1010,10 @@ struct AVCodecParserContext *av_stream_get_parser(const AVStream *s);
|
|
||||||
*/
|
|
||||||
int64_t av_stream_get_end_pts(const AVStream *st);
|
|
||||||
|
|
||||||
+// Chromium: We use the internal field first_dts vvv
|
|
||||||
+int64_t av_stream_get_first_dts(const AVStream *st);
|
|
||||||
+// Chromium: We use the internal field first_dts ^^^
|
|
||||||
+
|
|
||||||
#define AV_PROGRAM_RUNNING 1
|
|
||||||
|
|
||||||
/**
|
|
||||||
diff --git a/libavformat/utils.c b/libavformat/utils.c
|
|
||||||
index de7580c32d..0ef0fe530e 100644
|
|
||||||
--- a/libavformat/utils.c
|
|
||||||
+++ b/libavformat/utils.c
|
|
||||||
@@ -121,6 +121,13 @@ int64_t av_stream_get_end_pts(const AVStream *st)
|
|
||||||
return AV_NOPTS_VALUE;
|
|
||||||
}
|
|
||||||
|
|
||||||
+// Chromium: We use the internal field first_dts vvv
|
|
||||||
+int64_t av_stream_get_first_dts(const AVStream *st)
|
|
||||||
+{
|
|
||||||
+ return cffstream(st)->first_dts;
|
|
||||||
+}
|
|
||||||
+// Chromium: We use the internal field first_dts ^^^
|
|
||||||
+
|
|
||||||
struct AVCodecParserContext *av_stream_get_parser(const AVStream *st)
|
|
||||||
{
|
|
||||||
return st->internal->parser;
|
|
31
ffmpeg-5.1-add-av_stream_get_first_dts-for-chromium.patch
Normal file
31
ffmpeg-5.1-add-av_stream_get_first_dts-for-chromium.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
diff '--color=auto' -rupN ffmpeg.orig/libavformat/avformat.h ffmpeg/libavformat/avformat.h
|
||||||
|
--- ffmpeg.orig/libavformat/avformat.h 2022-08-19 17:42:47.323422603 +0200
|
||||||
|
+++ ffmpeg/libavformat/avformat.h 2022-08-19 17:42:51.347130436 +0200
|
||||||
|
@@ -1128,6 +1128,10 @@ struct AVCodecParserContext *av_stream_g
|
||||||
|
*/
|
||||||
|
int64_t av_stream_get_end_pts(const AVStream *st);
|
||||||
|
|
||||||
|
+// Chromium: We use the internal field first_dts vvv
|
||||||
|
+int64_t av_stream_get_first_dts(const AVStream *st);
|
||||||
|
+// Chromium: We use the internal field first_dts ^^^
|
||||||
|
+
|
||||||
|
#define AV_PROGRAM_RUNNING 1
|
||||||
|
|
||||||
|
/**
|
||||||
|
diff '--color=auto' -rupN ffmpeg.orig/libavformat/mux_utils.c ffmpeg/libavformat/mux_utils.c
|
||||||
|
--- ffmpeg.orig/libavformat/mux_utils.c 2022-08-19 17:42:47.346758108 +0200
|
||||||
|
+++ ffmpeg/libavformat/mux_utils.c 2022-08-19 17:47:28.549589002 +0200
|
||||||
|
@@ -37,6 +37,13 @@ int64_t av_stream_get_end_pts(const AVSt
|
||||||
|
return AV_NOPTS_VALUE;
|
||||||
|
}
|
||||||
|
|
||||||
|
+// Chromium: We use the internal field first_dts vvv
|
||||||
|
+int64_t av_stream_get_first_dts(const AVStream *st)
|
||||||
|
+{
|
||||||
|
+ return cffstream(st)->first_dts;
|
||||||
|
+}
|
||||||
|
+// Chromium: We use the internal field first_dts ^^^
|
||||||
|
+
|
||||||
|
int avformat_query_codec(const AVOutputFormat *ofmt, enum AVCodecID codec_id,
|
||||||
|
int std_compliance)
|
||||||
|
{
|
22
ffmpeg.spec
22
ffmpeg.spec
@ -4,8 +4,8 @@
|
|||||||
|
|
||||||
Name: ffmpeg
|
Name: ffmpeg
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 5.0.1
|
Version: 5.1
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Hyper fast MPEG1/MPEG4/H263/RV and AC3/MPEG audio encoder
|
Summary: Hyper fast MPEG1/MPEG4/H263/RV and AC3/MPEG audio encoder
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -17,7 +17,7 @@ Patch1: %{name}-0.4.9-pic.patch
|
|||||||
Patch2: %{name}-20080820svn-libx264.patch
|
Patch2: %{name}-20080820svn-libx264.patch
|
||||||
Patch3: %{name}-0.5-x264.patch
|
Patch3: %{name}-0.5-x264.patch
|
||||||
Patch4: %{name}-0.11-install_url_h.patch
|
Patch4: %{name}-0.11-install_url_h.patch
|
||||||
Patch5: ffmpeg-5.0-add-av_stream_get_first_dts-for-chromium.patch
|
Patch5: ffmpeg-5.1-add-av_stream_get_first_dts-for-chromium.patch
|
||||||
License: LGPL, GPL
|
License: LGPL, GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -143,7 +143,7 @@ Summary: ffmpeg library implementing various Audio/Video codecs
|
|||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Requires: ffmpegpresets
|
Requires: ffmpegpresets
|
||||||
Provides: libavcodec
|
Provides: libavcodec
|
||||||
Obsoletes: libavcodec
|
Obsoletes: libavcodec < 1:5.0
|
||||||
Obsoletes: libavcodec-libav < 1:5.0
|
Obsoletes: libavcodec-libav < 1:5.0
|
||||||
|
|
||||||
%description -n libavcodec-ffmpeg
|
%description -n libavcodec-ffmpeg
|
||||||
@ -312,7 +312,7 @@ This is a virtual package that contains the dependencies necessary for installin
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n ffmpeg-%{buildver}
|
%setup -q -n ffmpeg-%{buildver}
|
||||||
%patch4 -p1
|
#%patch4 -p1
|
||||||
%patch5 -p1 -b .add-av_stream_get_first_dts-for-chromium
|
%patch5 -p1 -b .add-av_stream_get_first_dts-for-chromium
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -468,8 +468,7 @@ ln -s ../libavcodec.a %{buildroot}%{_libdir}/libavcodec/libavcodec.a
|
|||||||
%files -n libavdevice-ffmpeg-devel
|
%files -n libavdevice-ffmpeg-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_includedir}/libavdevice
|
%dir %{_includedir}/libavdevice
|
||||||
%{_includedir}/libavdevice/avdevice.h
|
%{_includedir}/libavdevice/*.h
|
||||||
%{_includedir}/libavdevice/version.h
|
|
||||||
%{_libdir}/libavdevice.a
|
%{_libdir}/libavdevice.a
|
||||||
%{_libdir}/libavdevice.so
|
%{_libdir}/libavdevice.so
|
||||||
%{_libdir}/pkgconfig/libavdevice.pc
|
%{_libdir}/pkgconfig/libavdevice.pc
|
||||||
@ -534,8 +533,7 @@ ln -s ../libavcodec.a %{buildroot}%{_libdir}/libavcodec/libavcodec.a
|
|||||||
%files -n libpostproc-ffmpeg-devel
|
%files -n libpostproc-ffmpeg-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_includedir}/libpostproc
|
%dir %{_includedir}/libpostproc
|
||||||
%{_includedir}/libpostproc/postprocess.h
|
%{_includedir}/libpostproc/*.h
|
||||||
%{_includedir}/libpostproc/version.h
|
|
||||||
%{_libdir}/libpostproc.a
|
%{_libdir}/libpostproc.a
|
||||||
%{_libdir}/libpostproc.so
|
%{_libdir}/libpostproc.so
|
||||||
%{_libdir}/pkgconfig/libpostproc.pc
|
%{_libdir}/pkgconfig/libpostproc.pc
|
||||||
@ -573,6 +571,12 @@ ln -s ../libavcodec.a %{buildroot}%{_libdir}/libavcodec/libavcodec.a
|
|||||||
%{_docdir}/ffmpeg/*
|
%{_docdir}/ffmpeg/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 30 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 5.1-2mamba
|
||||||
|
- reapply add-av_stream_get_first_dts-for-chromium patch for 5.1
|
||||||
|
|
||||||
|
* Wed Aug 03 2022 Automatic Build System <autodist@mambasoft.it> 5.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Tue Apr 05 2022 Automatic Build System <autodist@mambasoft.it> 5.0.1-1mamba
|
* Tue Apr 05 2022 Automatic Build System <autodist@mambasoft.it> 5.0.1-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user