automatic version update by autodist [release 7.1.1-1mamba;Wed Mar 26 2025]
This commit is contained in:
parent
d168caa38d
commit
5366ab9c77
@ -1,29 +0,0 @@
|
||||
--- ffmpeg-7.1/libavcodec/libx265.c.orig 2025-01-16 21:54:38.449157281 +0100
|
||||
+++ ffmpeg-7.1/libavcodec/libx265.c 2025-01-16 21:54:43.055166676 +0100
|
||||
@@ -661,7 +661,7 @@
|
||||
{
|
||||
libx265Context *ctx = avctx->priv_data;
|
||||
x265_picture x265pic;
|
||||
-#if X265_BUILD >= 210
|
||||
+#if (X265_BUILD >= 210) && (X265_BUILD < 213)
|
||||
x265_picture x265pic_layers_out[MAX_SCALABLE_LAYERS];
|
||||
x265_picture* x265pic_lyrptr_out[MAX_SCALABLE_LAYERS];
|
||||
#else
|
||||
@@ -805,7 +805,7 @@
|
||||
#endif
|
||||
}
|
||||
|
||||
-#if X265_BUILD >= 210
|
||||
+#if (X265_BUILD >= 210) && (X265_BUILD < 213)
|
||||
for (i = 0; i < MAX_SCALABLE_LAYERS; i++)
|
||||
x265pic_lyrptr_out[i] = &x265pic_layers_out[i];
|
||||
|
||||
@@ -844,7 +844,7 @@
|
||||
pkt->flags |= AV_PKT_FLAG_KEY;
|
||||
}
|
||||
|
||||
-#if X265_BUILD >= 210
|
||||
+#if (X265_BUILD >= 210) && (X265_BUILD < 213)
|
||||
x265pic_out = x265pic_lyrptr_out[0];
|
||||
#else
|
||||
x265pic_out = &x265pic_solo_out;
|
@ -1,280 +0,0 @@
|
||||
Submitted By: Douglas R. Reno <renodr at linuxfromscratch dot org>
|
||||
Date: 2025-01-02
|
||||
Initial Package Version: 7.1
|
||||
Origin: Upstream Mailing List (https://ffmpeg.org/pipermail/ffmpeg-devel/2024-November/335575.html)
|
||||
Upstream Status: Submitted
|
||||
Description: Fixes building ffmpeg-7.1 with texinfo-7.2. The issue
|
||||
is due to API changes in the Texinfo::Convert::HTML
|
||||
perl submodule, where the gdt method was removed. The
|
||||
patch uses the cdt method instead, and portability
|
||||
guards are put into place for users who are using
|
||||
older versions of Texinfo. Thanks goes to Marty Jack
|
||||
for bringing it to our attention in the LFS ticket.
|
||||
|
||||
diff -Naurp ffmpeg-7.1.orig/doc/t2h.pm ffmpeg-7.1/doc/t2h.pm
|
||||
--- ffmpeg-7.1.orig/doc/t2h.pm 2025-01-02 14:52:50.960834600 -0600
|
||||
+++ ffmpeg-7.1/doc/t2h.pm 2025-01-02 14:53:01.048047754 -0600
|
||||
@@ -54,12 +54,24 @@ sub get_formatting_function($$) {
|
||||
}
|
||||
|
||||
# determine texinfo version
|
||||
-my $program_version_num = version->declare(ff_get_conf('PACKAGE_VERSION'))->numify;
|
||||
+my $package_version = ff_get_conf('PACKAGE_VERSION');
|
||||
+$package_version =~ s/\+dev$//;
|
||||
+my $program_version_num = version->declare($package_version)->numify;
|
||||
my $program_version_6_8 = $program_version_num >= 6.008000;
|
||||
|
||||
# no navigation elements
|
||||
ff_set_from_init_file('HEADERS', 0);
|
||||
|
||||
+my %sectioning_commands = %Texinfo::Common::sectioning_commands;
|
||||
+if (scalar(keys(%sectioning_commands)) == 0) {
|
||||
+ %sectioning_commands = %Texinfo::Commands::sectioning_heading_commands;
|
||||
+}
|
||||
+
|
||||
+my %root_commands = %Texinfo::Common::root_commands;
|
||||
+if (scalar(keys(%root_commands)) == 0) {
|
||||
+ %root_commands = %Texinfo::Commands::root_commands;
|
||||
+}
|
||||
+
|
||||
sub ffmpeg_heading_command($$$$$)
|
||||
{
|
||||
my $self = shift;
|
||||
@@ -77,6 +89,9 @@ sub ffmpeg_heading_command($$$$$)
|
||||
return $result;
|
||||
}
|
||||
|
||||
+ # no need to set it as the $element_id is output unconditionally
|
||||
+ my $heading_id;
|
||||
+
|
||||
my $element_id = $self->command_id($command);
|
||||
$result .= "<a name=\"$element_id\"></a>\n"
|
||||
if (defined($element_id) and $element_id ne '');
|
||||
@@ -84,24 +99,40 @@ sub ffmpeg_heading_command($$$$$)
|
||||
print STDERR "Process $command "
|
||||
.Texinfo::Structuring::_print_root_command_texi($command)."\n"
|
||||
if ($self->get_conf('DEBUG'));
|
||||
- my $element;
|
||||
- if ($Texinfo::Common::root_commands{$command->{'cmdname'}}
|
||||
- and $command->{'parent'}
|
||||
- and $command->{'parent'}->{'type'}
|
||||
- and $command->{'parent'}->{'type'} eq 'element') {
|
||||
- $element = $command->{'parent'};
|
||||
+ my $output_unit;
|
||||
+ if ($root_commands{$command->{'cmdname'}}) {
|
||||
+ if ($command->{'associated_unit'}) {
|
||||
+ $output_unit = $command->{'associated_unit'};
|
||||
+ } elsif ($command->{'structure'}
|
||||
+ and $command->{'structure'}->{'associated_unit'}) {
|
||||
+ $output_unit = $command->{'structure'}->{'associated_unit'};
|
||||
+ } elsif ($command->{'parent'}
|
||||
+ and $command->{'parent'}->{'type'}
|
||||
+ and $command->{'parent'}->{'type'} eq 'element') {
|
||||
+ $output_unit = $command->{'parent'};
|
||||
+ }
|
||||
}
|
||||
- if ($element) {
|
||||
+
|
||||
+ if ($output_unit) {
|
||||
$result .= &{get_formatting_function($self, 'format_element_header')}($self, $cmdname,
|
||||
- $command, $element);
|
||||
+ $command, $output_unit);
|
||||
}
|
||||
|
||||
my $heading_level;
|
||||
# node is used as heading if there is nothing else.
|
||||
if ($cmdname eq 'node') {
|
||||
- if (!$element or (!$element->{'extra'}->{'section'}
|
||||
- and $element->{'extra'}->{'node'}
|
||||
- and $element->{'extra'}->{'node'} eq $command
|
||||
+ if (!$output_unit or
|
||||
+ (((!$output_unit->{'extra'}->{'section'}
|
||||
+ and $output_unit->{'extra'}->{'node'}
|
||||
+ and $output_unit->{'extra'}->{'node'} eq $command)
|
||||
+ or
|
||||
+ ((($output_unit->{'extra'}->{'unit_command'}
|
||||
+ and $output_unit->{'extra'}->{'unit_command'} eq $command)
|
||||
+ or
|
||||
+ ($output_unit->{'unit_command'}
|
||||
+ and $output_unit->{'unit_command'} eq $command))
|
||||
+ and $command->{'extra'}
|
||||
+ and not $command->{'extra'}->{'associated_section'}))
|
||||
# bogus node may not have been normalized
|
||||
and defined($command->{'extra'}->{'normalized'}))) {
|
||||
if ($command->{'extra'}->{'normalized'} eq 'Top') {
|
||||
@@ -111,7 +142,15 @@ sub ffmpeg_heading_command($$$$$)
|
||||
}
|
||||
}
|
||||
} else {
|
||||
- $heading_level = $command->{'level'};
|
||||
+ if (defined($command->{'extra'})
|
||||
+ and defined($command->{'extra'}->{'section_level'})) {
|
||||
+ $heading_level = $command->{'extra'}->{'section_level'};
|
||||
+ } elsif ($command->{'structure'}
|
||||
+ and defined($command->{'structure'}->{'section_level'})) {
|
||||
+ $heading_level = $command->{'structure'}->{'section_level'};
|
||||
+ } else {
|
||||
+ $heading_level = $command->{'level'};
|
||||
+ }
|
||||
}
|
||||
|
||||
my $heading = $self->command_text($command);
|
||||
@@ -119,8 +158,8 @@ sub ffmpeg_heading_command($$$$$)
|
||||
# if there is an error in the node.
|
||||
if (defined($heading) and $heading ne '' and defined($heading_level)) {
|
||||
|
||||
- if ($Texinfo::Common::root_commands{$cmdname}
|
||||
- and $Texinfo::Common::sectioning_commands{$cmdname}) {
|
||||
+ if ($root_commands{$cmdname}
|
||||
+ and $sectioning_commands{$cmdname}) {
|
||||
my $content_href = $self->command_contents_href($command, 'contents',
|
||||
$self->{'current_filename'});
|
||||
if ($content_href) {
|
||||
@@ -140,7 +179,13 @@ sub ffmpeg_heading_command($$$$$)
|
||||
}
|
||||
}
|
||||
|
||||
- if ($self->in_preformatted()) {
|
||||
+ my $in_preformatted;
|
||||
+ if ($program_version_num >= 7.001090) {
|
||||
+ $in_preformatted = $self->in_preformatted_context();
|
||||
+ } else {
|
||||
+ $in_preformatted = $self->in_preformatted();
|
||||
+ }
|
||||
+ if ($in_preformatted) {
|
||||
$result .= $heading."\n";
|
||||
} else {
|
||||
# if the level was changed, set the command name right
|
||||
@@ -149,21 +194,25 @@ sub ffmpeg_heading_command($$$$$)
|
||||
$cmdname
|
||||
= $Texinfo::Common::level_to_structuring_command{$cmdname}->[$heading_level];
|
||||
}
|
||||
- # format_heading_text expects an array of headings for texinfo >= 7.0
|
||||
if ($program_version_num >= 7.000000) {
|
||||
- $heading = [$heading];
|
||||
- }
|
||||
- $result .= &{get_formatting_function($self,'format_heading_text')}(
|
||||
+ $result .= &{get_formatting_function($self,'format_heading_text')}($self,
|
||||
+ $cmdname, [$cmdname], $heading,
|
||||
+ $heading_level +$self->get_conf('CHAPTER_HEADER_LEVEL') -1,
|
||||
+ $heading_id, $command);
|
||||
+
|
||||
+ } else {
|
||||
+ $result .= &{get_formatting_function($self,'format_heading_text')}(
|
||||
$self, $cmdname, $heading,
|
||||
$heading_level +
|
||||
$self->get_conf('CHAPTER_HEADER_LEVEL') - 1, $command);
|
||||
+ }
|
||||
}
|
||||
}
|
||||
$result .= $content if (defined($content));
|
||||
return $result;
|
||||
}
|
||||
|
||||
-foreach my $command (keys(%Texinfo::Common::sectioning_commands), 'node') {
|
||||
+foreach my $command (keys(%sectioning_commands), 'node') {
|
||||
texinfo_register_command_formatting($command, \&ffmpeg_heading_command);
|
||||
}
|
||||
|
||||
@@ -188,28 +237,56 @@ sub ffmpeg_begin_file($$$)
|
||||
my $filename = shift;
|
||||
my $element = shift;
|
||||
|
||||
- my $command;
|
||||
- if ($element and $self->get_conf('SPLIT')) {
|
||||
- $command = $self->element_command($element);
|
||||
+ my ($element_command, $node_command, $command_for_title);
|
||||
+ if ($element) {
|
||||
+ if ($element->{'unit_command'}) {
|
||||
+ $element_command = $element->{'unit_command'};
|
||||
+ } elsif ($self->can('tree_unit_element_command')) {
|
||||
+ $element_command = $self->tree_unit_element_command($element);
|
||||
+ } elsif ($self->can('tree_unit_element_command')) {
|
||||
+ $element_command = $self->element_command($element);
|
||||
+ }
|
||||
+
|
||||
+ $node_command = $element_command;
|
||||
+ if ($element_command and $element_command->{'cmdname'}
|
||||
+ and $element_command->{'cmdname'} ne 'node'
|
||||
+ and $element_command->{'extra'}
|
||||
+ and $element_command->{'extra'}->{'associated_node'}) {
|
||||
+ $node_command = $element_command->{'extra'}->{'associated_node'};
|
||||
+ }
|
||||
+
|
||||
+ $command_for_title = $element_command if ($self->get_conf('SPLIT'));
|
||||
}
|
||||
|
||||
- my ($title, $description, $encoding, $date, $css_lines,
|
||||
- $doctype, $bodytext, $copying_comment, $after_body_open,
|
||||
- $extra_head, $program_and_version, $program_homepage,
|
||||
+ my ($title, $description, $keywords, $encoding, $date, $css_lines, $doctype,
|
||||
+ $root_html_element_attributes, $body_attributes, $copying_comment,
|
||||
+ $after_body_open, $extra_head, $program_and_version, $program_homepage,
|
||||
$program, $generator);
|
||||
- if ($program_version_num >= 7.000000) {
|
||||
- ($title, $description, $encoding, $date, $css_lines,
|
||||
- $doctype, $bodytext, $copying_comment, $after_body_open,
|
||||
+ if ($program_version_num >= 7.001090) {
|
||||
+ ($title, $description, $keywords, $encoding, $date, $css_lines, $doctype,
|
||||
+ $root_html_element_attributes, $body_attributes, $copying_comment,
|
||||
+ $after_body_open, $extra_head, $program_and_version, $program_homepage,
|
||||
+ $program, $generator) = $self->_file_header_information($command_for_title,
|
||||
+ $filename);
|
||||
+ } elsif ($program_version_num >= 7.000000) {
|
||||
+ ($title, $description, $encoding, $date, $css_lines, $doctype,
|
||||
+ $root_html_element_attributes, $copying_comment, $after_body_open,
|
||||
$extra_head, $program_and_version, $program_homepage,
|
||||
- $program, $generator) = $self->_file_header_information($command);
|
||||
+ $program, $generator) = $self->_file_header_information($command_for_title,
|
||||
+ $filename);
|
||||
} else {
|
||||
($title, $description, $encoding, $date, $css_lines,
|
||||
- $doctype, $bodytext, $copying_comment, $after_body_open,
|
||||
- $extra_head, $program_and_version, $program_homepage,
|
||||
- $program, $generator) = $self->_file_header_informations($command);
|
||||
+ $doctype, $root_html_element_attributes, $copying_comment,
|
||||
+ $after_body_open, $extra_head, $program_and_version, $program_homepage,
|
||||
+ $program, $generator) = $self->_file_header_informations($command_for_title);
|
||||
}
|
||||
|
||||
- my $links = $self->_get_links ($filename, $element);
|
||||
+ my $links;
|
||||
+ if ($program_version_num >= 7.000000) {
|
||||
+ $links = $self->_get_links($filename, $element, $node_command);
|
||||
+ } else {
|
||||
+ $links = $self->_get_links ($filename, $element);
|
||||
+ }
|
||||
|
||||
my $head1 = $ENV{"FFMPEG_HEADER1"} || <<EOT;
|
||||
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
|
||||
@@ -252,13 +329,25 @@ sub ffmpeg_program_string($)
|
||||
if (defined($self->get_conf('PROGRAM'))
|
||||
and $self->get_conf('PROGRAM') ne ''
|
||||
and defined($self->get_conf('PACKAGE_URL'))) {
|
||||
- return $self->convert_tree(
|
||||
+ if ($program_version_num >= 7.001090) {
|
||||
+ return $self->convert_tree(
|
||||
+ $self->cdt('This document was generated using @uref{{program_homepage}, @emph{{program}}}.',
|
||||
+ { 'program_homepage' => {'text' => $self->get_conf('PACKAGE_URL')},
|
||||
+ 'program' => {'text' => $self->get_conf('PROGRAM') }}));
|
||||
+ } else {
|
||||
+ return $self->convert_tree(
|
||||
$self->gdt('This document was generated using @uref{{program_homepage}, @emph{{program}}}.',
|
||||
- { 'program_homepage' => $self->get_conf('PACKAGE_URL'),
|
||||
- 'program' => $self->get_conf('PROGRAM') }));
|
||||
+ { 'program_homepage' => {'text' => $self->get_conf('PACKAGE_URL')},
|
||||
+ 'program' => {'text' => $self->get_conf('PROGRAM') }}));
|
||||
+ }
|
||||
} else {
|
||||
- return $self->convert_tree(
|
||||
- $self->gdt('This document was generated automatically.'));
|
||||
+ if ($program_version_num >= 7.001090) {
|
||||
+ return $self->convert_tree(
|
||||
+ $self->cdt('This document was generated automatically.'));
|
||||
+ } else {
|
||||
+ return $self->convert_tree(
|
||||
+ $self->gdt('This document was generated automatically.'));
|
||||
+ }
|
||||
}
|
||||
}
|
||||
if ($program_version_6_8) {
|
30
ffmpeg-7.1.1-svt-av1-3.0.patch
Normal file
30
ffmpeg-7.1.1-svt-av1-3.0.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From d1ed5c06e3edc5f2b5f3664c80121fa55b0baa95 Mon Sep 17 00:00:00 2001
|
||||
From: Gyan Doshi <ffmpeg@gyani.pro>
|
||||
Date: Sat, 22 Feb 2025 10:38:53 +0530
|
||||
Subject: [PATCH] avcodec/libsvtav1: unbreak build with latest svtav1
|
||||
|
||||
SVT-AV1 made a change in their public API in 988e930c but without a
|
||||
version bump or any other accessible marker, thus breaking ffmpeg build
|
||||
with current versions of SVT-AV1.
|
||||
|
||||
They have finally bumped versions a month later, so check added.
|
||||
---
|
||||
libavcodec/libsvtav1.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/libavcodec/libsvtav1.c b/libavcodec/libsvtav1.c
|
||||
index 79b28eb4df546..43fe531fde74d 100644
|
||||
--- a/libavcodec/libsvtav1.c
|
||||
+++ b/libavcodec/libsvtav1.c
|
||||
@@ -435,7 +435,11 @@ static av_cold int eb_enc_init(AVCodecContext *avctx)
|
||||
|
||||
svt_enc->eos_flag = EOS_NOT_REACHED;
|
||||
|
||||
+#if SVT_AV1_CHECK_VERSION(3, 0, 0)
|
||||
+ svt_ret = svt_av1_enc_init_handle(&svt_enc->svt_handle, &svt_enc->enc_params);
|
||||
+#else
|
||||
svt_ret = svt_av1_enc_init_handle(&svt_enc->svt_handle, svt_enc, &svt_enc->enc_params);
|
||||
+#endif
|
||||
if (svt_ret != EB_ErrorNone) {
|
||||
return svt_print_error(avctx, svt_ret, "Error initializing encoder handle");
|
||||
}
|
13
ffmpeg.spec
13
ffmpeg.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Name: ffmpeg
|
||||
Epoch: 2
|
||||
Version: 7.1
|
||||
Release: 2mamba
|
||||
Version: 7.1.1
|
||||
Release: 1mamba
|
||||
Summary: Hyper fast MPEG1/MPEG4/H263/RV and AC3/MPEG audio encoder
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -12,8 +12,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://ffmpeg.org/
|
||||
Source: http://ffmpeg.mplayerhq.hu/releases/ffmpeg-%{version}.tar.bz2
|
||||
Patch0: ffmpeg-5.1-add-av_stream_get_first_dts-for-chromium.patch
|
||||
Patch1: ffmpeg-7.1-libx265-4.1.patch
|
||||
Patch2: ffmpeg-7.1-texinfo-7.2.patch
|
||||
Patch1: ffmpeg-7.1.1-svt-av1-3.0.patch
|
||||
License: LGPL, GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -351,8 +350,7 @@ This is a virtual package that contains the dependencies necessary for installin
|
||||
%prep
|
||||
%setup -q -n ffmpeg-%{buildver}
|
||||
%patch 0 -p1 -F2 -b .add-av_stream_get_first_dts-for-chromium
|
||||
%patch 1 -p1
|
||||
%patch 2 -p1 -b .texinfo-7.2
|
||||
%patch 1 -p1 -b .svt-av1-3.0
|
||||
|
||||
%build
|
||||
# configure not generated by autoconf
|
||||
@ -611,6 +609,9 @@ ln -s ../libavcodec.a %{buildroot}%{_libdir}/libavcodec/libavcodec.a
|
||||
%{_docdir}/ffmpeg/*
|
||||
|
||||
%changelog
|
||||
* Wed Mar 26 2025 Automatic Build System <autodist@openmamba.org> 7.1.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jan 16 2025 Silvan Calarco <silvan.calarco@mambasoft.it> 7.1-2mamba
|
||||
- rebuilt with reviewed configure options to ensure support for needed codecs
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user