automatic version update by autodist [release 2.2.2-1mamba;Tue May 06 2014]

This commit is contained in:
Automatic Build System 2024-01-05 22:15:19 +01:00
parent 6d99d76de5
commit 4d58f4a498
6 changed files with 886 additions and 0 deletions

View File

@ -1,2 +1,8 @@
# ffmpeg
FFmpeg is a very fast video and audio converter.
It can also grab from a live audio/video source.
The command line interface is designed to be intuitive, in the sense that ffmpeg tries to figure out all the parameters, when possible.
You have usually to give only the target bitrate you want.
FFmpeg can also convert from any sample rate to any other, and resize video on the fly with a high quality polyphase filter.

View File

@ -0,0 +1,11 @@
diff -Nru ffmpeg-0.11.orig/libavformat/Makefile ffmpeg-0.11/libavformat/Makefile
--- ffmpeg-0.11.orig/libavformat/Makefile 2012-05-25 20:02:16.000000000 +0200
+++ ffmpeg-0.11/libavformat/Makefile 2012-06-07 15:44:41.922379209 +0200
@@ -6,6 +6,7 @@
HEADERS = avformat.h \
avio.h \
version.h \
+ url.h \
OBJS = allformats.o \
avio.o \

40
ffmpeg-0.4.9-pic.patch Normal file
View File

@ -0,0 +1,40 @@
--- ffmpeg-0.4.9-pre1/libavcodec/Makefile.pic 2004-07-23 12:04:25.586018114 +0200
+++ ffmpeg-0.4.9-pre1/libavcodec/Makefile 2004-07-23 12:05:57.274315938 +0200
@@ -9,6 +9,10 @@
# NOTE: -I.. is needed to include config.h
CFLAGS=$(OPTFLAGS) -DHAVE_AV_CONFIG_H -I.. -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE
+ifeq ($(BUILD_SHARED),yes)
+CFLAGS+=$(PIC)
+endif
+
OBJS= common.o utils.o mem.o allcodecs.o \
mpegvideo.o jrevdct.o jfdctfst.o jfdctint.o\
mpegaudio.o ac3enc.o mjpeg.o resample.o resample2.o dsputil.o \
--- ffmpeg-0.4.9-pre1/libavformat/Makefile.pic 2004-04-24 17:16:23.000000000 +0200
+++ ffmpeg-0.4.9-pre1/libavformat/Makefile 2004-07-23 12:06:18.109608754 +0200
@@ -8,6 +8,10 @@
CFLAGS=$(OPTFLAGS) -I.. -I$(SRC_PATH) -I$(SRC_PATH)/libavcodec -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE
+ifeq ($(BUILD_SHARED),yes)
+CFLAGS+=$(PIC)
+endif
+
OBJS= utils.o cutils.o os_support.o allformats.o
PPOBJS=
--- ffmpeg-0.4.9-pre1/configure.pic 2004-07-05 20:06:16.000000000 +0200
+++ ffmpeg-0.4.9-pre1/configure 2004-07-23 12:04:25.593018213 +0200
@@ -1144,7 +1144,10 @@
fi
if test "$lshared" = "yes" ; then
echo "BUILD_SHARED=yes" >> config.mak
- echo "PIC=-fPIC" >> config.mak
+ # it can work without PIC on x86
+ if test "$cpu" != "x86"; then
+ echo "PIC=-fPIC" >> config.mak
+ fi
fi
echo "EXTRALIBS=$extralibs" >> config.mak
version=`grep '#define FFMPEG_VERSION ' $source_path/libavcodec/avcodec.h |

12
ffmpeg-0.5-x264.patch Normal file
View File

@ -0,0 +1,12 @@
diff -Nru ffmpeg-0.5.orig/configure ffmpeg-0.5/configure
--- ffmpeg-0.5.orig/configure 2009-03-01 18:57:14.000000000 +0100
+++ ffmpeg-0.5/configure 2009-10-17 05:33:41.000000000 +0200
@@ -1993,7 +1993,7 @@
enabled libspeex && require libspeex speex/speex.h speex_decoder_init -lspeex
enabled libtheora && require libtheora theora/theora.h theora_info_init -ltheora -logg
enabled libvorbis && require libvorbis vorbis/vorbisenc.h vorbis_info_init -lvorbisenc -lvorbis -logg
-enabled libx264 && require libx264 x264.h x264_encoder_open -lx264 -lm &&
+enabled libx264 && 1 -lx264 -lm &&
{ check_cpp_condition x264.h "X264_BUILD >= 65" ||
die "ERROR: libx264 version must be >= 0.65."; }
enabled libxvid && require libxvid xvid.h xvid_global -lxvidcore

View File

@ -0,0 +1,11 @@
--- ffmpeg/libavcodec/libx264.c 2008-08-20 18:34:13.000000000 +0200
+++ ffmpeg/libavcodec/libx264.c-gil 2008-08-20 21:10:26.000000000 +0200
@@ -221,7 +221,7 @@
else if(avctx->me_method == ME_FULL)
x4->params.analyse.i_me_method = X264_ME_ESA;
else if(avctx->me_method == ME_TESA)
- x4->params.analyse.i_me_method = X264_ME_TESA;
+ x4->params.analyse.i_me_method = 4; //X264_ME_TESA;
else x4->params.analyse.i_me_method = X264_ME_HEX;
x4->params.analyse.i_me_range = avctx->me_range;

806
ffmpeg.spec Normal file
View File

@ -0,0 +1,806 @@
%define enable_gpl 1
%define enable_non_free 1
#% define buildyear %(echo %{version} | cut -b 7-10)
#% define buildmonth %(echo %{version} | cut -b 11-12)
#% define buildday %(echo %{version} | cut -b 13-14)
%define buildver %{version}
#% define buildver export-%{buildyear}-%{buildmonth}-%{buildday}
Name: ffmpeg
Epoch: 1
Version: 2.2.2
Release: 1mamba
Summary: Hyper fast MPEG1/MPEG4/H263/RV and AC3/MPEG audio encoder
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://ffmpeg.mplayerhq.hu/
Source: http://ffmpeg.mplayerhq.hu/releases/ffmpeg-%{version}.tar.bz2
#Source: http://ffmpeg.mplayerhq.hu/releases/ffmpeg-export-snapshot.tar.bz2
# Source now taken from exported snapshot
# Source chekout from SVN:
# svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg && find ffmpeg -name .svn | xargs rm -rf && tar cjvf ffmpeg-`date '+%Y%m%d'`svn.tar.bz2 ffmpeg
Patch1: %{name}-0.4.9-pic.patch
Patch2: %{name}-20080820svn-libx264.patch
Patch3: %{name}-0.5-x264.patch
Patch4: %{name}-0.11-install_url_h.patch
License: LGPL, GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libSDL-devel
BuildRequires: libX11-devel
BuildRequires: libXext-devel
BuildRequires: libXfixes-devel
BuildRequires: libXv-devel
BuildRequires: libalsa-devel
BuildRequires: libass-devel
BuildRequires: libbluray-devel
BuildRequires: libbzip2-devel
%ifarch %{ix86} x86_64
BuildRequires: libcrystalhd-devel
%endif
BuildRequires: libdc1394-devel
BuildRequires: libfaac-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgnutls-devel
BuildRequires: libgsm-devel
BuildRequires: libjack-devel
BuildRequires: liblame-devel
BuildRequires: libmodplug-devel
BuildRequires: libopencore-amr-devel
BuildRequires: libopenjpeg1-devel
BuildRequires: libopus-devel
BuildRequires: libpulseaudio-devel
BuildRequires: librtmp-devel
BuildRequires: libschroedinger-devel
BuildRequires: libspeex-devel
BuildRequires: libtheora-devel
BuildRequires: libv4l-devel
BuildRequires: libva-devel
BuildRequires: libvdpau-devel
BuildRequires: libvorbis-devel
BuildRequires: libvpx-devel
BuildRequires: libx264-devel
BuildRequires: libxvidcore-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: liborc-devel
BuildRequires: libopenjpeg-devel
BuildRequires: libogg-devel
BuildRequires: libfaad2-devel
BuildRequires: libraw1394-devel
BuildRequires: liba52dec-devel
BuildRequires: yasm-devel
BuildRequires: ldconfig
# texi2html required
BuildRequires: tetex >= 3.0
Obsoletes: libffmpeg
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
FFmpeg is a very fast video and audio converter.
It can also grab from a live audio/video source.
The command line interface is designed to be intuitive, in the sense that ffmpeg tries to figure out all the parameters, when possible.
You have usually to give only the target bitrate you want.
FFmpeg can also convert from any sample rate to any other, and resize video on the fly with a high quality polyphase filter.
%package examples
Summary: ffmpeg coding examples
Group: Development/Libraries
%description examples
ffmpeg coding examples.
%package presets
Summary: Preset configuration files used by libavcodec
Group: System/Libraries
Provides: ffmpegpresets
%description presets
Preset configuration files used by libavcodec.
%package -n libswscale-ffmpeg
Summary: ffmpeg video scaling library
Group: System/Libraries
Provides: libswscale
Obsoletes: libswscale
%description -n libswscale-ffmpeg
ffmpeg video scaling library.
%package -n libswscale-ffmpeg-devel
Summary: Shared header files and static libraries part of ffmpeg
Group: Development/Libraries
Requires: libswscale-ffmpeg = %{?epoch:%epoch:}%{version}-%{release}
Provides: libswscale-devel
Obsoletes: libswscale-devel
%description -n libswscale-ffmpeg-devel
ffmpeg video scaling library.
This package contains the header files and static libraries needed to compile applications or shared objects that use libswscale
%package -n libswresample-ffmpeg
Summary: ffmpeg resampling library
Group: System/Libraries
Provides: libswresample
%description -n libswresample-ffmpeg
ffmpeg resampling library.
%package -n libswresample-ffmpeg-devel
Summary: Shared header files and static libraries part of ffmpeg
Group: Development/Libraries
Requires: libswresample-ffmpeg = %{?epoch:%epoch:}%{version}-%{release}
Provides: libresample-devel
%description -n libswresample-ffmpeg-devel
ffmpeg resampling library.
This package contains the header files and static libraries needed to compile applications or shared objects that use libswscale
%package -n libavcodec-ffmpeg
Summary: ffmpeg library implementing various Audio/Video codecs
Group: System/Libraries
Requires: ffmpegpresets
Provides: libavcodec
Obsoletes: libavcodec
%description -n libavcodec-ffmpeg
ffmpeg library implementing various Audio/Video codecs.
%package -n libavcodec-ffmpeg-devel
Summary: Shared header files and static libraries part of ffmpeg
Group: Development/Libraries
Requires: libavcodec-ffmpeg = %{?epoch:%epoch:}%{version}-%{release}
Provides: libavcodec-devel
Obsoletes: libavcodec-devel
%description -n libavcodec-ffmpeg-devel
ffmpeg library implementing various Audio/Video codecs.
This package contains the header files and static libraries needed to compile applications or shared objects that use libavcodec
%package -n libavdevice-ffmpeg
Summary: ffmpeg device handling library
Group: System/Libraries
Provides: libavdevice
Obsoletes: libavdevice
%description -n libavdevice-ffmpeg
ffmpeg device handling library.
%package -n libavdevice-ffmpeg-devel
Summary: Shared header files and static libraries part of ffmpeg
Group: Development/Libraries
Requires: libavdevice-ffmpeg = %{?epoch:%epoch:}%{version}-%{release}
Provides: libavdevice-devel
Obsoletes: libavdevice-devel
%description -n libavdevice-ffmpeg-devel
ffmpeg device handling library.
This package contains the header files and static libraries needed to compile applications or shared objects that use libavdevice.
%package -n libavfilter-ffmpeg
Summary: ffmpeg filtering library
Group: System/Libraries
Provides: libavfilter
Obsoletes: libavfilter
%description -n libavfilter-ffmpeg
ffmpeg filtering library.
%package -n libavfilter-ffmpeg-devel
Summary: Shared header files and static libraries part of ffmpeg
Group: Development/Libraries
Requires: libavfilter-ffmpeg = %{?epoch:%epoch:}%{version}-%{release}
Provides: libavfilter-devel
Obsoletes: libavfilter-devel
%description -n libavfilter-ffmpeg-devel
ffmpeg filtering library.
This package contains the header files and static libraries needed to compile applications or shared objects that use libavformat
%package -n libavformat-ffmpeg
Summary: ffmpeg format library
Group: System/Libraries
Provides: libavformat
Obsoletes: libavformat
%description -n libavformat-ffmpeg
ffmpeg format library.
%package -n libavformat-ffmpeg-devel
Summary: Shared header files and static libraries part of ffmpeg
Group: Development/Libraries
Requires: libavformat-ffmpeg = %{?epoch:%epoch:}%{version}-%{release}
Provides: libavformat-devel
Obsoletes: libavformat-devel
%description -n libavformat-ffmpeg-devel
ffmpeg format library.
This package contains the header files and static libraries needed to compile applications or shared objects that use libavformat
%package -n libavutil-ffmpeg
Summary: Shared library part of ffmpeg
Group: System/Libraries
Provides: libavutil
Obsoletes: libavutil
%description -n libavutil-ffmpeg
Shared library part of ffmpeg
%package -n libavutil-ffmpeg-devel
Summary: Shared header files and static libraries part of ffmpeg
Group: Development/Libraries
Requires: libavutil-ffmpeg = %{?epoch:%epoch:}%{version}-%{release}
Provides: libavutil-devel
Obsoletes: libavutil-devel
%description -n libavutil-ffmpeg-devel
This is the common utility library from the ffmpeg project.
It is required by all other ffmpeg libraries.
This package contains the header files and static libraries needed to compile applications or shared objects that use libavutil
%package -n libpostproc-ffmpeg
Summary: Video postprocessing library from ffmpeg
Group: System/Libraries
Provides: libpostproc
Obsoletes: libpostproc
%description -n libpostproc-ffmpeg
FFmpeg is a very fast video and audio converter. It can also grab from a live audio/video source.
This package contains only ffmpeg's postproc post-processing library which other projects such as transcode may use. Install this package if you intend to use MPlayer, transcode or other similar programs.
%package -n libpostproc-ffmpeg-devel
Summary: Video postprocessing library from ffmpeg
Group: Development/Libraries
Requires: libpostproc-ffmpeg = %{?epoch:%epoch:}%{version}-%{release}
Provides: libpostproc-devel
Obsoletes: libpostproc-devel
%description -n libpostproc-ffmpeg-devel
FFmpeg is a very fast video and audio converter. It can also grab from a live audio/video source.
This package contains only ffmpeg's postproc post-processing headers and static libraries which other projects such as transcode may use. Install this package if you intend to use MPlayer, transcode or other similar programs.
%package -n libavresample-ffmpeg
Summary: ffmpeg resample library
Group: System/Libraries
%description -n libavresample-ffmpeg
FFmpeg resample library.
%package -n libavresample-ffmpeg-devel
Summary: Shared header files and static libraries part of ffmpeg libavresample
Group: System/Libraries
Requires: libavresample-ffmpeg = %{?epoch:%epoch:}%{version}-%{release}
%description -n libavresample-ffmpeg-devel
FFmpeg resample library.
This package contains the header files and static libraries needed to compile applications or shared objects that use libavutil
%package devel
Summary: Virtual package that installs all the FFmpeg development packages
Group: Development/Libraries
Requires: libavcodec-ffmpeg-devel
Requires: libavdevice-ffmpeg-devel
Requires: libavfilter-ffmpeg-devel
Requires: libavformat-ffmpeg-devel
Requires: libavutil-ffmpeg-devel
Requires: libpostproc-ffmpeg-devel
Requires: libswscale-ffmpeg-devel
Requires: libswresample-ffmpeg-devel
%description devel
This is a virtual package that contains the dependencies necessary for installing all the FFmpeg development packages.
%prep
%setup -q -n ffmpeg-%{buildver}
%patch4 -p1
%build
# configure not generated by autoconf
# -D__LINUX_USER__ is required by crystalhd
export CFLAGS="%{optflags} -fno-unit-at-a-time -D__LINUX_USER__"
./configure \
--prefix="%{_prefix}" \
--libdir="%{_libdir}" \
--shlibdir="%{_libdir}" \
--mandir="%{_mandir}" \
--enable-libmp3lame \
--enable-libvorbis \
--enable-libtheora \
--enable-libfaac \
--enable-libgsm \
--enable-libdc1394 \
--enable-libschroedinger \
--enable-shared \
--enable-pthreads \
--disable-stripping \
--enable-libopenjpeg \
--enable-libspeex \
--enable-swscale \
--enable-x11grab \
--enable-avresample \
--enable-dxva2 \
--enable-libass \
--enable-libbluray \
--enable-libfreetype \
--enable-libmodplug \
--enable-libopenjpeg \
--enable-libopus \
--enable-libpulse \
--enable-librtmp \
--enable-libv4l2 \
--enable-libvpx \
--enable-libxvid \
--enable-pic \
--enable-postproc \
--enable-runtime-cpudetect \
--enable-shared \
--enable-swresample \
--enable-vdpau \
%if %enable_gpl
--enable-gpl \
--enable-fontconfig \
--enable-gnutls \
--enable-version3 \
--enable-libxvid \
--enable-postproc \
--enable-libx264 \
--enable-libopencore-amrnb \
--enable-libopencore-amrwb \
%if %enable_non_free
--enable-nonfree \
%endif
%endif
# --enable-libx265 \
# --enable-libfaad \
# --enable-avfilter-lavf \
# --enable-libfaadbin \
# --cpu=%{_target_cpu} \
# --enable-swscale \
## --incdir="%{_includedir}/ffmpeg" \
# FIXME:
# software scaler enabled no
# Sun medialib support no
# AVISynth enabled no
# liba52 dlopened no
# enable non free (libamrnb, libamrwb) License: unredistributable
# libamr-nb support no
# libamr-wb support no
# libgsm enabled no
# libnut enabled no
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall \
shlibdir="%{buildroot}%{_libdir}" \
libdir="%{buildroot}%{_libdir}"
#\
# incdir="%{buildroot}%{_includedir}/ffmpeg" \
# shlibdir="%{buildroot}%{_libdir}" \
# libdir="%{buildroot}%{_libdir}"
# Remove unwanted files from the included docs
#%{__cp} -a doc _docs
#%{__rm} -rf _docs/{Makefile,*.texi,*.pl}
# make installlib is broken, so we do it by hand
#install -m 644 libavcodec/libavcodec.a %{buildroot}%{_libdir}
#install -m 644 libavformat/libavformat.a %{buildroot}%{_libdir}
# create compat symlink
install -d %{buildroot}%{_libdir}/libavcodec
ln -s ../libavcodec.a %{buildroot}%{_libdir}/libavcodec/libavcodec.a
#install -d %{buildroot}%{_includedir}/ffmpeg
#cp -a %{buildroot}%{_includedir}/libavcodec/*.h \
# %{buildroot}%{_includedir}/libavdevice/*.h \
# %{buildroot}%{_includedir}/libavformat/*.h \
# %{buildroot}%{_includedir}/libavutil/*.h \
# %{buildroot}%{_includedir}/libswscale/*.h \
# %{buildroot}%{_includedir}/ffmpeg
#install -d %{buildroot}%{_includedir}/postproc
#cp -a %{buildroot}%{_includedir}/libpostproc/*.h \
# %{buildroot}%{_includedir}/postproc
# The <postproc/postprocess.h> is now at <ffmpeg/postprocess.h>, so provide
# a compatibility symlink
#%{__mkdir_p} %{buildroot}%{_includedir}/postproc/
#%{__mkdir_p} %{buildroot}%{_includedir}/libswscale/
#%{__ln_s} ../ffmpeg/postprocess.h \
# %{buildroot}%{_includedir}/postproc/postprocess.h
#%{__ln_s} ../ffmpeg/rgb2rgb.h\
# %{buildroot}%{_includedir}/libswscale/rgb2rgb.h
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n libavcodec-ffmpeg -p /sbin/ldconfig
%postun -n libavcodec-ffmpeg -p /sbin/ldconfig
%post -n libavdevice-ffmpeg -p /sbin/ldconfig
%postun -n libavdevice-ffmpeg -p /sbin/ldconfig
%post -n libavfilter-ffmpeg -p /sbin/ldconfig
%postun -n libavfilter-ffmpeg -p /sbin/ldconfig
%post -n libavformat-ffmpeg -p /sbin/ldconfig
%postun -n libavformat-ffmpeg -p /sbin/ldconfig
%post -n libavresample-ffmpeg -p /sbin/ldconfig
%postun -n libavresample-ffmpeg -p /sbin/ldconfig
%post -n libavutil-ffmpeg -p /sbin/ldconfig
%postun -n libavutil-ffmpeg -p /sbin/ldconfig
%post -n libpostproc-ffmpeg -p /sbin/ldconfig
%postun -n libpostproc-ffmpeg -p /sbin/ldconfig
%post -n libswscale-ffmpeg -p /sbin/ldconfig
%postun -n libswscale-ffmpeg -p /sbin/ldconfig
%post -n libswresample-ffmpeg -p /sbin/ldconfig
%postun -n libswresample-ffmpeg -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/ffmpeg
%{_bindir}/ffplay
%{_bindir}/ffprobe
%{_bindir}/ffserver
%{_datadir}/ffmpeg/ffprobe.xsd
%{_mandir}/man1/ffmpeg.1*
%{_mandir}/man1/ffplay.1*
%{_mandir}/man1/ffprobe.1*
%{_mandir}/man1/ffserver.1*
%{_mandir}/man1/ffmpeg-all.1*
%{_mandir}/man1/ffplay-all.1*
%{_mandir}/man1/ffprobe-all.1*
%{_mandir}/man1/ffserver-all.1*
%{_mandir}/man1/ffmpeg-bitstream-filters.1*
%{_mandir}/man1/ffmpeg-codecs.1*
%{_mandir}/man1/ffmpeg-devices.1*
%{_mandir}/man1/ffmpeg-filters.1*
%{_mandir}/man1/ffmpeg-formats.1*
%{_mandir}/man1/ffmpeg-protocols.1*
%{_mandir}/man1/ffmpeg-resampler.1*
%{_mandir}/man1/ffmpeg-scaler.1*
%{_mandir}/man1/ffmpeg-utils.1*
%doc CREDITS README
%files examples
%defattr(-,root,root)
%dir %{_datadir}/ffmpeg/examples
%{_datadir}/ffmpeg/examples/Makefile
%{_datadir}/ffmpeg/examples/*.c
%files presets
%defattr(-,root,root)
%dir %{_datadir}/ffmpeg
%{_datadir}/ffmpeg/libx264-*.ffpreset
%{_datadir}/ffmpeg/libvpx-*.ffpreset
%files -n libavcodec-ffmpeg
%defattr(-,root,root)
%{_libdir}/libavcodec.so.*
%files -n libavcodec-ffmpeg-devel
%defattr(-,root,root)
%dir %{_includedir}/libavcodec
%{_includedir}/libavcodec/*
%dir %{_libdir}/libavcodec
%{_libdir}/libavcodec/libavcodec.a
%{_libdir}/libavcodec.a
%{_libdir}/libavcodec.so
%{_libdir}/pkgconfig/libavcodec.pc
%{_mandir}/man3/libavcodec.3.gz
%files -n libavdevice-ffmpeg
%defattr(-,root,root)
%{_libdir}/libavdevice.so.*
%files -n libavdevice-ffmpeg-devel
%defattr(-,root,root)
%dir %{_includedir}/libavdevice
%{_includedir}/libavdevice/avdevice.h
%{_includedir}/libavdevice/version.h
%{_libdir}/libavdevice.a
%{_libdir}/libavdevice.so
%{_libdir}/pkgconfig/libavdevice.pc
%{_mandir}/man3/libavdevice.3.gz
%files -n libavfilter-ffmpeg
%defattr(-,root,root)
%{_libdir}/libavfilter.so.*
%files -n libavfilter-ffmpeg-devel
%defattr(-,root,root)
%dir %{_includedir}/libavfilter
%{_includedir}/libavfilter/*.h
%{_libdir}/libavfilter.a
%{_libdir}/libavfilter.so
%{_libdir}/pkgconfig/libavfilter.pc
%{_mandir}/man3/libavfilter.3.gz
%files -n libavformat-ffmpeg
%defattr(-,root,root)
%{_libdir}/libavformat.so.*
%files -n libavformat-ffmpeg-devel
%defattr(-,root,root)
%dir %{_includedir}/libavformat
%{_includedir}/libavformat/*.h
%{_libdir}/libavformat.a
%{_libdir}/libavformat.so
%{_libdir}/pkgconfig/libavformat.pc
%{_mandir}/man3/libavformat.3.gz
%files -n libavresample-ffmpeg
%defattr(-,root,root)
%{_libdir}/libavresample.so.*
%files -n libavresample-ffmpeg-devel
%defattr(-,root,root)
%dir %{_includedir}/libavresample
%{_includedir}/libavresample/avresample.h
%{_includedir}/libavresample/version.h
%{_libdir}/libavresample.a
%{_libdir}/libavresample.so
%{_libdir}/pkgconfig/libavresample.pc
%files -n libavutil-ffmpeg
%defattr(-,root,root)
%{_libdir}/libavutil.so.*
%files -n libavutil-ffmpeg-devel
%defattr(-,root,root)
%dir %{_includedir}/libavutil
%{_includedir}/libavutil/*.h
%{_libdir}/libavutil.a
%{_libdir}/libavutil.so
%{_libdir}/pkgconfig/libavutil.pc
%{_mandir}/man3/libavutil.3.gz
%files -n libpostproc-ffmpeg
%defattr(-,root,root)
%{_libdir}/libpostproc.so.*
%files -n libpostproc-ffmpeg-devel
%defattr(-,root,root)
%dir %{_includedir}/libpostproc
%{_includedir}/libpostproc/postprocess.h
%{_includedir}/libpostproc/version.h
%{_libdir}/libpostproc.a
%{_libdir}/libpostproc.so
%{_libdir}/pkgconfig/libpostproc.pc
%{_datadir}/ffmpeg/examples/README
%files -n libswscale-ffmpeg
%defattr(-,root,root)
%{_libdir}/libswscale.so.*
%files -n libswscale-ffmpeg-devel
%defattr(-,root,root)
%dir %{_includedir}/libswscale
%{_includedir}/libswscale/*.h
%{_libdir}/libswscale.a
%{_libdir}/libswscale.so
%{_libdir}/pkgconfig/libswscale.pc
%{_mandir}/man3/libswscale.3.gz
%files -n libswresample-ffmpeg
%defattr(-,root,root)
%{_libdir}/libswresample.so.*
%files -n libswresample-ffmpeg-devel
%defattr(-,root,root)
%dir %{_includedir}/libswresample
%{_includedir}/libswresample/*.h
%{_libdir}/libswresample.a
%{_libdir}/libswresample.so
%{_libdir}/pkgconfig/libswresample.pc
%{_mandir}/man3/libswresample.3.gz
%files devel
%defattr(-,root,root)
%dir %{_docdir}/ffmpeg
%{_docdir}/ffmpeg/*
%changelog
* Tue May 06 2014 Automatic Build System <autodist@mambasoft.it> 2.2.2-1mamba
- automatic version update by autodist
* Thu Apr 10 2014 Automatic Build System <autodist@mambasoft.it> 2.2.1-1mamba
- automatic version update by autodist
* Tue Mar 25 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2-2mamba
- enable build of libavresample and many other support options
* Mon Mar 24 2014 Automatic Build System <autodist@mambasoft.it> 2.2-1mamba
- automatic version update by autodist
* Mon Feb 24 2014 Automatic Build System <autodist@mambasoft.it> 2.1.4-1mamba
- automatic version update by autodist
* Thu Jan 16 2014 Automatic Build System <autodist@mambasoft.it> 2.1.3-1mamba
- automatic version update by autodist
* Tue Jan 14 2014 Automatic Build System <autodist@mambasoft.it> 2.1.2-1mamba
- automatic version update by autodist
* Wed Nov 20 2013 Automatic Build System <autodist@mambasoft.it> 2.1.1-1mamba
- automatic version update by autodist
* Tue Oct 29 2013 Automatic Build System <autodist@mambasoft.it> 2.1-1mamba
- automatic version update by autodist
* Wed Oct 09 2013 Automatic Build System <autodist@mambasoft.it> 2.0.2-1mamba
- automatic version update by autodist
* Sun Aug 11 2013 Automatic Build System <autodist@mambasoft.it> 2.0.1-1mamba
- automatic version update by autodist
* Thu Jul 11 2013 Automatic Build System <autodist@mambasoft.it> 2.0-1mamba
- automatic version update by autodist
* Sun Jun 23 2013 openmamba WebBuild System <webbuild@openmamba.org> 1.2.1-2mamba
- add a virtual package that help installing all the ffmpeg development packages
* Wed May 29 2013 Automatic Build System <autodist@mambasoft.it> 1.2.1-1mamba
- automatic version update by autodist
* Tue Mar 19 2013 Automatic Build System <autodist@mambasoft.it> 1.2-1mamba
- automatic version update by autodist
* Wed Feb 27 2013 Automatic Build System <autodist@mambasoft.it> 1.1.3-1mamba
- automatic version update by autodist
* Tue Feb 12 2013 Automatic Build System <autodist@mambasoft.it> 1.1.2-1mamba
- automatic version update by autodist
* Fri Dec 07 2012 Automatic Build System <autodist@mambasoft.it> 1.0.1-1mamba
- automatic version update by autodist
* Fri Sep 28 2012 Automatic Build System <autodist@mambasoft.it> 1.0-1mamba
- automatic version update by autodist
* Wed Sep 19 2012 Automatic Build System <autodist@mambasoft.it> 0.11.2-1mamba
- automatic version update by autodist
* Fri Jun 08 2012 Automatic Build System <autodist@mambasoft.it> 0.11.1-1mamba
- automatic version update by autodist
* Sun May 06 2012 Automatic Build System <autodist@mambasoft.it> 0.10.3-1mamba
- automatic version update by autodist
* Mon Apr 02 2012 Automatic Build System <autodist@mambasoft.it> 0.10.2-1mamba
- automatic version update by autodist
* Sun Apr 01 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.1-1mamba
- update to 0.10.1
* Wed Mar 28 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.08.10-2mamba
- added --enable-x11grab option
* Fri Mar 16 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.10-1mamba
- update to 0.8.10
- added libavformat/url.h as required by recent chromium
* Tue Nov 22 2011 Automatic Build System <autodist@mambasoft.it> 0.8.7-1mamba
- automatic version update by autodist
* Sat Nov 05 2011 Automatic Build System <autodist@mambasoft.it> 0.8.6-1mamba
- automatic version update by autodist
* Tue Oct 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.5-2mamba
- obsolete libav*
* Tue Oct 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.5-1mamba
- update to 0.8.5
* Mon Oct 18 2010 Automatic Build System <autodist@mambasoft.it> 0.6.1-1mamba
- automatic update to 0.6.1 by autodist
* Tue Jun 22 2010 Automatic Build System <autodist@mambasoft.it> 0.6-1mamba
- automatic update to 0.6 by autodist
* Tue May 25 2010 Automatic Build System <autodist@mambasoft.it> 0.5.2-1mamba
- automatic update to 0.5.2 by autodist
* Tue Mar 16 2010 Automatic Build System <autodist@mambasoft.it> 0.5.1-2mamba
- automatic rebuild by autodist
* Fri Mar 05 2010 Automatic Build System <autodist@mambasoft.it> 0.5.1-1mamba
- automatic update to 0.5.1 by autodist
* Thu Nov 19 2009 Automatic Build System <autodist@mambasoft.it> 0.5.0.20091119-1mamba
- update to 0.5.snapshot20091119
* Wed Aug 12 2009 Automatic Build System <autodist@mambasoft.it> 0.5-3mamba
- automatic rebuild by autodist
* Fri Jul 10 2009 Automatic Build System <autodist@mambasoft.it> 0.5-2mamba
- automatic rebuild by autodist
* Mon Apr 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5-1mamba
- update to 0.5
- removed compatibility headers as complained by libxine 1.1.16.3
* Mon Dec 01 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20081113-5mamba
- remove provides for libffmpeg and libffmpeg-devel
* Thu Nov 20 2008 gil <puntogil@libero.it> 20081113-4mamba
- rebuilt with new libdc1394 2.0.2
* Thu Nov 20 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20081113-3mamba
- add obsoletes for libffmpeg and libffmpeg to all subpackages
* Wed Nov 19 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20081113-2mamba
- ffmpeg: don't obsolete libpostproc
* Fri Nov 14 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20081113-1mamba
- package renamed to ffmpeg; rename libraries to standard names and add proper provides and obsoletes for upgrade
* Wed Aug 20 2008 gil <puntogil@libero.it> 20080820-1mamba
- update to 20080820
- edit configure options
- added patch
- rebuilt with: libschroedinger, libamrnb, libamrwb, ffmpeg-checkout-snapshot.tar.bz2,
- enable non free (libamrnb, libamrwb) License: unredistributable
* Mon Jun 02 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20080504-2mamba
- rebuilt with recent libdc1394
* Mon May 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20080504-1mamba
- update to 20080505
* Wed Apr 02 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20080402-1mamba
- update to 20080402
* Fri Feb 29 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20080229-1mamba
- update to 20080229
- set exported-snapshot as source instead of svn
* Sun Feb 03 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20080203-1mamba
- update to 20080203
* Thu Dec 13 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 20071213-1mamba
- update to 20071213
- enabled pthread support
- changed package maintainer
- enabled support for libtheora and libx264
* Fri Jan 19 2007 Davide Madrisan <davide.madrisan@qilinux.it> 20070119-1qilnx
- updated to subversion 20070119
- dropped patch against CVE-2005-4048 (merged upstream)
- the shared libraries are now compiled with the -fPIC option: dropped patch
* Mon Dec 19 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.4.9-2qilnx
- fixed security issue CVE-2005-4048 (qibug#97)
- gcc4 fixes; compile the library with -fPIC
- HTML documentation moved to devel package
* Fri Jun 17 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.4.9-pre1-1qilnx
- update to version 0.4.9-pre1 by autospec
* Sun Oct 03 2004 Davide Madrisan <davide.madrisan@qilinux.it> 0.4.8-2qilnx
- specfile modified to match QiLinux standards
- library name modified (was ffmpeg)
- added a path to fix the broken configure check for the imlib2 library
* Mon Sep 13 2004 Matteo Bernasconi <voyagernm@virgilio.it> 0.4.8-1qilnx
- first build