automatic rebuild by autodist [release 2.1-3mamba;Mon Jul 29 2013]
This commit is contained in:
parent
159044a955
commit
c9191bfd49
@ -1,2 +1,6 @@
|
||||
# fbset
|
||||
|
||||
Fbset is a utility for maintaining frame buffer resolutions. Fbset can change the video mode properties of a frame buffer device, and is usually used to change the current video mode.
|
||||
|
||||
Install fbset if you need to manage frame buffer resolutions.
|
||||
|
||||
|
20
fbset-2.1-fixmode.patch
Normal file
20
fbset-2.1-fixmode.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- fbset-2.1/etc/fb.modes.ATI Fri Feb 23 11:20:29 2001
|
||||
+++ fbset-2.1/etc/fb.modes.ATI Fri Feb 23 11:20:38 2001
|
||||
@@ -430,7 +430,7 @@
|
||||
# 1024x768, 72 Hz, Non-Interlaced (75.00 MHz dotclock)
|
||||
#
|
||||
# Horizontal Vertical
|
||||
-# Resolution 10224 768
|
||||
+# Resolution 1024 768
|
||||
# Scan Frequency 58.230 kHz 72.245 Hz
|
||||
# Sync Width 1.813 us 0.103 ms
|
||||
# 17 chars 6 lines
|
||||
@@ -447,7 +447,7 @@
|
||||
|
||||
mode "1024x768-72"
|
||||
# D: 75.00 MHz, H: 58.230 kHz, V: 72.245 Hz
|
||||
- geometry 10224 768 10224 768 8
|
||||
+ geometry 1024 768 1024 768 8
|
||||
timings 13334 104 24 29 3 136 6
|
||||
endmode
|
||||
|
44
fbset-2.1-makefile.patch
Normal file
44
fbset-2.1-makefile.patch
Normal file
@ -0,0 +1,44 @@
|
||||
--- fbset-2.1/Makefile Sun Jan 17 14:15:46 1999
|
||||
+++ fbset-2.1/Makefile Thu Jun 15 11:10:30 2000
|
||||
@@ -7,6 +7,12 @@
|
||||
FLEX = flex
|
||||
INSTALL = install
|
||||
RM = rm -f
|
||||
+PREFIX =
|
||||
+
|
||||
+prefix = /usr
|
||||
+sbindir = $(prefix)/sbin
|
||||
+mandir = $(prefix)/man
|
||||
+sysconfdir = /etc
|
||||
|
||||
All: fbset
|
||||
|
||||
@@ -24,18 +30,16 @@
|
||||
$(BISON) modes.y
|
||||
|
||||
install: fbset
|
||||
- if [ -f /sbin/fbset ]; then rm /sbin/fbset; fi
|
||||
- $(INSTALL) fbset /usr/sbin
|
||||
- $(INSTALL) fbset.8 /usr/man/man8
|
||||
- $(INSTALL) fb.modes.5 /usr/man/man5
|
||||
- if [ ! -c /dev/fb0 ]; then mknod /dev/fb0 c 29 0; fi
|
||||
- if [ ! -c /dev/fb1 ]; then mknod /dev/fb1 c 29 32; fi
|
||||
- if [ ! -c /dev/fb2 ]; then mknod /dev/fb2 c 29 64; fi
|
||||
- if [ ! -c /dev/fb3 ]; then mknod /dev/fb3 c 29 96; fi
|
||||
- if [ ! -c /dev/fb4 ]; then mknod /dev/fb4 c 29 128; fi
|
||||
- if [ ! -c /dev/fb5 ]; then mknod /dev/fb5 c 29 160; fi
|
||||
- if [ ! -c /dev/fb6 ]; then mknod /dev/fb6 c 29 192; fi
|
||||
- if [ ! -c /dev/fb7 ]; then mknod /dev/fb7 c 29 224; fi
|
||||
+ if [ -f $(PREFIX)/sbin/fbset ]; then rm $(PREFIX)/sbin/fbset; fi
|
||||
+ mkdir -p $(PREFIX)$(sbindir)
|
||||
+ $(INSTALL) -m 755 fbset $(PREFIX)$(sbindir)/
|
||||
+ $(INSTALL) -m 755 modeline2fb $(PREFIX)$(sbindir)/
|
||||
+ mkdir -p $(PREFIX)$(mandir)/man8
|
||||
+ $(INSTALL) -m 644 fbset.8 $(PREFIX)$(mandir)/man8/
|
||||
+ mkdir -p $(PREFIX)$(sysconfdir)
|
||||
+ $(INSTALL) -m 644 etc/fb.modes.ATI $(PREFIX)$(sysconfdir)/fb.modes
|
||||
+ mkdir -p $(PREFIX)$(mandir)/man5
|
||||
+ $(INSTALL) -m 644 fb.modes.5 $(PREFIX)$(mandir)/man5/
|
||||
|
||||
clean:
|
||||
$(RM) *.o fbset lex.yy.c modes.tab.c modes.tab.h
|
55
fbset.spec
Normal file
55
fbset.spec
Normal file
@ -0,0 +1,55 @@
|
||||
Name: fbset
|
||||
Version: 2.1
|
||||
Release: 3mamba
|
||||
Summary: Tools for managing a frame buffer's video mode properties
|
||||
Group: System/Tools
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://users.telenet.be/geertu/Linux/fbdev/
|
||||
Source: http://users.telenet.be/geertu/Linux/fbdev//%{name}-%{version}.tar.gz
|
||||
Patch0: fbset-2.1-makefile.patch
|
||||
Patch1: fbset-2.1-fixmode.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Fbset is a utility for maintaining frame buffer resolutions. Fbset can change the video mode properties of a frame buffer device, and is usually used to change the current video mode.
|
||||
|
||||
Install fbset if you need to manage frame buffer resolutions.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%make -j1 CC=%{_target_platform}-gcc
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeoldinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_sbindir}/fbset
|
||||
%{_sbindir}/modeline2fb
|
||||
%{_sysconfdir}/fb.modes
|
||||
%{_mandir}/man5/fb.modes.5.gz
|
||||
%{_mandir}/man8/fbset.8.gz
|
||||
|
||||
%changelog
|
||||
* Mon Jul 29 2013 Automatic Build System <autodist@mambasoft.it> 2.1-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Mon Jun 29 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1-2mamba
|
||||
- specfile updated and rebuilt
|
||||
|
||||
* Wed Oct 19 2005 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 2.1-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user