automatic version update by autodist [release 2.54.9-1mamba;Sun Jan 01 2023]

This commit is contained in:
Automatic Build System 2024-01-05 22:13:37 +01:00
parent 945b89b256
commit cadca93bf0
2 changed files with 58 additions and 1 deletions

View File

@ -0,0 +1,43 @@
From 2ec1754dc9863f87cc193d3e33b05fbe52ac4036 Mon Sep 17 00:00:00 2001
From: David Runge <dave@sleepmap.de>
Date: Tue, 20 Dec 2022 21:41:18 +0100
Subject: [PATCH] Revert "Correct and document sound2reader Makefile."
This reverts commit d1fe8570d2d77839359c0cd6c13bb4abc0c7efb5.
---
tools/sound2faust/Makefile | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/tools/sound2faust/Makefile b/tools/sound2faust/Makefile
index 3f7114263..5d779d158 100644
--- a/tools/sound2faust/Makefile
+++ b/tools/sound2faust/Makefile
@@ -12,20 +12,23 @@ LIBS = -lwsock32
EXE = .exe
endif
-all : static
+all : sound2faust sound2file
sound2faust : sound2faust.cpp
+
$(CXX) -O3 $(LDFLAGS) sound2faust.cpp -I../../architecture $(shell pkg-config --cflags --static --libs sndfile) -o sound2faust $(LIBS)
sound2file : sound2file.cpp
+
$(CXX) -O3 $(LDFLAGS) sound2file.cpp -I../../architecture $(shell pkg-config --cflags --static --libs sndfile) -o sound2file $(LIBS)
static:
- # To compile libsndfile in static mode and no external libs: ./configure --enable-static=yes --enable-dynamic=no --disable-external-libs
+
$(CXX) -O3 $(LDFLAGS) sound2faust.cpp -I../../architecture $(shell pkg-config --cflags sndfile) /usr/local/lib/libsndfile.a -o sound2faust
$(CXX) -O3 $(LDFLAGS) sound2file.cpp -I../../architecture $(shell pkg-config --cflags sndfile) /usr/local/lib/libsndfile.a -o sound2file
install :
+
([ -e sound2faust ]) && install sound2faust $(prefix)/bin/ || echo sound2faust not found
([ -e sound2file ]) && install sound2file $(prefix)/bin/ || echo sound2file not found
([ -e sound2reader ]) && install sound2reader $(prefix)/bin/ || echo sound2reader not found
--
2.39.0

View File

@ -1,5 +1,5 @@
Name: faust
Version: 2.41.1
Version: 2.54.9
Release: 1mamba
Summary: Functional programming language for signal processing and sound synthesis
Group: Applications/Development
@ -12,6 +12,7 @@ Patch0: faust-2.30.5-llvm-11.1.0.patch
Patch1: faust-2.30.5-missing-include-limits.patch
Patch2: faust-2.30.5-sound2file-missing-include-limits.patch
Patch3: faust-2.40.0-llvm-14.0.3.patch
Patch4: faust-2.54.9-sound2faust_makefile.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -58,6 +59,7 @@ This package contains libraries and header files for developing applications tha
#:<< _EOF
%patch2 -p1
#%patch3 -p1 -b .llvm-14.0.3
%patch4 -p1 -b .sound2faust_makefile
%build
#:<< _EOF
@ -91,6 +93,12 @@ cmake \
rm -f %{buildroot}%{_libdir}/ios-libsndfile.a
rm -f %{buildroot}%{_datadir}/faust/max-msp/sndfile/*/libsndfile.a
# remove unusable scripts
rm -v %{buildroot}%{_bindir}/faust2au
# remove precompiled shared libraries for android:
# https://github.com/grame-cncm/faust/issues/370
rm -rvf %{buildroot}%{_datadir}/faust/android/app/{lib,oboe} %{buildroot}%{_datadir}/faust/smartKeyboard/android/app/oboe
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
@ -137,6 +145,12 @@ rm -f %{buildroot}%{_datadir}/faust/max-msp/sndfile/*/libsndfile.a
%changelog
* Sun Jan 01 2023 Automatic Build System <autodist@mambasoft.it> 2.54.9-1mamba
- automatic version update by autodist
* Fri Oct 07 2022 Automatic Build System <autodist@mambasoft.it> 2.50.6-1mamba
- automatic version update by autodist
* Wed Jul 06 2022 Automatic Build System <autodist@mambasoft.it> 2.41.1-1mamba
- automatic version update by autodist