automatic version update by autodist [release 0.2.9-1mamba;Fri May 21 2021]
This commit is contained in:
parent
35d06a326e
commit
492417459e
60
farstream-0.2.9-make-4.3.patch
Normal file
60
farstream-0.2.9-make-4.3.patch
Normal file
@ -0,0 +1,60 @@
|
|||||||
|
From aa9603c6ca6055499fa5b3dcd8eb9c6cb060c86e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Lars Wendler <polynomial-c@gentoo.org>
|
||||||
|
Date: Wed, 22 Jan 2020 12:42:57 +0100
|
||||||
|
Subject: [PATCH] autotools: Fix build with make-4.3
|
||||||
|
|
||||||
|
make-4.3 introduced an incompatible change where \# is no longer necessary
|
||||||
|
inside of macro references in order to get a literal hash character.
|
||||||
|
|
||||||
|
The provided fix keeps compatibility with both make-4.3 and older make
|
||||||
|
releases
|
||||||
|
|
||||||
|
Gentoo-bug: https://bugs.gentoo.org/706080
|
||||||
|
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
|
||||||
|
---
|
||||||
|
common-modified/gst-glib-gen.mak | 4 +++-
|
||||||
|
farstream/Makefile.am | 4 +++-
|
||||||
|
2 files changed, 6 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/common-modified/gst-glib-gen.mak b/common-modified/gst-glib-gen.mak
|
||||||
|
index 14f1ba37..69ef0273 100644
|
||||||
|
--- a/common-modified/gst-glib-gen.mak
|
||||||
|
+++ b/common-modified/gst-glib-gen.mak
|
||||||
|
@@ -1,12 +1,14 @@
|
||||||
|
# these are the variables your Makefile.am should set
|
||||||
|
# the example is based on the colorbalance interface
|
||||||
|
|
||||||
|
+H := \#
|
||||||
|
+
|
||||||
|
#glib_enum_headers=$(colorbalance_headers)
|
||||||
|
#glib_enum_define=GST_COLOR_BALANCE
|
||||||
|
#glib_gen_prefix=gst_color_balance
|
||||||
|
#glib_gen_basename=colorbalance
|
||||||
|
|
||||||
|
-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
|
||||||
|
+enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
|
||||||
|
|
||||||
|
# these are all the rules generating the relevant files
|
||||||
|
$(glib_gen_basename)-enumtypes.h: $(glib_enum_headers)
|
||||||
|
diff --git a/farstream/Makefile.am b/farstream/Makefile.am
|
||||||
|
index e6b509c1..ddf03a0b 100644
|
||||||
|
--- a/farstream/Makefile.am
|
||||||
|
+++ b/farstream/Makefile.am
|
||||||
|
@@ -69,11 +69,13 @@ public_headers = fs-candidate.h \
|
||||||
|
fs-conference.h \
|
||||||
|
fs-utils.h
|
||||||
|
|
||||||
|
+H := \#
|
||||||
|
+
|
||||||
|
glib_enum_headers=$(public_headers)
|
||||||
|
glib_enum_define=FS
|
||||||
|
glib_gen_prefix=_fs
|
||||||
|
glib_gen_basename=fs
|
||||||
|
-glib_gen_decl_include=\#include <glib-object.h>
|
||||||
|
+glib_gen_decl_include=$(H)include <glib-object.h>
|
||||||
|
|
||||||
|
include $(top_srcdir)/common-modified/gst-glib-gen.mak
|
||||||
|
|
||||||
|
--
|
||||||
|
2.25.0
|
||||||
|
|
@ -1,55 +1,26 @@
|
|||||||
Name: farstream
|
Name: farstream
|
||||||
Version: 0.2.8
|
Version: 0.2.9
|
||||||
Release: 3mamba
|
Release: 1mamba
|
||||||
Summary: A collection of GStreamer modules and libraries for videoconferencing
|
Summary: A collection of GStreamer modules and libraries for videoconferencing
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.freedesktop.org/wiki/Software/Farstream
|
URL: https://www.freedesktop.org/wiki/Software/Farstream/
|
||||||
Source: http://freedesktop.org/software/farstream/releases/farstream/farstream-%{version}.tar.gz
|
Source: http://freedesktop.org/software/farstream/releases/farstream/farstream-%{version}.tar.gz
|
||||||
|
Patch0: farstream-0.2.9-make-4.3.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libblkid-devel
|
|
||||||
BuildRequires: libdw-devel
|
|
||||||
BuildRequires: libe2fs-devel
|
|
||||||
BuildRequires: libelf-devel
|
|
||||||
BuildRequires: libffi-devel
|
|
||||||
BuildRequires: libgcc
|
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
BuildRequires: libgmp-devel
|
|
||||||
BuildRequires: libgnutls-devel
|
|
||||||
BuildRequires: libgssdp-devel
|
|
||||||
BuildRequires: libgst-plugins-base-devel
|
BuildRequires: libgst-plugins-base-devel
|
||||||
BuildRequires: libgstreamer-devel
|
BuildRequires: libgstreamer-devel
|
||||||
BuildRequires: libgupnp-devel
|
|
||||||
BuildRequires: libgupnp-igd-devel
|
BuildRequires: libgupnp-igd-devel
|
||||||
BuildRequires: libidn-devel
|
|
||||||
BuildRequires: libkrb5-devel
|
|
||||||
BuildRequires: liblzma-devel
|
|
||||||
BuildRequires: libmount-devel
|
|
||||||
BuildRequires: libnettle-devel
|
|
||||||
BuildRequires: libnice-devel
|
BuildRequires: libnice-devel
|
||||||
BuildRequires: libp11-kit-devel
|
|
||||||
BuildRequires: libpcre-devel
|
|
||||||
BuildRequires: libselinux-devel
|
|
||||||
BuildRequires: libsepol-devel
|
|
||||||
BuildRequires: libsoup-devel
|
|
||||||
BuildRequires: libsqlite-devel
|
|
||||||
BuildRequires: libtasn1-devel
|
|
||||||
BuildRequires: libunistring-devel
|
|
||||||
BuildRequires: libunwind-devel
|
|
||||||
BuildRequires: libuuid-devel
|
|
||||||
BuildRequires: libxml2-devel
|
|
||||||
BuildRequires: libz-devel
|
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libnice-devel >= 0.1.3
|
BuildRequires: libnice-devel >= 0.1.8
|
||||||
Provides: libfarsight2 = %{version}
|
Provides: libfarsight2 = %{version}
|
||||||
Obsoletes: libfarsight2 < 0.0.32
|
Obsoletes: libfarsight2 < 0.0.32
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%debug_package
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Farstream is a collection of GStreamer modules and libraries for videoconferencing.
|
Farstream is a collection of GStreamer modules and libraries for videoconferencing.
|
||||||
@ -81,8 +52,12 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
%description -n python-%{name}
|
%description -n python-%{name}
|
||||||
Python bindings for %{name}.
|
Python bindings for %{name}.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
./autogen.sh
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -142,6 +117,9 @@ rm -f %{buildroot}%{_libdir}/libfarstream-*.a
|
|||||||
#%{python_sitearch}/farstream.so
|
#%{python_sitearch}/farstream.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 21 2021 Automatic Build System <autodist@mambasoft.it> 0.2.9-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sun Aug 26 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.8-3mamba
|
* Sun Aug 26 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.8-3mamba
|
||||||
- fix for arm, added package name and origin
|
- fix for arm, added package name and origin
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user