falcon/falcon.spec

153 lines
4.6 KiB
RPMSpec

%define majver %(echo %{version} | cut -d. -f 1-3)
Name: falcon
Version: 0.9.6.8
Release: 3mamba
Summary: The Falcon programming language
Group: Development/Languages
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.falconpl.org
Source: http://www.falconpl.org/project_dl/_official_rel/Falcon-%{version}.tgz
Patch: %{name}-0.8.3-tmppath_install.patch
Patch1: falcon-0.9.6.8-x86_64-int64.patch
Patch2: falcon-0.9.6.8-gcc-11.patch
Patch3: falcon-0.9.6.8-mariadb-10.6.3.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libSDL-devel
BuildRequires: libSDL_image-devel
BuildRequires: libSDL_mixer-devel
BuildRequires: libSDL_ttf-devel
BuildRequires: libatk-devel
BuildRequires: libcairo-devel
BuildRequires: libcurl-devel
BuildRequires: libdbus-devel
BuildRequires: libfreetype-devel
BuildRequires: libgcc
BuildRequires: libgd-devel
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel
BuildRequires: libgtk2-devel
BuildRequires: libharfbuzz-devel
BuildRequires: libjpeg-devel
BuildRequires: libmariadb-devel
BuildRequires: libpango-devel
BuildRequires: libpcre-devel
BuildRequires: libpng-devel
BuildRequires: libpostgresql-devel
BuildRequires: libsqlite-devel
BuildRequires: libstdc++6-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: cmake
BuildRequires: libgd-devel >= 2.3.2
Provides: Falcon = %{name}-%{version}
%description
The Falcon Programming Language is an embeddable scripting language aiming to empower even simple applications with a powerful, flexible, extensible and highly configurable scripting engine.
Falcon is also a standalone multiplatform scripting language that aims to be both simple and powerful.
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Provides: Falcon-devel = %{name}-%{version}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
The Falcon Programming Language is an embeddable scripting language aiming to empower even simple applications with a powerful, flexible, extensible and highly configurable scripting engine.
Falcon is also a standalone multiplatform scripting language that aims to be both simple and powerful.
This package contains static libraries and header files needed for development.
%debug_package
%prep
%setup -q -n Falcon-%{version}
%patch1 -p1
%patch2 -p1
%patch3 -p1
%build
%cmake -d build \
-DFALCON_INC_DIR="include" \
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
-DCMAKE_INSTALL_LIBDIR:PATH=%{_libdir} \
-DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
-DLIB_INSTALL_DIR:PATH=%{_libdir} \
-DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
-DSHARE_INSTALL_PREFIX:PATH=%{_datadir} \
-DBUILD_SHARED_LIBS:BOOL=ON . \
-DMONGO_HAVE_STDINT=ON \
-DCMAKE_CXX_FLAGS="%{optflags} --std=c++11"
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
#./build.sh -i
%makeinstall -C build
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/falcon
%{_bindir}/falconenv.sh
%{_bindir}/faldisass
%{_bindir}/faldoc
%{_bindir}/fallc.fal
%{_bindir}/falpack
%{_bindir}/falrun
%{_bindir}/icomp.sh
%{_libdir}/falcon/
%{_libdir}/libfalcon_engine.so.*
%{_mandir}/man1/falcon.*
%{_mandir}/man1/faldisass.*
%{_mandir}/man1/fallc.fal.*
%{_mandir}/man1/falpack.*
%{_mandir}/man1/falrun.*
%doc AUTHORS
%files devel
%defattr(-,root,root)
%{_bindir}/falcon-conf
%{_bindir}/falconeer.fal
%{_bindir}/faltest
%{_datadir}/falcon%{majver}/*
%{_datadir}/cmake/faldoc/faldoc-config.cmake
%{_includedir}/falcon/*
#%{_includedir}/fasm/
%{_libdir}/libfalcon_engine.so
%{_mandir}/man1/falcon-conf.*
%{_mandir}/man1/falconeer.fal.*
%{_mandir}/man1/faltest.*
%doc ChangeLog README
%changelog
* Sun Aug 01 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.6.8-3mamba
- rebuilt with libgd 2.3.2 and debug package
* Wed Jul 24 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.6.8-2mamba
- rebuild with libpcre 8.33
* Wed Feb 23 2011 Automatic Build System <autodist@mambasoft.it> 0.9.6.8-1mamba
- automatic update by autodist
* Wed Dec 15 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.6.6-1mamba
- update to 0.9.6.6
* Tue Nov 09 2010 Automatic Build System <autodist@mambasoft.it> 0.9.6.5-1mamba
- automatic update by autodist
* Fri Feb 05 2010 Davide Madrisan <davide.madrisan@gmail.com> 0.8.14.2-1mamba
- update to 0.8.14.2
* Tue Sep 11 2007 Aleph0 <aleph0@openmamba.org> 0.8.3-1mamba
- package created by autospec