rebuild with libpcre 8.33 [release 0.9.6.8-2mamba;Wed Jul 24 2013]

This commit is contained in:
Silvan Calarco 2024-01-05 22:12:52 +01:00
parent e06e32070c
commit 99cb568938
4 changed files with 219 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# falcon # falcon
The Falcon Programming Language is an embeddable scripting language aiming to empower even simple applications with a powerful, flexible, extensible and highly configurable scripting engine.
Falcon is also a standalone multiplatform scripting language that aims to be both simple and powerful.

View File

@ -0,0 +1,18 @@
--- Falcon-0.8.3/src/falcon_engine/Makefile.in.orig 2007-08-18 14:25:16.000000000 +0200
+++ Falcon-0.8.3/src/falcon_engine/Makefile.in 2007-09-11 22:32:05.000000000 +0200
@@ -652,13 +652,13 @@
install: libfalcon_engine.@DYNEXT@
- mkdir -p @dynlibdir@
+ mkdir -p $(DESTDIR)@dynlibdir@
rm -f libfalcon_engine.@DYNEXT@.@ENGINE_VERSION_CURRENT@.@ENGINE_VERSION_REVISION@.@ENGINE_VERSION_AGE@
rm -f libfalcon_engine.@DYNEXT@.@ENGINE_VERSION_CURRENT@.@ENGINE_VERSION_REVISION@
rm -f libfalcon_engine.@DYNEXT@.@ENGINE_VERSION_CURRENT@
mv -f libfalcon_engine.@DYNEXT@ libfalcon_engine.@DYNEXT@.@ENGINE_VERSION_CURRENT@.@ENGINE_VERSION_REVISION@.@ENGINE_VERSION_AGE@
ln -s libfalcon_engine.@DYNEXT@.@ENGINE_VERSION_CURRENT@.@ENGINE_VERSION_REVISION@.@ENGINE_VERSION_AGE@ libfalcon_engine.@DYNEXT@.@ENGINE_VERSION_CURRENT@
- cp -d libfalcon_engine.@DYNEXT@* @dynlibdir@
+ cp -d libfalcon_engine.@DYNEXT@* $(DESTDIR)@dynlibdir@
uninstall:
rm -f @dynlibdir@/libfalcon_engine.@DYNEXT@.@ENGINE_VERSION_CURRENT@.@ENGINE_VERSION_REVISION@.@ENGINE_VERSION_AGE@

View File

@ -0,0 +1,75 @@
From 64526ea7d3b5ec04f398bd28cb4e505e6a0f3218 Mon Sep 17 00:00:00 2001
From: Stanislas Marquis <stnsls@gmail.com>
Date: Sun, 9 Jan 2011 08:40:00 +0100
Subject: [PATCH] [mongo] [cmake] Fix problems with Linux x64.
---
modules/native/mongodb/CMakeLists.txt | 11 +++++++++--
modules/native/mongodb/mongodb_mod.cpp | 2 +-
modules/native/mongodb/src/CMakeLists.txt | 8 ++++++--
3 files changed, 16 insertions(+), 5 deletions(-)
diff --git a/modules/native/mongodb/CMakeLists.txt b/modules/native/mongodb/CMakeLists.txt
index ba7e5cf..bf2d869 100644
--- a/modules/native/mongodb/CMakeLists.txt
+++ b/modules/native/mongodb/CMakeLists.txt
@@ -8,6 +8,10 @@ falcon_define_module( FALCON_MODULE mongo )
message( STATUS "Adding mongodb module" )
+if ( NOT MSVC )
+ option( MONGO_HAVE_STDINT "MongoDB problem with int64_t?" OFF )
+endif()
+
##
# Find Falcon
#
@@ -28,8 +32,11 @@ add_subdirectory( src )
if ( MSVC )
add_definitions( -DMONGO_USE__INT64 )
else()
- #add_definitions( -DMONGO_HAVE_STDINT )
- add_definitions( -DMONGO_USE_LONG_LONG_INT )
+ if ( MONGO_HAVE_STDINT )
+ add_definitions( -DMONGO_HAVE_STDINT )
+ else()
+ add_definitions( -DMONGO_USE_LONG_LONG_INT )
+ endif()
endif()
##
diff --git a/modules/native/mongodb/mongodb_mod.cpp b/modules/native/mongodb/mongodb_mod.cpp
index 6102664..4d47fac 100644
--- a/modules/native/mongodb/mongodb_mod.cpp
+++ b/modules/native/mongodb/mongodb_mod.cpp
@@ -1321,7 +1321,7 @@ BSONIter::makeItem( const bson_type tp,
//...
break;
case bson_long:
- it = new Item( bson_iterator_long_raw( iter ) );
+ it = new Item( (int64) bson_iterator_long_raw( iter ) );
break;
case bson_eoo:
default:
diff --git a/modules/native/mongodb/src/CMakeLists.txt b/modules/native/mongodb/src/CMakeLists.txt
index 48cdaef..d883af3 100644
--- a/modules/native/mongodb/src/CMakeLists.txt
+++ b/modules/native/mongodb/src/CMakeLists.txt
@@ -7,8 +7,12 @@ include_directories( BEFORE . )
if ( MSVC )
add_definitions( -DMONGO_USE__INT64 )
else()
- add_definitions( -DMONGO_USE_LONG_LONG_INT )
- #add_definitions( --std=c99 )
+ add_definitions( -fPIC )
+ if ( MONGO_HAVE_STDINT )
+ add_definitions( -DMONGO_HAVE_STDINT )
+ else()
+ add_definitions( -DMONGO_USE_LONG_LONG_INT )
+ endif()
endif()
set( MONGO_SRCS
--
1.7.9.1

123
falcon.spec Normal file
View File

@ -0,0 +1,123 @@
%define majver %(echo %{version} | cut -d. -f 1-3)
Name: falcon
Version: 0.9.6.8
Release: 2mamba
Summary: The Falcon programming language
Group: Development/Languages
Vendor: openmamba
Distribution: openmamba
Packager: Davide Madrisan <davide.madrisan@gmail.com>
URL: http://www.falconpl.org
Source: http://www.falconpl.org/project_dl/_official_rel/Falcon-%{version}.tgz
Patch: %{name}-0.8.3-tmppath_install.patch
Patch1: falcon-0.9.6.8-x86_64-int64.patch
License: GPL
Provides: Falcon = %{name}-%{version}
BuildRequires: cmake
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcc
BuildRequires: libpcre-devel
BuildRequires: libstdc++6-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
The Falcon Programming Language is an embeddable scripting language aiming to empower even simple applications with a powerful, flexible, extensible and highly configurable scripting engine.
Falcon is also a standalone multiplatform scripting language that aims to be both simple and powerful.
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Provides: Falcon-devel = %{name}-%{version}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
The Falcon Programming Language is an embeddable scripting language aiming to empower even simple applications with a powerful, flexible, extensible and highly configurable scripting engine.
Falcon is also a standalone multiplatform scripting language that aims to be both simple and powerful.
This package contains static libraries and header files need for development.
%prep
%setup -q -n Falcon-%{version}
%patch1 -p1
%build
cmake \
-DFALCON_INC_DIR="include" \
-DFALCON_LIB_DIR="%{_lib}" \
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
-DCMAKE_INSTALL_LIBDIR:PATH=%{_libdir} \
-DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
-DLIB_INSTALL_DIR:PATH=%{_libdir} \
-DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
-DSHARE_INSTALL_PREFIX:PATH=%{_datadir} \
-DBUILD_SHARED_LIBS:BOOL=ON . \
-DMONGO_HAVE_STDINT=ON
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
#./build.sh -i
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/falcon
%{_bindir}/falconenv.sh
%{_bindir}/faldisass
%{_bindir}/faldoc
%{_bindir}/fallc.fal
%{_bindir}/falpack
%{_bindir}/falrun
%{_bindir}/icomp.sh
%{_libdir}/falcon/
%{_libdir}/libfalcon_engine.so.*
%{_mandir}/man1/falcon.*
%{_mandir}/man1/faldisass.*
%{_mandir}/man1/fallc.fal.*
%{_mandir}/man1/falpack.*
%{_mandir}/man1/falrun.*
%doc AUTHORS ChangeLog README
%files devel
%defattr(-,root,root)
%{_bindir}/falcon-conf
%{_bindir}/falconeer.fal
%{_bindir}/faltest
%{_datadir}/falcon%{majver}/*
%{_datadir}/cmake/faldoc/faldoc-config.cmake
%{_includedir}/falcon/*
#%{_includedir}/fasm/
%{_libdir}/libfalcon_engine.so
%{_mandir}/man1/falcon-conf.*
%{_mandir}/man1/falconeer.fal.*
%{_mandir}/man1/faltest.*
%changelog
* Wed Jul 24 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.6.8-2mamba
- rebuild with libpcre 8.33
* Wed Feb 23 2011 Automatic Build System <autodist@mambasoft.it> 0.9.6.8-1mamba
- automatic update by autodist
* Wed Dec 15 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.6.6-1mamba
- update to 0.9.6.6
* Tue Nov 09 2010 Automatic Build System <autodist@mambasoft.it> 0.9.6.5-1mamba
- automatic update by autodist
* Fri Feb 05 2010 Davide Madrisan <davide.madrisan@gmail.com> 0.8.14.2-1mamba
- update to 0.8.14.2
* Tue Sep 11 2007 Aleph0 <aleph0@openmamba.org> 0.8.3-1mamba
- package created by autospec