rebuilt with libgd 2.3.2 and debug package [release 0.9.6.8-3mamba;Sun Aug 01 2021]
This commit is contained in:
parent
99cb568938
commit
6232e94cf1
11
falcon-0.9.6.8-gcc-11.patch
Normal file
11
falcon-0.9.6.8-gcc-11.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- Falcon-0.9.6.8/engine/stringstream.cpp.orig 2021-08-01 11:59:44.996279728 +0200
|
||||
+++ Falcon-0.9.6.8/engine/stringstream.cpp 2021-08-01 11:57:31.978930456 +0200
|
||||
@@ -199,7 +199,7 @@
|
||||
switch( m_lastError )
|
||||
{
|
||||
case 0: description = "None"; return true;
|
||||
- case -1: description = "Out of Memory"; return true;
|
||||
+ //case -1: description = "Out of Memory"; return true;
|
||||
}
|
||||
|
||||
return false;
|
11
falcon-0.9.6.8-mariadb-10.6.3.patch
Normal file
11
falcon-0.9.6.8-mariadb-10.6.3.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- Falcon-0.9.6.8/modules/native/dbi/mysql/mysql_mod.cpp.orig 2021-08-01 12:10:19.638687653 +0200
|
||||
+++ Falcon-0.9.6.8/modules/native/dbi/mysql/mysql_mod.cpp 2021-08-01 12:29:02.491416367 +0200
|
||||
@@ -22,6 +22,8 @@
|
||||
#include "mysql_mod.h"
|
||||
#include <mysqld_error.h>
|
||||
|
||||
+#define IS_LONGDATA(t) ((t) >= MYSQL_TYPE_TINY_BLOB && (t) <= MYSQL_TYPE_STRING)
|
||||
+
|
||||
|
||||
namespace Falcon
|
||||
{
|
51
falcon.spec
51
falcon.spec
@ -2,27 +2,49 @@
|
||||
|
||||
Name: falcon
|
||||
Version: 0.9.6.8
|
||||
Release: 2mamba
|
||||
Release: 3mamba
|
||||
Summary: The Falcon programming language
|
||||
Group: Development/Languages
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.falconpl.org
|
||||
Source: http://www.falconpl.org/project_dl/_official_rel/Falcon-%{version}.tgz
|
||||
Patch: %{name}-0.8.3-tmppath_install.patch
|
||||
Patch1: falcon-0.9.6.8-x86_64-int64.patch
|
||||
Patch2: falcon-0.9.6.8-gcc-11.patch
|
||||
Patch3: falcon-0.9.6.8-mariadb-10.6.3.patch
|
||||
License: GPL
|
||||
Provides: Falcon = %{name}-%{version}
|
||||
BuildRequires: cmake
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libSDL_image-devel
|
||||
BuildRequires: libSDL_mixer-devel
|
||||
BuildRequires: libSDL_ttf-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgd-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libmariadb-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpostgresql-devel
|
||||
BuildRequires: libsqlite-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRequires: cmake
|
||||
BuildRequires: libgd-devel >= 2.3.2
|
||||
Provides: Falcon = %{name}-%{version}
|
||||
|
||||
%description
|
||||
The Falcon Programming Language is an embeddable scripting language aiming to empower even simple applications with a powerful, flexible, extensible and highly configurable scripting engine.
|
||||
@ -37,17 +59,19 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
%description devel
|
||||
The Falcon Programming Language is an embeddable scripting language aiming to empower even simple applications with a powerful, flexible, extensible and highly configurable scripting engine.
|
||||
Falcon is also a standalone multiplatform scripting language that aims to be both simple and powerful.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n Falcon-%{version}
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
cmake \
|
||||
%cmake -d build \
|
||||
-DFALCON_INC_DIR="include" \
|
||||
-DFALCON_LIB_DIR="%{_lib}" \
|
||||
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
|
||||
-DCMAKE_INSTALL_LIBDIR:PATH=%{_libdir} \
|
||||
-DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
|
||||
@ -55,14 +79,15 @@ cmake \
|
||||
-DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
|
||||
-DSHARE_INSTALL_PREFIX:PATH=%{_datadir} \
|
||||
-DBUILD_SHARED_LIBS:BOOL=ON . \
|
||||
-DMONGO_HAVE_STDINT=ON
|
||||
-DMONGO_HAVE_STDINT=ON \
|
||||
-DCMAKE_CXX_FLAGS="%{optflags} --std=c++11"
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
#./build.sh -i
|
||||
%makeinstall
|
||||
%makeinstall -C build
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -87,7 +112,7 @@ cmake \
|
||||
%{_mandir}/man1/fallc.fal.*
|
||||
%{_mandir}/man1/falpack.*
|
||||
%{_mandir}/man1/falrun.*
|
||||
%doc AUTHORS ChangeLog README
|
||||
%doc AUTHORS
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
@ -102,8 +127,12 @@ cmake \
|
||||
%{_mandir}/man1/falcon-conf.*
|
||||
%{_mandir}/man1/falconeer.fal.*
|
||||
%{_mandir}/man1/faltest.*
|
||||
%doc ChangeLog README
|
||||
|
||||
%changelog
|
||||
* Sun Aug 01 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.6.8-3mamba
|
||||
- rebuilt with libgd 2.3.2 and debug package
|
||||
|
||||
* Wed Jul 24 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.6.8-2mamba
|
||||
- rebuild with libpcre 8.33
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user