added a patch for gcc 8.1 [release 1.2.1-2mamba;Tue Aug 21 2018]
This commit is contained in:
parent
3db3a3d7eb
commit
61e9e8b1bd
23
etl-1.2.1-gc-8.1.patch
Normal file
23
etl-1.2.1-gc-8.1.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
From cb05b072fe6fffb4433140c631f422bdbc036722 Mon Sep 17 00:00:00 2001
|
||||||
|
From: ice0 <konoplin@gmail.com>
|
||||||
|
Date: Sat, 26 May 2018 07:54:58 -0700
|
||||||
|
Subject: [PATCH] fixed error preventing builing on gcc 8.1
|
||||||
|
|
||||||
|
---
|
||||||
|
ETL/ETL/_pen.h | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/ETL/ETL/_pen.h b/ETL/ETL/_pen.h
|
||||||
|
index 7c57f702e..13913be97 100644
|
||||||
|
--- a/ETL/ETL/_pen.h
|
||||||
|
+++ b/ETL/ETL/_pen.h
|
||||||
|
@@ -136,7 +136,8 @@ class generic_pen
|
||||||
|
typedef int value_type;
|
||||||
|
value_type x,y;
|
||||||
|
difference_type(value_type x, value_type y):x(x),y(y) { }
|
||||||
|
- value_type &operator[](int i)const { return i?y:x; }
|
||||||
|
+ const value_type &operator[](int i) const { return i?y:x; }
|
||||||
|
+ value_type &operator[](int i) { return i?y:x; }
|
||||||
|
};
|
||||||
|
|
||||||
|
protected:
|
7
etl.spec
7
etl.spec
@ -1,6 +1,6 @@
|
|||||||
Name: etl
|
Name: etl
|
||||||
Version: 1.2.1
|
Version: 1.2.1
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A multi-platform class and template library designed to add new datatypes and functions
|
Summary: A multi-platform class and template library designed to add new datatypes and functions
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,6 +8,7 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://synfig.org/
|
URL: http://synfig.org/
|
||||||
Source: https://downloads.sourceforge.net/project/synfig/releases/%{version}/source/ETL-%{version}.tar.gz
|
Source: https://downloads.sourceforge.net/project/synfig/releases/%{version}/source/ETL-%{version}.tar.gz
|
||||||
|
Patch0: etl-1.2.1-gc-8.1.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
@ -28,6 +29,7 @@ ETL is a multi-platform class and template library designed to add new datatypes
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n ETL-%{version}
|
%setup -q -n ETL-%{version}
|
||||||
|
%patch0 -p2
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -50,6 +52,9 @@ ETL is a multi-platform class and template library designed to add new datatypes
|
|||||||
%doc ChangeLog NEWS README
|
%doc ChangeLog NEWS README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 21 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.1-2mamba
|
||||||
|
- added a patch for gcc 8.1
|
||||||
|
|
||||||
* Sat Dec 23 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.1-1mamba
|
* Sat Dec 23 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.1-1mamba
|
||||||
- update to 1.2.1
|
- update to 1.2.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user