update to 1.5.3 [release 1.5.3-1mamba;Fri Jan 03 2025]
This commit is contained in:
parent
f90f66641d
commit
38a5c0ab21
@ -1,23 +0,0 @@
|
||||
From cb05b072fe6fffb4433140c631f422bdbc036722 Mon Sep 17 00:00:00 2001
|
||||
From: ice0 <konoplin@gmail.com>
|
||||
Date: Sat, 26 May 2018 07:54:58 -0700
|
||||
Subject: [PATCH] fixed error preventing builing on gcc 8.1
|
||||
|
||||
---
|
||||
ETL/ETL/_pen.h | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/ETL/ETL/_pen.h b/ETL/ETL/_pen.h
|
||||
index 7c57f702e..13913be97 100644
|
||||
--- a/ETL/ETL/_pen.h
|
||||
+++ b/ETL/ETL/_pen.h
|
||||
@@ -136,7 +136,8 @@ class generic_pen
|
||||
typedef int value_type;
|
||||
value_type x,y;
|
||||
difference_type(value_type x, value_type y):x(x),y(y) { }
|
||||
- value_type &operator[](int i)const { return i?y:x; }
|
||||
+ const value_type &operator[](int i) const { return i?y:x; }
|
||||
+ value_type &operator[](int i) { return i?y:x; }
|
||||
};
|
||||
|
||||
protected:
|
11
etl.spec
11
etl.spec
@ -1,5 +1,5 @@
|
||||
Name: etl
|
||||
Version: 1.4.5
|
||||
Version: 1.5.3
|
||||
Release: 1mamba
|
||||
Summary: A multi-platform class and template library designed to add new datatypes and functions
|
||||
Group: Development/Libraries
|
||||
@ -7,8 +7,7 @@ Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.synfig.org/
|
||||
Source: https://sourceforge.net/projects/synfig/files/stable/%{version}/source/ETL-%{version}.tar.gz
|
||||
Patch0: etl-1.2.1-gc-8.1.patch
|
||||
Source: https://github.com/synfig/synfig/releases/download/v%{version}/ETL-%{version}.tar.gz
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
## AUTOBUILDREQ-END
|
||||
@ -24,11 +23,10 @@ Provides: ETL-devel
|
||||
%description devel
|
||||
ETL is a multi-platform class and template library designed to add new datatypes and functions which combine well with the existing types and functions from the C++ Standard Template Library (STL).
|
||||
|
||||
#% debug_package
|
||||
%define debug_package %{nil}
|
||||
|
||||
%prep
|
||||
%setup -q -n ETL-%{version}
|
||||
#%patch0 -p2
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -51,6 +49,9 @@ ETL is a multi-platform class and template library designed to add new datatypes
|
||||
#%doc ChangeLog NEWS README
|
||||
|
||||
%changelog
|
||||
* Fri Jan 03 2025 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.3-1mamba
|
||||
- update to 1.5.3
|
||||
|
||||
* Thu Nov 07 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.5-1mamba
|
||||
- update to 1.4.5
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user