189 lines
7.7 KiB
RPMSpec
189 lines
7.7 KiB
RPMSpec
Name: eric
|
|
Version: 5.5.2
|
|
Release: 2mamba
|
|
Summary: A full featured Python and Ruby editor and IDE, written in Python
|
|
Group: Graphical Desktop/Applications/Development
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
|
|
URL: http://eric-ide.python-projects.org
|
|
Source: http://downloads.sourceforge.net/eric-ide/eric5/stable/%{version}/eric5-%{version}.tar.gz
|
|
Source1: http://downloads.sourceforge.net/eric-ide/eric5/stable/%{version}/eric5-i18n-cs-%{version}.tar.gz
|
|
Source2: http://downloads.sourceforge.net/eric-ide/eric5/stable/%{version}/eric5-i18n-de-%{version}.tar.gz
|
|
Source3: http://downloads.sourceforge.net/eric-ide/eric5/stable/%{version}/eric5-i18n-es-%{version}.tar.gz
|
|
Source4: http://downloads.sourceforge.net/eric-ide/eric5/stable/%{version}/eric5-i18n-fr-%{version}.tar.gz
|
|
Source5: http://downloads.sourceforge.net/eric-ide/eric5/stable/%{version}/eric5-i18n-it-%{version}.tar.gz
|
|
Source6: http://downloads.sourceforge.net/eric-ide/eric5/stable/%{version}/eric5-i18n-tr-%{version}.tar.gz
|
|
Source7: http://downloads.sourceforge.net/eric-ide/eric5/stable/%{version}/eric5-i18n-ru-%{version}.tar.gz
|
|
Source8: http://downloads.sourceforge.net/eric-ide/eric5/stable/%{version}/eric5-i18n-zh_CN.GB2312-%{version}.tar.gz
|
|
Source9: eric4.desktop
|
|
Patch0: eric4-4.3.9-python.patch
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libpython-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: python-qscintilla-py3
|
|
BuildRequires: python-qscintilla-devel
|
|
BuildRequires: python-xml
|
|
BuildRequires: qscintilla-devel
|
|
BuildRequires: PyQt4-py3
|
|
BuildRequires: PyQt4-devel
|
|
Requires: PyQt4-py3
|
|
Requires: python-qscintilla-py3
|
|
Requires: libqt4-designer
|
|
Requires: python-sip-py3
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
Eric Integrated Development Environment is based on the cross platform Qt gui toolkit, integrating the highly flexible Scintilla editor control.
|
|
It is designed to be usable as everdays' quick and dirty editor as well as being usable as a professional project management tool integrating many advanced features Python offers the professional coder.
|
|
Eric includes a plugin system, which allows easy extension of the IDE functionality with plugins downloadable from the net.
|
|
|
|
%prep
|
|
%setup -q -n eric5-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8
|
|
%patch0 -p1
|
|
|
|
mv eric5-%{version}/eric/i18n/*.qm eric/i18n/
|
|
rm -fr eric5-%{version}
|
|
|
|
%build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%{__python3} install.py \
|
|
-i %{buildroot}/ \
|
|
-b %{_bindir} \
|
|
-d %{python3_sitearch}
|
|
|
|
# Remove %{builddir} in API path
|
|
sed -i -e 's|%{buildroot}||' %{buildroot}%{python3_sitearch}/eric5config.py
|
|
|
|
# Generate api files
|
|
install -d %{buildroot}%{_datadir}/eric/
|
|
PyQt4_apis="QtAssistant.api QtCore.api QtGui.api QtNetwork.api QtOpenGL.api QtSql.api QtSvg.api QtXml.api"
|
|
PyKDE_apis="dcop.api kdecore.api kdefx.api kdeprint.api kdeui.api kfile.api khtml.api kmdi.api kparts.api kspell.api kutils.api"
|
|
for api in $PyQt4_apis $PyKDE_apis ; do
|
|
> %{buildroot}%{_datadir}/eric/$api
|
|
echo "%ghost %{_datadir}/eric/$api" >> %{name}-api.list
|
|
done
|
|
|
|
# Fix some permission
|
|
chmod a+x %{buildroot}%{python3_sitearch}/eric5/ThirdParty/brm/bike/parsing/fastparser.py ||:
|
|
chmod a+x %{buildroot}%{python3_sitearch}/eric5/*.py ||:
|
|
chmod a+x %{buildroot}%{python3_sitearch}/eric5/uninstall.py
|
|
chmod a+x %{buildroot}%{python3_sitearch}/eric5/Examples/hallo.py
|
|
#chmod a+x %{buildroot}%{python3_sitearch}/eric5/DebugClients/Python/PyCoverage.py
|
|
chmod a+x %{buildroot}%{python3_sitearch}/eric5/Examples/rhallo.py
|
|
#chmod a-x %{buildroot}%{python3_sitearch}/eric5/patch_pyxml.py
|
|
|
|
# Add environment variables for PySide, PyQt5, PyKDE5, Qt, Qt5 and Python documentations
|
|
sed -i -e 's|exec|QT5DIR=%{_qt5_prefix}\nPYTHONDOCDIR=\$(echo %{_docdir}/python-[0-9\.]*/html)\nQT5DOCDIR=%{_qt5_docdir}/html\nPYQT5DOCDIR=\$(echo %{_docdir}/PyQt5-devel-*/html)\nPYKDE5DOCDIR=\$(echo %{_docdir}/PyKDE5-devel-*/html)\nPYSIDEDOCDIR=$(echo %{_docdir}/python-pyside-devel-*/html)\nexport QT5DIR PYTHONDOCDIR QTDOCDIR QT5DOCDIR PYQT5DOCDIR PYKDE5DOCDIR PYSIDEDOCDIR\n&|' %{buildroot}%{_bindir}/eric5
|
|
#sed -i -e 's|"QtToolsPostfix4" : "",|"QtToolsPostfix4" : "-qt4",|' %{buildroot}%{python3_sitearch}/eric4/Preferences/__init__.py
|
|
|
|
#desktop-file-install \
|
|
# --dir %{buildroot}/%{_datadir}/applications/ \
|
|
# --vendor="" \
|
|
# %{S:9}
|
|
#
|
|
#install -m 644 -p -D \
|
|
# %{buildroot}%{python_sitearch}/eric4/icons/default/eric.png \
|
|
# %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/eric4.png
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f %{name}-api.list
|
|
%defattr(-,root,root)
|
|
%{_bindir}/eric5
|
|
%{_bindir}/eric5_*
|
|
%dir %{python3_sitearch}/eric5
|
|
%{python3_sitearch}/eric5/*
|
|
%{python3_sitearch}/eric5config.py
|
|
%dir %{python3_sitearch}/eric5plugins
|
|
%{python3_sitearch}/eric5plugins/__init__.py
|
|
%{_datadir}/applications/eric5.desktop
|
|
%{_datadir}/appdata/eric5.appdata.xml
|
|
%{_datadir}/applications/eric5_webbrowser.desktop
|
|
%{_datadir}/pixmaps/eric*.png
|
|
%{_datadir}/qt4/qsci/api/python/*
|
|
%{_datadir}/qt4/qsci/api/ruby/*
|
|
%{_datadir}/qt4/qsci/api/qss/qss.api
|
|
%doc THANKS
|
|
#README README-i18n.txt
|
|
|
|
%changelog
|
|
* Fri Jan 02 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 5.5.2-2mamba
|
|
- require python-sip-py3
|
|
|
|
* Thu Dec 11 2014 Automatic Build System <autodist@mambasoft.it> 5.5.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 21 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 5.4.6-1mamba
|
|
- update to 5.4.6
|
|
|
|
* Mon Sep 15 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.24-1mamba
|
|
- update to 4.5.24
|
|
|
|
* Mon Aug 04 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.23-1mamba
|
|
- update to 4.5.23
|
|
|
|
* Tue Apr 01 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.20-1mamba
|
|
- update to 4.5.20
|
|
|
|
* Tue Feb 25 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.19-1mamba
|
|
- update to 4.5.19
|
|
|
|
* Thu Jul 11 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.13-1mamba
|
|
- update to 4.5.13
|
|
|
|
* Sat Dec 15 2012 Automatic Build System <autodist@mambasoft.it> 4.5.7-1mamba
|
|
- update to 4.5.7
|
|
|
|
* Fri Sep 09 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.17-1mamba
|
|
- update to 4.4.17
|
|
|
|
* Sun Aug 21 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.16-1mamba
|
|
- update to 4.4.16
|
|
|
|
* Wed May 18 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.14-1mamba
|
|
- update to 4.4.14
|
|
|
|
* Sun Nov 07 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.9-2mamba
|
|
- added support to python-pyside documentation
|
|
|
|
* Sat Nov 06 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.9-1mamba
|
|
- update to 4.4.9
|
|
|
|
* Tue Sep 28 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.8-1mamba
|
|
- update to 4.4.8
|
|
|
|
* Thu Aug 26 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.7-1mamba
|
|
- update to 4.4.7
|
|
|
|
* Fri Jul 23 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.6-1mamba
|
|
- update to 4.4.6
|
|
|
|
* Mon Jun 14 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.5-1mamba
|
|
- update to 4.4.5
|
|
|
|
* Wed May 12 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.4a-1mamba
|
|
- update to 4.4.4a
|
|
|
|
* Mon May 10 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.4-1mamba
|
|
- update to 4.4.4
|
|
|
|
* Mon Apr 12 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.3-1mamba
|
|
- update to 4.4.3
|
|
- added italian language
|
|
|
|
* Wed Dec 30 2009 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.3.10-2mamba
|
|
- fixed file permissions
|
|
- added environment variables to launch script
|
|
- added missing build requirements
|
|
|
|
* Wed Dec 23 2009 Automatic Build System <autodist@mambasoft.it> 4.3.10-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon Dec 07 2009 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.3.9-1mamba
|
|
- package created by autospec
|