automatic version update by autodist [release 25.1-1mamba;Sat Jan 18 2025]
This commit is contained in:
parent
5e1a82a2f6
commit
56ca0b0089
28
eric.spec
28
eric.spec
@ -1,7 +1,7 @@
|
||||
%define MAJver 7
|
||||
%define pkgver %(echo %version | cut -d. -f1-2 | tr -d 0)
|
||||
Name: eric
|
||||
Version: 24.12
|
||||
Version: 25.1
|
||||
Release: 1mamba
|
||||
Summary: A full featured Python and Ruby editor and IDE, written in Python
|
||||
Group: Graphical Desktop/Applications/Development
|
||||
@ -11,13 +11,12 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://eric-ide.python-projects.org
|
||||
Source: http://downloads.sourceforge.net/sourceforge/eric-ide/eric7-%{version}.tar.gz
|
||||
Source9: eric4.desktop
|
||||
Patch0: eric4-4.3.9-python.patch
|
||||
License: GPL
|
||||
BuildArch: noarch
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: libpython311-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: python-qscintilla-py3 >= 2.10.8-2mamba
|
||||
#BuildRequires: python-xml
|
||||
BuildRequires: qscintilla-devel
|
||||
BuildRequires: PyQt5-py3
|
||||
BuildRequires: PyQt5-devel
|
||||
@ -37,7 +36,6 @@ Eric includes a plugin system, which allows easy extension of the IDE functional
|
||||
|
||||
%prep
|
||||
%setup -q -n eric%{MAJver}-%{version}
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
|
||||
@ -49,25 +47,6 @@ Eric includes a plugin system, which allows easy extension of the IDE functional
|
||||
-b %{_bindir} \
|
||||
-d %{python3_sitearch}
|
||||
|
||||
## Remove %{builddir} in API path
|
||||
#sed -i -e 's|%{buildroot}||' %{buildroot}%{python3_sitearch}/eric%{MAJver}config.py
|
||||
|
||||
## Generate api files
|
||||
#install -d %{buildroot}%{_datadir}/eric/
|
||||
#PyQt4_apis="QtAssistant.api QtCore.api QtGui.api QtNetwork.api QtOpenGL.api QtSql.api QtSvg.api QtXml.api"
|
||||
#PyKDE_apis="dcop.api kdecore.api kdefx.api kdeprint.api kdeui.api kfile.api khtml.api kmdi.api kparts.api kspell.api kutils.api"
|
||||
#for api in $PyQt4_apis $PyKDE_apis ; do
|
||||
# > %{buildroot}%{_datadir}/eric/$api
|
||||
# echo "%ghost %{_datadir}/eric/$api" >> %{name}-api.list
|
||||
#done
|
||||
|
||||
## Fix some permission
|
||||
#chmod a+x %{buildroot}%{python3_sitearch}/eric%{MAJver}/*.py ||:
|
||||
|
||||
## Add environment variables for PySide, PyQt5, PyKDE5, Qt, Qt5 and Python documentations
|
||||
#sed -i -e 's|exec|QT5DIR=%{_qt5_prefix}\nPYTHONDOCDIR=\$(echo %{_docdir}/python-[0-9\.]*/html)\nQT5DOCDIR=%{_qt5_docdir}/html\nPYQT5DOCDIR=\$(echo %{_docdir}/PyQt5-devel-*/html)\nPYKDE5DOCDIR=\$(echo %{_docdir}/PyKDE5-devel-*/html)\nPYSIDEDOCDIR=$(echo %{_docdir}/python-pyside-devel-*/html)\nexport QT5DIR PYTHONDOCDIR QTDOCDIR QT5DOCDIR PYQT5DOCDIR PYKDE5DOCDIR PYSIDEDOCDIR\n&|' %{buildroot}%{_bindir}/eric%{MAJver}
|
||||
##sed -i -e 's|"QtToolsPostfix4" : "",|"QtToolsPostfix4" : "-qt4",|' %{buildroot}%{python3_sitearch}/eric4/Preferences/__init__.py
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
@ -95,6 +74,9 @@ Eric includes a plugin system, which allows easy extension of the IDE functional
|
||||
#README README-i18n.txt
|
||||
|
||||
%changelog
|
||||
* Sat Jan 18 2025 Automatic Build System <autodist@openmamba.org> 25.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Dec 02 2024 Automatic Build System <autodist@openmamba.org> 24.12-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
@ -1,16 +0,0 @@
|
||||
diff -up eric4-4.3.3/eric/__init__.py.patch eric4-4.3.3/eric/__init__.py
|
||||
--- eric4-4.3.3/eric/__init__.py.patch 2009-05-19 07:19:09.000000000 +0200
|
||||
+++ eric4-4.3.3/eric/__init__.py 2009-05-19 07:19:16.000000000 +0200
|
||||
@@ -1,3 +1,4 @@
|
||||
+#!/usr/bin/env python
|
||||
# -*- coding: utf-8 -*-
|
||||
|
||||
# Copyright (c) 2003 - 2009 Detlev Offenbach <detlev@die-offenbachs.de>
|
||||
diff -up eric4-4.3.3/eric/patch_modpython.py.patch eric4-4.3.3/eric/patch_modpython.py
|
||||
--- eric4-4.3.3/eric/patch_modpython.py.patch 2009-05-19 07:18:51.000000000 +0200
|
||||
+++ eric4-4.3.3/eric/patch_modpython.py 2009-05-19 07:19:00.000000000 +0200
|
||||
@@ -1,3 +1,4 @@
|
||||
+#!/usr/bin/env python
|
||||
# -*- coding: utf-8 -*-
|
||||
|
||||
# Copyright (c) 2003-2009 Detlev Offenbach <detlev@die-offenbachs.de>
|
Loading…
x
Reference in New Issue
Block a user