update to 4.5.20 [release 4.5.20-1mamba;Tue Apr 01 2014]
This commit is contained in:
parent
79b9a8edb4
commit
2a96a6afd4
@ -1,2 +1,6 @@
|
|||||||
# eric
|
# eric
|
||||||
|
|
||||||
|
Eric Integrated Development Environment is based on the cross platform Qt gui toolkit, integrating the highly flexible Scintilla editor control.
|
||||||
|
It is designed to be usable as everdays' quick and dirty editor as well as being usable as a professional project management tool integrating many advanced features Python offers the professional coder.
|
||||||
|
Eric includes a plugin system, which allows easy extension of the IDE functionality with plugins downloadable from the net.
|
||||||
|
|
||||||
|
160
eric.spec
Normal file
160
eric.spec
Normal file
@ -0,0 +1,160 @@
|
|||||||
|
Name: eric
|
||||||
|
Version: 4.5.20
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A full featured Python and Ruby editor and IDE, written in Python
|
||||||
|
Group: Graphical Desktop/Applications/Development
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
|
||||||
|
URL: http://eric-ide.python-projects.org
|
||||||
|
Source: http://downloads.sourceforge.net/eric-ide/eric4/stable/%{version}/eric4-%{version}.tar.gz
|
||||||
|
Source1: http://downloads.sourceforge.net/eric-ide/eric4/stable/%{version}/eric4-i18n-cs-%{version}.tar.gz
|
||||||
|
Source2: http://downloads.sourceforge.net/eric-ide/eric4/stable/%{version}/eric4-i18n-de-%{version}.tar.gz
|
||||||
|
Source3: http://downloads.sourceforge.net/eric-ide/eric4/stable/%{version}/eric4-i18n-es-%{version}.tar.gz
|
||||||
|
Source4: http://downloads.sourceforge.net/eric-ide/eric4/stable/%{version}/eric4-i18n-fr-%{version}.tar.gz
|
||||||
|
Source5: http://downloads.sourceforge.net/eric-ide/eric4/stable/%{version}/eric4-i18n-it-%{version}.tar.gz
|
||||||
|
Source6: http://downloads.sourceforge.net/eric-ide/eric4/stable/%{version}/eric4-i18n-tr-%{version}.tar.gz
|
||||||
|
Source7: http://downloads.sourceforge.net/eric-ide/eric4/stable/%{version}/eric4-i18n-ru-%{version}.tar.gz
|
||||||
|
Source8: http://downloads.sourceforge.net/eric-ide/eric4/stable/%{version}/eric4-i18n-zh_CN.GB2312-%{version}.tar.gz
|
||||||
|
Source9: eric4.desktop
|
||||||
|
Patch0: eric4-4.3.9-python.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: libpython-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: python-qscintilla-devel
|
||||||
|
BuildRequires: python-xml
|
||||||
|
BuildRequires: qscintilla-devel
|
||||||
|
Requires: python-qscintilla
|
||||||
|
Requires: libqt4-designer
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Eric Integrated Development Environment is based on the cross platform Qt gui toolkit, integrating the highly flexible Scintilla editor control.
|
||||||
|
It is designed to be usable as everdays' quick and dirty editor as well as being usable as a professional project management tool integrating many advanced features Python offers the professional coder.
|
||||||
|
Eric includes a plugin system, which allows easy extension of the IDE functionality with plugins downloadable from the net.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n eric4-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
mv eric4-%{version}/eric/i18n/*.qm eric/i18n/
|
||||||
|
rm -fr eric4-%{version}
|
||||||
|
|
||||||
|
%build
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%{__python} install.py \
|
||||||
|
-i %{buildroot}/ \
|
||||||
|
-b %{_bindir} \
|
||||||
|
-d %{python_sitearch}
|
||||||
|
|
||||||
|
# Remove %{builddir} in API path
|
||||||
|
sed -i -e 's|%{buildroot}||' %{buildroot}%{python_sitearch}/eric4config.py
|
||||||
|
|
||||||
|
# Generate api files
|
||||||
|
install -d %{buildroot}%{_datadir}/eric/
|
||||||
|
PyQt4_apis="QtAssistant.api QtCore.api QtGui.api QtNetwork.api QtOpenGL.api QtSql.api QtSvg.api QtXml.api"
|
||||||
|
PyKDE_apis="dcop.api kdecore.api kdefx.api kdeprint.api kdeui.api kfile.api khtml.api kmdi.api kparts.api kspell.api kutils.api"
|
||||||
|
for api in $PyQt4_apis $PyKDE_apis ; do
|
||||||
|
> %{buildroot}%{_datadir}/eric/$api
|
||||||
|
echo "%ghost %{_datadir}/eric/$api" >> %{name}-api.list
|
||||||
|
done
|
||||||
|
|
||||||
|
# Fix some permission
|
||||||
|
chmod a+x %{buildroot}%{python_sitearch}/eric4/ThirdParty/brm/bike/parsing/fastparser.py ||:
|
||||||
|
chmod a+x %{buildroot}%{python_sitearch}/eric4/*.py ||:
|
||||||
|
chmod a+x %{buildroot}%{python_sitearch}/eric4/uninstall.py
|
||||||
|
chmod a+x %{buildroot}%{python_sitearch}/eric4/Examples/hallo.py
|
||||||
|
#chmod a+x %{buildroot}%{python_sitearch}/eric4/DebugClients/Python/PyCoverage.py
|
||||||
|
chmod a+x %{buildroot}%{python_sitearch}/eric4/Examples/rhallo.py
|
||||||
|
chmod a-x %{buildroot}%{python_sitearch}/eric4/patch_pyxml.py
|
||||||
|
|
||||||
|
# Add environment variables for PySide, PyQt4, PyKDE4, Qt, Qt4 and Python documentations
|
||||||
|
sed -i -e 's|exec|QT4DIR=%{_qt4_prefix}\nPYTHONDOCDIR=\$(echo %{_docdir}/python-[0-9\.]*/html)\nQTDOCDIR=%{_qt3_docdir}/html\nQT4DOCDIR=%{_qt4_docdir}/html\nPYQT4DOCDIR=\$(echo %{_docdir}/PyQt4-devel-*/html)\nPYKDE4DOCDIR=\$(echo %{_docdir}/PyKDE4-devel-*/html)\nPYSIDEDOCDIR=$(echo %{_docdir}/python-pyside-devel-*/html)\nexport QT4DIR PYTHONDOCDIR QTDOCDIR QT4DOCDIR PYQT4DOCDIR PYKDE4DOCDIR PYSIDEDOCDIR\n&|' %{buildroot}%{_bindir}/eric4
|
||||||
|
sed -i -e 's|"QtToolsPostfix4" : "",|"QtToolsPostfix4" : "-qt4",|' %{buildroot}%{python_sitearch}/eric4/Preferences/__init__.py
|
||||||
|
|
||||||
|
desktop-file-install \
|
||||||
|
--dir %{buildroot}/%{_datadir}/applications/ \
|
||||||
|
--vendor="" \
|
||||||
|
%{S:9}
|
||||||
|
|
||||||
|
install -m 644 -p -D \
|
||||||
|
%{buildroot}%{python_sitearch}/eric4/icons/default/eric.png \
|
||||||
|
%{buildroot}%{_datadir}/icons/hicolor/32x32/apps/eric4.png
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -f %{name}-api.list
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/eric4
|
||||||
|
%{_bindir}/eric4_*
|
||||||
|
%{python_sitearch}/eric4*
|
||||||
|
%{_datadir}/applications/eric4.desktop
|
||||||
|
%{_datadir}/icons/hicolor/32x32/apps/eric4.png
|
||||||
|
%{_datadir}/qt4/qsci/api/python/*.api
|
||||||
|
%{_datadir}/qt4/qsci/api/ruby/*.api
|
||||||
|
%doc README README-i18n.txt THANKS
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Apr 01 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.20-1mamba
|
||||||
|
- update to 4.5.20
|
||||||
|
|
||||||
|
* Tue Feb 25 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.19-1mamba
|
||||||
|
- update to 4.5.19
|
||||||
|
|
||||||
|
* Thu Jul 11 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.13-1mamba
|
||||||
|
- update to 4.5.13
|
||||||
|
|
||||||
|
* Sat Dec 15 2012 Automatic Build System <autodist@mambasoft.it> 4.5.7-1mamba
|
||||||
|
- update to 4.5.7
|
||||||
|
|
||||||
|
* Fri Sep 09 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.17-1mamba
|
||||||
|
- update to 4.4.17
|
||||||
|
|
||||||
|
* Sun Aug 21 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.16-1mamba
|
||||||
|
- update to 4.4.16
|
||||||
|
|
||||||
|
* Wed May 18 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.14-1mamba
|
||||||
|
- update to 4.4.14
|
||||||
|
|
||||||
|
* Sun Nov 07 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.9-2mamba
|
||||||
|
- added support to python-pyside documentation
|
||||||
|
|
||||||
|
* Sat Nov 06 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.9-1mamba
|
||||||
|
- update to 4.4.9
|
||||||
|
|
||||||
|
* Tue Sep 28 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.8-1mamba
|
||||||
|
- update to 4.4.8
|
||||||
|
|
||||||
|
* Thu Aug 26 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.7-1mamba
|
||||||
|
- update to 4.4.7
|
||||||
|
|
||||||
|
* Fri Jul 23 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.6-1mamba
|
||||||
|
- update to 4.4.6
|
||||||
|
|
||||||
|
* Mon Jun 14 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.5-1mamba
|
||||||
|
- update to 4.4.5
|
||||||
|
|
||||||
|
* Wed May 12 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.4a-1mamba
|
||||||
|
- update to 4.4.4a
|
||||||
|
|
||||||
|
* Mon May 10 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.4-1mamba
|
||||||
|
- update to 4.4.4
|
||||||
|
|
||||||
|
* Mon Apr 12 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.4.3-1mamba
|
||||||
|
- update to 4.4.3
|
||||||
|
- added italian language
|
||||||
|
|
||||||
|
* Wed Dec 30 2009 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.3.10-2mamba
|
||||||
|
- fixed file permissions
|
||||||
|
- added environment variables to launch script
|
||||||
|
- added missing build requirements
|
||||||
|
|
||||||
|
* Wed Dec 23 2009 Automatic Build System <autodist@mambasoft.it> 4.3.10-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Mon Dec 07 2009 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.3.9-1mamba
|
||||||
|
- package created by autospec
|
16
eric4-4.3.9-python.patch
Normal file
16
eric4-4.3.9-python.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
diff -up eric4-4.3.3/eric/__init__.py.patch eric4-4.3.3/eric/__init__.py
|
||||||
|
--- eric4-4.3.3/eric/__init__.py.patch 2009-05-19 07:19:09.000000000 +0200
|
||||||
|
+++ eric4-4.3.3/eric/__init__.py 2009-05-19 07:19:16.000000000 +0200
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+#!/usr/bin/env python
|
||||||
|
# -*- coding: utf-8 -*-
|
||||||
|
|
||||||
|
# Copyright (c) 2003 - 2009 Detlev Offenbach <detlev@die-offenbachs.de>
|
||||||
|
diff -up eric4-4.3.3/eric/patch_modpython.py.patch eric4-4.3.3/eric/patch_modpython.py
|
||||||
|
--- eric4-4.3.3/eric/patch_modpython.py.patch 2009-05-19 07:18:51.000000000 +0200
|
||||||
|
+++ eric4-4.3.3/eric/patch_modpython.py 2009-05-19 07:19:00.000000000 +0200
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+#!/usr/bin/env python
|
||||||
|
# -*- coding: utf-8 -*-
|
||||||
|
|
||||||
|
# Copyright (c) 2003-2009 Detlev Offenbach <detlev@die-offenbachs.de>
|
9
eric4.desktop
Normal file
9
eric4.desktop
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
[Desktop Entry]
|
||||||
|
Name=Eric
|
||||||
|
Comment=Python IDE
|
||||||
|
Exec=eric4
|
||||||
|
Icon=eric4
|
||||||
|
Terminal=false
|
||||||
|
Type=Application
|
||||||
|
Encoding=UTF-8
|
||||||
|
Categories=Development;
|
Loading…
Reference in New Issue
Block a user