automatic version update by autodist [release 3.10.3-1mamba;Wed Dec 11 2013]
This commit is contained in:
parent
67811196a5
commit
649555cfa9
@ -1,2 +1,5 @@
|
||||
# epiphany
|
||||
|
||||
Epiphany is the web browser for the GNOME desktop. Its goal is to be simple and easy to use.
|
||||
Epiphany ties together many GNOME components in order to let you focus on the Web content, instead of the browser application.
|
||||
|
||||
|
11
epiphany-2.24.0.1-desktop.patch
Normal file
11
epiphany-2.24.0.1-desktop.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- epiphany-2.24.0.1/data/epiphany.desktop.in.in 2008-09-01 13:58:34.000000000 +0200
|
||||
+++ epiphany-2.24.0.1/data/epiphany.desktop.in.in-gil 2008-10-21 14:23:57.000000000 +0200
|
||||
@@ -6,7 +6,7 @@
|
||||
StartupNotify=true
|
||||
Terminal=false
|
||||
Type=Application
|
||||
-Icon=gnome-web-browser
|
||||
+Icon=/usr/share/pixmaps/epiphany.png
|
||||
X-GNOME-Bugzilla-Bugzilla=GNOME
|
||||
X-GNOME-Bugzilla-Product=epiphany
|
||||
X-GNOME-Bugzilla-Component=BugBuddyBugs
|
11
epiphany-2.24.0.1-homepage.patch
Normal file
11
epiphany-2.24.0.1-homepage.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- epiphany-2.24.0.1/data/epiphany.schemas.in 2008-03-28 15:59:45.000000000 +0100
|
||||
+++ epiphany-2.24.0.1/data/epiphany.schemas.in-gil 2008-10-21 14:53:42.000000000 +0200
|
||||
@@ -5,7 +5,7 @@
|
||||
<applyto>/apps/epiphany/general/homepage</applyto>
|
||||
<owner>epiphany</owner>
|
||||
<type>string</type>
|
||||
- <default>http://www.google.com</default>
|
||||
+ <default>file:///usr/share/epiphany/bookmarks/0-openmamba-default-bookmars2.html</default>
|
||||
<locale name="C">
|
||||
<short>Home page</short>
|
||||
<long>Address of the user's home page.</long>
|
18
epiphany-2.28.2-bookmarks.patch
Normal file
18
epiphany-2.28.2-bookmarks.patch
Normal file
@ -0,0 +1,18 @@
|
||||
--- src/bookmarks/ephy-bookmarks.c 2009-12-16 11:26:27.000000000 +0100
|
||||
+++ src/bookmarks/ephy-bookmarks.c-gil 2010-09-25 14:34:46.000000000 +0200
|
||||
@@ -129,14 +129,7 @@
|
||||
static void
|
||||
ephy_bookmarks_init_defaults (EphyBookmarks *eb)
|
||||
{
|
||||
- int i;
|
||||
-
|
||||
- for (i = 0; i < G_N_ELEMENTS (default_topics); i++)
|
||||
- {
|
||||
- ephy_bookmarks_add_keyword (eb, _(default_topics[i]));
|
||||
- }
|
||||
-
|
||||
- ephy_bookmarks_import_rdf (eb, DATADIR "/default-bookmarks.rdf");
|
||||
+ ephy_bookmarks_import_mozilla (eb, "/usr/share/epiphany/bookmarks/0-openmamba-default-bookmars2.html");
|
||||
}
|
||||
|
||||
static void
|
38
epiphany-2.30.6-libnotify-0.7.patch
Normal file
38
epiphany-2.30.6-libnotify-0.7.patch
Normal file
@ -0,0 +1,38 @@
|
||||
--- embed/downloader-view.c
|
||||
+++ embed/downloader-view.c
|
||||
@@ -36,6 +36,9 @@
|
||||
|
||||
#ifdef HAVE_LIBNOTIFY
|
||||
#include <libnotify/notify.h>
|
||||
+#ifndef NOTIFY_CHECK_VERSION
|
||||
+#define NOTIFY_CHECK_VERSION(x,y,z) 0
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
enum
|
||||
@@ -337,7 +340,12 @@
|
||||
g_object_ref (dv);
|
||||
|
||||
notification = notify_notification_new (title, msg,
|
||||
- GTK_STOCK_INFO, NULL);
|
||||
+ GTK_STOCK_INFO
|
||||
+#if NOTIFY_CHECK_VERSION (0, 7, 0)
|
||||
+ );
|
||||
+#else
|
||||
+ , NULL);
|
||||
+#endif
|
||||
|
||||
g_signal_connect_after (notification, "closed",
|
||||
G_CALLBACK (notification_closed_cb), dv);
|
||||
@@ -346,7 +354,11 @@
|
||||
notify_notification_set_timeout (notification, NOTIFY_EXPIRES_DEFAULT);
|
||||
notify_notification_set_urgency (notification, NOTIFY_URGENCY_LOW);
|
||||
|
||||
+#if NOTIFY_CHECK_VERSION (0, 7, 0)
|
||||
+ /* notify_notification_attach_to_status_icon was removed */
|
||||
+#else
|
||||
notify_notification_attach_to_status_icon (notification, status_icon);
|
||||
+#endif
|
||||
|
||||
/* There are some visual glitches when the notification is shown and
|
||||
* the GtkStatusIcon is still not visible. To avoid that, we delay the
|
14
epiphany-2.30.6-password-migration.patch
Normal file
14
epiphany-2.30.6-password-migration.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- lib/ephy-profile-migration.c 2010-04-02 18:17:25.000000000 +0200
|
||||
+++ lib/ephy-profile-migration.c-gil 2010-10-05 23:46:44.000000000 +0200
|
||||
@@ -193,7 +193,10 @@
|
||||
while (lines[end] && !g_str_equal (lines[end], "."))
|
||||
end++;
|
||||
|
||||
- i = end + 1;
|
||||
+ if (lines[end])
|
||||
+ i = end + 1;
|
||||
+ else
|
||||
+ i = end;
|
||||
|
||||
/* A block has at least five lines */
|
||||
if (end - begin < 5)
|
BIN
epiphany-64.png
Normal file
BIN
epiphany-64.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 4.7 KiB |
61
epiphany-default-bookmarks.rdf
Normal file
61
epiphany-default-bookmarks.rdf
Normal file
@ -0,0 +1,61 @@
|
||||
<?xml version="1.0"?>
|
||||
<rdf:RDF xmlns="http://purl.org/rss/1.0/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:ephy="http://gnome.org/ns/epiphany#" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
|
||||
<channel rdf:about="file:///usr/share/epiphany/default-bookmarks.rdf">
|
||||
<title>Epiphany bookmarks</title>
|
||||
<link>http://www.gnome.org/projects/epiphany/</link>
|
||||
<items>
|
||||
<rdf:Seq>
|
||||
<rdf:li rdf:resource="http://www.openmamba.org/community/"/>
|
||||
<rdf:li rdf:resource="http://www.openmamba.org/distribution/packages.html"/>
|
||||
<rdf:li rdf:resource="http://www.openmamba.org/distribution/download.html"/>
|
||||
<rdf:li rdf:resource="http://wiki.openmamba.org/it/index.php/Pagina_principale"/>
|
||||
<rdf:li rdf:resource="http://www.openmamba.org/distribution/development.html"/>
|
||||
<rdf:li rdf:resource="http://forum.openmamba.org/"/>
|
||||
<rdf:li rdf:resource="http://www.openmamba.org/info.html"/>
|
||||
<rdf:li rdf:resource="http://www.openmamba.org/distribution/install.html"/>
|
||||
<rdf:li rdf:resource="http://bugs.openmamba.org/my_view_page.php/"/>
|
||||
<rdf:li rdf:resource="http://www.google.com/"/>
|
||||
</rdf:Seq>
|
||||
</items>
|
||||
</channel>
|
||||
<item rdf:about="http://www.openmamba.org/community/">
|
||||
<title>Community</title>
|
||||
<link>http://www.openmamba.org/community/</link>
|
||||
</item>
|
||||
<item rdf:about="http://www.openmamba.org/distribution/packages.html">
|
||||
<title>Usa</title>
|
||||
<link>http://www.openmamba.org/distribution/packages.html</link>
|
||||
</item>
|
||||
<item rdf:about="http://www.openmamba.org/distribution/download.html">
|
||||
<title>Scarica</title>
|
||||
<link>http://www.openmamba.org/distribution/download.html</link>
|
||||
</item>
|
||||
<item rdf:about="http://wiki.openmamba.org/it/index.php/Pagina_principale">
|
||||
<title>Wiki</title>
|
||||
<link>http://wiki.openmamba.org/it/index.php/Pagina_principale</link>
|
||||
</item>
|
||||
<item rdf:about="http://www.openmamba.org/distribution/development.html">
|
||||
<title>Sviluppa</title>
|
||||
<link>http://www.openmamba.org/distribution/development.html</link>
|
||||
</item>
|
||||
<item rdf:about="http://forum.openmamba.org/">
|
||||
<title>Forum</title>
|
||||
<link>http://forum.openmamba.org/</link>
|
||||
</item>
|
||||
<item rdf:about="http://www.openmamba.org/info.html">
|
||||
<title>Leggi</title>
|
||||
<link>http://www.openmamba.org/info.html</link>
|
||||
</item>
|
||||
<item rdf:about="http://www.openmamba.org/distribution/install.html">
|
||||
<title>Installa</title>
|
||||
<link>http://www.openmamba.org/distribution/install.html</link>
|
||||
</item>
|
||||
<item rdf:about="http://bugs.openmamba.org/my_view_page.php/">
|
||||
<title>Aggiusta</title>
|
||||
<link>http://bugs.openmamba.org/my_view_page.php/</link>
|
||||
</item>
|
||||
<item rdf:about="http://www.google.com/">
|
||||
<title>Google</title>
|
||||
<link>http://www.google.com/</link>
|
||||
</item>
|
||||
</rdf:RDF>
|
BIN
epiphany.png
Normal file
BIN
epiphany.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 4.6 KiB |
460
epiphany.spec
Normal file
460
epiphany.spec
Normal file
@ -0,0 +1,460 @@
|
||||
%define majver %(echo %version | cut -d. -f 1-2)
|
||||
%define with_ca_mgr 1
|
||||
%define with_seed 0
|
||||
Name: epiphany
|
||||
Version: 3.10.3
|
||||
Release: 1mamba
|
||||
Summary: The web browser for the GNOME desktop
|
||||
Group: Graphical Desktop/Applications/Internet
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Automatic Build System <autodist@mambasoft.it>
|
||||
URL: http://www.gnome.org/projects/epiphany/
|
||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/%{majver}/epiphany-%{version}.tar.xz
|
||||
Source1: epiphany-64.png
|
||||
# TODO
|
||||
# tar -cz bookmarks > bookmarks.tar.gz
|
||||
Source2: epiphany-1-bookmarks.tar.gz
|
||||
|
||||
Source3: epiphany.png
|
||||
Source4: epiphany-default-bookmarks.rdf
|
||||
Patch0: epiphany-2.24.0.1-desktop.patch
|
||||
# TODO
|
||||
Patch1: epiphany-2.24.0.1-homepage.patch
|
||||
Patch2: epiphany-2.28.2-bookmarks.patch
|
||||
|
||||
Patch3: epiphany-2.30.6-password-migration.patch
|
||||
Patch4: epiphany-2.30.6-libnotify-0.7.patch
|
||||
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: GConf-devel
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: gobject-introspection
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libavahi-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libdbus-glib-devel
|
||||
BuildRequires: libenchant-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libgeoclue-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libglitz-devel
|
||||
BuildRequires: libgnome-keyring-devel
|
||||
BuildRequires: libgnutls-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libgst-plugins-base-devel
|
||||
BuildRequires: libgstreamer-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libicu-devel
|
||||
#BuildRequires: libjpeg-turbo-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libnotify-devel
|
||||
BuildRequires: libnspr-devel
|
||||
BuildRequires: libnss-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpixman-devel
|
||||
BuildRequires: libpng12-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libproxy-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libsoup-devel
|
||||
BuildRequires: libsqlite-devel
|
||||
BuildRequires: libstartup-notification-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtasn1-devel
|
||||
BuildRequires: libwebkit-gtk-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxcb-util-devel
|
||||
BuildRequires: libXcomposite-devel
|
||||
BuildRequires: libXcursor-devel
|
||||
BuildRequires: libXdamage-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXi-devel
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libxslt-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: ORBit2-devel
|
||||
%if %with_seed
|
||||
BuildRequires: seed-devel
|
||||
%endif
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: ca-certificates
|
||||
BuildRequires: eggdbus
|
||||
BuildRequires: glib-gettextize
|
||||
BuildRequires: gnome-desktop-devel
|
||||
BuildRequires: iso-codes-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libart_lgpl-devel
|
||||
BuildRequires: libaudiofile-devel
|
||||
BuildRequires: libbonobo-devel
|
||||
BuildRequires: libbonoboui-devel
|
||||
BuildRequires: libcanberra-devel
|
||||
BuildRequires: libcares-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libe2fs-devel
|
||||
BuildRequires: libesound-devel
|
||||
BuildRequires: libglade-devel
|
||||
BuildRequires: libgnomecanvas-devel
|
||||
BuildRequires: libgnome-devel
|
||||
BuildRequires: libgnomeui-devel
|
||||
BuildRequires: libgnome-vfs-devel
|
||||
BuildRequires: libidn-devel
|
||||
BuildRequires: libkrb5-devel
|
||||
BuildRequires: libnm-devel
|
||||
BuildRequires: libopenldap-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpopt-devel
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libsasl-devel
|
||||
BuildRequires: libssh2-devel
|
||||
BuildRequires: pygtk-devel
|
||||
BuildRequires: python-gnome-devel
|
||||
Requires: ca-certificates
|
||||
Requires(post):desktop-file-utils
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
# Epiphany was configured with the following options:
|
||||
|
||||
# Zeroconf bookmarks support : yes
|
||||
# NetworkManager support : yes
|
||||
|
||||
# TODO
|
||||
# GObject introspection : no
|
||||
# Seed support : no
|
||||
|
||||
# Namespace is empty; likely causes are:
|
||||
# Not including .h files to be scanned
|
||||
# Broken --identifier-prefix
|
||||
# [Epiphany-2.29.gir] Error 1
|
||||
|
||||
# NSS support : yes
|
||||
# Build tests : yes
|
||||
# CA Certificates file : %{_sysconfdir}/pki/tls/certs/ca-bundle.crt
|
||||
|
||||
%description
|
||||
Epiphany is the web browser for the GNOME desktop. Its goal is to be simple and easy to use.
|
||||
Epiphany ties together many GNOME components in order to let you focus on the Web content, instead of the browser application.
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Epiphany is a GNOME web browser based on the WebKit rendering engine.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package apidocs
|
||||
Summary: %{name} api docunentation
|
||||
Group: Documentation
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description apidocs
|
||||
Epiphany is a GNOME web browser based on the WebKit rendering engine.
|
||||
|
||||
This package contains %{name} api docunentation.
|
||||
.
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
# TODO
|
||||
#%patch1 -p1
|
||||
#sed -i "s|<default>file:///usr/share/epiphany/bookmarks/0-openmamba-default-bookmars2.html</default>|<default>http://www.openmamba.org/</default>|" data/epiphany.schemas.in
|
||||
%patch2
|
||||
|
||||
#%patch3
|
||||
#%patch4 -p0
|
||||
|
||||
cat >> data/default-prefs-common.js << EOF
|
||||
pref("general.useragent.vendor", "openmamba");
|
||||
pref("general.useragent.vendorSub", "%{version}-%{release}");
|
||||
EOF
|
||||
|
||||
for p in $(find . -name "*.py"); do
|
||||
sed -i 's|#!python|#!%{__python}|' $p
|
||||
sed -i 's|#! python|#!%{__python}|' $p
|
||||
sed -i 's|#!/usr/bin/python|#!%{__python}|' $p
|
||||
sed -i 's|#!/usr/bin/env python|#!%{__python}|' $p
|
||||
sed -i 's|#! /usr/bin/env python|#!%{__python}|' $p
|
||||
done
|
||||
|
||||
sed -i "s|python2.5|python2.6|" configure
|
||||
|
||||
%build
|
||||
|
||||
#autoreconf -i -f
|
||||
export RPM_OPT_FLAGS="$(echo %{optflags} | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')"
|
||||
%configure \
|
||||
--with-ca-file=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
|
||||
--enable-debug \
|
||||
--with-distributor-name=openmamba \
|
||||
%if %with_seed
|
||||
--enable-introspection=yes \
|
||||
--enable-seed \
|
||||
%else
|
||||
--enable-introspection=no \
|
||||
%endif
|
||||
--enable-network-manager \
|
||||
--disable-schemas-install \
|
||||
--disable-scrollkeeper \
|
||||
--enable-nss \
|
||||
--enable-zeroconf \
|
||||
--enable-gtk-doc \
|
||||
PYTHON=%{__python}
|
||||
%make
|
||||
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=474987
|
||||
cd po
|
||||
grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$\|.*[.]schemas[.]in$" POTFILES.in > POTFILES.keep
|
||||
mv POTFILES.keep POTFILES.in
|
||||
intltool-update --pot
|
||||
for p in *.po; do
|
||||
msgmerge $p %{name}.pot > $p.out
|
||||
msgfmt -o `basename $p .po`.gmo $p.out
|
||||
done
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
|
||||
%makeinstall
|
||||
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/pixmaps
|
||||
install -m 644 %{S:1} %{buildroot}%{_datadir}/pixmaps/%{name}.png
|
||||
|
||||
# TODO
|
||||
tar -C %{buildroot}%{_datadir}/epiphany -zxvf %{S:2}
|
||||
|
||||
rm -f %{buildroot}%{_datadir}/epiphany/default-bookmarks.rdf
|
||||
install -pm 644 %{S:4} %{buildroot}%{_datadir}/epiphany/default-bookmarks.rdf
|
||||
|
||||
rm -f %{buildroot}%{_libdir}/epiphany/*/plugins/*.la
|
||||
|
||||
# Don't ship icon caches, either
|
||||
rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
|
||||
rm -f %{buildroot}%{_datadir}/icons/HighContrastLargePrint/icon-theme.cache
|
||||
rm -f %{buildroot}%{_datadir}/icons/HighContrastLargePrintInverse/icon-theme.cache
|
||||
|
||||
# LowContrastLargePrint seems to be obsolete, so remove it until further notice
|
||||
rm -rf %{buildroot}%{_datadir}/icons/LowContrastLargePrint
|
||||
|
||||
helpdir=%{buildroot}%{_datadir}/gnome/help/%{name}
|
||||
for f in $helpdir/C/figures/*.png; do
|
||||
b="$(basename $f)"
|
||||
for d in $helpdir/*; do
|
||||
if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
|
||||
g="$d/figures/$b"
|
||||
if [ -f "$g" ]; then
|
||||
if cmp -s $f $g; then
|
||||
rm "$g"; ln -s "../../C/figures/$b" "$g"
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
done
|
||||
done
|
||||
|
||||
mkdir -p %{buildroot}%{_libdir}/epiphany/%{majver}/{plugins,extensions}
|
||||
ln -sf %{majver}/plugins %{buildroot}%{_libdir}/epiphany/plugins
|
||||
ln -sf %{majver}/extensions %{buildroot}%{_libdir}/epiphany/extensions
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
%{_bindir}/update-desktop-database -q %{_datadir}/applications
|
||||
if [ $1 -ge 1 ]; then
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
fi
|
||||
touch --no-create %{_datadir}/icons/hicolor
|
||||
touch --no-create %{_datadir}/icons/HighContrastLargePrint
|
||||
touch --no-create %{_datadir}/icons/HighContrastLargePrintInverse
|
||||
exit 0
|
||||
|
||||
%preun
|
||||
if [ $1 -eq 0 ]; then
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%postun
|
||||
%{_bindir}/update-desktop-database -q %{_datadir}/applications
|
||||
if [ $1 -eq 0 ]; then
|
||||
touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
|
||||
touch --no-create %{_datadir}/icons/HighContrastLargePrint &> /dev/null || :
|
||||
touch --no-create %{_datadir}/icons/HighContrastLargePrintInverse &> /dev/null || :
|
||||
%{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
|
||||
%{_bindir}/gtk-update-icon-cache %{_datadir}/icons/HighContrastLargePrint &> /dev/null || :
|
||||
%{_bindir}/gtk-update-icon-cache %{_datadir}/icons/HighContrastLargePrintInverse &> /dev/null || :
|
||||
fi
|
||||
:
|
||||
|
||||
%posttrans
|
||||
%{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
|
||||
%{_bindir}/gtk-update-icon-cache %{_datadir}/icons/HighContrastLargePrint &> /dev/null || :
|
||||
%{_bindir}/gtk-update-icon-cache %{_datadir}/icons/HighContrastLargePrintInverse &> /dev/null || :
|
||||
:
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/epiphany
|
||||
%{_bindir}/ephy-profile-migrator
|
||||
%if %with_seed
|
||||
%{_libdir}/girepository-*/Epiphany-*.typelib
|
||||
%endif
|
||||
%dir %{_libdir}/epiphany/plugins
|
||||
%dir %{_libdir}/epiphany/%{majver}/plugins
|
||||
%dir %{_libdir}/epiphany/extensions
|
||||
%dir %{_libdir}/epiphany/%{majver}/extensions
|
||||
%dir %{_libdir}/epiphany/%{majver}/web-extensions
|
||||
%{_libdir}/epiphany/%{majver}/web-extensions/libephywebextension.la
|
||||
%{_libdir}/epiphany/%{majver}/web-extensions/libephywebextension.so
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.Epiphany.enums.xml
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.epiphany.gschema.xml
|
||||
%{_datadir}/GConf/gsettings/epiphany.convert
|
||||
%{_datadir}/appdata/epiphany.appdata.xml
|
||||
#%{_datadir}/applications/bme.desktop
|
||||
%{_datadir}/applications/epiphany.desktop
|
||||
%{_datadir}/pixmaps/epiphany.png
|
||||
%{_datadir}/dbus-1/services/org.gnome.Epiphany.service
|
||||
%{_datadir}/gnome-shell/search-providers/epiphany-search-provider.ini
|
||||
%dir %{_datadir}/epiphany
|
||||
%{_datadir}/epiphany/*.xml
|
||||
%{_datadir}/epiphany/*.xsl
|
||||
%{_datadir}/epiphany/about.ini
|
||||
%{_datadir}/epiphany/epiphany.xhtml
|
||||
%dir %{_datadir}/epiphany/bookmarks
|
||||
%attr(755,root,root) %{_datadir}/epiphany/bookmarks/*.html
|
||||
%attr(644,root,root) %{_datadir}/epiphany/bookmarks/*.png
|
||||
%attr(644,root,root) %{_datadir}/epiphany/bookmarks/*.gif
|
||||
%attr(644,root,root) %{_datadir}/epiphany/bookmarks/*.xml
|
||||
%{_datadir}/epiphany/default-bookmarks.rdf
|
||||
%dir %{_datadir}/epiphany/icons
|
||||
%{_datadir}/epiphany/icons/*
|
||||
#%{_datadir}/epiphany/epiphany.css
|
||||
#%dir %{_datadir}/epiphany/glade
|
||||
#%{_datadir}/epiphany/glade/*.ui
|
||||
#%dir %{_datadir}/epiphany/icons
|
||||
#%{_datadir}/epiphany/icons/hicolor/*x*/*/*.png
|
||||
#%{_datadir}/epiphany/icons/hicolor/32x32/actions/location-entry.svg
|
||||
#%{_datadir}/epiphany/icons/hicolor/scalable/actions/*.svg
|
||||
#%{_datadir}/epiphany/icons/hicolor/scalable/status/popup-hidden.svg
|
||||
#%{_datadir}/icons/*/*x*/apps/*.png
|
||||
#%{_datadir}/epiphany/pages/*.html
|
||||
%{_datadir}/epiphany/pages/about.css
|
||||
%dir %{_datadir}/help/*/epiphany
|
||||
%{_datadir}/help/*/epiphany/*
|
||||
#%{_datadir}/icons/hicolor/scalable/apps/gnome-web-browser.svg
|
||||
#%dir %{_datadir}/omf/epiphany
|
||||
#%{_datadir}/omf/epiphany/epiphany-*.omf
|
||||
%{_mandir}/man1/epiphany.1.gz
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
#%{_datadir}/aclocal/epiphany.m4
|
||||
#%dir %{_includedir}/epiphany/%{majver}/epiphany
|
||||
#%{_includedir}/epiphany/%{majver}/epiphany/*.h
|
||||
#%{_libdir}/pkgconfig/*.pc
|
||||
%if %with_seed
|
||||
%{_datadir}/gir-*/Epiphany-*.gir
|
||||
%endif
|
||||
#%doc ChangeLog ChangeLog-* NEWS README TODO
|
||||
|
||||
#%files apidocs
|
||||
#%defattr(-,root,root)
|
||||
#%dir %{_datadir}/gtk-doc/html/epiphany
|
||||
#%doc %{_datadir}/gtk-doc/html/epiphany/*
|
||||
|
||||
%changelog
|
||||
* Wed Dec 11 2013 Automatic Build System <autodist@mambasoft.it> 3.10.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Nov 15 2013 Automatic Build System <autodist@mambasoft.it> 3.10.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Oct 30 2013 Automatic Build System <autodist@mambasoft.it> 3.10.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri May 31 2013 Automatic Build System <autodist@mambasoft.it> 3.8.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Apr 17 2013 Automatic Build System <autodist@mambasoft.it> 3.8.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Apr 04 2013 Automatic Build System <autodist@mambasoft.it> 3.8.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Oct 16 2012 Automatic Build System <autodist@mambasoft.it> 3.6.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Oct 07 2012 Automatic Build System <autodist@mambasoft.it> 3.6.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Aug 15 2012 Automatic Build System <autodist@mambasoft.it> 3.4.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Jun 12 2012 Automatic Build System <autodist@mambasoft.it> 3.4.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jul 25 2011 Automatic Build System <autodist@mambasoft.it> 3.0.4-1mamba
|
||||
- update to 3.0.4
|
||||
|
||||
* Mon Jul 25 2011 Automatic Build System <autodist@mambasoft.it> 3.0.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun May 22 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.30.6-3mamba
|
||||
- added patch for libnotify 0.7
|
||||
|
||||
* Tue Nov 30 2010 gil <puntogil@libero.it> 2.30.6-2mamba
|
||||
- rebuilt devel
|
||||
|
||||
* Sat Sep 25 2010 gil <puntogil@libero.it> 2.30.6-1mamba
|
||||
- update to 2.30.6
|
||||
- edit spec file
|
||||
|
||||
* Tue Dec 01 2009 gil <puntogil@libero.it> 2.28.2-1mamba
|
||||
- update to 2.28.2
|
||||
|
||||
* Mon Apr 27 2009 gil <puntogil@libero.it> 2.26.1-1mamba
|
||||
- update to 2.26.1
|
||||
|
||||
* Tue Jan 13 2009 gil <puntogil@libero.it> 2.24.3-1mamba
|
||||
- update to 2.24.3
|
||||
|
||||
* Mon Jan 12 2009 gil <puntogil@libero.it> 2.24.2.1-2mamba
|
||||
- added %post %postun %preun
|
||||
|
||||
* Sun Dec 07 2008 gil <puntogil@libero.it> 2.24.2.1-1mamba
|
||||
- update to 2.24.2.1
|
||||
- built with: xulrunner 1.9.0.4
|
||||
|
||||
* Tue Nov 25 2008 gil <puntogil@libero.it> 2.24.2-1mamba
|
||||
- update to 2.24.2
|
||||
|
||||
* Tue Oct 21 2008 gil <puntogil@libero.it> 2.24.1-2mamba
|
||||
- edit default-bookmars.html
|
||||
|
||||
* Tue Oct 21 2008 gil <puntogil@libero.it> 2.24.1-1mamba
|
||||
- update to 2.24.1
|
||||
|
||||
* Tue Oct 21 2008 gil <puntogil@libero.it> 2.24.0.1-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user