specfile and build requirements cleanup [release 45.2-2mamba;Fri Feb 02 2024]
This commit is contained in:
parent
80dacc59fc
commit
4971d79e47
@ -1,11 +0,0 @@
|
||||
--- epiphany-2.24.0.1/data/epiphany.desktop.in.in 2008-09-01 13:58:34.000000000 +0200
|
||||
+++ epiphany-2.24.0.1/data/epiphany.desktop.in.in-gil 2008-10-21 14:23:57.000000000 +0200
|
||||
@@ -6,7 +6,7 @@
|
||||
StartupNotify=true
|
||||
Terminal=false
|
||||
Type=Application
|
||||
-Icon=gnome-web-browser
|
||||
+Icon=/usr/share/pixmaps/epiphany.png
|
||||
X-GNOME-Bugzilla-Bugzilla=GNOME
|
||||
X-GNOME-Bugzilla-Product=epiphany
|
||||
X-GNOME-Bugzilla-Component=BugBuddyBugs
|
@ -1,11 +0,0 @@
|
||||
--- epiphany-2.24.0.1/data/epiphany.schemas.in 2008-03-28 15:59:45.000000000 +0100
|
||||
+++ epiphany-2.24.0.1/data/epiphany.schemas.in-gil 2008-10-21 14:53:42.000000000 +0200
|
||||
@@ -5,7 +5,7 @@
|
||||
<applyto>/apps/epiphany/general/homepage</applyto>
|
||||
<owner>epiphany</owner>
|
||||
<type>string</type>
|
||||
- <default>http://www.google.com</default>
|
||||
+ <default>file:///usr/share/epiphany/bookmarks/0-openmamba-default-bookmars2.html</default>
|
||||
<locale name="C">
|
||||
<short>Home page</short>
|
||||
<long>Address of the user's home page.</long>
|
@ -1,18 +0,0 @@
|
||||
--- src/bookmarks/ephy-bookmarks.c 2009-12-16 11:26:27.000000000 +0100
|
||||
+++ src/bookmarks/ephy-bookmarks.c-gil 2010-09-25 14:34:46.000000000 +0200
|
||||
@@ -129,14 +129,7 @@
|
||||
static void
|
||||
ephy_bookmarks_init_defaults (EphyBookmarks *eb)
|
||||
{
|
||||
- int i;
|
||||
-
|
||||
- for (i = 0; i < G_N_ELEMENTS (default_topics); i++)
|
||||
- {
|
||||
- ephy_bookmarks_add_keyword (eb, _(default_topics[i]));
|
||||
- }
|
||||
-
|
||||
- ephy_bookmarks_import_rdf (eb, DATADIR "/default-bookmarks.rdf");
|
||||
+ ephy_bookmarks_import_mozilla (eb, "/usr/share/epiphany/bookmarks/0-openmamba-default-bookmars2.html");
|
||||
}
|
||||
|
||||
static void
|
@ -1,38 +0,0 @@
|
||||
--- embed/downloader-view.c
|
||||
+++ embed/downloader-view.c
|
||||
@@ -36,6 +36,9 @@
|
||||
|
||||
#ifdef HAVE_LIBNOTIFY
|
||||
#include <libnotify/notify.h>
|
||||
+#ifndef NOTIFY_CHECK_VERSION
|
||||
+#define NOTIFY_CHECK_VERSION(x,y,z) 0
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
enum
|
||||
@@ -337,7 +340,12 @@
|
||||
g_object_ref (dv);
|
||||
|
||||
notification = notify_notification_new (title, msg,
|
||||
- GTK_STOCK_INFO, NULL);
|
||||
+ GTK_STOCK_INFO
|
||||
+#if NOTIFY_CHECK_VERSION (0, 7, 0)
|
||||
+ );
|
||||
+#else
|
||||
+ , NULL);
|
||||
+#endif
|
||||
|
||||
g_signal_connect_after (notification, "closed",
|
||||
G_CALLBACK (notification_closed_cb), dv);
|
||||
@@ -346,7 +354,11 @@
|
||||
notify_notification_set_timeout (notification, NOTIFY_EXPIRES_DEFAULT);
|
||||
notify_notification_set_urgency (notification, NOTIFY_URGENCY_LOW);
|
||||
|
||||
+#if NOTIFY_CHECK_VERSION (0, 7, 0)
|
||||
+ /* notify_notification_attach_to_status_icon was removed */
|
||||
+#else
|
||||
notify_notification_attach_to_status_icon (notification, status_icon);
|
||||
+#endif
|
||||
|
||||
/* There are some visual glitches when the notification is shown and
|
||||
* the GtkStatusIcon is still not visible. To avoid that, we delay the
|
@ -1,14 +0,0 @@
|
||||
--- lib/ephy-profile-migration.c 2010-04-02 18:17:25.000000000 +0200
|
||||
+++ lib/ephy-profile-migration.c-gil 2010-10-05 23:46:44.000000000 +0200
|
||||
@@ -193,7 +193,10 @@
|
||||
while (lines[end] && !g_str_equal (lines[end], "."))
|
||||
end++;
|
||||
|
||||
- i = end + 1;
|
||||
+ if (lines[end])
|
||||
+ i = end + 1;
|
||||
+ else
|
||||
+ i = end;
|
||||
|
||||
/* A block has at least five lines */
|
||||
if (end - begin < 5)
|
BIN
epiphany-64.png
BIN
epiphany-64.png
Binary file not shown.
Before Width: | Height: | Size: 4.7 KiB |
@ -1,61 +0,0 @@
|
||||
<?xml version="1.0"?>
|
||||
<rdf:RDF xmlns="http://purl.org/rss/1.0/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:ephy="http://gnome.org/ns/epiphany#" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
|
||||
<channel rdf:about="file:///usr/share/epiphany/default-bookmarks.rdf">
|
||||
<title>Epiphany bookmarks</title>
|
||||
<link>http://www.gnome.org/projects/epiphany/</link>
|
||||
<items>
|
||||
<rdf:Seq>
|
||||
<rdf:li rdf:resource="http://www.openmamba.org/community/"/>
|
||||
<rdf:li rdf:resource="http://www.openmamba.org/distribution/packages.html"/>
|
||||
<rdf:li rdf:resource="http://www.openmamba.org/distribution/download.html"/>
|
||||
<rdf:li rdf:resource="http://wiki.openmamba.org/it/index.php/Pagina_principale"/>
|
||||
<rdf:li rdf:resource="http://www.openmamba.org/distribution/development.html"/>
|
||||
<rdf:li rdf:resource="http://forum.openmamba.org/"/>
|
||||
<rdf:li rdf:resource="http://www.openmamba.org/info.html"/>
|
||||
<rdf:li rdf:resource="http://www.openmamba.org/distribution/install.html"/>
|
||||
<rdf:li rdf:resource="http://bugs.openmamba.org/my_view_page.php/"/>
|
||||
<rdf:li rdf:resource="http://www.google.com/"/>
|
||||
</rdf:Seq>
|
||||
</items>
|
||||
</channel>
|
||||
<item rdf:about="http://www.openmamba.org/community/">
|
||||
<title>Community</title>
|
||||
<link>http://www.openmamba.org/community/</link>
|
||||
</item>
|
||||
<item rdf:about="http://www.openmamba.org/distribution/packages.html">
|
||||
<title>Usa</title>
|
||||
<link>http://www.openmamba.org/distribution/packages.html</link>
|
||||
</item>
|
||||
<item rdf:about="http://www.openmamba.org/distribution/download.html">
|
||||
<title>Scarica</title>
|
||||
<link>http://www.openmamba.org/distribution/download.html</link>
|
||||
</item>
|
||||
<item rdf:about="http://wiki.openmamba.org/it/index.php/Pagina_principale">
|
||||
<title>Wiki</title>
|
||||
<link>http://wiki.openmamba.org/it/index.php/Pagina_principale</link>
|
||||
</item>
|
||||
<item rdf:about="http://www.openmamba.org/distribution/development.html">
|
||||
<title>Sviluppa</title>
|
||||
<link>http://www.openmamba.org/distribution/development.html</link>
|
||||
</item>
|
||||
<item rdf:about="http://forum.openmamba.org/">
|
||||
<title>Forum</title>
|
||||
<link>http://forum.openmamba.org/</link>
|
||||
</item>
|
||||
<item rdf:about="http://www.openmamba.org/info.html">
|
||||
<title>Leggi</title>
|
||||
<link>http://www.openmamba.org/info.html</link>
|
||||
</item>
|
||||
<item rdf:about="http://www.openmamba.org/distribution/install.html">
|
||||
<title>Installa</title>
|
||||
<link>http://www.openmamba.org/distribution/install.html</link>
|
||||
</item>
|
||||
<item rdf:about="http://bugs.openmamba.org/my_view_page.php/">
|
||||
<title>Aggiusta</title>
|
||||
<link>http://bugs.openmamba.org/my_view_page.php/</link>
|
||||
</item>
|
||||
<item rdf:about="http://www.google.com/">
|
||||
<title>Google</title>
|
||||
<link>http://www.google.com/</link>
|
||||
</item>
|
||||
</rdf:RDF>
|
BIN
epiphany.png
BIN
epiphany.png
Binary file not shown.
Before Width: | Height: | Size: 4.6 KiB |
135
epiphany.spec
135
epiphany.spec
@ -1,10 +1,6 @@
|
||||
%define MAJver %(echo %version | cut -d. -f 1)
|
||||
%define majver %(echo %version | cut -d. -f 1-2)
|
||||
%define with_ca_mgr 1
|
||||
%define with_seed 0
|
||||
Name: epiphany
|
||||
Version: 45.2
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: The web browser for the GNOME desktop
|
||||
Group: Graphical Desktop/Applications/Internet
|
||||
Vendor: openmamba
|
||||
@ -12,19 +8,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://wiki.gnome.org/Apps
|
||||
Source0: https://gitlab.gnome.org/GNOME/epiphany.git/%{version}/epiphany-%{version}.tar.bz2
|
||||
#Source0: https://download.gnome.org/sources/epiphany/%{majver}/epiphany-%{version}.tar.xz
|
||||
Source1: epiphany-64.png
|
||||
# TODO
|
||||
# tar -cz bookmarks > bookmarks.tar.gz
|
||||
Source2: epiphany-1-bookmarks.tar.gz
|
||||
Source3: epiphany.png
|
||||
Source4: epiphany-default-bookmarks.rdf
|
||||
Patch0: epiphany-2.24.0.1-desktop.patch
|
||||
# TODO
|
||||
Patch1: epiphany-2.24.0.1-homepage.patch
|
||||
Patch2: epiphany-2.28.2-bookmarks.patch
|
||||
Patch3: epiphany-2.30.6-password-migration.patch
|
||||
Patch4: epiphany-2.30.6-libnotify-0.7.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -48,64 +31,12 @@ BuildRequires: libsqlite-devel
|
||||
BuildRequires: libwebkitgtk-6.0-devel
|
||||
BuildRequires: libxml2-devel
|
||||
## AUTOBUILDREQ-END
|
||||
#BuildRequires: gnome-desktop-devel >= %{MAJver}
|
||||
%if %with_seed
|
||||
BuildRequires: seed-devel
|
||||
%endif
|
||||
BuildRequires: ca-certificates
|
||||
BuildRequires: eggdbus
|
||||
BuildRequires: glib-gettextize
|
||||
BuildRequires: iso-codes-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libart_lgpl-devel
|
||||
BuildRequires: libaudiofile-devel
|
||||
BuildRequires: libbonobo-devel
|
||||
BuildRequires: libbonoboui-devel
|
||||
BuildRequires: libcanberra-devel
|
||||
BuildRequires: libcares-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libe2fs-devel
|
||||
BuildRequires: libesound-devel
|
||||
BuildRequires: libglade-devel
|
||||
BuildRequires: libgnomecanvas-devel
|
||||
BuildRequires: libgnome-devel
|
||||
BuildRequires: libgnomeui-devel
|
||||
BuildRequires: libgnome-vfs-devel
|
||||
BuildRequires: libidn-devel
|
||||
BuildRequires: libkrb5-devel
|
||||
BuildRequires: libnm-devel
|
||||
BuildRequires: libopenldap-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpopt-devel
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libsasl-devel
|
||||
BuildRequires: libssh2-devel
|
||||
BuildRequires: pygtk-devel
|
||||
BuildRequires: python-gnome-devel
|
||||
BuildRequires: libdazzle-devel
|
||||
BuildRequires: libhandy-devel
|
||||
BuildRequires: libportal-devel
|
||||
Requires: ca-certificates
|
||||
Requires(post):desktop-file-utils
|
||||
|
||||
# Epiphany was configured with the following options:
|
||||
|
||||
# Zeroconf bookmarks support : yes
|
||||
# NetworkManager support : yes
|
||||
|
||||
# TODO
|
||||
# GObject introspection : no
|
||||
# Seed support : no
|
||||
|
||||
# Namespace is empty; likely causes are:
|
||||
# Not including .h files to be scanned
|
||||
# Broken --identifier-prefix
|
||||
# [Epiphany-2.29.gir] Error 1
|
||||
|
||||
# NSS support : yes
|
||||
# Build tests : yes
|
||||
# CA Certificates file : %{_sysconfdir}/pki/tls/certs/ca-bundle.crt
|
||||
|
||||
%description
|
||||
Epiphany is the web browser for the GNOME desktop. Its goal is to be simple and easy to use.
|
||||
Epiphany ties together many GNOME components in order to let you focus on the Web content, instead of the browser application.
|
||||
@ -150,46 +81,6 @@ EOF
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%meson_install
|
||||
|
||||
:<< __OLD
|
||||
mkdir -p %{buildroot}%{_datadir}/pixmaps
|
||||
install -m 644 %{S:1} %{buildroot}%{_datadir}/pixmaps/%{name}.png
|
||||
|
||||
# TODO
|
||||
tar -C %{buildroot}%{_datadir}/epiphany -zxvf %{S:2}
|
||||
|
||||
rm -f %{buildroot}%{_datadir}/epiphany/default-bookmarks.rdf
|
||||
install -pm 644 %{S:4} %{buildroot}%{_datadir}/epiphany/default-bookmarks.rdf
|
||||
|
||||
rm -f %{buildroot}%{_libdir}/epiphany/*/plugins/*.la
|
||||
|
||||
# Don't ship icon caches, either
|
||||
rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
|
||||
rm -f %{buildroot}%{_datadir}/icons/HighContrastLargePrint/icon-theme.cache
|
||||
rm -f %{buildroot}%{_datadir}/icons/HighContrastLargePrintInverse/icon-theme.cache
|
||||
|
||||
# LowContrastLargePrint seems to be obsolete, so remove it until further notice
|
||||
rm -rf %{buildroot}%{_datadir}/icons/LowContrastLargePrint
|
||||
|
||||
helpdir=%{buildroot}%{_datadir}/gnome/help/%{name}
|
||||
for f in $helpdir/C/figures/*.png; do
|
||||
b="$(basename $f)"
|
||||
for d in $helpdir/*; do
|
||||
if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
|
||||
g="$d/figures/$b"
|
||||
if [ -f "$g" ]; then
|
||||
if cmp -s $f $g; then
|
||||
rm "$g"; ln -s "../../C/figures/$b" "$g"
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
done
|
||||
done
|
||||
|
||||
mkdir -p %{buildroot}%{_libdir}/epiphany/%{majver}/{plugins,extensions}
|
||||
ln -sf %{majver}/plugins %{buildroot}%{_libdir}/epiphany/plugins
|
||||
ln -sf %{majver}/extensions %{buildroot}%{_libdir}/epiphany/extensions
|
||||
__OLD
|
||||
|
||||
%find_lang %{name} --with-gnome
|
||||
|
||||
%clean
|
||||
@ -232,9 +123,6 @@ fi
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/epiphany
|
||||
%if %with_seed
|
||||
%{_libdir}/girepository-*/Epiphany-*.typelib
|
||||
%endif
|
||||
%dir %{_libdir}/epiphany
|
||||
%{_libdir}/epiphany/libephymain.so
|
||||
%{_libdir}/epiphany/libephymisc.so
|
||||
@ -255,28 +143,13 @@ fi
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.epiphany.gschema.xml
|
||||
%dir %{_datadir}/epiphany
|
||||
%{_datadir}/epiphany/default-bookmarks.rdf
|
||||
%if %with_seed
|
||||
%{_datadir}/gir-*/Epiphany-*.gir
|
||||
%endif
|
||||
#%dir %{_datadir}/help/*/epiphany
|
||||
#%{_datadir}/help/*/epiphany/*
|
||||
%{_mandir}/man1/epiphany.1*
|
||||
%doc COPYING
|
||||
|
||||
#%files devel
|
||||
#%defattr(-,root,root)
|
||||
#%{_datadir}/aclocal/epiphany.m4
|
||||
#%dir %{_includedir}/epiphany/%{majver}/epiphany
|
||||
#%{_includedir}/epiphany/%{majver}/epiphany/*.h
|
||||
#%{_libdir}/pkgconfig/*.pc
|
||||
#%doc ChangeLog ChangeLog-* NEWS README TODO
|
||||
|
||||
#%files apidocs
|
||||
#%defattr(-,root,root)
|
||||
#%dir %{_datadir}/gtk-doc/html/epiphany
|
||||
#%doc %{_datadir}/gtk-doc/html/epiphany/*
|
||||
|
||||
%changelog
|
||||
* Fri Feb 02 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 45.2-2mamba
|
||||
- specfile and build requirements cleanup
|
||||
|
||||
* Tue Jan 09 2024 Automatic Build System <autodist@openmamba.org> 45.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user