205 lines
5.9 KiB
RPMSpec
205 lines
5.9 KiB
RPMSpec
%define libname libenchant1
|
|
|
|
Name: enchant1
|
|
Version: 1.6.0
|
|
Release: 6mamba
|
|
Summary: An Enchanting Spell Checking Library
|
|
Group: Applications/Spelling Checker
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Aleph0 <aleph0@openmamba.org>
|
|
URL: http://www.abisource.com/projects/enchant/
|
|
Source: http://www.abisource.com/downloads/enchant/%{version}/enchant-%{version}.tar.gz
|
|
License: LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: ldconfig
|
|
BuildRequires: libacl-devel
|
|
BuildRequires: libarchive-devel
|
|
BuildRequires: libaspell-devel
|
|
BuildRequires: libattr-devel
|
|
BuildRequires: libbzip2-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libhfstospell-devel
|
|
BuildRequires: libhunspell-devel
|
|
BuildRequires: libicu-devel
|
|
BuildRequires: liblz4-devel
|
|
BuildRequires: liblzma-devel
|
|
BuildRequires: libncurses-devel
|
|
BuildRequires: libopenssl-devel
|
|
BuildRequires: libsigc++-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libvoikko-devel
|
|
BuildRequires: libxml++2-devel
|
|
BuildRequires: libxml2-devel
|
|
BuildRequires: libz-devel
|
|
BuildRequires: libzstd-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: pkgconfig
|
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
A library that wraps around other spell checking back-ends.
|
|
|
|
%package -n %{libname}
|
|
Summary: Dynamic libraries and headers for %{name}
|
|
Group: System/Libraries
|
|
|
|
%description -n %{libname}
|
|
A library that wraps around other spell checking back-ends.
|
|
This package contains dynamic libraries provided by %{name}.
|
|
|
|
%package -n %{libname}-devel
|
|
Summary: Devel package for %{name}
|
|
Group: Development/Libraries
|
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n %{libname}-devel
|
|
A library that wraps around other spell checking back-ends.
|
|
This package contains libraries and header files need for development.
|
|
|
|
%package -n %{libname}-static
|
|
Summary: Static package for %{name}
|
|
Group: Development/Libraries
|
|
Requires: %{libname}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n %{libname}-static
|
|
A library that wraps around other spell checking back-ends.
|
|
|
|
This package contains static libraries need for development.
|
|
|
|
%package aspell
|
|
Summary: Integration with aspell for libenchant
|
|
Group: System/Libraries
|
|
|
|
%description aspell
|
|
Libraries necessary to integrate applications using libenchant with aspell.
|
|
|
|
%package voikko
|
|
Summary: Integration with voikko for libenchant
|
|
Group: System/Libraries
|
|
|
|
%description voikko
|
|
Libraries necessary to integrate applications using libenchant with voikko.
|
|
|
|
# NOTE:
|
|
# Build Aspell backend: yes
|
|
# Build Ispell backend: yes
|
|
# Build Uspell backend: no
|
|
# Build Hspell backend: no
|
|
# Build Myspell/Hunspell backend: yes
|
|
# Build Voikko backend: yes
|
|
# Build Zemberek backend: yes
|
|
# Build a relocatable library: no
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n enchant-%{version}
|
|
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," config.sub
|
|
|
|
%build
|
|
%configure \
|
|
--with-myspell-dir=%{_datadir}/myspell \
|
|
--disable-hspell \
|
|
--disable-static
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall
|
|
|
|
%post -n %{libname} -p /sbin/ldconfig
|
|
%postun -n %{libname} -p /sbin/ldconfig
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/*
|
|
%dir %{_datadir}/enchant
|
|
%{_datadir}/enchant/*
|
|
%{_mandir}/man1/enchant.*
|
|
|
|
%files -n %{libname}
|
|
%defattr(-,root,root)
|
|
%{_libdir}/*.so.*
|
|
%dir %{_libdir}/enchant
|
|
%{_libdir}/enchant/lib*_ispell.so
|
|
%{_libdir}/enchant/lib*myspell.so*
|
|
%{_libdir}/enchant/lib*_ispell.la
|
|
%{_libdir}/enchant/lib*myspell.la
|
|
%doc AUTHORS COPYING.LIB
|
|
|
|
%files -n %{libname}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/enchant/
|
|
%{_includedir}/enchant/*.h
|
|
%{_libdir}/libenchant.so
|
|
%{_libdir}/libenchant.la
|
|
#%{_libdir}/enchantlib*.la
|
|
%{_libdir}/pkgconfig/*.pc
|
|
%doc BUGS ChangeLog NEWS README TODO
|
|
|
|
%files aspell
|
|
%defattr(-,root,root)
|
|
%dir %{_libdir}/enchant
|
|
%{_libdir}/enchant/libenchant_aspell.so*
|
|
%{_libdir}/enchant/libenchant_aspell.la
|
|
|
|
%files voikko
|
|
%defattr(-,root,root)
|
|
%dir %{_libdir}/enchant
|
|
%{_libdir}/enchant/libenchant_voikko.so*
|
|
%{_libdir}/enchant/libenchant_voikko.la
|
|
|
|
%changelog
|
|
* Sun Dec 27 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-6mamba
|
|
- rebuilt with debug package and aarch64 build fix
|
|
|
|
* Tue Jan 16 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-5mamba
|
|
- other requirements fixes as legacy package
|
|
|
|
* Mon Jan 15 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-4mamba
|
|
- remove an obsolete
|
|
|
|
* Sun Jan 14 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-3mamba
|
|
- legacy package
|
|
|
|
* Mon Aug 15 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-2mamba
|
|
- remove package libenchant-static which only contained .la files (moved to -devel)
|
|
|
|
* Sat Jul 30 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-1mamba
|
|
- update to 1.6.0
|
|
|
|
* Sat Jun 26 2010 Automatic Build System <autodist@mambasoft.it> 1.4.2-3mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Mon Feb 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.2-2mamba
|
|
- fixed %expoch requirement for subpackages
|
|
|
|
* Mon Feb 02 2009 gil <puntogil@libero.it> 1.4.2-1mamba
|
|
- update to 1.4.2
|
|
- added libvokkio support
|
|
- new packages: aspell; voikko; static
|
|
- edit configure options
|
|
|
|
* Thu Oct 30 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.0-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Oct 30 2007 Aleph0 <aleph0@openmamba.org> 1.3.0-2mamba
|
|
- specfile updated and fixed
|
|
- create package enchant with binaries
|
|
|
|
* Tue Apr 10 2007 Tiziano Pratellesi <tiziano.pratellesi@openmamba.org> 1.3.0-1mamba
|
|
- update to version 1.3.0
|
|
|
|
* Tue Jun 27 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.2.6-1qilnx
|
|
- update to version 1.2.6 by autospec
|
|
|
|
* Tue Aug 09 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 1.1.6-1qilnx
|
|
- package created by autospec
|