rebuilt by autoport with build requirements: libvigra-devel>=1.11.1-2mamba [release 4.2-2mamba;Sun Jun 27 2021]

This commit is contained in:
Silvan Calarco 2024-01-05 22:05:38 +01:00
parent 4d42f0da34
commit 476d602fdf
2 changed files with 96 additions and 20 deletions

View File

@ -0,0 +1,77 @@
diff -r ef8470f9d682 src/anneal.h
--- a/src/anneal.h Sun Feb 12 15:25:10 2017 +0100
+++ b/src/anneal.h Tue Jul 28 10:48:23 2020 +0100
@@ -29,6 +29,7 @@
#include <algorithm>
#include <limits>
#include <vector>
+#include <limits>
#ifdef _WIN32
#include <cmath>
diff -r ef8470f9d682 src/exposure_weight.cc
--- a/src/exposure_weight.cc Sun Feb 12 15:25:10 2017 +0100
+++ b/src/exposure_weight.cc Tue Jul 28 10:48:23 2020 +0100
@@ -21,6 +21,7 @@
#include <cassert>
#include <iostream>
+#include <limits>
#include "global.h"
#include "openmp_def.h" // omp::atomic_t
diff -r ef8470f9d682 src/fixmath.h
--- a/src/fixmath.h Sun Feb 12 15:25:10 2017 +0100
+++ b/src/fixmath.h Tue Jul 28 10:48:23 2020 +0100
@@ -27,6 +27,7 @@
#endif
#include <cmath>
+#include <limits>
#include <time.h>
diff -r ef8470f9d682 src/minimizer.h
--- a/src/minimizer.h Sun Feb 12 15:25:10 2017 +0100
+++ b/src/minimizer.h Tue Jul 28 10:48:23 2020 +0100
@@ -26,6 +26,7 @@
#include <config.h>
#endif
+#include <limits>
#include <string>
#include <stdexcept>
#include <vector>
diff -r ef8470f9d682 src/opencl.h
--- a/src/opencl.h Sun Feb 12 15:25:10 2017 +0100
+++ b/src/opencl.h Tue Jul 28 10:48:23 2020 +0100
@@ -37,6 +37,7 @@
#include <thread>
#include <type_traits> // std::add_const
#include <vector>
+#include <limits>
#define __CL_ENABLE_EXCEPTIONS
diff -r ef8470f9d682 src/openmp_vigra.h
--- a/src/openmp_vigra.h Sun Feb 12 15:25:10 2017 +0100
+++ b/src/openmp_vigra.h Tue Jul 28 10:48:23 2020 +0100
@@ -31,6 +31,7 @@
#include <vigra/combineimages.hxx>
#include <vigra/convolution.hxx>
#include <vigra/distancetransform.hxx>
+#include <limits>
#include "openmp_def.h"
diff -r ef8470f9d682 src/self_test.cc
--- a/src/self_test.cc Sun Feb 12 15:25:10 2017 +0100
+++ b/src/self_test.cc Tue Jul 28 10:48:23 2020 +0100
@@ -34,6 +34,7 @@
#include <cmath> // fabsf
#include <iostream>
#include <string>
+#include <limits>
#include "self_test.h"

View File

@ -1,11 +1,11 @@
Name: enblend-enfuse Name: enblend-enfuse
Version: 4.2 Version: 4.2
Release: 1mamba Release: 2mamba
Summary: Image Blending with Multiresolution Splines Summary: Image Blending with Multiresolution Splines
Group: Applications/Multimedia Group: Applications/Multimedia
Vendor: openmamba Vendor: openmamba
Distribution: openmamba Distribution: openmamba
Packager: Davide Madrisan <davide.madrisan@gmail.com> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://enblend.sourceforge.net/ URL: http://enblend.sourceforge.net/
Source: http://downloads.sourceforge.net/enblend/enblend-enfuse-%{version}.tar.gz Source: http://downloads.sourceforge.net/enblend/enblend-enfuse-%{version}.tar.gz
Patch1: enblend-enfuse-4.0-libpng-1.5.patch Patch1: enblend-enfuse-4.0-libpng-1.5.patch
@ -13,45 +13,37 @@ Patch2: enblend-enfuse-4.0-boost-1.46.1.patch
Patch3: enblend-enfuse-4.0-boost-1.50.patch Patch3: enblend-enfuse-4.0-boost-1.50.patch
Patch4: enblend-enfuse-4.1.1-texinfo-5.patch Patch4: enblend-enfuse-4.1.1-texinfo-5.patch
Patch5: enblend-enfuse-4.1.1-texinfo-5.1.patch Patch5: enblend-enfuse-4.1.1-texinfo-5.1.patch
Patch6: enblend-enfuse-4.2-gcc-11.1.0.patch
License: GPL License: GPL
Provides: enblend = %{version}
Requires(post):%{__install_info}
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
BuildRequires: libGL-devel
BuildRequires: libGLU-devel
BuildRequires: libICE-devel
BuildRequires: libSM-devel
BuildRequires: libXi-devel
BuildRequires: libXmu-devel
BuildRequires: libboost-devel
BuildRequires: libfreeglut-devel
BuildRequires: libgcc BuildRequires: libgcc
BuildRequires: libglew-devel BuildRequires: libgomp-devel
BuildRequires: libgperftools-devel
BuildRequires: libgsl-devel BuildRequires: libgsl-devel
BuildRequires: libilmbase-devel
BuildRequires: libjpeg-devel
BuildRequires: liblcms2-devel BuildRequires: liblcms2-devel
BuildRequires: libopenexr-devel BuildRequires: libopenexr-devel
BuildRequires: libpng-devel
BuildRequires: libstdc++6-devel BuildRequires: libstdc++6-devel
BuildRequires: libtiff-devel BuildRequires: libtiff-devel
BuildRequires: libvigra-devel BuildRequires: libvigra-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
BuildRequires: libvigra-devel >= 1.10.0-1mamba BuildRequires: libvigra-devel >= 1.11.1-2mamba
BuildRoot: %{_tmppath}/%{name}-%{version}-root Provides: enblend = %{version}
Requires(post):%{__install_info}
%description %description
Enblend blends away the seams in a panoramic image mosaic using a multi-resolution spline. Enblend blends away the seams in a panoramic image mosaic using a multi-resolution spline.
Enfuse merges different exposures of the same scene to produce an image that looks much like a tone-mapped image. Enfuse merges different exposures of the same scene to produce an image that looks much like a tone-mapped image.
%debug_package
%prep %prep
%setup -q -n %{name}-%{version} %setup -q -n %{name}-%{version}
#%patch1 -p0 #%patch1 -p0
#%patch2 -p1 #%patch2 -p1
#%patch3 -p0 #%patch3 -p0
#%patch5 -p1 #%patch5 -p1
%patch6 -p1
#sed -i -e 's/src:://g;s/CFG::/CFG_/g' doc/*.texi doc/define2set.pl configure.in #sed -i -e 's/src:://g;s/CFG::/CFG_/g' doc/*.texi doc/define2set.pl configure.in
@ -59,7 +51,11 @@ Enfuse merges different exposures of the same scene to produce an image that loo
#autoreconf -f -i #autoreconf -f -i
%configure \ %configure \
--disable-static \ --disable-static \
--with-boost-filesystem --with-boost-filesystem \
--with-tcmalloc \
--enable-opencl \
--enable-openmp \
CXXFLAGS="%{optflags} -std=gnu++14"
# --enable-openmp # --enable-openmp
@ -98,6 +94,9 @@ exit 0
#ChangeLog NEWS README README.txt #ChangeLog NEWS README README.txt
%changelog %changelog
* Sun Jun 27 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2-2mamba
- rebuilt by autoport with build requirements: libvigra-devel>=1.11.1-2mamba
* Sat Apr 02 2016 Automatic Build System <autodist@mambasoft.it> 4.2-1mamba * Sat Apr 02 2016 Automatic Build System <autodist@mambasoft.it> 4.2-1mamba
- automatic version update by autodist - automatic version update by autodist