rebuilt with openexr 2.1.0 [release 4.1.1-2mamba;Mon Mar 31 2014]
This commit is contained in:
parent
9ccbf4a4be
commit
078fa820bc
@ -1,2 +1,5 @@
|
|||||||
# enblend-enfuse
|
# enblend-enfuse
|
||||||
|
|
||||||
|
Enblend blends away the seams in a panoramic image mosaic using a multi-resolution spline.
|
||||||
|
Enfuse merges different exposures of the same scene to produce an image that looks much like a tone-mapped image.
|
||||||
|
|
||||||
|
126
enblend-enfuse-4.0-boost-1.46.1.patch
Normal file
126
enblend-enfuse-4.0-boost-1.46.1.patch
Normal file
@ -0,0 +1,126 @@
|
|||||||
|
diff -r 76ad0679d06d src/filenameparse.cc
|
||||||
|
--- a/src/filenameparse.cc Tue Mar 15 18:52:46 2011 +0100
|
||||||
|
+++ b/src/filenameparse.cc Sat Apr 09 20:17:05 2011 -0700
|
||||||
|
@@ -50,7 +50,7 @@
|
||||||
|
#ifdef HAVE_BOOST_FILESYSTEM
|
||||||
|
#include <boost/filesystem.hpp>
|
||||||
|
|
||||||
|
-typedef boost::filesystem::basic_path<std::string, boost::filesystem::path_traits> basic_path;
|
||||||
|
+//typedef boost::filesystem::basic_path<std::string, boost::filesystem::path_traits> basic_path;
|
||||||
|
#endif
|
||||||
|
|
||||||
|
|
||||||
|
@@ -60,7 +60,7 @@
|
||||||
|
isRelativePath(const std::string& aFilename)
|
||||||
|
{
|
||||||
|
#ifdef HAVE_BOOST_FILESYSTEM
|
||||||
|
- const basic_path path(aFilename);
|
||||||
|
+ const boost::filesystem::path path(aFilename);
|
||||||
|
return !path.has_root_directory();
|
||||||
|
#else
|
||||||
|
const std::string::size_type separator = aFilename.find(PATH_SEPARATOR);
|
||||||
|
@@ -80,7 +80,7 @@
|
||||||
|
extractDirname(const std::string& aFilename)
|
||||||
|
{
|
||||||
|
#ifdef HAVE_BOOST_FILESYSTEM
|
||||||
|
- const basic_path path(aFilename);
|
||||||
|
+ const boost::filesystem::path path(aFilename);
|
||||||
|
const std::string directory(path.branch_path().string());
|
||||||
|
return directory.empty() ? DOT : directory;
|
||||||
|
#else
|
||||||
|
@@ -94,8 +94,8 @@
|
||||||
|
extractBasename(const std::string& aFilename)
|
||||||
|
{
|
||||||
|
#ifdef HAVE_BOOST_FILESYSTEM
|
||||||
|
- const basic_path path(aFilename);
|
||||||
|
- return path.leaf();
|
||||||
|
+ const boost::filesystem::path path(aFilename);
|
||||||
|
+ return path.leaf().string();
|
||||||
|
#else
|
||||||
|
const std::string::size_type separator = aFilename.rfind(PATH_SEPARATOR);
|
||||||
|
return
|
||||||
|
@@ -110,7 +110,7 @@
|
||||||
|
extractFilename(const std::string& aFilename)
|
||||||
|
{
|
||||||
|
#ifdef HAVE_BOOST_FILESYSTEM
|
||||||
|
- const basic_path path(aFilename);
|
||||||
|
+ const boost::filesystem::path path(aFilename);
|
||||||
|
return basename(path);
|
||||||
|
#else
|
||||||
|
const std::string::size_type separator = aFilename.rfind(PATH_SEPARATOR);
|
||||||
|
@@ -134,7 +134,7 @@
|
||||||
|
extractExtension(const std::string& aFilename)
|
||||||
|
{
|
||||||
|
#ifdef HAVE_BOOST_FILESYSTEM
|
||||||
|
- const basic_path path(aFilename);
|
||||||
|
+ const boost::filesystem::path path(aFilename);
|
||||||
|
return extension(path);
|
||||||
|
#else
|
||||||
|
const std::string::size_type dot = aFilename.rfind(DOT);
|
||||||
|
@@ -151,11 +151,11 @@
|
||||||
|
|
||||||
|
#ifdef HAVE_BOOST_FILESYSTEM
|
||||||
|
|
||||||
|
-inline basic_path
|
||||||
|
-removeDotsBoost(const basic_path& aPath)
|
||||||
|
+inline boost::filesystem::path
|
||||||
|
+removeDotsBoost(const boost::filesystem::path& aPath)
|
||||||
|
{
|
||||||
|
- basic_path result;
|
||||||
|
- for (basic_path::const_iterator p = aPath.begin(); p != aPath.end(); ++p)
|
||||||
|
+ boost::filesystem::path result;
|
||||||
|
+ for (boost::filesystem::path::const_iterator p = aPath.begin(); p != aPath.end(); ++p)
|
||||||
|
{
|
||||||
|
if (*p != DOT)
|
||||||
|
{
|
||||||
|
@@ -166,11 +166,12 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
-inline basic_path
|
||||||
|
-removeDotDotsBoost(const basic_path& aPath)
|
||||||
|
+inline boost::filesystem::path
|
||||||
|
+removeDotDotsBoost(const boost::filesystem::path& aPath)
|
||||||
|
{
|
||||||
|
list_t directories;
|
||||||
|
- for (basic_path::const_iterator p = aPath.begin(); p != aPath.end(); ++p)
|
||||||
|
+ for (boost::filesystem::path::const_iterator p = aPath.begin(); p != aPath.end(); ++p)
|
||||||
|
+
|
||||||
|
{
|
||||||
|
if (*p == DOTDOT &&
|
||||||
|
!directories.empty() && directories.back() != DOTDOT)
|
||||||
|
@@ -179,10 +180,10 @@
|
||||||
|
}
|
||||||
|
else
|
||||||
|
{
|
||||||
|
- directories.push_back(*p);
|
||||||
|
+ directories.push_back((*p).string());
|
||||||
|
}
|
||||||
|
}
|
||||||
|
- basic_path result;
|
||||||
|
+ boost::filesystem::path result;
|
||||||
|
for (list_t::const_iterator p = directories.begin(); p != directories.end(); ++p)
|
||||||
|
{
|
||||||
|
result /= *p;
|
||||||
|
@@ -295,8 +296,8 @@
|
||||||
|
canonicalizePath(const std::string& aPathname, bool keepDot)
|
||||||
|
{
|
||||||
|
#ifdef HAVE_BOOST_FILESYSTEM
|
||||||
|
- const basic_path result =
|
||||||
|
- removeDotDotsBoost(removeDotsBoost(basic_path(aPathname)));
|
||||||
|
+ const boost::filesystem::path result =
|
||||||
|
+ removeDotDotsBoost(removeDotsBoost(boost::filesystem::path(aPathname)));
|
||||||
|
if (keepDot && result.empty())
|
||||||
|
{
|
||||||
|
return std::string(DOT);
|
||||||
|
@@ -331,8 +332,8 @@
|
||||||
|
concatPath(const std::string& aPathname, const std::string& anotherPathname)
|
||||||
|
{
|
||||||
|
#ifdef HAVE_BOOST_FILESYSTEM
|
||||||
|
- basic_path path(aPathname);
|
||||||
|
- basic_path leaf(anotherPathname);
|
||||||
|
+ boost::filesystem::path path(aPathname);
|
||||||
|
+ boost::filesystem::path leaf(anotherPathname);
|
||||||
|
path /= leaf;
|
||||||
|
return path.string();
|
||||||
|
#else
|
62
enblend-enfuse-4.0-boost-1.50.patch
Normal file
62
enblend-enfuse-4.0-boost-1.50.patch
Normal file
@ -0,0 +1,62 @@
|
|||||||
|
--- configure.in.orig 2012-08-01 18:12:30.000000000 +0200
|
||||||
|
+++ configure.in 2012-08-01 18:13:35.000000000 +0200
|
||||||
|
@@ -140,6 +140,8 @@
|
||||||
|
no_gpu_reason=", because it was disabled"
|
||||||
|
fi
|
||||||
|
|
||||||
|
+AX_PTHREAD
|
||||||
|
+
|
||||||
|
# Memory allocation debug support
|
||||||
|
AC_MSG_CHECKING([if malloc debugging is wanted])
|
||||||
|
AC_ARG_WITH(dmalloc,
|
||||||
|
@@ -149,7 +151,7 @@
|
||||||
|
AC_MSG_RESULT(yes)
|
||||||
|
AC_DEFINE(WITH_DMALLOC, 1,
|
||||||
|
[Define if using the dmalloc debugging malloc package])
|
||||||
|
- if test x$acx_pthread_ok = xyes; then
|
||||||
|
+ if test x$ax_pthread_ok = xyes; then
|
||||||
|
LIBS="$LIBS -ldmallocthcxx"
|
||||||
|
enable_dmalloc="yes (thread aware)"
|
||||||
|
else
|
||||||
|
@@ -214,14 +216,14 @@
|
||||||
|
[AC_MSG_NOTICE([forcing use of Boost "filesystem" library])
|
||||||
|
AC_DEFINE(HAVE_BOOST_FILESYSTEM, 1,
|
||||||
|
[Define if you have boost/filesystem.hpp])
|
||||||
|
- EXTRA_LIBS="-lboost_filesystem ${EXTRA_LIBS}"],
|
||||||
|
+ EXTRA_LIBS="-lboost_filesystem -lboost_system ${EXTRA_LIBS}"],
|
||||||
|
[AC_CHECK_HEADER(boost/filesystem.hpp,
|
||||||
|
[],
|
||||||
|
AC_MSG_NOTICE([Boost "filesystem" header is missing.]))
|
||||||
|
if test x$ac_cv_header_boost_filesystem_hpp = xyes; then
|
||||||
|
found_boost_filesystem_lib=no
|
||||||
|
candidates="-lboost_filesystem"
|
||||||
|
- if test x$acx_pthread_ok = xyes; then
|
||||||
|
+ if test x$ax_pthread_ok = xyes; then
|
||||||
|
candidates="-lboost_filesystem-mt $candidates"
|
||||||
|
fi
|
||||||
|
if test "x$with_boost_filesystem" != xCHECK \
|
||||||
|
@@ -231,20 +233,21 @@
|
||||||
|
fi
|
||||||
|
LIBS_ORIG=$LIBS
|
||||||
|
for x in $candidates; do
|
||||||
|
- LIBS="$LIBS_ORIG $x"
|
||||||
|
+ y=`echo $x | sed s/boost_filesystem/boost_system/g`
|
||||||
|
+ LIBS="$LIBS_ORIG $x $y"
|
||||||
|
AC_LINK_IFELSE([AC_LANG_PROGRAM([[
|
||||||
|
#include <string>
|
||||||
|
#include "boost/filesystem.hpp"
|
||||||
|
]],
|
||||||
|
[[
|
||||||
|
-boost::filesystem::basic_path<std::string, boost::filesystem::path_traits> p("foo/bar/baz.oo");
|
||||||
|
+boost::filesystem::path p("foo/bar/baz.oo");
|
||||||
|
p.branch_path().string();
|
||||||
|
p.leaf();
|
||||||
|
basename(p);
|
||||||
|
extension(p);
|
||||||
|
]]
|
||||||
|
)],
|
||||||
|
- [EXTRA_LIBS="$x ${EXTRA_LIBS}"
|
||||||
|
+ [EXTRA_LIBS="$x $y ${EXTRA_LIBS}"
|
||||||
|
found_boost_filesystem_lib=yes
|
||||||
|
AC_MSG_NOTICE([compiling with Boost's generic filename parsing support.])
|
||||||
|
break])
|
266
enblend-enfuse-4.0-libpng-1.5.patch
Normal file
266
enblend-enfuse-4.0-libpng-1.5.patch
Normal file
@ -0,0 +1,266 @@
|
|||||||
|
--- src/vigra_impex/png.cxx.orig 2012-09-05 19:55:15.000000000 +0200
|
||||||
|
+++ src/vigra_impex/png.cxx 2012-09-05 19:55:28.000000000 +0200
|
||||||
|
@@ -65,10 +65,20 @@
|
||||||
|
#include <png.h>
|
||||||
|
}
|
||||||
|
|
||||||
|
+#define STRINGIFY(m_argument) #m_argument
|
||||||
|
+
|
||||||
|
#if PNG_LIBPNG_VER < 10201
|
||||||
|
#error "please update your libpng to at least 1.2.1"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#if PNG_LIBPNG_VER >= 10400
|
||||||
|
+#define PNG_SET_EXPAND_GRAY_1_2_4_TO_8_NAME png_set_expand_gray_1_2_4_to_8
|
||||||
|
+#else
|
||||||
|
+#define PNG_SET_EXPAND_GRAY_1_2_4_TO_8_NAME png_set_gray_1_2_4_to_8
|
||||||
|
+#endif
|
||||||
|
+#define PNG_SET_EXPAND_GRAY_1_2_4_TO_8_FUNCTION_NAME STRINGIFY(PNG_SET_EXPAND_GRAY_1_2_4_TO_8_NAME)
|
||||||
|
+#define PNG_SET_EXPAND_GRAY_1_2_4_TO_8(m_image) PNG_SET_EXPAND_GRAY_1_2_4_TO_8_NAME(m_image)
|
||||||
|
+
|
||||||
|
// TODO: per-scanline reading/writing
|
||||||
|
|
||||||
|
namespace {
|
||||||
|
@@ -81,7 +91,7 @@
|
||||||
|
static void PngError( png_structp png_ptr, png_const_charp error_msg )
|
||||||
|
{
|
||||||
|
png_error_message = std::string(error_msg);
|
||||||
|
- longjmp( png_ptr->jmpbuf, 1 );
|
||||||
|
+ longjmp( png_jmpbuf(png_ptr), 1 );
|
||||||
|
}
|
||||||
|
|
||||||
|
// called on non-fatal errors
|
||||||
|
@@ -203,9 +213,9 @@
|
||||||
|
// check if the file is a png file
|
||||||
|
const unsigned int sig_size = 8;
|
||||||
|
png_byte sig[sig_size];
|
||||||
|
- std::fread( sig, sig_size, 1, file.get() );
|
||||||
|
+ std::size_t readCount = std::fread( sig, sig_size, 1, file.get() );
|
||||||
|
const int no_png = png_sig_cmp( sig, 0, sig_size );
|
||||||
|
- vigra_precondition( !no_png, "given file is not a png file.");
|
||||||
|
+ vigra_precondition( (readCount == 1) && !no_png, "given file is not a png file.");
|
||||||
|
|
||||||
|
// create png read struct with user defined handlers
|
||||||
|
png = png_create_read_struct( PNG_LIBPNG_VER_STRING, NULL,
|
||||||
|
@@ -213,7 +223,7 @@
|
||||||
|
vigra_postcondition( png != 0, "could not create the read struct." );
|
||||||
|
|
||||||
|
// create info struct
|
||||||
|
- if (setjmp(png->jmpbuf)) {
|
||||||
|
+ if (setjmp(png_jmpbuf(png))) {
|
||||||
|
png_destroy_read_struct( &png, &info, NULL );
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_create_info_struct(): ").c_str() );
|
||||||
|
}
|
||||||
|
@@ -221,14 +231,14 @@
|
||||||
|
vigra_postcondition( info != 0, "could not create the info struct." );
|
||||||
|
|
||||||
|
// init png i/o
|
||||||
|
- if (setjmp(png->jmpbuf)) {
|
||||||
|
+ if (setjmp(png_jmpbuf(png))) {
|
||||||
|
png_destroy_read_struct( &png, &info, NULL );
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_init_io(): ").c_str() );
|
||||||
|
}
|
||||||
|
png_init_io( png, file.get() );
|
||||||
|
|
||||||
|
// specify that the signature was already read
|
||||||
|
- if (setjmp(png->jmpbuf)) {
|
||||||
|
+ if (setjmp(png_jmpbuf(png))) {
|
||||||
|
png_destroy_read_struct( &png, &info, NULL );
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_set_sig_bytes(): ").c_str() );
|
||||||
|
}
|
||||||
|
@@ -244,13 +254,13 @@
|
||||||
|
void PngDecoderImpl::init()
|
||||||
|
{
|
||||||
|
// read all chunks up to the image data
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_read_info(): ").c_str() );
|
||||||
|
png_read_info( png, info );
|
||||||
|
|
||||||
|
// pull over the header fields
|
||||||
|
int interlace_method, compression_method, filter_method;
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_get_IHDR(): ").c_str() );
|
||||||
|
png_get_IHDR( png, info, &width, &height, &bit_depth, &color_type,
|
||||||
|
&interlace_method, &compression_method, &filter_method );
|
||||||
|
@@ -264,7 +274,7 @@
|
||||||
|
|
||||||
|
// transform palette to rgb
|
||||||
|
if ( color_type == PNG_COLOR_TYPE_PALETTE) {
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_palette_to_rgb(): ").c_str() );
|
||||||
|
png_set_palette_to_rgb(png);
|
||||||
|
color_type = PNG_COLOR_TYPE_RGB;
|
||||||
|
@@ -273,9 +283,9 @@
|
||||||
|
|
||||||
|
// expand gray values to at least one byte size
|
||||||
|
if ( color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8 ) {
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
- vigra_postcondition( false,png_error_message.insert(0, "error in png_set_gray_1_2_4_to_8(): ").c_str());
|
||||||
|
- png_set_gray_1_2_4_to_8(png);
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
+ vigra_postcondition( false, png_error_message.insert(0, "error in " PNG_SET_EXPAND_GRAY_1_2_4_TO_8_FUNCTION_NAME " (): ").c_str());
|
||||||
|
+ PNG_SET_EXPAND_GRAY_1_2_4_TO_8(png);
|
||||||
|
bit_depth = 8;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -283,7 +293,7 @@
|
||||||
|
#if 0
|
||||||
|
// strip alpha channel
|
||||||
|
if ( color_type & PNG_COLOR_MASK_ALPHA ) {
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_set_strip_alpha(): ").c_str() );
|
||||||
|
png_set_strip_alpha(png);
|
||||||
|
color_type ^= PNG_COLOR_MASK_ALPHA;
|
||||||
|
@@ -325,9 +335,13 @@
|
||||||
|
#if (PNG_LIBPNG_VER > 10008) && defined(PNG_READ_iCCP_SUPPORTED)
|
||||||
|
char * dummyName;
|
||||||
|
int dummyCompType;
|
||||||
|
+#if (PNG_LIBPNG_VER < 10500)
|
||||||
|
char * profilePtr;
|
||||||
|
+#else
|
||||||
|
+ png_byte * profilePtr;
|
||||||
|
+#endif
|
||||||
|
png_uint_32 profileLen;
|
||||||
|
- if (info->valid & PNG_INFO_iCCP) {
|
||||||
|
+ if (png_get_valid( png, info, PNG_INFO_iCCP )) {
|
||||||
|
png_get_iCCP(png, info, &dummyName, &dummyCompType, &profilePtr, &profileLen) ;
|
||||||
|
iccProfilePtr = (unsigned char *) profilePtr;
|
||||||
|
iccProfileLength = profileLen;
|
||||||
|
@@ -340,7 +354,7 @@
|
||||||
|
// image gamma
|
||||||
|
double image_gamma = 0.45455;
|
||||||
|
if ( png_get_valid( png, info, PNG_INFO_gAMA ) ) {
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_get_gAMA(): ").c_str() );
|
||||||
|
png_get_gAMA( png, info, &image_gamma );
|
||||||
|
}
|
||||||
|
@@ -349,26 +363,26 @@
|
||||||
|
double screen_gamma = 2.2;
|
||||||
|
|
||||||
|
// set gamma correction
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_set_gamma(): ").c_str() );
|
||||||
|
png_set_gamma( png, screen_gamma, image_gamma );
|
||||||
|
#endif
|
||||||
|
|
||||||
|
// interlace handling, get number of read passes needed
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false,png_error_message.insert(0, "error in png_set_interlace_handling(): ").c_str());
|
||||||
|
n_interlace_passes = png_set_interlace_handling(png);
|
||||||
|
|
||||||
|
// update png library state to reflect any changes that were made
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_read_update_info(): ").c_str() );
|
||||||
|
png_read_update_info( png, info );
|
||||||
|
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false,png_error_message.insert(0, "error in png_get_channels(): ").c_str());
|
||||||
|
n_channels = png_get_channels(png, info);
|
||||||
|
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false,png_error_message.insert(0, "error in png_get_rowbytes(): ").c_str());
|
||||||
|
rowsize = png_get_rowbytes(png, info);
|
||||||
|
|
||||||
|
@@ -378,9 +392,10 @@
|
||||||
|
|
||||||
|
void PngDecoderImpl::nextScanline()
|
||||||
|
{
|
||||||
|
- for (int i=0; i < n_interlace_passes; i++) {
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
- vigra_postcondition( false,png_error_message.insert(0, "error in png_read_row(): ").c_str());
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
+ vigra_postcondition( false,png_error_message.insert(0, "error in png_read_row(): ").c_str());
|
||||||
|
+ for (int i=0; i < n_interlace_passes; i++)
|
||||||
|
+ {
|
||||||
|
png_read_row(png, row_data.begin(), NULL);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
@@ -545,7 +560,7 @@
|
||||||
|
vigra_postcondition( png != 0, "could not create the write struct." );
|
||||||
|
|
||||||
|
// create info struct
|
||||||
|
- if (setjmp(png->jmpbuf)) {
|
||||||
|
+ if (setjmp(png_jmpbuf(png))) {
|
||||||
|
png_destroy_write_struct( &png, &info );
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_info_struct(): ").c_str() );
|
||||||
|
}
|
||||||
|
@@ -556,7 +571,7 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
// init png i/o
|
||||||
|
- if (setjmp(png->jmpbuf)) {
|
||||||
|
+ if (setjmp(png_jmpbuf(png))) {
|
||||||
|
png_destroy_write_struct( &png, &info );
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_init_io(): ").c_str() );
|
||||||
|
}
|
||||||
|
@@ -571,7 +586,7 @@
|
||||||
|
void PngEncoderImpl::finalize()
|
||||||
|
{
|
||||||
|
// write the IHDR
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_set_IHDR(): ").c_str() );
|
||||||
|
png_set_IHDR( png, info, width, height, bit_depth, color_type,
|
||||||
|
PNG_INTERLACE_NONE, PNG_COMPRESSION_TYPE_DEFAULT,
|
||||||
|
@@ -579,7 +594,7 @@
|
||||||
|
|
||||||
|
// set resolution
|
||||||
|
if (x_resolution > 0 && y_resolution > 0) {
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_set_pHYs(): ").c_str() );
|
||||||
|
png_set_pHYs(png, info, (png_uint_32) (x_resolution / 0.0254 + 0.5),
|
||||||
|
(png_uint_32) (y_resolution / 0.0254 + 0.5),
|
||||||
|
@@ -588,7 +603,7 @@
|
||||||
|
|
||||||
|
// set offset
|
||||||
|
if (position.x > 0 && position.y > 0) {
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_set_oFFs(): ").c_str() );
|
||||||
|
png_set_oFFs(png, info, position.x, position.y, PNG_OFFSET_PIXEL);
|
||||||
|
}
|
||||||
|
@@ -596,13 +611,17 @@
|
||||||
|
#if (PNG_LIBPNG_VER > 10008) && defined(PNG_WRITE_iCCP_SUPPORTED)
|
||||||
|
// set icc profile
|
||||||
|
if (iccProfile.size() > 0) {
|
||||||
|
- png_set_iCCP(png, info, "icc", 0,
|
||||||
|
- (char *)iccProfile.begin(), iccProfile.size());
|
||||||
|
+ png_set_iCCP(png, info, (png_charp)("icc"), 0,
|
||||||
|
+#if (PNG_LIBPNG_VER < 10500)
|
||||||
|
+ (png_charp)iccProfile.begin(), (png_uint_32)iccProfile.size());
|
||||||
|
+#else
|
||||||
|
+ (png_byte*)iccProfile.begin(), (png_uint_32)iccProfile.size());
|
||||||
|
+#endif
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
|
||||||
|
// write the info struct
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_write_info(): ").c_str() );
|
||||||
|
png_write_info( png, info );
|
||||||
|
|
||||||
|
@@ -634,10 +653,10 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
// write the whole image
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_write_image(): ").c_str() );
|
||||||
|
png_write_image( png, row_pointers.begin() );
|
||||||
|
- if (setjmp(png->jmpbuf))
|
||||||
|
+ if (setjmp(png_jmpbuf(png)))
|
||||||
|
vigra_postcondition( false, png_error_message.insert(0, "error in png_write_end(): ").c_str() );
|
||||||
|
png_write_end(png, info);
|
||||||
|
}
|
37
enblend-enfuse-4.1.1-texinfo-5.1.patch
Normal file
37
enblend-enfuse-4.1.1-texinfo-5.1.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
diff -up enblend-enfuse-4.1.1/doc/Makefile.am.doc enblend-enfuse-4.1.1/doc/Makefile.am
|
||||||
|
diff -up enblend-enfuse-4.1.1/doc/Makefile.in.doc enblend-enfuse-4.1.1/doc/Makefile.in
|
||||||
|
--- enblend-enfuse-4.1.1/doc/Makefile.in.doc 2013-02-15 08:14:30.000000000 -0600
|
||||||
|
+++ enblend-enfuse-4.1.1/doc/Makefile.in 2013-03-14 12:18:42.002825015 -0500
|
||||||
|
@@ -387,12 +387,12 @@ smooth-edge.gp: $(top_builddir)/config.s
|
||||||
|
rm -rf $$backupdir; exit $$rc
|
||||||
|
|
||||||
|
.texi.dvi:
|
||||||
|
- TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS" \
|
||||||
|
+ TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS:" \
|
||||||
|
MAKEINFO='$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir)' \
|
||||||
|
$(TEXI2DVI) $<
|
||||||
|
|
||||||
|
.texi.pdf:
|
||||||
|
- TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS" \
|
||||||
|
+ TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS:" \
|
||||||
|
MAKEINFO='$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir)' \
|
||||||
|
$(TEXI2PDF) $<
|
||||||
|
|
||||||
|
@@ -450,7 +450,7 @@ mostlyclean-1:
|
||||||
|
maintainer-clean-1:
|
||||||
|
-rm -f $(srcdir)/stamp-1 $(srcdir)/versenfuse.texi
|
||||||
|
.dvi.ps:
|
||||||
|
- TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS" \
|
||||||
|
+ TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS:" \
|
||||||
|
$(DVIPS) -o $@ $<
|
||||||
|
|
||||||
|
uninstall-dvi-am:
|
||||||
|
@@ -788,7 +788,7 @@ uninstall-am: uninstall-dvi-am uninstall
|
||||||
|
uninstall-dvi-am uninstall-html-am uninstall-info-am \
|
||||||
|
uninstall-pdf-am uninstall-ps-am
|
||||||
|
|
||||||
|
-export TEXINPUTS=$(top_builddir):$(srcdir)
|
||||||
|
+export TEXINPUTS=$(top_builddir):$(srcdir):
|
||||||
|
|
||||||
|
# Phony Targets
|
||||||
|
|
37
enblend-enfuse-4.1.1-texinfo-5.patch
Normal file
37
enblend-enfuse-4.1.1-texinfo-5.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
diff -up enblend-enfuse-4.1.1/doc/Makefile.am.doc enblend-enfuse-4.1.1/doc/Makefile.am
|
||||||
|
diff -up enblend-enfuse-4.1.1/doc/Makefile.in.doc enblend-enfuse-4.1.1/doc/Makefile.in
|
||||||
|
--- enblend-enfuse-4.1.1/doc/Makefile.in.doc 2013-02-15 08:14:30.000000000 -0600
|
||||||
|
+++ enblend-enfuse-4.1.1/doc/Makefile.in 2013-03-14 12:18:42.002825015 -0500
|
||||||
|
@@ -387,12 +387,12 @@ smooth-edge.gp: $(top_builddir)/config.s
|
||||||
|
rm -rf $$backupdir; exit $$rc
|
||||||
|
|
||||||
|
.texi.dvi:
|
||||||
|
- TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS" \
|
||||||
|
+ TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS:" \
|
||||||
|
MAKEINFO='$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir)' \
|
||||||
|
$(TEXI2DVI) $<
|
||||||
|
|
||||||
|
.texi.pdf:
|
||||||
|
- TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS" \
|
||||||
|
+ TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS:" \
|
||||||
|
MAKEINFO='$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir)' \
|
||||||
|
$(TEXI2PDF) $<
|
||||||
|
|
||||||
|
@@ -450,7 +450,7 @@ mostlyclean-1:
|
||||||
|
maintainer-clean-1:
|
||||||
|
-rm -f $(srcdir)/stamp-1 $(srcdir)/versenfuse.texi
|
||||||
|
.dvi.ps:
|
||||||
|
- TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS" \
|
||||||
|
+ TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS:" \
|
||||||
|
$(DVIPS) -o $@ $<
|
||||||
|
|
||||||
|
uninstall-dvi-am:
|
||||||
|
@@ -788,7 +788,7 @@ uninstall-am: uninstall-dvi-am uninstall
|
||||||
|
uninstall-dvi-am uninstall-html-am uninstall-info-am \
|
||||||
|
uninstall-pdf-am uninstall-ps-am
|
||||||
|
|
||||||
|
-export TEXINPUTS=$(top_builddir):$(srcdir)
|
||||||
|
+export TEXINPUTS=$(top_builddir):$(srcdir):
|
||||||
|
|
||||||
|
# Phony Targets
|
||||||
|
|
116
enblend-enfuse.spec
Normal file
116
enblend-enfuse.spec
Normal file
@ -0,0 +1,116 @@
|
|||||||
|
Name: enblend-enfuse
|
||||||
|
Version: 4.1.1
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: Image Blending with Multiresolution Splines
|
||||||
|
Group: Applications/Multimedia
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||||
|
URL: http://enblend.sourceforge.net/
|
||||||
|
Source: http://downloads.sourceforge.net/enblend/enblend-enfuse-%{version}.tar.gz
|
||||||
|
Patch1: enblend-enfuse-4.0-libpng-1.5.patch
|
||||||
|
Patch2: enblend-enfuse-4.0-boost-1.46.1.patch
|
||||||
|
Patch3: enblend-enfuse-4.0-boost-1.50.patch
|
||||||
|
Patch4: enblend-enfuse-4.1.1-texinfo-5.patch
|
||||||
|
Patch5: enblend-enfuse-4.1.1-texinfo-5.1.patch
|
||||||
|
License: GPL
|
||||||
|
Provides: enblend = %{version}
|
||||||
|
Requires(post):%{__install_info}
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libGL-devel
|
||||||
|
BuildRequires: libGLU-devel
|
||||||
|
BuildRequires: libICE-devel
|
||||||
|
BuildRequires: libSM-devel
|
||||||
|
BuildRequires: libXi-devel
|
||||||
|
BuildRequires: libXmu-devel
|
||||||
|
BuildRequires: libboost-devel
|
||||||
|
BuildRequires: libfreeglut-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libglew-devel
|
||||||
|
BuildRequires: libgsl-devel
|
||||||
|
BuildRequires: libilmbase-devel
|
||||||
|
BuildRequires: libjpeg-devel
|
||||||
|
BuildRequires: liblcms2-devel
|
||||||
|
BuildRequires: libopenexr-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libtiff-devel
|
||||||
|
BuildRequires: libvigra-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Enblend blends away the seams in a panoramic image mosaic using a multi-resolution spline.
|
||||||
|
Enfuse merges different exposures of the same scene to produce an image that looks much like a tone-mapped image.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}-%{version}
|
||||||
|
#%patch1 -p0
|
||||||
|
#%patch2 -p1
|
||||||
|
#%patch3 -p0
|
||||||
|
#%patch5 -p1
|
||||||
|
|
||||||
|
sed -i -e 's/src:://g;s/CFG::/CFG_/g' doc/*.texi doc/define2set.pl configure.in
|
||||||
|
|
||||||
|
%build
|
||||||
|
#autoreconf -f -i
|
||||||
|
%configure \
|
||||||
|
--disable-static \
|
||||||
|
--with-boost-filesystem
|
||||||
|
# --enable-openmp
|
||||||
|
|
||||||
|
# Workaround: texinfo 5.1 fails to make info pages
|
||||||
|
(cd doc && make pdf MAKEINFO=/bin/true || true)
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
#% post
|
||||||
|
#install_info enblend.info
|
||||||
|
#install_info enfuse.info
|
||||||
|
#exit 0
|
||||||
|
|
||||||
|
#% preun
|
||||||
|
#%uninstall_info enblend.info
|
||||||
|
#%uninstall_info enfuse.info
|
||||||
|
#exit 0
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/enblend
|
||||||
|
%{_bindir}/enfuse
|
||||||
|
#%{_infodir}/enblend.info.*
|
||||||
|
#%{_infodir}/enfuse.info.*
|
||||||
|
%{_mandir}/man1/enblend.*
|
||||||
|
%{_mandir}/man1/enfuse.*
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
#ChangeLog NEWS README README.txt
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Mar 31 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.1.1-2mamba
|
||||||
|
- rebuilt with openexr 2.1.0
|
||||||
|
|
||||||
|
* Wed Dec 25 2013 Automatic Build System <autodist@mambasoft.it> 4.1.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Dec 15 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0-5mamba
|
||||||
|
- libboost 1.52 mass rebuild
|
||||||
|
|
||||||
|
* Wed Sep 19 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0-4mamba
|
||||||
|
- rebuild with libpng 1.5 (added patch)
|
||||||
|
|
||||||
|
* Wed Dec 15 2010 Automatic Build System <autodist@mambasoft.it> 4.0-3mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Sun Jun 13 2010 Automatic Build System <autodist@mambasoft.it> 4.0-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Sun Mar 07 2010 Davide Madrisan <davide.madrisan@gmail.com> 4.0-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user