automatic version update by autodist [release 29.4-1mamba;Sat Jun 22 2024]

This commit is contained in:
Automatic Build System 2024-06-24 21:55:55 +02:00
parent 05e905b7f9
commit 6f7b8f584b
6 changed files with 6 additions and 364 deletions

View File

@ -1,13 +0,0 @@
--- emacs-20.6.orig/src/coding.h Fri May 19 23:20:52 2000
+++ emacs-20.6/src/coding.h Fri May 19 22:58:43 2000
@@ -495,6 +495,9 @@
s2 = c2 + 0x7E; \
} while (0)
+/* Must declare this, so that we don't lose high 4 bytes on 64-bit machines. */
+extern Lisp_Object code_convert_string_norecord ();
+
/* Encode the file name NAME using the specified coding system
for file names, if any. */
#define ENCODE_FILE(name) \

View File

@ -1,220 +0,0 @@
--- emacs-21.2/src/m/x86_64.h.x86_64 2002-07-09 11:04:36.000000000 +0200
+++ emacs-21.2/src/m/x86_64.h 2002-07-09 11:07:23.000000000 +0200
@@ -0,0 +1,175 @@
+/* machine description file for the X86-64 architecture.
+ Copyright (C) 2000 Free Software Foundation, Inc.
+
+This file is part of GNU Emacs.
+
+GNU Emacs is free software; you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation; either version 1, or (at your option)
+any later version.
+
+GNU Emacs is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with GNU Emacs; see the file COPYING. If not, write to
+the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+Boston, MA 02111-1307, USA. */
+
+#define BITS_PER_LONG 64
+#define BITS_PER_EMACS_INT 64
+
+/* Define WORDS_BIG_ENDIAN iff lowest-numbered byte in a word
+ is the most significant byte. */
+
+#undef WORDS_BIG_ENDIAN
+
+/* Define NO_ARG_ARRAY if you cannot take the address of the first of a
+ group of arguments and treat it as an array of the arguments. */
+
+#define NO_ARG_ARRAY
+
+/* Define WORD_MACHINE if addresses and such have
+ to be corrected before they can be used as byte counts. */
+
+/* #define WORD_MACHINE */
+
+/* Now define a symbol for the cpu type, if your compiler
+ does not define it automatically:
+ Ones defined so far include vax, m68000, ns16000, pyramid,
+ orion, tahoe, APOLLO and many others */
+
+/* __x86_64__ defined automatically */
+
+
+/* Use type EMACS_INT rather than a union, to represent Lisp_Object */
+/* This is desirable for most machines. */
+
+#define NO_UNION_TYPE
+
+/* Define the type to use. */
+#define EMACS_INT long
+#define EMACS_UINT unsigned long
+#define SPECIAL_EMACS_INT
+
+/* Define EXPLICIT_SIGN_EXTEND if XINT must explicitly sign-extend
+ the 24-bit bit field into an int. In other words, if bit fields
+ are always unsigned.
+
+ If you use NO_UNION_TYPE, this flag does not matter. */
+
+#define EXPLICIT_SIGN_EXTEND
+
+/* Data type of load average, as read out of kmem. */
+
+#define LOAD_AVE_TYPE long
+
+/* Convert that into an integer that is 100 for a load average of 1.0 */
+
+#define LOAD_AVE_CVT(x) (int) (((double) (x)) * 100.0 / FSCALE)
+
+/* Define CANNOT_DUMP on machines where unexec does not work.
+ Then the function dump-emacs will not be defined
+ and temacs will do (load "loadup") automatically unless told otherwise. */
+#if 0
+#define CANNOT_DUMP
+#endif
+
+/* Define VIRT_ADDR_VARIES if the virtual addresses of
+ pure and impure space as loaded can vary, and even their
+ relative order cannot be relied on.
+
+ Otherwise Emacs assumes that text space precedes data space,
+ numerically. */
+
+/* #define VIRT_ADDR_VARIES */
+
+/* Define C_ALLOCA if this machine does not support a true alloca
+ and the one written in C should be used instead.
+ Define HAVE_ALLOCA to say that the system provides a properly
+ working alloca function and it should be used.
+ Define neither one if an assembler-language alloca
+ in the file alloca.s should be used. */
+
+#define HAVE_ALLOCA
+
+/* Define the following if GNU malloc and the relocating allocator do
+ not work together with X. */
+
+/* #define SYSTEM_MALLOC */
+
+/* Define NO_REMAP if memory segmentation makes it not work well
+ to change the boundary between the text section and data section
+ when Emacs is dumped. If you define this, the preloaded Lisp
+ code will not be sharable; but that's better than failing completely. */
+
+/* #define NO_REMAP */
+
+/* Some really obscure 4.2-based systems (like Sequent DYNIX) do not
+ support asynchronous I/O (using SIGIO) on sockets, even though it
+ works fine on tty's. If you have one of these systems, define the
+ following, and then use it in config.h (or elsewhere) to decide
+ when (not) to use SIGIO.
+
+ You'd think this would go in an operating-system description file,
+ but since it only occurs on some, but not all, BSD systems, the
+ reasonable place to select for it is in the machine description
+ file. */
+
+/* #define NO_SOCK_SIGIO */
+
+#ifdef __ELF__
+#undef UNEXEC
+#define UNEXEC unexelf.o
+#endif
+
+#define PNTR_COMPARISON_TYPE unsigned long
+
+/* On the 64 bit architecture, we can use 60 bits for addresses */
+
+#define VALBITS 60
+
+/* Define XINT and XUINT so that they can take arguments of type int */
+
+#define XINT(a) (((long) (a) << (BITS_PER_LONG - VALBITS)) >> (BITS_PER_LONG - VALBITS))
+#define XUINT(a) ((long) (a) & VALMASK)
+
+/* Declare malloc and realloc in a way that is clean.
+ But not in makefiles! */
+
+#ifndef NOT_C_CODE
+/* We need these because pointers are larger than the default ints. */
+# if !defined(__NetBSD__) && !defined(__OpenBSD__)
+# include <alloca.h>
+# else
+# include <stdlib.h>
+# endif
+
+/* We need to prototype these for the lib-src programs even if we don't
+ use the system malloc for the Emacs proper. */
+#ifdef _MALLOC_INTERNAL
+/* These declarations are designed to match the ones in gmalloc.c. */
+#if defined (__STDC__) && __STDC__
+extern void *malloc (), *realloc (), *calloc ();
+#else
+extern char *malloc (), *realloc (), *calloc ();
+#endif
+#else /* not _MALLOC_INTERNAL */
+extern void *malloc (), *realloc (), *calloc ();
+#endif /* not _MALLOC_INTERNAL */
+
+#ifdef REL_ALLOC
+#ifndef _MALLOC_INTERNAL
+/* "char *" because ralloc.c defines it that way. gmalloc.c thinks it
+ is allowed to prototype these as "void *" so we don't prototype in
+ that case. You're right: it stinks! */
+extern char *r_alloc (), *r_re_alloc ();
+extern void r_alloc_free ();
+#endif /* not _MALLOC_INTERNAL */
+#endif /* REL_ALLOC */
+
+#endif /* not NOT_C_CODE */
+
+#define HAVE_TEXT_START
--- emacs-21.2/src/s/gnu-linux.h.x86_64 2001-09-28 17:50:04.000000000 +0200
+++ emacs-21.2/src/s/gnu-linux.h 2002-07-09 11:14:34.000000000 +0200
@@ -173,8 +173,12 @@ Boston, MA 02111-1307, USA. */
/* GNU/Linux usually has crt0.o in a non-standard place */
#define START_FILES pre-crt0.o /usr/lib/crt0.o
#else
+#if defined(__x86_64)
+#define START_FILES pre-crt0.o /usr/lib64/crt1.o /usr/lib64/crti.o
+#else
#define START_FILES pre-crt0.o /usr/lib/crt1.o /usr/lib/crti.o
#endif
+#endif
#ifdef __ELF__
/* Here is how to find X Windows. LD_SWITCH_X_SITE_AUX gives an -R option
@@ -225,8 +229,12 @@ Boston, MA 02111-1307, USA. */
#else
#undef LIB_GCC
#define LIB_GCC
+#if defined(__x86_64)
+#define LIB_STANDARD -lgcc -lc -lgcc /usr/lib64/crtn.o
+#else
#define LIB_STANDARD -lgcc -lc -lgcc /usr/lib/crtn.o
#endif
+#endif
/* Don't use -g in test compiles in configure.
This is so we will use the same shared libs for that linking
--- emacs-21.2/configure.in.x86_64 2002-07-09 10:23:41.000000000 +0200
+++ emacs-21.2/configure.in 2002-07-09 10:49:54.000000000 +0200
@@ -997,6 +997,11 @@ case "${canonical}" in
machine=ia64 opsys=gnu-linux
;;
+ ## X86-64
+ x86_64*-*-linux* )
+ machine=x86_64 opsys=gnu-linux
+ ;;
+
## Intel 386 machines where we don't care about the manufacturer
i[3456]86-*-* )
machine=intel386

View File

@ -1,47 +0,0 @@
diff -Nru emacs-22.2.orig/etc/emacs.1 emacs-22.2/etc/emacs.1
--- emacs-22.2.orig/etc/emacs.1 2008-01-10 13:15:28.000000000 +0100
+++ emacs-22.2/etc/emacs.1 2008-06-03 12:41:01.000000000 +0200
@@ -630,28 +630,28 @@
.
.
.SH FILES
-/usr/local/share/info \(em files for the Info documentation browser.
+/usr/share/info \(em files for the Info documentation browser.
The complete text of the Emacs reference manual is included in a
convenient tree structured form.
Also includes the Emacs Lisp Reference Manual, useful to anyone
wishing to write programs in the Emacs Lisp extension language.
-/usr/local/share/emacs/$VERSION/lisp \(em Lisp source files and
+/usr/share/emacs/$VERSION/lisp \(em Lisp source files and
compiled files that define most editing commands.
Some are preloaded; others are autoloaded from this directory when
used.
-/usr/local/libexec/emacs/$VERSION/$ARCH \(em various programs that are
+/usr/libexec/emacs/$VERSION/$ARCH \(em various programs that are
used with GNU Emacs.
-/usr/local/share/emacs/$VERSION/etc \(em various files of information.
+/usr/share/emacs/$VERSION/etc \(em various files of information.
-/usr/local/share/emacs/$VERSION/etc/DOC.* \(em contains the documentation
+/usr/share/emacs/$VERSION/etc/DOC.* \(em contains the documentation
strings for the Lisp primitives and preloaded Lisp functions
of GNU Emacs.
They are stored here to reduce the size of Emacs proper.
-/usr/local/share/emacs/$VERSION/etc/SERVICE lists people offering
+/usr/share/emacs/$VERSION/etc/SERVICE lists people offering
various services to assist users of GNU Emacs, including education,
troubleshooting, porting and customization.
.
@@ -675,7 +675,7 @@
Please do not send anything but bug reports to this mailing list.
For more information about Emacs mailing lists, see the
-file /usr/local/emacs/etc/MAILINGLISTS.
+file /usr/share/emacs/etc/MAILINGLISTS.
Bugs tend actually to be fixed if they can be isolated, so it is
in your interest to report them in such a way that they can be
easily reproduced.

View File

@ -1,12 +0,0 @@
diff -Nru emacs-22.3.orig/lib-src/rcs2log emacs-22.3/lib-src/rcs2log
--- emacs-22.3.orig/lib-src/rcs2log 2008-01-07 09:39:42.000000000 +0100
+++ emacs-22.3/lib-src/rcs2log 2008-09-08 01:48:39.000000000 +0200
@@ -205,7 +205,7 @@
m[9]="Oct"; m[10]="Nov"; m[11]="Dec"
'
-logdir=$TMPDIR/rcs2log$$
+logdir=`mktemp -d /tmp/rcs2log.XXXXXX` || exit 1
llogout=$logdir/l
trap exit 1 2 13 15
trap "rm -fr $logdir 2>/dev/null" 0

View File

@ -1,56 +0,0 @@
diff --git a/configure.ac b/configure.ac
index 62f53a3..ad9d948 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2659,15 +2659,15 @@ LIBGIF=
if test "${HAVE_X11}" = "yes" && test "${with_gif}" != "no" \
|| test "${HAVE_W32}" = "yes"; then
AC_CHECK_HEADER(gif_lib.h,
-# EGifPutExtensionLast only exists from version libungif-4.1.0b1.
+# EGifPutExtensionTrailer only exists from version libungif-4.1.0b1.
# Earlier versions can crash Emacs.
- [AC_CHECK_LIB(gif, EGifPutExtensionLast, HAVE_GIF=yes, HAVE_GIF=maybe)])
+ [AC_CHECK_LIB(gif, EGifPutExtensionTrailer, HAVE_GIF=yes, HAVE_GIF=maybe)])
if test "$HAVE_GIF" = yes; then
LIBGIF=-lgif
elif test "$HAVE_GIF" = maybe; then
# If gif_lib.h but no libgif, try libungif.
- AC_CHECK_LIB(ungif, EGifPutExtensionLast, HAVE_GIF=yes, HAVE_GIF=no)
+ AC_CHECK_LIB(ungif, EGifPutExtensionTrailer, HAVE_GIF=yes, HAVE_GIF=no)
test "$HAVE_GIF" = yes && LIBGIF=-lungif
fi
diff --git a/src/image.c b/src/image.c
index ce36699..bbc5c49 100644
--- a/src/image.c
+++ b/src/image.c
@@ -7101,8 +7101,8 @@ gif_image_p (Lisp_Object object)
/* GIF library details. */
DEF_IMGLIB_FN (int, DGifCloseFile, (GifFileType *));
DEF_IMGLIB_FN (int, DGifSlurp, (GifFileType *));
-DEF_IMGLIB_FN (GifFileType *, DGifOpen, (void *, InputFunc));
-DEF_IMGLIB_FN (GifFileType *, DGifOpenFileName, (const char *));
+DEF_IMGLIB_FN (GifFileType *, DGifOpen, (void *, InputFunc, int*));
+DEF_IMGLIB_FN (GifFileType *, DGifOpenFileName, (const char *, int*));
static bool
init_gif_functions (void)
@@ -7192,7 +7192,7 @@ gif_load (struct frame *f, struct image *img)
}
/* Open the GIF file. */
- gif = fn_DGifOpenFileName (SSDATA (file));
+ gif = fn_DGifOpenFileName (SSDATA (file), NULL);
if (gif == NULL)
{
image_error ("Cannot open `%s'", file, Qnil);
@@ -7213,7 +7213,7 @@ gif_load (struct frame *f, struct image *img)
memsrc.len = SBYTES (specified_data);
memsrc.index = 0;
- gif = fn_DGifOpen (&memsrc, gif_read_from_memory);
+ gif = fn_DGifOpen (&memsrc, gif_read_from_memory, NULL);
if (!gif)
{
image_error ("Cannot open memory source `%s'", img->spec, Qnil);

View File

@ -3,7 +3,7 @@
%define dirver %(echo %version | sed "s|[a-z]$||")
Name: emacs
Version: 29.3
Version: 29.4
Release: 1mamba
Summary: Common files needed to run the GNU Emacs text editor
Group: Applications/Text
@ -14,11 +14,6 @@ URL: https://www.gnu.org/software/emacs/
Source: ftp://ftp.gnu.org/pub/gnu/%{name}/%{name}-%{version}.tar.gz
Source1: %{name}-xemacs.desktop
Source2: %{name}-xemacs.png
Patch0: %{name}-22.2-infofix.patch
Patch1: %{name}-22.3-security_mktemp.patch
Patch2: %{name}-21.3-ia64.patch
Patch3: %{name}-21.3-x86_64.patch
Patch4: emacs-24.3-libgif-5.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -146,11 +141,6 @@ You'll also need to install the emacs package in order to run Emacs.
%prep
%setup -q -n %{name}-%{dirver}
#-D -T
#%patch0 -p1 -b .infofix
#%patch1 -p1 -b .security_mktemp
#patch2 -p1 -b .ia64
#patch3 -p1 -b .x86_64
#%patch4 -p1
#sed -i 's/ctags/gctags/g' etc/etags.1
#./autogen.sh
@ -353,18 +343,15 @@ exit 0
%{_bindir}/emacsclient
%{_bindir}/ebrowse
%{_bindir}/etags
#%{_bindir}/grep-changelog
#%{_bindir}/rcs-checkin
%{_userunitdir}/emacs.service
%dir %{_libdir}/%{name}
%dir %{_libdir}/%{name}/%{dirver}
%dir %{_libdir}/%{name}/%{dirver}/%{_host}
%ifarch arm
%attr(755,root,root) %{_libdir}/%{name}/%{dirver}/%{_host}/movemail
%ifarch aarch64
%attr(755,root,root) %{_libdir}/emacs/%{dirver}/%{_host}/movemail
%endif
%dir %{_datadir}/%{name}/site-lisp
%dir %{_datadir}/%{name}/%{dirver}/site-lisp
#%{_localstatedir}/games/%{name}/
%{_includedir}/emacs-module.h
%{_mandir}/man?/*
%{_infodir}/*
@ -415,6 +402,9 @@ exit 0
%endif
%changelog
* Sat Jun 22 2024 Automatic Build System <autodist@openmamba.org> 29.4-1mamba
- automatic version update by autodist
* Mon Mar 25 2024 Automatic Build System <autodist@openmamba.org> 29.3-1mamba
- automatic version update by autodist